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S E C T I O N  1  

The Detailed Engineering User's Guide contains information about various modules and 
advanced features that were not mentioned in the Basic User's Guide.  These module and 
features include: 
 Projects and As-Built Data 
 Process Data 
 Calculation module 
 Specifications module 
 Working with different interfaces 
 Working in an integrated environment 
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S E C T I O N  2  

SmartPlant Instrumentation provides the means to efficiently create a comprehensive and 
detailed wiring design of your plant.  You can create various types of wiring items that perform 
specific functions in your plant.  You can define and manage the following: 
 Panels belonging to a number of different categories, such as junction boxes, DCS and PLC 

panels, marshaling racks, and so forth 
 Plug-and-socket boxes that support Foundation Fieldbus and Profibus systems 
 Field devices and their cables 
 Multi-input devices with either terminal or plug-and-socket connections 
 Terminal strips and terminals 
 Wiring equipment (I/O cards, fieldbus bricks, safety barriers, hubs, relays, and so forth) 
 Cables based on shipped and user-defined configurations that include cable sets (pairs, 

triads, and so forth), wires, and connectors 
After creating the required wiring items, you can effect I/O assignment and make the required 
connections.  This will enable you to create a point-to-point wiring diagram and generate 
numerous wiring reports using the Enhanced Report Utility. 
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S E C T I O N  3  

General Wiring Definitions 
This section deals with various general definitions in wiring. 

In This Section 
Principles of Wiring Operations in SmartPlant Instrumentation ..... 19 
Splitting the Wiring Design Among Several Teams ....................... 19 
Creating a Wiring Scheme ............................................................. 21 
Name and Sequence Uniqueness of Wiring Items ........................ 21 
Apply Naming Conventions to Wiring Items .................................. 22 
Associate a Symbol with an Item ................................................... 23 
Associate a Symbol with Multiple Items ........................................ 23 
Remove Trailing Separators From Wiring Item Names ................. 24 
 
 

Principles of Wiring Operations in SmartPlant 
Instrumentation 

SmartPlant Instrumentation creates and keeps track of wiring routing and connections by 
identifying the wires and their connection points. 
The wires and the items to which they are connected are arranged hierarchically as they appear in 
the Domain Explorer.  These terms are described in detail in the relevant help topics. 
You can make connections between or within any of the <unit> in a <plant>.  Reference cables 
and panels are, however, available for all the <plants> in the domain. 
The following sequence of operations is necessary for the creation of a wiring scheme: 
 Creation of panels, plug-and- socket boxes, terminal strips, wiring equipment, terminals, and 

so on 
 Creation of cables, cable sets, and wires 
 Connecting wires to terminals 

In addition, tagged instruments may be wired so that their wiring routing is automatically tracked 
and wire names are automatically propagated.  For details, see: 
 Device Panels (see "Device Panels in SmartPlant Instrumentation" on page 49) 
 I/O Assignment (on page 105) 

 

Splitting the Wiring Design Among Several Teams 
There are projects in which, for various reasons, several teams work on the wiring design of the 
same project.  These teams can be located at the same site or be in different geographical 
locations. 
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A good example of such a project is when the main contractor designs the field instrumentation 
wiring up to the marshaling racks while the DCS vendor is responsible for the DCS design and 
also for the design of the wiring from the marshaling panels to the terminals of the I/O cards that 
they supply, as shown below: 

 
At the end of the project, or at any intermediate stage, there is a need to integrate both designs 
into one database to complete the wiring from the field to the DCS and then generate the complete 
loop diagrams and the wiring reports. 
At this time, the boundary or the scope of the design that each party is responsible for can vary 
from project to project.  Usually, the intersection point would be somewhere around a marshaling 
panel, either at the field side of a terminal strip and the control system terminal strip side.  This 
issue is usually discussed between the parties and they agree where to draw this line. 
In SmartPlant Instrumentation, we recommend the following strategy to handle this split wiring 
design: 
1. The main contractor or the EPC starts with the creation of an As-Built domain and then 

creates a project for each of the working parties involved in the overall design.  In the 
example mentioned above, the main contractor works on the main As-Built plant and defines 
the projects for the DCS vendors. 

2. All the teams work on the same database using Citrix.  However, it is also possible to work 
offline. 

Using this approach for splitting the design has the following advantages: 
 Provides the ability to see the current As-Built data while connecting to the data (and not the 

other way around). 
 Enables good control of new tag numbers and subcomponents. 
 Retains the uniqueness of rules when adding various subcomponents such as terminals on a 

terminal strip. 
 Enables the comparison of As- Built loops and project loops. 

Note that the members of the various teams working on the projects have to be informed of the 
changes made in As-Built so that they can update their databases.  Consequently, based on the 
data maturity, teams should coordinate among themselves when to transfer their wiring data to the 
rest of the projects. 
For more information, see Owner Operator Domain (As-Built and Projects) in the Administration 
User's Guide, under Domain and Project Administration, Owner Operator: General Activities. 
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Creating a Wiring Scheme 
After the System Administrator initializes and creates a domain, SmartPlant Instrumentation 
creates the following items: 
 Reference cables 
 Reference device panels with terminal strips 
 Connection types 

These reference items suffice for the most common connections to device panels.  For more 
sophisticated combinations, you should create your own reference items. 
For example, for a 2-wire device you need to create in the Reference Explorer: 
 A device panel with a two- terminal strip named DEFAULT 2W DEVICE PANEL 
 A cable with a shielded twisted pair (cable + one shielded pair), named DEFAULT 2W CABLE 
 A connection device that connects two wires from a pair one after the other named 2 IN A 

ROW 
You can then select the above items the wiring profile to define the reference wiring properties for 
a given instrument type. 
When you start a new wiring scheme, the folders in the Domain Explorer are empty.  You can 
right-click one of the panel folders in the Domain Explorer and on the shortcut menu, click New 
and then click the required option.  The Reference Explorer contains several reference panels 
and cables that are provided as shipped data that you can copy to the Domain Explorer. 

 You must have appropriate access rights to alter the reference items. 
 

Name and Sequence Uniqueness of Wiring Items 
When creating or editing the properties of a wiring item , SmartPlant Instrumentation validates that 
the wiring item has a unique name and sequence.  The software applies the following validation 
rules: 
Item Sequence 
If SmartPlant Instrumentation detects that the sequence of a wiring item is not unique, the 
software displays an appropriate message and does not create the item until you enter a unique 
sequence. 
The software validates sequence uniqueness according to the following rules: 
 In an owner operator domain, the software validates sequence uniqueness in As-Built and all 

the projects belonging to the current owner operator domain. 
 Panels, cables, and connectors do not require any sequence. 
 Terminals must have a sequence which is unique at the terminal strip level. 
 All the other wiring items must have a sequence which is unique at the level of the immediate 

parent item under which the item exists. 
Item Names 
If SmartPlant Instrumentation detects that an item does not have a unique name, the software 
displays a warning message, after which you proceed depending on the setting you made on the 
General page of the wiring preferences.  You can set the software to proceed without changing 
the item name if you do not select the Enforce name uniqueness wiring preference option on the 
General page.  If you select the Enforce name uniqueness check box, you must rename the 
item in order to proceed with your work. 
The software validates name uniqueness according to the following rules: 
 In an owner operator domain, the software validates name uniqueness in As-Built and all the 

projects belonging to the current owner operator domain. 
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 For panels and cables, SmartPlant Instrumentation checks for name uniqueness at the level of 
the current <plant>. 

 Wires do not require name uniqueness. 
 The software checks for terminal name uniqueness at the terminal strip level. 
 For all the other wiring items, SmartPlant Instrumentation checks for name uniqueness at the 

level of the immediate parent item under which the item exists. 
 If you try to create a wiring item that has no name, the software prompts you to enter a 

name.  If you select the Enforce name uniqueness wiring preference option, the software 
treats items without names according to the validation rules stated above.  If you do not select 
this wiring preference option, the software allows you to create wiring items without names. 

 When moving an item to another parent item , the software validates the name uniqueness at 
the target level.  If you did not select the Enforce name uniqueness wiring preference 
option, the software moves the item and retains its name.  If you selected the Enforce name 
uniqueness wiring preference option, the software does not allow you to move the item if the 
item name violates the validation rules. 

For more information, see Naming Conventions in the Administration User's Guide, under Domain 
and Project Administration, Naming Conventions. 
 

Apply Naming Conventions to Wiring Items 
SmartPlant Instrumentation allows you to apply naming conventions to various wiring items.  You 
can apply naming conventions to all panels, racks, and wiring equipment.  Note that naming 
conventions are set by your Domain Administrator. 
After applying the naming conventions, the software renames the selected items according to the 
existing conventions.  You can apply naming conventions to a single item or multiple items.  If 
you need to that for a single wiring item, you can do it in the Properties dialog box of that item by 
selecting the Apply naming convention check box. 
1. In the Domain Explorer, do one of the following: 

 In the Tree view, select one desired item. 
 Expand a folder and in the Items pane, select the items you require. 

2. Right-click the selected items and then on the shortcut menu, click one of the following: 
 Apply Naming Conventions to Selected Items — to rename only the items you 

selected without renaming the child items that exist on the lower hierarchy level of these 
items. 

 Apply Naming Conventions to Selected Items and Child Items — to rename the 
items you selected and all the child items that exist on the lower hierarchy level of these 
items. 
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Associate a Symbol with an Item 
 

 Make sure that you have defined a custom symbol folder in the SmartPlant Instrumentation 
Preferences dialog box for the appropriate enhanced report type before you associate a 
symbol with an item. 

 When you associate a symbol with an item that can have more than one possible relation to 
other items for which you want to display data, make sure that the symbol you select uses 
macros with the appropriate relations.  If a macro has an incorrect relation, the software 
cannot display the data. 

1. In the Domain Explorer, select the desired item , for example, a particular panel. 
2. Right-click the item and click Properties. 
3. Click the Associate Symbols tab. 
4. Click New. 
5. In the Name column, select the desired report type. 
6. Beside the Symbol File column, click Browse. 
7. Navigate to the desired .sym file. 
8. If you require, repeat steps 4 -7 to associate symbols with the item for other report types. 

 When associating symbols with a panel, for example, you will use one symbol to represent 
the panel in a Location Layout report, and another symbol to represent the panel in a Panel Layout 
report. 

 
 For an instrument, when you associate a symbol for Enhanced Report Utility reports, the 

symbol will also be displayed in other wiring reports. 
 You can associate each item with one symbol only per available report type. 
 You can associate the same symbol with more than one item if you desire. 
 When using custom terminal symbols in enhanced reports, there are two ways of displaying 

the terminals on the drawing sheet: 
 Associating a symbol with a panel, where the symbol exactly represents the 

panel-strip-terminal configuration, and dragging the panel onto the drawing sheet.  With 
this method, the software displays the entire panel. 

 Associating a symbol with each individual terminal and dragging the desired terminals 
onto the drawing sheet.  With this method, the software displays the selected terminals 
with their associated strips and panels, together with the appropriate macros. 

 

Associate a Symbol with Multiple Items 
You can associate a symbol with multiple items using the Symbols Batch Association 
command. 

 
 Make sure that you have defined a custom symbol folder in the SmartPlant Instrumentation 

Preferences dialog box for the appropriate enhanced report type before you associate a 
symbol with an item. 

 When you associate a symbol with an item that can have more than one possible relation to 
other items for which you want to display data, make sure that the symbol you select uses 
macros with the appropriate relations.  If a macro has an incorrect relation, the software 
cannot display the data. 
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1. In the Domain Explorer click on the folder that contains the items you want to associate with a 
symbol. For example, Device Panels. 

2. In the Items pane of the Domain Explorer, select the items you want to associate with a 
symbol. 

3. Right-click on the selected items, and from the shortcut menu select Actions > Symbols 
Batch Association. 

4. On the Symbols Batch Association dialog box, click New. 
5. In the Name column, select the desired report type. 
6. Beside the Symbol File column, click Browse. 
7. Navigate to the required symbol. 
8. Click OK. 

 The Symbols Batch Association command is also available in various browsers using 
the browser shortcut menu > browser category, for example Wiring or Instrument Index > 
Symbols Batch Association. 
 

Remove Trailing Separators From Wiring Item Names 
Wiring items that have been created according to naming conventions sometimes may have 
trailing separators.  This happens when the last naming convention segment is not defined and 
there is no value for it.  You can instruct the software to remove the trailing separators 
automatically when creating wiring items. 
1. In the Wiring module, click File > Preferences. 
2. In the Preferences dialog box, under Wiring, click Custom. 
3. In the Custom features for the Wiring module group box, under Parameter, type Remove 

Trailing Separator. 
4. Under Value type Y. 

 The default setting is N which instructs the software not to remove the trailing separators. 
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S E C T I O N  4  

Cables, Cable Sets, and Wires 
This section describes the creation and management of cables, cable sets, and wires. 

In This Section 
Creating and Managing Cables ..................................................... 25 
Define a Cable Configuration......................................................... 26 
Edit a Cable Configuration ............................................................. 27 
Delete a Cable Configuration......................................................... 28 
Create a Cable ............................................................................... 28 
Create a Connector ....................................................................... 29 
Edit Cable Properties ..................................................................... 30 
Add a Cable Set ............................................................................. 31 
Add a Wire to a Cable Set ............................................................. 32 
Create a Cable Without Sets and Wires ........................................ 33 
Apply a Reference Cable to Multiple Cables Without Sets and Wires
 ....................................................................................................... 33 
Apply a Reference Cable to One Cable Without Sets and Wires .. 34 
Edit Wire Properties ....................................................................... 34 
Apply Regional Wire Colors to Project Cables .............................. 35 
 
 

Creating and Managing Cables 
You create new cables in SmartPlant Instrumentation based on a particular cable 
configuration.  A cable configuration includes a particular arrangement of cable sets (pairs, triads, 
and so forth within a cable) and wires to be built with the cable.  Therefore, when creating a new 
cable, you have to select an existing cable configuration or define a new one.  After creating a 
cable, you can add additional cable sets and wires to that cable if required. 
As a time saver, it is recommended that you create reference items for the cable, cable set, and 
wire arrangements you intend to use frequently.  You create these reference cables in the 
Reference Explorer.  You can then drag them to the Domain Explorer and this way create 
numerous cables on the fly. 
In SmartPlant Instrumentation Explorer, cables occupy the top hierarchy level under which you 
can create various wiring items such as cable sets, wires, and connectors.  There is a lot of 
flexibility in creating a cable hierarchy.  There is no rigid structure like "cable – cable set – wire" 
that limits your cable design.  You can create various cable hierarchy structures, as you 
require.  See Cable Hierarchy Example to examine a possible structure. 
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Define a Cable Configuration 
This option allows you to create a new cable configuration.  All SmartPlant Instrumentation cables 
are based on a particular cable configuration.  Therefore, you need a cable configuration to 
create a new cable.  A cable configuration includes a cable set (pairs, triads, and so forth within a 
cable) and a wire arrangement.  As a result, when creating a new cable, SmartPlant 
Instrumentation automatically creates the required cable sets and wires within that cable based on 
the configuration that you define.  You can add more cable sets and wires to that cable manually 
later if needed. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. In the Domain Explorer or Reference Explorer, right-click the Cables folder and then click 
New > Cable. 

3. In the Cable Configuration dialog box, click New. 
4. In the New Cable Configuration dialog box, enter the total number of sets (pairs, triads, and 

so forth) that SmartPlant Instrumentation will create automatically when a new cable is based 
on this new configuration. 

 Add an additional cable set for an overall shield. 
5. From the Default cable set type list, select the appropriate cable type. 

 The selected cable type determines whether cables based on this configuration have 
multiple wires, pairs, triads, and so forth. 

6. Click OK to return to the Cable Configuration dialog box. 
7. In the Cable Configuration dialog box, type the name of the new configuration in the Cable 

Configuration data field. 
8. In the Cable default name field, type a name of the cables that will be based on the current 

configuration. 
 This means that every time you create a new cable based on this new configuration, 

SmartPlant Instrumentation uses this default setting to name the new cable.  You can then 
modify this name as needed when you define the cable in the Cable Properties dialog box. 

9. In the Description text field, type a brief description of the new configuration. 
10. Click in the Cable Set text field and type the name of each cable set that is defined in this 

configuration.  You can rename the individual cable sets later if needed when editing the 
cable set in the Cable Set Properties dialog box. 

11. For each cable set, in the Cable Set Type field, accept the displayed value (the cable set type 
you selected in the New Cable Configuration dialog box) or select another one if needed. 

12. For each first cable set of a given cable set type, do the following under Cable set wire 
details: 
a. Click in the Wire Tag text field and type the names of the individual wires within the cable 

sets.  You can accept the displayed value if needed. 
b. From the Wire Color list, select a color for each wire.  If the required value is not 

available, you can add it in the Wire Color dialog box that you access from the Tables 
menu in the Wiring Module window. 

c. From the Wire Type list, select a type for each wire.  If the required value is not available, 
you can add it in the Wire Type dialog box that you access from the Tables menu in the 
Wiring Module window. 

d. From the Polarity list, select the appropriate polarity or shield for each wire. 
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e. For additional cable sets based on a cable set type for which you already entered settings 
under Cable set wire details, do one of the following: 

 To copy the values from a selected cable set to all sets based on the current cable set 
type, click Apply.  You can select the Exclude wire tags check box before you click 
Apply if you do not wish to copy the wire tags while copying wire color, wire type, and 
polarity details. 

 Enter the settings individually for each cable set. 
13. Click Save. 
 

Edit a Cable Configuration 
This procedure explains how to modify an existing cable configuration. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. In the Domain Explorer or Reference Explorer, right-click the Cables folder and then click 
New > Cable. 

3. In the Cable Configuration dialog box, select a configuration from the Cable configuration 
list. 

4. Click Edit. 
5. In the Cable Configuration dialog box, enter the total number of sets (pairs, triads, and so 

forth) that SmartPlant Instrumentation will create automatically when a new cable is based on 
this new configuration. 

 Add an additional cable set for an overall shield. 
6. From the Default cable set type list, select the appropriate cable type. 

 The selected cable type determines whether cables based on this configuration have 
multiple wires, pairs, triads, and so forth. 

7. Click OK to return to the Cable Configuration dialog box. 
8. In the Cable Configuration dialog box, type the name of the new configuration in the Cable 

Configuration data field. 
9. In the Cable default name field, type a name of the cables that will be based on the current 

configuration. 
 This means that every time you create a new cable based on this new configuration, 

SmartPlant Instrumentation uses this default setting to name the new cable.  You can then 
modify this name as needed when you define the cable in the Cable Properties dialog box. 

10. In the Description text field, type a brief description of the new configuration. 
11. Click in the Cable Set text field and type the name of each cable set that is defined in this 

configuration.  You can rename the individual cable sets later if needed when editing the 
cable set in the Cable Set Properties dialog box. 

12. For each cable set, in the Cable Set Type field, accept the displayed value (the cable set type 
you selected in the New Cable Configuration dialog box) or select another one if needed. 

13. For each first cable set of a given cable set type, do the following under Cable set wire 
details: 
a. Click in the Wire Tag text field and type the names of the individual wires within the cable 

sets.  You can accept the displayed value if needed. 
b. From the Wire Color list, select a color for each wire.  If the required value is not 

available, you can add it in the Wire Color dialog box that you access from the Tables 
menu in the Wiring Module window. 
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c. From the Wire Type list, select a type for each wire.  If the required value is not available, 
you can add it in the Wire Type dialog box that you access from the Tables menu in the 
Wiring Module window. 

d. From the Polarity list, select the appropriate polarity or shield for each wire. 
e. For additional cable sets based on a cable set type for which you already entered settings 

under Cable set wire details, do one of the following: 
 To copy the values from a selected cable set to all sets based on the current cable set 

type, click Apply.  You can select the Exclude wire tags check box before you click 
Apply if you do not wish to copy the wire tags while copying wire color, wire type, and 
polarity details. 

 Enter the settings individually for each cable set. 
14. Click Save. 
 

Delete a Cable Configuration 
This procedure explains how to delete a cable configuration. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. In the Domain Explorer or Reference Explorer, right-click the Cables folder and then click 
New > Cable. 

3. In the Cable Configuration dialog box, select a configuration from the Cable configuration 
list. 

4. Click Delete. 
 

Create a Cable 
You can create new cables either in the Domain Explorer or the Reference Explorer.  If you are 
creating a cable that is going to have a frequently used configuration, we recommend that you 
create it in the Reference Explorer.  Reference cables facilitate fast creation of plant cables by 
copying an existing cable configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a cable that does not have a configuration that you 
intend to use frequently, we recommend that you create this cable in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the cables in the 
current <unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. In the Domain Explorer or Reference Explorer, right-click the Cables folder and then click 
New > Cable. 

3. In the Cable Configuration dialog box, select a cable configuration from the Cable 
configuration list. 

 Click New if you do not have a suitable configuration.  For details, see Define a Cable 
Configuration (on page 26). 

4. Click Create. 
5. In the Cable Properties dialog box, under Cable, type the cable name. 

 If you are working under cable type dependency, your selection of cable type determines 
the reference cable name. 
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6. Under Description, type the new cable description as needed. 
7. Select one of the following under Cable class: 

 To create a conventional cable, accept the default setting Conventional. 
 To create a fieldbus spur, select Conventional. 
 To create a fieldbus home- run cable, select Fieldbus home-run. 
 To create a telecom cable, select Telecom. 

8. Under Type, select the required cable type if needed.  If the required type is not available, 

click  next to the list arrow to add the required item to the list. 
9. Select the cable manufacturer, model, color as appropriate.  If the item that you need is not 

on the list, click . 
10. Type the end one, and end two locations of the cable. 
11. Type the cable length and select the unit of measure. 
12. To assign this cable to a cable drum, select values from the Pulling area list and from the 

Cable drum list.  For details, see Assign Cables to Drums Manually (Without Optimization) 
(on page 156). 

13. To define a cable harness, select the cable harness from the list.  If the item that you need is 

not on the list, click . 
14. To name the wires ends in this cable according to a naming convention, select the appropriate 

naming convention from the Wire end naming convention list. 
15. To define the cable as intrinsically safe, select Set as intrinsically safe. 
16. To define glands for the cable, from the Glands group box, select the End 1, End 2 or both 

cable glands.  If the required gland is not available, click .  
Note the graphic representation of cable glands in the software: 

  — A cable with no glands 

  — A cable with a gland on one of its sides 

  — A cable with a gland on both sides 
17. Click Connectors to create connectors for the cable and manage connector-wire 

assignments. 
18. In the Cable Properties dialog box, click OK. 
 

Create a Connector 
Connectors are needed for fieldbus home-run cables, telecom cables, and other cables that 
require connectors.  SmartPlant Instrumentation allows you to build your wiring system with any 
of the following connector implementations: 

 Connector at one or both cable ends 
 Connector at end of a single cable set 
 Connector at end of wires from different cable sets 

1. In the Domain Explorer or Reference Explorer, do one of the following: 
 To create a new cable, right-click the Cables folder and on the shortcut menu click New > 

Cable. 
 Right-click an existing cable, and on the shortcut menu click Properties. 

2. Modify cable properties as needed.  For details, see Create a Cable (on page 28). 
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3. Click Connectors. 
4. In the Connector Assignments dialog box, do one of the following: 

 To manage connector-wire associations for end 1 of the cable, click the End 1 tab. 
 To manage connector-wire associations for end 2 of the cable, click the End 2 tab. 

5. In the Connector Assignments dialog box, click New. 
6. In the Connector Properties dialog box that opens, under Connector, type the name of the 

new connector. 
 From the list, select a connector type as configured. 

 To modify or create a connector type, click .  For details, see Define or Edit a 
Connector Type (on page 199). 

7. Under Male/female select Male or Female as needed. 
8. Click OK to return to the Connector Assignments dialog box. 
 

Edit Cable Properties 
This procedure shows you how to edit the properties of a cable. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Expand the Cables folder and right-click a cable. 
3. On the shortcut menu, click Properties. 
4. In the Cable Properties dialog box, under Cable, type the cable name. 

 If you are working under cable type dependency, and have already created plant cables 
based on a reference cable that you are editing, certain reference cable fields are not enabled 
for editing.  The System Administrator can enable cable type dependency when making 
domain definitions. 

5. Under Description, type the new cable description as needed. 
6. Select one of the following under Cable class: 

 To create a conventional cable, accept the default setting Conventional. 
 To create a fieldbus spur, select Conventional. 
 To create a fieldbus home- run cable, select Fieldbus home-run. 
 To create a telecom cable, select Telecom. 

7. Under Type, select the required cable type if needed.  If the required type is not available, 

click  next to the list arrow to add the required item to the list. 
8. Select the cable manufacturer, model, color as appropriate.  If the item that you need is not 

on the list, click . 
9. Type the end one, and end two locations of the cable. 
10. Type the cable length and select the unit of measure. 
11. To assign this cable to a cable drum, select values from the Pulling area list and from the 

Cable drum list.  For details, see Assign Cables to Drums Manually (Without Optimization) 
(on page 156). 

12. To define a cable harness, select the cable harness from the list.  If the item that you need is 

not on the list, click . 
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13. To name the wires ends in this cable according to a naming convention, select the appropriate 
naming convention from the Wire end naming convention list. 

14. To define the cable as intrinsically safe, select Set as intrinsically safe. 
15. To define glands for the cable, from the Glands group box, select the End 1, End 2 or both 

cable glands.  If the required gland is not available, click .  
Note the graphic representation of cable glands in the software: 

  — A cable with no glands 

  — A cable with a gland on one of its sides 

  — A cable with a gland on both sides 
16. Click Connectors to create connectors for the cable and manage connector-wire 

assignments. 
17. In the Cable Properties dialog box, click OK. 
 

Add a Cable Set 
SmartPlant Instrumentation adds cable sets (pairs, triads, and so forth within a cable) 
automatically when you create a new cable based on a cable configuration.  This procedure 
describes how you can add another cable set to an existing cable that already contains a number 
of cable sets. 

 If you are working under cable type dependency, and have already created plant 
cables based on a particular reference cable, the software does not allow you to add cable sets to 
such a reference cable.  Further, you cannot add cable sets to a plant cable created under cable 
type dependency.  The System Administrator can enable cable type dependency when making 
domain definitions. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Expand the Cables folder and right-click a cable. 
3. On the shortcut menu, click New > Cable Set. 
4. In the Cable Set Properties dialog box, type the cable set name in the Cable set text field. 
5. Under Cable set sequence, enter the sequence of the cable set in the cable. 

 Typically, the cable set sequence is determined by the manufacturer.  If you change the 
sequence number of a cable set, make sure that you also change the sequence number of the 
other cable sets in the cable as appropriate to avoid duplicate values and erroneous 
terminations. 

6. Click OK to add a new cable set. 
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Add a Wire to a Cable Set 
SmartPlant Instrumentation adds wires automatically when you create a new cable based on a 
cable configuration.  This procedure describes how you can add another wire to an existing cable 
set.  You can add a wire either to a cable set created automatically or to a cable set that you 
added manually. 

 If you are working under cable type dependency, and have already created plant 
cables based on a particular reference cable, the software does not allow you to add cable sets or 
wires to such a reference cable.  Further, you cannot add cable sets or wires to a plant cable 
created under cable type dependency.  The System Administrator can enable cable type 
dependency when making domain definitions. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Expand the Cables folder and then double-click a cable to display its cable sets. 
3. Right-click a cable set and then on the shortcut menu, click New > Cable Wire. 
4. In the Wire Properties dialog box, under Wire, type the wire tag. 

 By default, wire tags are based on the signal that they carry.  To name wires based on 
user input the Domain Administrator needs to enable cable type dependency when making 
domain definitions. 

5. In the Details group box, under Wire sequence in set, accept the automatically assigned 
value that determines the numbering sequence of the wire in the cable set. 

 The values that SmartPlant Instrumentation suggests under Wire sequence in set are 
unique throughout As-Built and all engineering projects where the current cable set appears. 

6. From the Polarity list, select the signal polarity or shield. 
 When you create a cable for the first time, or when you copy from reference cables, 

check for the existence of shield indication wherever needed.  Shield indication is important 
when SmartPlant Instrumentation propagates signals through wires.  In this case, the 
software does not overwrite the wire tag with the tag signal.  You can also define a wire as an 
overall shield if required. 

7. From the Type list, select the required wire type.  If the required type is not on this list, click 

 next to the list arrow to open a dialog box where you can add, modify, or delete items 
from the Wire type list. 

8. From the Color list, select the required wire color.  If the required color is not on this list, click 

 next to the list arrow to open a dialog box where you can add, modify, or delete items 
from the Wire color list. 

9. In the Note text field, type a brief note if needed. 
10. To name the wire ends according to a naming convention, select the appropriate naming 

convention from the Wire end naming convention list.  Note that this check box is available 
only if the Domain Administrator has enabled it in the Wire End Naming Conventions dialog 
box. 

11. Do the following to name the wire ends not according to a naming convention: 
a. Select Override naming convention. 
b. Under Wire end 1, type the first wire end name. 
c. Under Wire end 2, type the second wire end name. 
d. Click Revisions to manage revisions for the current wire. 
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12. Click OK in the Wire Properties dialog box. 
 

Create a Cable Without Sets and Wires 
This option allows you to create a cable that does not have any cable sets or wires.  You can use 
such cables in the early stages of your design and when creating cable block diagrams where it is 
not necessary to specify cable types, the number of sets and wires in the cables, and so forth. 

 The software does not allow you to create cables without sets and wires if you are 
working under cable type dependency. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Right-click the Cables folder and then on the shortcut menu click New > Cable. 
3. On the Cable Configuration dialog box, click New. 
4. Do the following on the New Cable Configuration dialog box: 

a. Under Number of cable sets, type 0 (zero). 
b. Click OK. 

5. On the Cable Configuration dialog box, click Save and then Create. 
6. On the Cable Properties dialog box, enter the cable properties as you require. 

 Since cables without cable sets and wires are useful during the early stages of plant 
design and when creating cable block diagrams, the only cable property that you need to 
enter is the cable name.  You can populate the other properties when you apply a reference 
cable to this cable. 

7. Click OK. 
 

Apply a Reference Cable to Multiple Cables Without Sets and 
Wires 

This feature enables you to apply a reference cable to cables that do not have any sets or 
wires.  This batch operation enables you to select multiple cables in the Domain Explorer and 
then select an appropriate reference cable for each cable that you selected. 
1. In the Domain Explorer, click the Cables folder. 
2. In the Items pane, press and hold the Ctrl key and then right-click the cables you require. 
3. On the shortcut menu, click Actions > Apply Reference Cable. 
4. On the Apply Reference Cable dialog box, select an appropriate reference cable for each 

cable. 
5. Click OK. 
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Apply a Reference Cable to One Cable Without Sets and 
Wires 

This procedure explains how to apply a reference cable to a single cable that does not have any 
sets or wires.  You can apply a reference cable or a cable structure as you require. 
1. In the Domain Explorer, click the Cables folder. 
2. In the tree view right-click a cable you require. 
3. On the shortcut menu, click Actions > Apply Cable Structure. 
4. On the Apply Cable Structure dialog box, do one of the following: 

 Click the Create items based on a reference cable option button and then select an 
appropriate reference cable from the list. 

 Click the Create items based on a cable configuration option button and then select an 

appropriate cables structure from the list.  You can click  to open the Cable 
Configuration dialog box to define a new cable configuration if needed. 

5. Click OK. 
 

Edit Wire Properties 
This option describes how to edit the properties of a wire. 

 If you are working under cable type dependency, and have already created plant 
cables based on a particular reference cable, the software does not allow you to add cable sets or 
wires to such a reference cable.  Further, you cannot add cable sets or wires to a plant cable 
created under cable type dependency.  The System Administrator can enable cable type 
dependency when making domain definitions. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Expand the Cables folder and then double-click a cable to display its cable sets. 
3. Double-click a cable set to display the existing wires. 
4. Right-click a wire and then on the shortcut menu, click Properties. 
5. In the Wire Properties dialog box, under Wire, type the wire tag. 

 By default, wire tags are based on the signal that they carry.  To name wires based on 
user input the Domain Administrator needs to enable cable type dependency when making 
domain definitions. 

6. In the Details group box, under Wire sequence in set, accept the automatically assigned 
value that determines the numbering sequence of the wire in the cable set. 

 The values that SmartPlant Instrumentation suggests under Wire sequence in set are 
unique throughout As-Built and all engineering projects where the current cable set appears. 

7. From the Polarity list, select the signal polarity or shield. 
 When you create a cable for the first time, or when you copy from reference cables, 

check for the existence of shield indication wherever needed.  Shield indication is important 
when SmartPlant Instrumentation propagates signals through wires.  In this case, the 
software does not overwrite the wire tag with the tag signal.  You can also define a wire as an 
overall shield if required. 
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8. From the Type list, select the required wire type.  If the required type is not on this list, click 

 next to the list arrow to open a dialog box where you can add, modify, or delete items 
from the Wire type list. 

9. From the Color list, select the required wire color.  If the required color is not on this list, click 

 next to the list arrow to open a dialog box where you can add, modify, or delete items 
from the Wire color list. 

10. In the Note text field, type a brief note if needed. 
11. To name the wire ends according to a naming convention, select the appropriate naming 

convention from the Wire end naming convention list.  Note that this check box is available 
only if the Domain Administrator has enabled it in the Wire End Naming Conventions dialog 
box. 

12. Do the following to name the wire ends not according to a naming convention: 
a. Select Override naming convention. 
b. Under Wire end 1, type the first wire end name. 
c. Under Wire end 2, type the second wire end name. 

13. Click Revisions to manage revisions for the current wire. 
14. Click OK in the Wire Properties dialog box. 
 

Apply Regional Wire Colors to Project Cables 
This procedure allows you to apply regional wire colors to your project cables based on reference 
cables. 

 This feature works only if your System Administrator has enabled the cable type 
dependency when making domain definitions. 
1. Import the required reference cables. 
2. In the target database, turn off the cable type dependency feature. 
3. Change the wire color of the reference cables. 
4. Turn on the cable type dependency feature. 
5. In the Wiring module, click Actions > Apply Regional Wire Colors. 
6. On the Apply Regional Wire Colors dialog box, click Apply. 

 
 You can view the results on the Regional Wire Colors Application Results dialog box. 
 The software applies the wire colors only to those project cables that fully conform to the 

structure of reference cables on the basis of which they were built.  That is, project cables 
must have the same number of cable sets and wires in each set as the appropriate reference 
cables. 
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S E C T I O N  5  

Conventional Panels 
The Wiring module enables you to create and configure various types of conventional 
panels.  Conventional panels in SmartPlant Instrumentation refer to all types of panels and 
cabinets that do not have a plug-and-socket connection.  In SmartPlant Instrumentation 
Explorer, panels occupy the top hierarchy level under which you can create various wiring items 
such as terminal strips, I/O cards, racks, and so on.  There is a lot of flexibility in creating a panel 
hierarchy.  There is no rigid structure like "panel — strip — terminal" that limits your wiring 
design.  You can create various wiring structures, as you require.  See Panels by Category 
Hierarchy Example to examine a few possible structures. 
Note that when duplicating a panel that has another panel as its child item (usually a device panel, 
the software duplicates the parent item without the child panel. 
SmartPlant Instrumentation allows you to create the following types (categories) of conventional 
panels: 
 Junction boxes 
 Marshaling racks 
 Cabinets (multi-purpose panels) 
 Device panels 
 Distributed Control System (DCS) panels 
 Programmable Logic Controller (PLC) panels 

 

Create a Junction Box 
This procedure explains how to create a generic junction box. 
You can create new panels either in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that first you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the place where it will be physically located.  This is helpful when filtering the panels in the current 
<unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder.  For more 

information, see Create a Reference Item. 
2. In the Domain Explorer, do one of the following: 

 Expand the Panels by Category folder to display all the panel category folders. 
 Expand the Panels by Location hierarchy and right-click a location where you want your 

new panel to reside. 
3. In the Domain Explorer under Panels by Category or in the Reference Explorer under 

Panels, right-click the Junction Boxes folder and then click New > Junction Box (Generic). 
4. In the Junction Box Properties dialog box, on the General tab, do one of the following to 

define the name of the new panel: 
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 Clear the Apply naming convention check box and under Panel, type the name of the 
new panel.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Panel. 

 Keep the Apply naming convention check box selected if you want the software to 
name the new panel automatically according to the naming conventions that are set for 
this type of panel in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

5. Select the required values from the Type, Manufacturer, Model, Dimensions, Area 

classification, and Location lists.  If the required value is not available, click  next to the 
relevant list arrow to open the appropriate supporting table.  (For details, see Add a New 
Value to a Select List.) 

6. Under Dimensions, type a value for the marshaling rack dimensions if needed. 
7. Under Maximum number of racks, type a value to set the maximum number of racks that 

can be created in this panel. 
 Setting this value to zero means that the current panel can have an unlimited number of 

racks. 
8. Under Mounting, type a value if needed. 
9. Under Backplane, type a value if needed. 
10. Select the Set as intrinsically safe check box if this junction box has intrinsic safety 

certification. 
11. Click the Associate Symbols tab to associate a symbol with the current panel.  The software 

will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

12. Click Revisions to manage the revisions of the new panel if needed. 
13. Click OK to accept your definitions for the new junction box and close this dialog box. 

 To create a junction box that contains both terminals and plug-and-socket connections, see 
Create a Panel with Terminals and Connectors (on page 44). 
 

Create a Marshaling Rack 
This procedure explains how to create a marshaling rack. 
You can create new panels either in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that first you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the place where it will be physically located.  This is helpful when filtering the panels in the current 
<unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder.  For more 

information, see Create a Reference Item. 
2. In the Domain Explorer, do one of the following: 

 Expand the Panels by Category folder to display all the panel category folders. 
 Expand the Panels by Location hierarchy and right-click a location where you want your 

new panel to reside. 
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3. In the Domain Explorer under Panels by Category or in the Reference Explorer under 
Panels, right-click the Marshaling Racks folder and then click New > Marshaling Rack. 

4. In the Marshaling Rack Properties dialog box, on the General tab, do one of the following to 
define the name of the new panel: 
 Clear the Apply naming convention check box and under Panel, type the name of the 

new panel.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Panel. 

 Keep the Apply naming convention check box selected if you want the software to 
name the new panel automatically according to the naming conventions that are set for 
this type of panel in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

5. Select the required values from the Type, Manufacturer, Model, Dimensions, Area 

classification, and Location lists.  If the required value is not available, click  next to the 
relevant list arrow to open the appropriate supporting table.  (For details, see Add a New 
Value to a Select List.) 

6. Under Dimensions, type a value for the marshaling rack dimensions if needed. 
7. Under Maximum number of racks, type a value to set the maximum number of racks that 

can be created in this panel. 
 Setting this value to zero means that the current panel can have an unlimited number of 

racks. 
8. Under Mounting, type a value if needed. 
9. Under Backplane, type a value if needed. 
10. Select the Set as intrinsically safe check box if this marshaling rack has intrinsic safety 

certification. 
11. If you need to enter power supply properties, select the Requires power supply check box 

and then click the Power Supply tab.  For details, see Enter Power Supply Data for Panels 
and Instrument Tags (on page 45). 

12. Click the Associate Symbols tab to associate a symbol with the current panel.  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

13. Click Revisions to manage the revisions of the new panel if needed. 
14. Click OK to accept your definitions for the new marshaling rack and close this dialog box. 

 To create a marshaling rack that contains both terminals and plug-and-socket connections, 
see Create a Panel with Terminals and Connectors (on page 44). 
 

Create a Cabinet 
This procedure explains how to create a cabinet. 
You can create new panels either in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that first you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the place where it will be physically located.  This is helpful when filtering the panels in the current 
<unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
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 Press F8 to open the Reference Explorer and expand the Panels folder.  For more 
information, see Create a Reference Item. 

2. In the Domain Explorer, do one of the following: 
 Expand the Panels by Category folder to display all the panel category folders. 
 Expand the Panels by Location hierarchy and right-click a location where you want your 

new panel to reside. 
3. In the Domain Explorer under Panels by Category or in the Reference Explorer under 

Panels, right-click the Cabinets folder and then click New > Cabinet. 
4. In the Cabinet Properties dialog box, on the General tab, do one of the following to define 

the name of the new panel: 
 Clear the Apply naming convention check box and under Panel, type the name of the 

new panel.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Panel. 

 Keep the Apply naming convention check box selected if you want the software to 
name the new panel automatically according to the naming conventions that are set for 
this type of panel in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

5. Select the required values from the Type, Manufacturer, Model, Dimensions, Area 

classification, and Location lists.  If the required value is not available, click  next to the 
relevant list arrow to open the appropriate supporting table.  (For details, see Add a New 
Value to a Select List.) 

6. Under Dimensions, type a value for the cabinet dimensions if needed. 
7. Under Maximum number of racks, type a value to set the maximum number of racks that 

can be created in this panel. 
 Setting this value to zero means that the current cabinet can have an unlimited number 

of racks. 
8. Under Mounting, type a value if needed. 
9. Under Backplane, type a value if needed. 
10. Select the Set as intrinsically safe check box if this cabinet has intrinsic safety certification. 
11. If you need to enter power supply properties, select the Requires power supply check box 

and then click the Power Supply tab.  For details, see Enter Power Supply Data for Panels 
and Instrument Tags (on page 45). 

12. Click the Associate Symbols tab to associate a symbol with the current panel.  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

13. Click Revisions to manage the revisions of the new cabinet if needed. 
14. Click OK to accept your definitions for the new cabinet and close this dialog box. 

 To create a cabinet that contains both terminals and plug-and-socket connections, see 
Create a Panel with Terminals and Connectors (on page 44). 
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Create an Unassociated Conventional Device Panel 
This procedure explains how to create a device panel that is not associated with any tag number 
and not connected to any device cable. 
You can create new panels either in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that first you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the place where it will be physically located.  This is helpful when filtering the panels in the current 
<unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder.  For more 

information, see Create a Reference Item. 
2. In the Domain Explorer, do one of the following: 

 Expand the Panels by Category folder to display all the panel category folders. 
 Expand the Panels by Location hierarchy and right-click a location where you want your 

new panel to reside. 
3. In the Domain Explorer under Panels by Category or in the Reference Explorer under 

Panels, right-click the Device Panels folder and then click New > Device Panel 
(Conventional). 

4. In the Device Panel Properties dialog box, on the General tab, do one of the following to 
define the name of the new panel: 
 Clear the Apply naming convention check box and under Panel, type the name of the 

new panel.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Panel. 

 Keep the Apply naming convention check box selected if you want the software to 
name the new panel automatically according to the naming conventions that are set for 
this type of panel in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

5. In the Address 1 and Address 2 fields, type the required definitions. 
 You can change the Address 1 and Address 2 field headers to reflect manufacturer 

specific terminology.  For details, see Customize Manufacturer-Specific Field Headers. 
6. Select the required values from the Type, Manufacturer, Model, Dimensions, Area 

classification, and Location lists.  If the required value is not available, click  next to the 
relevant list arrow to open the appropriate supporting table.  (For details, see Add a New 
Value to a Drop-Down List.) 

7. Under Dimensions, type a value for the marshaling rack dimensions if needed. 
8. Under Mounting, type a value if needed. 
9. Select the Set as intrinsically safe check box if this marshaling rack has intrinsic safety 

certification. 
10. Click the Associate Symbols tab to associate a symbol with the current panel.  The software 

will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new panel if needed. 
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12. Click OK to accept your definitions for the new device panel and close this dialog box. 
 To create a device panel that contains both terminals and plug-and-socket connections, 

see Create a Panel with Terminals and Connectors (on page 44). 
 

Create a DCS (Distributed Control System) Panel 
This procedure explains how to create a DCS (distributed control system) panel. 
You can create new panels either in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that first you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the place where it will be physically located.  This is helpful when filtering the panels in the current 
<unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder.  For more 

information, see Create a Reference Item . 
2. In the Domain Explorer, do one of the following: 

 Expand the Panels by Category folder to display all the panel category folders. 
 Expand the Panels by Location hierarchy and right-click a location where you want your 

new panel to reside. 
3. In the Domain Explorer under Panels by Category or in the Reference Explorer under 

Panels, right-click the DCS Panels folder and then click New > DCS Panel. 
4. In the Distributed Control System (DCS) Properties dialog box, on the General tab, do one 

of the following to define the name of the new panel: 
 Clear the Apply naming convention check box and under Panel, type the name of the 

new panel.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Panel. 

 Keep the Apply naming convention check box selected if you want the software to 
name the new panel automatically according to the naming conventions that are set for 
this type of panel in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

5. In the Highway and Node fields, type the required DCS definitions. 
 You can change the Highway and Node field headers to reflect manufacturer-specific 

terminology.  For details, see Customize Manufacturer-Specific Field Headers. 
6. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table.  (For details, see Add a New Value to a Select List.) 

7. Under Maximum number of racks, type a value to set the maximum number of racks that 
can be created in this panel. 

 Setting this value to zero means that the current panel can have an unlimited number of 
racks. 

8. To create a DCS panel compatible with a Profibus DP segment, do the following: 
9. Select the Enable DP Profibus check box. 
10. Under DP Profibus node, type a node for the new panel. 
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11. If you need to enter power supply properties, select the Requires power supply check box 
and then click the Power Supply tab.  For details, see Enter Power Supply Data for Panels 
and Instrument Tags (on page 45). 

12. Click the Associate Symbols tab to associate a symbol with the current panel.  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

13. Click Revisions to manage the revisions of the new panel if needed. 
14. Click OK to accept your definitions for the new DCS panel and close this dialog box. 

 
 To create a DCS panel that contains both terminals and plug-and-socket connections, 

see Create a Panel with Terminals and Connectors (on page 44). 
 Two detail symbols are supplied with the software, the DcsDetail.sym which displays the 

CS tags first and then the I/0 and channel data, and the Alt_DcsDetail.sym which 
displays the CS tags below the I/O and channel data. You can replace the DcsDetail.sym 
with the Alt_DcsDetail.sym in two ways: 

a. By changing the name of the Alt_DcsDetail.sym to DcsDetail.sym, this will replace the 
existing symbol with the alternative (this cannot be undone). 

b. By selecting the Alt_DcsDetail.sym as the Symbol Detail File in the Panel Manufactures 
dialog box for a specific manufacture, this way panels associated with the specific 
manufacture will use the Alt_DcsDetail.sym instead of the DcsDetail.sym. 

 

Create a PLC (Programmable Logic Controller) Panel 
This procedure explains how to create a PLC (programmable logic controller) panel. 
You can create new panels either in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that first you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the place where it will be physically located.  This is helpful when filtering the panels in the current 
<unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer.  For more information, see Create a 

Reference Item. 
2. Do one of the following: 

 Double-click the Panels by Location folder, right-click a location and then on the shortcut 
menu click New > PLC Panel. 

 Double-click the Panels by Category folder, right-click the DCS Panels folder and then 
on the shortcut menu click New > PLC Panel. 

3. In the Programmable Logic Controller (PLC) Properties dialog box, on the General tab, do 
one of the following to define the name of the new panel: 
 Clear the Apply naming convention check box and under Panel, type the name of the 

new panel.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Panel. 
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 Keep the Apply naming convention check box selected if you want the software to 
name the new panel automatically according to the naming conventions that are set for 
this type of panel in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

4. In the Address 1 and Address 2 fields, type the required PLC definitions. 
 You can change the Address 1 and Address 2 field headers to reflect 

manufacturer-specific terminology.  For details, see Customize Manufacturer-Specific Field 
Headers. 

5. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table.  (For details, see Add a New Value to a Select List.) 

6. Under Maximum number of racks, type a value to set the maximum number of racks that 
can be created in this panel. 

 Setting this value to zero means that the current panel can have an unlimited number of 
racks. 

7. To create a PLC panel compatible with a Profibus DP segment, do the following: 
8. Select the Enable DP Profibus check box. 
9. Under DP Profibus node, type a node for the new panel. 
10. If you need to enter power supply properties, select the Requires power supply check box 

and then click the Power Supply tab.  For details, see Enter Power Supply Data for Panels 
and Instrument Tags (on page 45). 

11. Click the Associate Symbols tab to associate a symbol with the current panel.  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

12. Click Revisions to manage the revisions of the new panel if needed. 
13. Click OK to accept your definitions for the new PLC panel and close this dialog box. 

 To create a PLC panel that contains both terminals and plug-and-socket connections, see 
Create a Panel with Terminals and Connectors (on page 44). 
 

Create a Panel with Terminals and Connectors 
Use this procedure to create a panel that contains both terminals and plug-and-socket 
connections.  Some fieldbus and Telecom devices have inputs via a plug-and socket 
arrangement and outputs via terminated wires on terminals.  To provide for this need, SmartPlant 
Instrumentation allows you to add a connector under any panel type (except for device panels) 
and then make the required connections either through the terminals or the connectors. 
1. In the Domain Explorer or Reference Explorer, create or select a panel. 

 You can select or create any type of panel except for device panels. 
2. Right-click the panel you selected and then on the shortcut menu, click New > Connector. 
3. In the Connector Properties dialog box, under Connector, type the name of the new 

connector. 
4. Under Connector type, do one of the following: 

 From the list, select a connector type with pins. 

 To modify or create a connector type, click .  For details, see Making Connections 
and Associations for Fieldbus (on page 199). 

5. Under Male/female select Male or Female as needed. 
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6. Click OK. 
 

Enter Power Supply Data for Panels and Instrument Tags 
This procedure explains how to enter power supply data for various panels that require power 
supply.  Although power supply data is not essential for SmartPlant Instrumentation functionality, 
it is indicated for the interface with the SmartPlant Electrical application.  SmartPlant 
Instrumentation allows you to enter power supply data in all panels except for junction boxes and 
device panels. 
1. Do one of the following to open the Properties dialog box of a panel or tag number: 

 In the Domain Explorer or Reference Explorer, right-click a desired panel and then click 
Properties. 

 In the Domain Explorer or Reference Explorer, right-click a desired instrument and then 
click Properties. 

2. On the General tab, select the Requires power supply check box. 
3. Click the Power Supply tab. 
4. Under Criticality, select the criticality, which is used in SmartPlant Electrical to determine 

whether the current instrument requires UPS power or regular power. 
5. Under Rated voltage, select a value that indicates the voltage at which the instrument is 

designed to operate. 
6. If the instrument is running on alternating current, under Power supply type click AC and do 

the following: 
a. Under Frequency, select the operating frequency of the instrument. 
b. Under Number of phases, select the number of phases in the power supply to the 

instrument. 
c. Under Power factor full load, enter a value between 0 and 1 for the ratio of active to 

apparent power at 100% of the rated power. 
7. If the instrument runs on direct current, under Power supply type, click DC. 
8. Under Rated active load, type the full load power consumption in kilowatts. 
9. Type the following values in amperes: 

a. Full load current. 
b. Starting current. 

10. In the Coincidence factors group box, do one of the following: 
 Under Operating mode, select Continuous, and under X — continuous, type a value 

between 0 and 1. 
 Under Operating mode, select Intermittent, and under Y — intermittent, type a value 

between 0 and 1. 
 Under Operating mode, select Spare, and under ZZ — spare, type a value between 0 

and 1 
 Under Operating mode, select Standby, and under Z — stand by, type a value between 

0 and 1. 
 The fields under Power distribution board data group box display data that is determined 

within SmartPlant Electrical.  On the Power Supply tab, click Help for more information. 
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Create a Rack 
This procedure deals with the creation of racks.  Since racks are panel child items, you can add a 
new rack under any panel except for device panels. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder.  Then, select a 

desired reference panel.  For more information, see Create a Reference Item. 
2. In the Domain Explorer, do one of the following: 

 Expand the Panels by Category folder to display all the panel category folders. 
 Expand the Panels by Location hierarchy to display the available locations and their 

panels.  Then, select a desired panel. 
3. In the Domain Explorer or in the Reference Explorer, right-click the selected panel and then 

click New > Rack. 
4. In the Rack Properties dialog box, on the General tab, do one of the following to define the 

name of the new panel: 
 Clear the Apply naming convention check box and under Rack, type the name of the 

new rack.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Rack. 

 Keep the Apply naming convention check box selected if you want the software to 
name the new panel automatically according to the naming conventions that are set for 
racks in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

5. In the Details group box, type a description and sequence as you require. 
6. Click Slots to add some slots for the current rack. 
7. In the Batch Slot Creation dialog box, type the number of new slots that you want to add in 

the new rack. 
8. Do the following to define the slot numbering: 
9. Type a prefix for the slot name. 
10. Enter a value in the Start from number and Increment by fields. 
11. Click OK and to add the new slots return to the Rack Properties dialog box. 

 In the Rack Properties dialog box, the software now displays the number of slots that 
you added. 

12. Click the Associate Symbols tab to associate a symbol with the current rack.  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

 When duplicating a rack that contains child items, the software duplicates the rack together 
with its child items. 
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Create a Slot 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder.  Then, select a 

desired reference panel.  For more information, see Create a Reference Item. 
2. In the Domain Explorer, do one of the following: 

 Expand the Panels by Category folder to display all the panel category folders. 
 Expand the Panels by Location hierarchy to display the available locations and their 

panels.  Then, select a desired panel. 
3. In the Domain Explorer or in the Reference Explorer, expand the hierarchy of a panel to 

display the existing racks. 
4. Right-click a rack and then click New > Slot. 
5. On the Slot Properties dialog box, enter the values for the new slot as you require and click 

OK. 
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S E C T I O N  6  

Device Panels and Cables 
This section describes the creation and management of device panels and device cables in 
SmartPlant Instrumentation. 

In This Section 
Device Panels in SmartPlant Instrumentation ............................... 49 
Principles of Creating Device Panels ............................................ 50 
Create an Instrument with an Automatically Configured Device Panel
 ....................................................................................................... 51 
Create an Instrument with a Manually Configured Device Panel .. 52 
Create an Instrument Without a Device Panel .............................. 54 
Create Device Panels and Cables in the Instrument Index Standard Browser 
View ............................................................................................... 55 
Create Device Panels for Selected Instruments ............................ 55 
Associate Instruments with Device Panels .................................... 57 
Dissociate Device Panels from Instruments .................................. 57 
Create a Device Cable ................................................................... 58 
Rename Device Cables in Batch Mode ......................................... 59 
 
 

Device Panels in SmartPlant Instrumentation 
A device panel in SmartPlant Instrumentation is a wiring item that has wiring and instrument tag 
information, for example transmitters, transducers, sensors, and so forth. 
Wiring information consists of a signal (a wire group), signal level, and signal sequence.  An 
instrument generates a signal which is carried through a group of wires.  These wires are 
connected to a device panel associated with that instrument.  The software propagates the signal 
through the wires on different levels.  Signal levels can be, for example, plus, minus, and 
shield.  A signal sequence is a method used by SmartPlant Instrumentation to assign numbers, in 
ascending or descending increments, to connection points along the signal propagation path at 
the same signal level. 
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The following diagram indicates how a device panel is associated with an instrument.  You may 
then continue the wiring routing as required. 

 
Each signal level defines a signal routing associated with a particular loop.  It is possible to have 
up to 99 levels within one signal. 
Note that SmartPlant Instrumentation automatically tracks signals and assigns the signal, signal 
level, and signal sequence values when you create a device panel. 
Also, if a device panel is a child item of another panel, the software does not duplicate the child 
device panel when duplicating the parent panel. 
 

Principles of Creating Device Panels 
SmartPlant Instrumentation offers the following options for device panel creation: 
 Creation of an individual device panel in the Domain Explorer.  This device panel will not be 

associated with any instrument and will not have a device cable. 
 Creation of a device panel for an existing instrument and configure its connection manually or 

automatically. 
 Creation of a new instrument with an associated device panel and device cable.  You can 

configure the connection automatically or manually as desired. 
SmartPlant Instrumentation provides you with an easy to use mechanism to create device panels 
and their wiring directly from the Instrument Index module.  Alternatively, you can create the 
connection information manually in the Device Panels window in the Wiring module, including the 
terminals, the cable, and the connections between them.  The Device Panels window can help 
create the connection information needed in most cases where a single cable is connected to the 
terminals of the instrument. 
Before creating a device panel with wiring information you need to define a number of reference 
items.  These reference items are the panel, cable, and connection type.  You can also define 
appropriate instrument type profiles that include wiring definitions.  When creating an instrument 
based on a defined instrument type profile, the software automatically checks if the instrument that 
is being added needs to have a device panel.  Based on the given default settings, the software 
will create the panel, the cable, and the connections between them.  Also, SmartPlant 
Instrumentation automatically propagates the signals and names the device panels and cables 
according to the appropriate naming conventions defined in the Administration module.  If no 
naming convention for device cables has been defined, the software names the cable after the 
instrument, when the name is prefixed with "C-". 
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Create an Instrument with an Automatically Configured 
Device Panel 

This option enables you to create a new instrument with an associated device panel and device 
cable.  In this case, SmartPlant Instrumentation automatically creates a device panel with a 
device cable and automatically configures the required connection.  SmartPlant Instrumentation 
does not prompt you to select a reference panel, reference cable, or a connection type.  The 
software selects the default configuration for the new device panel, device cable, and connection 
type that you have defined in the Wiring and I/O Profile group box of the Instrument Type 
Profile dialog box in the Instrument Index module.  The new device panel will have the same 
name as the new instrument.  SmartPlant Instrumentation will create the new instrument 
according to the wiring profile defined for it in the Instrument Index module.  Make sure that you 
set and activate all the required instrument type profiles before you start creating new instruments. 
1. Activate the instrument type profile default settings as follows: 

a. Click File > Preferences. 
b. In the tree view pane, to expand the tree, click  beside Instrument Index. 
c. Click Profile. 
d. Under Activate instrument type profile options, select the Wiring check box. 
e. Click OK 

2. In the Wiring Module window, do one of the following: 

 Click . 
 On the menu bar click Actions > Device Panels. 

3. In the Device Panels window, clear the Manual configuration check box. 
4. Do one of the following: 

 Click . 
 On the menu bar click Actions > New Tag. 

5. In the New Tag Number dialog box, do the following: 
a. From the Tag class list, select the desired tag class according to whether you want to 

create a conventional instrument, Foundation Fieldbus instrument, HART instrument, 
Telecom instrument, and so forth. 

b. Type the name of the new instrument.  If needed, it is possible for instruments and device 
panels to have the same names.  Make sure that you follow the naming conventions for 
new tag numbers.  For details, see Instrument Tag Naming Convention. 

c. Click OK to create the instrument. 
d. If more than one function identifier exists for the current instrument type acronym, on the 

Select Instrument Type dialog box, select the appropriate instrument type, and then, 
click OK. 

 
 If the instrument name does not correspond to an existing loop name, SmartPlant 

Instrumentation prompts you to enter a loop name based on the tag number you have 
entered.  The software automatically associates the new instrument with the loop if the 
loop identifier already matches an existing loop. 
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 If the loop convention includes the loop function parameter, the prompt always 
appears.  In this case, you have to complete the loop number.  If a profile exists for the 
selected instrument type, the software creates the new instruments for that instrument 
type according to the selected reference items.  For details, see Define an Instrument 
Type Profile. 

6. In the Loop Name dialog box, do one of the following: 
 Type the loop number name that the new instrument will be associated with. 
 Accept the displayed value to create a new loop with this name. 

7. In the Loop Name dialog box, do one of the following: 
 Click OK to create the new loop number. 
 Click Cancel to create the new instrument without a loop association. 

8. On the Tag Number Properties dialog box, edit the instrument properties as you require and 
click OK. 

 The software adds the new instrument to the list of instruments in the Device Panels 
window.  Also, you can see the new instrument in the Instruments folder of the Domain 
Explorer. 
 

Create an Instrument with a Manually Configured Device 
Panel 

You use this option to create a new instrument with an associated device panel and device 
cable.  In this case, SmartPlant Instrumentation creates a device panel and a device cable and 
lets you manually configure the required connection.  The software prompts you to select a 
reference device panel and reference cable that will be used to create the new device panel and 
cable.  SmartPlant Instrumentation copies the definitions for the new device panel and cable from 
the selected reference panel and cable that you defined in the Reference Explorer.  You can 
also select an existing connection type and you can name the new device panel as you 
require.  SmartPlant Instrumentation creates the new instruments according to the wiring profile 
that you defined in the Instrument Index module.  Make sure that you set and activate all the 
required instrument type profiles before you start creating new instruments. 
1. Activate the instrument type profile default settings as follows: 

a. Click File > Preferences. 
b. In the tree view pane, to expand the tree, click  beside Instrument Index. 
c. Click Profile. 
d. Under Activate instrument type profile options, select the Wiring check box. 
e. Click OK 

2. In the Wiring Module window, do one of the following: 

 Click . 
 On the menu bar click Actions > Device Panels. 

3. In the Device Panels window, select the Manual configuration check box. 
4. Do one of the following: 

 Click . 
 On the menu bar click Actions > New Tag. 

5. On the New Tag Number dialog box, do the following: 
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a. From the Tag class list, select the desired tag class according to whether you want to 
create a conventional instrument, Foundation Fieldbus instrument, HART instrument, 
Telecom instrument, and so forth. 

b. Type the name of the new instrument.  If needed, it is possible for instruments and device 
panels to have the same names.  Make sure that you follow the naming conventions for 
new tag numbers.  For details, see Instrument Tag Naming Convention. 

c. Click OK to create the instrument. 
d. If more than one function identifier exists for the current instrument type acronym, on the 

Select Instrument Type dialog box, select the appropriate instrument type, and then, 
click OK. 

 
 If the instrument name does not correspond to an existing loop name, SmartPlant 

Instrumentation prompts you to enter a loop name based on the tag number you have 
entered.  The software automatically associates the new instrument with the loop if the 
loop identifier already matches an existing loop. 

 If the loop convention includes the loop function parameter, the prompt always 
appears.  In this case, you have to complete the loop number.  If a profile exists for the 
selected instrument type, the software creates the new instruments for that instrument 
type according to the selected reference items   For details, see Define an Instrument 
Type Profile. 

6. In the Loop Name dialog box, do one of the following: 
 Type the loop number name that the new instrument will be associated with. 
 Accept the displayed value to create a new loop with this name. 

7. In the Loop Name dialog box, do one of the following: 
 Click OK to create the new loop number. 
 Click Cancel to create the new instrument without a loop association. 

8. On the Create Device Panel and Cable dialog box, under Device panel, accept or the 
displayed name of the device panel that will be created with the current instrument. 

 The Create Device Panel and Cable dialog box opens only if the instrument that you 
are creating is based on an instrument type profile that has at least partial wiring definitions. 

9. From the Reference device panel list, select a reference device panel that you want to use 
as a basis for the new device panel. 

 
 The displayed reference panel is the one that you defined in the Instrument Index module, 

in the Instrument Type Profile dialog box, under Wiring and I/O Profile. 
 The properties of the reference panel that you select determine whether one or both of the 

Conventional connections and Plug-and-socket connections group boxes are 
enabled, and the values that are initially displayed. 

10. In the active group boxes, to define the device cables, do the following as necessary: 
 To modify the properties of a selected device cable connection, click Properties, and in 

the dialog box that opens, change the values as necessary. 
 To add an additional device cable connection, click New, and in the dialog box that opens, 

enter the appropriate values. 
 To delete selected cable connections, click Delete. 

11. Click OK to complete the process. 
12. On the Tag Number Properties dialog box, edit the instrument properties as you require and 

click OK. 
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 The new device panel appears next to the selected instrument in the Device Panels 

window.  SmartPlant Instrumentation displays a cable icon  next to the new device cable 
indicating that a device cable is connected to it. 
 

Create an Instrument Without a Device Panel 
This option enables you to create a new instrument in the Device Panels window without creating 
a device panel or  device cable.  You can then select an existing device panel and associate it 
with the new instrument.  You can also create a new device panel for the new instrument if 
needed.  Note that SmartPlant Instrumentation creates the new instrument according to the 
wiring profile defined for it in the Instrument Index module.  Make sure that you set all the required 
instrument type profiles before you start creating new instruments. 
1. Deactivate the instrument type profile default settings as follows: 

a. Click File > Preferences. 
b. In the tree view pane, to expand the tree, click  beside Instrument Index. 
c. Click Profile. 
d. Under Activate instrument type profile options, clear the Wiring check box. 
e. Click OK 

2. In the Wiring Module window, do one of the following: 

 Click . 
 On the menu bar click Actions > Device Panels. 

3. In the Device Panels window, do one of the following: 

 Click . 
 On the menu bar click Actions > New Tag. 

4. In the New Tag Number dialog box, do the following: 
5. From the Tag class list, select the desired tag class according to whether you want to create 

a conventional instrument, Foundation Fieldbus instrument, HART instrument, Telecom 
instrument, and so forth. 

6. Type the name of the new instrument.  If needed, it is possible for instruments and device 
panels to have the same names.  make sure that you follow the naming conventions for new 
tag numbers.  For details, see Instrument Tag Naming Convention. 

7. Click OK to create the instrument. 
8. If more than one function identifier exists for the current instrument type acronym, on the 

Select Instrument Type dialog box, select the appropriate instrument type, and then, click 
OK. 

 
 If the instrument name does not correspond to an existing loop name, SmartPlant 

Instrumentation prompts you to enter a loop name based on the tag number you have 
entered.  The software automatically associates the new instrument with the loop if the 
loop identifier already matches an existing loop 

 If the loop convention includes the loop function parameter, the prompt always 
appears.  In this case, you have to complete the loop number.  If a profile exists for the 
selected instrument type, the software creates the new instruments for that instrument 
type according to the selected reference items   For details, see Define an Instrument 
Type Profile. 

9. In the Loop Name dialog box, do one of the following: 
 Type the loop number name that the new instrument will be associated with. 
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 Accept the displayed value to create a new loop with this name. 
10. In the Loop Name dialog box, do one of the following: 

 Click OK to create the new loop number. 
 Click Cancel to create the new instrument without a loop association. 

11. On the Tag Number Properties dialog box, edit the instrument properties as you require and 
click OK. 

 The software adds the new instrument to the list of instruments in the Device Panels 
window.  Also, you can see the new instrument in the Instruments folder of the Domain 
Explorer. 
 

Create Device Panels and Cables in the Instrument Index 
Standard Browser View 

This procedure shows you how to create a device panel with a device cable in the Instrument 
Index standard browser. 
1. In the Instrument Index Module window, do one of the following to open the Instrument 

Index Standard Browser view: 
 On the menu bar, click Actions > Standard Browser View. 

 On the toolbar, click  
2. Select the desired tag numbers. 
3. Do one of the following: 

 Right-click, and on the shortcut menu, click Apply Profile > Create Device Panel and 
Cable. 

 On the Actions menu, click Apply Profile > Create Device Panel and Cable. 
4. On the Results dialog box, view the propagation results, and then click Close. 

 To make this feature work, you must select the Create wiring check box and choose a 
reference device panel on the Wiring and Control System tab in the instrument type profile of 
the selected tag number before you attempt to create a new device panel.  You can also select a 
reference device cable if you want SmartPlant Instrumentation to create device cables with the 
device panels.  For more details, see Define an Instrument Type. 
 

Create Device Panels for Selected Instruments 
This option enables you to create device panels associated with selected a instruments.  This 
process also includes the creation of the required device cables that will be connected to the new 
device panels.  You can let SmartPlant Instrumentation configure the connection for you or you 
can choose the manual configuration option that allows you to configure the connection: 
 Automatic configuration — the software creates a device panel, a device cable, and 

automatically configures the required connection for you.  SmartPlant Instrumentation does 
not prompt you to select a reference panel, reference cable, or a connection type.  Instead, 
the software selects the reference configuration for the new device panel, device cable, and 
connection type that you have defined in the Wiring and I/O Profile group box of the 
Instrument Type Profile dialog box in the Instrument Index module.  The new device panel 
will have the same name as the new instrument.  Make sure that you set and activate all the 
required instrument type profiles before you start creating new instruments. 
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 Manual configuration — SmartPlant Instrumentation creates a device panel and a device 
cable and lets you manually configure the required connection.  The software prompts you to 
select a reference panel and reference cable that will be used to create the new device panel 
and cable.  SmartPlant Instrumentation copies the definitions for the new device panel and 
cable from the selected reference panel and cable that you defined in the Reference 
Explorer.  You can also select an existing connection type and name the new device panel as 
needed. 

1. In the Wiring Module window, do one of the following: 

 Click . 
 On the menu bar click Actions > Device Panels. 

2. In the Device Panels window, do one of the following: 
 Select the Manual configuration check box to define the device panel and cable 

manually. 
 Clear the Manual configuration check box to define the device panel and cable 

automatically. 

3. On the menu bar, click Actions > New Tag or click  on the toolbar. 
4. Select the instruments for which you want to create device panels and cables.  You can use 

the Ctrl and Shift keys to select multiple instruments. 
5. On the menu bar click Actions > Create. 

 
 If you cleared the Manual configuration check box, SmartPlant Instrumentation creates 

and configures the device panel automatically.  The creation process ends at this point 
and the new device panels appear next to the selected instruments in the Device Panels 

window.  The software displays a cable icon  next to the new device panel 
indicating that a device cable is connected to it. 

 If you selected the Manual configuration check box, the creation process continues. 
6. On the Create Device Panel and Cable dialog box, under Device panel, accept the 

displayed name of the device panel that will be created with the current instrument. 
 The Create Device Panel and Cable dialog box opens only if the instrument that you 

are creating is based on an instrument type profile that has at least partial wiring definitions. 
7. From the Reference device panel list, select a reference device panel that you want to use 

as a basis for the new device panel. 

 
 The displayed reference panel is the one that you defined in the Instrument Index module, 

in the Instrument Type Profile dialog box, under Wiring and I/O Profile. 
 The properties of the reference panel that you select determine whether one or both of the 

Conventional connections and Plug-and-socket connections group boxes are 
enabled, and the values that are initially displayed. 

8. In the active group boxes, to define the device cables, do the following as necessary: 
 To modify the properties of a selected device cable connection, click Properties, and in 

the dialog box that opens, change the values as necessary. 
 To add an additional device cable connection, click New, and in the dialog box that opens, 

enter the appropriate values. 
 To delete selected cable connections, click Delete. 

9. To apply the values that you set to the selected instruments with incomplete wiring profiles, 
select Apply to all selected instruments with incomplete profile. 



 Wiring in SmartPlant Instrumentation 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 57 
 

 You can also create device panels and cables for selected instruments in the Instrument 
Index Standard Browser view.  For details, see Create Device Panels and Cables in the 
Instrument Index Standard Browser View (on page 55). 
 

Associate Instruments with Device Panels 
This option enables you to associate an instrument with a device panel.  This feature is useful 
when, for instance, you create a number of device panels in the Domain Explorer by copying a 
reference item from the Reference Explorer.  The device panels you create in the Domain 
Explorer are not associated with any instruments and they are not connected to device cables.  A 
device panel must be associated with an instrument before you can create a device cable for it. 
1. In the Wiring Module window, do one of the following: 

 Click . 
 On the menu bar click Actions > Device Panels. 

2. In the Device Panels window, select the Manual configuration check box. 
3. In the Device Panels window, select the instruments you require and then do one of the 

following: 

 Click . 
 On the menu bar, click Actions > Associate. 

4. On the Select Device Panels dialog box, select the appropriate device panels. 
5. Click OK. 

 The new device panel appears next to the selected instrument in the Device Panels 
window.  You can now create a device cable for these panels. 
 

Dissociate Device Panels from Instruments 
This feature enables you to dissociate an instrument from a device panel.  When carrying out this 
procedure, SmartPlant Instrumentation automatically disconnects single cables belonging to the 
dissociated device panels.  Furthermore, the software renames the disconnected cables to '?–' 
plus <name>.  For example, a cable named 'C–FT –2221' is renamed to '?–C–FT –2221'. 
SmartPlant Instrumentation renames the cable to draw your attention to the fact that the cable is 
not connected to any device.  In addition, the software renames the wires to SPARE throughout 
the signal run. 
1. In the Wiring Module window, do one of the following: 

 Click . 
 On the menu bar click Actions > Device Panels. 

2. In the Device Panels window, select the instruments you require and then do one of the 
following: 

 Click . 
 On the menu bar, click Actions > Dissociate. 
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Create a Device Cable 
You use this option to create a new device cable and connect it to a selected device panel.  This 
feature is useful when you created a device panel in the Domain Explorer, associated it with an 
instrument in the Device Panels window, but have not yet defined a device cable for it.  You can 
configure the cable and its connection type manually or you can let SmartPlant Instrumentation 
select the reference cable and connection type automatically. 
1. In the Wiring Module window, do one of the following: 

 Click . 
 On the menu bar click Actions > Device Panels. 

2. In the Device Panels window, do one of the following: 
 Select the Manual configuration check box to define the device panel and cable 

manually. 
 Clear the Manual configuration check box to define the device panel and cable 

automatically. 
3. Select the required device panel – instrument associations for which you want to create 

device cables. 
4. On the menu bar, click Actions > Create. 

 
 If you cleared the Manual configuration check box, SmartPlant Instrumentation creates 

and configures the device panel automatically.  The creation process ends at this point 
and the new device panels appear next to the selected instruments in the Device Panels 

window.  The software displays a cable icon  next to the new device panel 
indicating that a device cable is connected to it. 

 If you selected the Manual configuration check box, the creation process continues. 
5. On the Create Device Panel and Cable dialog box, in the active group box ( Conventional 

connections or Plug-and-socket connections) do the following for each device panel 
associated with an instrument: 
a. Click New. 
b. On the dialog box that opens, enter the appropriate values. 
c. Click OK. 

6. On the Create Device Panel and Cable dialog box, click OK. 
 The new device cable appears in the Device Panels window next to the selected 

instrument. 
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Rename Device Cables in Batch Mode 
This option enables you to select a panel with device cables (cables connecting a device panel 
and any other panel) and rename all the device panel cables connected to this panel in batch 
mode. 
1. In the Domain Explorer, expand the Panels by Location or Panels by Category folder. 
2. Right-click a junction box in the tree view or select several junction boxes in the Items pane 

and then right-click them. 
3. On the shortcut menu, click Actions > Rename Device Cables. 
4. On the Rename tab of the Rename Device Cables dialog box, select the check boxes next to 

the cables that you want to rename or choose the Select All check box to select all the cables 
displayed in the data window. 

5. Click the Convention tab to define the cable name template, that is, the rules how the cable 
names will change. 

 If a name template has been defined, it is displayed in the Current Convention field. 
6. Insert and define as many conventions as required. 
7. Select the Use as default check box to use the convention row definitions as your default 

naming conventions. 
8. Click Apply when done. 

 You can modify the device panel name according to your needs.  Device cable names are, 
however, not editable in this dialog box.  You can rename device cables in the Domain Explorer. 
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S E C T I O N  7  

Wiring Equipment and Apparatus 
This section describes the creation and management of wiring equipment and apparatuses. 

In This Section 
Wiring Equipment .......................................................................... 61 
Customize and Use Wiring Equipment Categories ....................... 62 
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Create a Wiring Equipment Item ................................................... 64 
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Create an I/O Termination ............................................................. 70 
Customize the Controller/Processor List Header in I/O Card Properties
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Associate an I/O card with an I/O Termination .............................. 72 
Apparatus....................................................................................... 73 
Define an Apparatus Configuration ............................................... 73 
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Add an Apparatus to an Apparatus Group .................................... 76 
Edit Apparatus Terminal Properties ............................................... 76 
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Modify the Internal Links of a Plug-and-Socket Group .................. 79 
 
 

Wiring Equipment 
SmartPlant Instrumentation enables you to create and manage various types of wiring 
equipment.  Wiring equipment is a generic name for different termination objects that can handle 
multiple input and output signals (channels).  These items need an external power supply and 
they usually have several terminals to feed the electronic components.  Examples of wiring 
equipment are barriers, isolators, trip amplifiers, relays, and so forth.  I/O cards, I/O termination 
items, and various terminal strips also belong to the group called wiring equipment. 
Prior to Version 7, SmartPlant Instrumentation provided for this type of objects only by letting you 
create an apparatus.  However, apparatus did not deal with certain aspects of wiring equipment 
such as electric properties.  Apparatus provided a "flat" structure that could only group terminals 
on an apparatus strip under a position name.  Wiring equipment, however, introduces a 
structured object which you can remove, add, and copy.  You can accurately define wiring 
equipment properties such as category, manufacturer, model, and so forth. 

 When copying wiring equipment that has associated with it a plug-and-socket group, 
the Wiring preferences > Copy Items > Duplicate jumpers must be selected for the internal links to 
be copied along with the plug-and-socket group. 
Wiring equipment is a much wider feature which allows you to create various types of termination 
objects and define their electric properties.  You can use wiring equipment whenever you need to 
define any type of card, or piece of hardware that you need to buy separately, count the number of 
units you need (BOM), install it inside a panel, and make connections 
SmartPlant Instrumentation enables you to create and manage wiring equipment items that: 
 Contain various terminal strips or combination of terminal strips. 
 Serve multiple tags or channels. 
 Contain terminal strips and connectors. 
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 Require custom properties for each wiring equipment category. 
 Require a specific presentation using special custom symbols. 

Wiring equipment items are classified according to various categories.  SmartPlant 
Instrumentation is shipped with a number of these categories.  You can customize your own 
wiring equipment categories and create various wiring equipment items belonging to these 
customized categories.  For more information, see the following: 
 Customize and Use Wiring Equipment Categories (on page 62) 
 Add User-Defined Wiring Equipment Category Properties (on page 63) 

When designing a Foundation Fieldbus or Profibus system, you can create a wiring equipment 
item belonging to the fieldbus brick category.  Then, under a fieldbus brick you can add a fieldbus 
apparatus.  This compound object provides for the creation and management of fieldbus 
termination objects required for your Foundation Fieldbus or Profibus system.  For details, see 
Fieldbus Bricks (on page 194). 
Also, note the following features of wiring equipment: 
 Wiring equipment can encapsulate multiple objects, terminal strips, and channels. 
 Since every wiring equipment is a separate item , the Connection window cannot display 

multiple objects as it does for an apparatus strip.  Nor is it possible to connect a cable to 
multiple wiring equipment items in one step. 

 Using wiring equipment in combination with custom symbols provides for a better 
representation of loop drawings. 

 Wiring equipment information does not appear in loop drawing generation.  In most cases, it is 
possible to add macros and retrieve information or use custom symbols. 

 Wiring reports do not show wiring equipment.  All reports continue to show panels, terminal 
strips, and terminals. 

 Wiring equipment can be displayed in cable block diagrams. 
 Wiring equipment can be placed under other wiring equipment. 

 

Customize and Use Wiring Equipment Categories 
SmartPlant Instrumentation provides you with a number of predefined wiring equipment 
categories.  However, you can also customize your own wiring equipment categories for wiring 
items that do not belong to any existing categories. 
This procedure explains how to customize a wiring equipment category and add a customized 
property to a category.  Note that some of the shipped wiring equipment categories have 
predefined properties.  You can add your own customized properties to the shipped categories as 
well as to the customized ones. 
After customizing a new wiring equipment category, it becomes available in the Categories list of 
the New Wiring Equipment dialog box and you can create new wiring equipment items belonging 
to this category.  
1. On the Wiring module menu bar, click Tables > Wiring Equipment > Categories. 
2. In the Wiring Equipment Category dialog box, click New. 
3. In the New Wiring Equipment Category dialog box, type a category name and description. 
4. To select a user-defined icon for the current wiring equipment category, under Icon file name, 

click Browse to navigate to the icon file that you require. 
 The icon that you select will appear in the Domain Explorer or the Reference Explorer 

next to each wiring equipment item belonging to the current category. 
5. In the Properties group box, click Add. 
6. Under Header, type the text that will appear as the property name on the Category 

Properties tab of the appropriate wiring equipment properties dialog box. 
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7. From the Type list, select the type of value for the new customized category property.  You 
will then be able to enter a value for this new property on the Category Properties tab of the 
appropriate wiring equipment properties dialog box.  The values can be numeric, text, or 
date/time. 

8. Do one of the following: 
 Click Add to define another new property. 
 Click OK to accept your definitions and close this dialog box. 

9. Create a new wiring equipment item . 
 In the Domain Explorer, right-click a panel or a panel child item, and then on the 

shortcut menu, click New > Wiring Equipment. 
10. In the New Wiring Equipment dialog box, from the Category list, select the newly created 

category, type the wiring equipment item name, and click OK. 
11. On the General tab of the Properties dialog box, define wring equipment properties as you 

require and click the Category Properties tab. 
12. On the Category Properties tab, enter the values for each property as you require, 
13. Continue defining the properties of the new wiring equipment item as you need. 

 The software does not allow you to delete or rename the shipped wiring equipment 
categories.  Nor can you delete or rename any of the predefined properties belonging to the 
shipped wiring equipment categories. 
 

Add User-Defined Wiring Equipment Category Properties 
This feature allows you to add user-defined properties to existing wiring equipment 
categories.  This option applies to the user-defined categories as well as to those that have been 
supplied with SmartPlant Instrumentation. 
1. On the Wiring module menu bar, click Tables > Wiring Equipment > Categories. 
2. In the Wiring Equipment Category dialog box, select a category and click Properties. 
3. To select a user-defined icon for the current wiring equipment category, under Icon file name, 

click Browse to navigate to the icon file that you require. 
 The icon that you select will appear in the Domain Explorer or the Reference Explorer 

next to each wiring equipment item belonging to the current category. 
4. In the Wiring Equipment Category Properties dialog box click Add. 
5. Under Header, type the text that will appear as the property name on the Category 

Properties tab of the appropriate wiring equipment properties dialog box. 
6. From the Type list, select the type of value for the new customized category property.  You 

will then be able to enter a value for this new property on the Category Properties tab of the 
appropriate wiring equipment properties dialog box.  The values can be numeric, text, or 
date/time. 

7. Do one of the following: 
 Click Add to define another new property. 
 Click OK to accept your definitions and close this dialog box. 

 
 You cannot delete or rename any of the predefined properties belonging to the shipped wiring 

equipment categories. 
 After adding a category property, it becomes available on the Category Properties tab of the 

appropriate wiring equipment properties dialog box. 
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Create a Wiring Equipment Item 
This procedure explains how to create a wiring equipment item that belongs to any wiring 
equipment category except for I/O cards and I/O terminations. 
You can create new wiring equipment items either in the Domain Explorer or the Reference 
Explorer.  If you are creating a wiring equipment item that is going to have a frequently used 
configuration, we recommend that you create it in the Reference Explorer.  Reference wiring 
equipment items facilitate fast creation of plant items by copying an existing wiring equipment item 
from the Reference Explorer to the Domain Explorer.  However, if you want to create a wiring 
equipment item that does not have a configuration that you intend to use frequently, we 
recommend that you create it in the Domain Explorer and in the <unit> where it is to be physically 
located.  This is helpful when filtering the wiring equipment items in the current <unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder. 

2. In the Domain Explorer, do one of the following: 
 Expand the Panels by Category folder and navigate to a wiring item under which you 

want to create a new wiring equipment item . 
 Expand the Panels by Location folder and navigate to a wiring item under which you 

want to create a new wiring equipment item . 
 There is a lot of flexibility in creating a wiring hierarchy in SmartPlant 

Instrumentation.  There is no rigid structure like "panel – terminal strip – terminal" that limits 
your wiring design.  Therefore, you can create wiring equipment items under various types of 
items.  To see examples of possible wiring hierarchy structures, see Hierarchy Examples of 
Wiring Items (see "Wiring Items Hierarchy Examples" on page 65). 

3. Right-click a wiring item under which you want to create new wiring equipment and then on 
the shortcut menu, click New > Wiring Equipment. 

4. In the New Wiring Equipment dialog box, from the Category list, select a category to which 
the new item belongs. 

5. Under Name, type the name of the item and click OK. 
6. In the Wiring Equipment Properties dialog box, on the General tab, do one of the following 

to define the name of the new equipment: 
 Select the Apply naming convention check box selected if you want the software to 

name the new equipment automatically according to the naming conventions that are set 
for this type of equipment in the Administration module.  For more information, see 
SmartPlant Instrumentation Administration Help, Domain Administration > Naming 
Conventions. 

 Clear the Apply naming convention check box and under Name, type the name of the 
new equipment.  Note that if you do not clear the Apply naming convention check box, 
the software will ignore the name that you type under Name. 

7. Select the Double width check box if the item occupies a double width slot. 
8. In the Details group box do the following as you require: 

a. Type a description. 
b. Select an item type, model, and manufacturer.  If the required value is not available on the 

list, click  to define a new one. 
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c. Enter a sequence if you need to define the sequence of the new item in its parent item 
.  This sequence also determines the order in which wiring items appear under their 
parent item in the Domain Explorer tree view. 

9. Click the Category Properties tab. 
 If you are creating a miscellaneous wiring equipment item , the Category Properties tab 

is not available. 
10. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 Wiring equipment categories that are shipped with SmartPlant Instrumentation have 

predefined properties.  You cannot delete or rename any of these categories or their 
properties.  You can only edit their values.  However, you can add user-defined properties to 
any category which you can rename or delete as you wish.  For details, see Customize and 
Use Wiring Equipment Categories (on page 62). 

11. Click the Associate Symbols tab to associate a symbol with the current item .  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

12. Click OK to accept your settings and close the dialog box. 
 

Wiring Items Hierarchy Examples 
There is a lot of flexibility in creating a wiring hierarchy in SmartPlant Instrumentation.  There is no 
rigid structure like "panel - terminal strip - terminal" that limits your wiring design.  Therefore, you 
can create wiring equipment items under various types of items. 
Example 1: 

 
Example 2: 
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Example 3: 

 
Example 4: 

 
Example 5: 
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Example 6: 

 
Example 7: 
This example shows the wiring items that can exist in the Panels by Location folder. 

 
Example 8: 
This example shows the items that can exist in the Cables folder. 

 
For a better understanding of the Domain Explorer, see Working with the Domain Explorer. 
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Create an I/O Card 
As a rule, I/O cards reside in slots.  Therefore, you have to navigate to a particular rack and select 
a slot where you want to create a new I/O card.  Note that I/O cards may or may not have built-in 
termination blocks.  If an I/O card does not have a built-in termination block, you need to 
associate it with an I/O termination.  To define an I/O card that has a built-in termination block, 
create an I/O card and then add a terminal strip with channels under this I/O card.  For an I/O card 
with a built-in terminal block, you need to create a terminal strip with channels under an I/O card to 
be able to effect I/O assignment and make connections. 
You can create new I/O cards either in the Domain Explorer or the Reference Explorer.  If you 
are creating an I/O card that is going to have a frequently used configuration, we recommend that 
you create it in the Reference Explorer.  Reference I/O cards facilitate fast creation of plant I/O 
cards by copying an existing item from the Reference Explorer to the Domain 
Explorer.  However, if you want to create an I/O card that does not have a configuration that you 
intend to use frequently, we recommend that you create it in the Domain Explorer and in the 
<unit> where it is to be physically located.  This is helpful when filtering I/O cards in the current 
<unit>. 
1. Press F7 to open the Domain Explorer. 
2. In the Domain Explorer, do one of the following: 

 Expand the Panels by Category folder and navigate to a wiring item under which you 
want to create a new I/O card. 

 Expand the Panels by Location folder and navigate to a wiring item under which you 
want to create a new I/O card. 

3. Double-click a panel and then a rack till you see the existing slots. 
 As a rule, I/O cards reside in rack slots.  Therefore, you have to navigate to a slot where 

you want to create an I/O card.  However, SmartPlant Instrumentation allows the creation of 
flexible wiring hierarchies and therefore you can add I/O cards to a number of various item 
types.  To see examples of possible wiring hierarchy structures, see Hierarchy Examples of 
Wiring Items (see "Wiring Items Hierarchy Examples" on page 65). 

4. Right-click a slot or any other wiring item under which you want the new card reside and then 
on the shortcut menu, click New > Wiring Equipment. 

5. In the New Wiring Equipment dialog box, from the Category list, select I/O Card. 
6. Under Name, type the name of the new I/O card and click OK. 
7. In the Wiring Equipment Properties – I/O Card dialog box, on the General tab, do one of 

the following to define the name of the new card: 
 Select the Apply naming convention check box selected if you want the software to 

name the new card automatically according to the naming conventions that are set for this 
type of equipment in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

 Clear the Apply naming convention check box and under Name, type the name of the 
new card.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Name. 

8. Select the Double width check box if the card occupies a double width slot. 
9. In the Details group box do the following as you require: 

a. Type a description. 
b. Select an I/O card type, model, and manufacturer.  If the required value is not available on 

the list, click  to define a new one. 
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c. Enter a sequence if you need to define the sequence of the new card in its parent item 
.  This sequence also determines the order in which wiring items appear under their 
parent item in the Domain Explorer tree view. 

10. Click the Control System tab. 
11. In the Control system details group box, under I/O type, select a I/O type to determine the 

actual function of the new I/O card.  For example, AI, AO, DI, DP, Fieldbus, Profibus, and so 
forth.  You can add more values to this list in the I/O Type supporting table in the Instrument 
Index module.  (See the important notes at the end of this procedure.) 

12. Under Module, type the software address that this card is assigned to. 
 Module, Controller/ Processor, Rack, and Slot are field headers specific to panel 

manufacturers.  Selecting a different manufacturer when editing the panel displays the 
headings used by that panel manufacturer.  For details, see Customize the 
Controller/Processor List Header in I/O Card Properties (on page 71). 

13. From the Controller/Processor list, select an I/O card controller.  If the required controller is 

not available on the list, click  to define a new one. 
14. To view the list of all I/O terminations associated with the current I/O card, click the I/O 

Terminations button. 
15. Click the Category Properties tab. 
16. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 I/O card is a wiring equipment category that is shipped with SmartPlant 

Instrumentation.  You cannot delete or rename any of the wiring equipment categories that 
have been shipped with the software.  Nor can you delete or rename the properties of the 
shipped categories.  However, when editing I/O card properties, you can add user-defined 
properties which you can rename or delete as you wish.  For details, see Customize and Use 
Wiring Equipment Categories (on page 62). 

17. Click the Associate Symbols tab to associate a symbol with the current I/O cards.  The 
software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

18. Click OK to accept your settings and close the dialog box. 

 
 In a redundant system configuration, an I/O card can function as a primary or secondary I/O 

card and can be associated with several I/O terminations.  Therefore, an I/O termination can 
serve multi-paired redundant I/O cards.  However, in these redundant I/O card configurations, 
the I/O termination can be associated only with one pair of primary and secondary I/O 
cards.  Also, an I/O card cannot function as both a primary and secondary I/O card for the 
same I/O termination. 

 If an I/O card functions as a primary I/O card, the Control System tab of the Wiring 
Equipment Properties – I/O Card dialog box displays the secondary I/O card data and the 
primary I/O card data properties remain blank.  If an I/O card functions as a secondary I/O 
card, the Control System tab displays the primary I/O card data and the secondary I/O card 
data properties remain blank. 
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Create an I/O Termination 
I/O terminations are wiring equipment items that are used to connect I/O cards and other wiring 
items that do not have built-in termination blocks.  You associate an I/O termination with an I/O 
card that does not have a built-in termination block and then make the required connections to the 
I/O termination.  You can also associate an I/O termination with several I/O cards if there are 
redundant I/O cards. 
Also, you can create an I/O termination when you need to define a distant I/O card that resides in 
a different panel or rack.  You need to create a terminal strip with channels under an I/O 
termination to be able to effect I/O assignment and make connections. 
You can create new I/O termination cards either in the Domain Explorer or the Reference 
Explorer.  If you are creating an item that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference items facilitate fast creation 
of plant items by copying an existing item from the Reference Explorer to the Domain 
Explorer.  However, if you want to create an I/O termination that does not have a configuration 
that you intend to use frequently, we recommend that you create it in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the wiring equipment 
items in the current <unit>. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder. 

2. In the Domain Explorer, do one of the following: 
 Expand the Panels by Category folder and navigate to a wiring item under which you 

want to create a new I/O termination. 
 Expand the Panels by Location folder and navigate to a wiring item under which you 

want to create a new I/O termination. 
3. Double-click a panel and then a rack till you see the existing slots. 

 As a rule, I/O terminations reside in DCS panels or marshaling racks.  However, 
SmartPlant Instrumentation allows to create flexible wiring hierarchies and therefore you can 
add I/O terminations to a number of various item types.  To see examples of possible wiring 
hierarchy structures, see Hierarchy Examples of Wiring Items (see "Wiring Items Hierarchy 
Examples" on page 65). 

4. Right-click a slot or any other wiring item under which you want the new card reside and then 
on the shortcut menu, click New > Wiring Equipment. 

5. In the New Wiring Equipment dialog box, from the Category list, select I/O Termination. 
6. Under Name, type the name of the new I/O termination and click OK. 
7. In the Wiring Equipment Properties – I/O Termination dialog box, on the General tab, do 

one of the following to define the name of the new card: 
 Select the Apply naming convention check box selected if you want the software to 

name the new card automatically according to the naming conventions that are set for this 
type of equipment in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

 Clear the Apply naming convention check box and under Name, type the name of the 
new card.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Name. 

8. Select the Double width check box if the card occupies a double width slot. 
9. In the Details group box do the following as you require: 

a. Type a description. 
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b. Select an I/O termination type, model, and manufacturer.  If the required value is not 

available on the list, click  to define a new one. 
c. Enter a sequence if you need to define the sequence of the new I/O termination in its 

parent item .  This sequence also determines the order in which wiring items appear 
under their parent item in the Domain Explorer tree view. 

10. Click the Control System tab. 
11. From the I/O type list, select a I/O type to determine the actual function of the new I/O 

termination.  For example, AI, AO, DI, DP, Fieldbus, Profibus, and so forth.  You can add 
more values to this list in the I/O Type supporting table in the Instrument Index module. 

12. To associate the current I/O termination with an I/O card that does not have a built-in 
termination block, select the required options in the Primary I/O card group box. 

 The I/O card list contains only those I/O cards that have been created under a rack and 
a slot.  For more information, see Associate an I/O card with an I/O Termination (on page 72). 

13. To define the current I/O termination as an I/O termination that serves two redundant I/O 
cards, do the following: 
a. Select the Define a redundant I/O card check box. 
b. Select the required options in the Secondary I/O card group box. 

14. Click the Category Properties tab. 
15. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
I/O termination is a wiring equipment category that is shipped with SmartPlant 

Instrumentation.  You cannot delete or rename any of the wiring equipment categories that 
have been shipped with the software.  Nor can you delete or rename the properties of the 
shipped categories.  However, when editing I/O termination properties, you can add 
user-defined properties which you can rename or delete as you wish.  For details, see 
Customize and Use Wiring Equipment Categories (on page 62). 

16. Click the Associate Symbols tab to associate a symbol with the current I/O termination.  The 
software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

17. Click OK to accept your settings and close the dialog box. 
 

Customize the Controller/Processor List Header in I/O Card 
Properties 

This option enables you to make the Controller/Processor list header on the Control System 
tab of the I/O Card Properties dialog box dependant on the panel manufacture to which the 
current I/O card belongs. 
1. In the Domain Explorer, navigate to a panel. 
2. Right-click the selected panel and then on the shortcut menu, click Properties. 

3. On the General tab of the Properties dialog box, click  beside the Manufacturer list. 
4. In the Panel Manufacturers supporting table, select a manufacturer and then scroll to the 

right to the Controller/Processor header. 
5. Click in the Controller/Processor field and type the text that you want to appear instead of 

the Controller/Processor list header on the Control System tab of the I/O Card Properties 
dialog box. 

6. Click OK to close the Panel Manufacturers supporting table. 
7. Click OK in the Panel Properties dialog box. 
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Associate an I/O card with an I/O Termination 
I/O terminations function as termination blocks for I/O cards that do not have built-in termination 
blocks.  Therefore, you need to associate an I/O termination with an I/O card that needs a built-in 
termination block.  You can associate only those I/O cards that have been created in a particular 
rack and slot. 

 
 In a redundant system configuration, an I/O card can function as a primary or secondary I/O 

card and can be associated with several I/O terminations.  Therefore, an I/O termination can 
serve multi-paired redundant I/O cards.  However, in these redundant I/O card configurations, 
the I/O termination can be associated only with one pair of primary and secondary I/O 
cards.  Also, an I/O card cannot function as both a primary and secondary I/O card for the 
same I/O termination. 

 If an I/O card functions as a primary I/O card, the Control System tab of the Wiring 
Equipment Properties – I/O Card dialog box displays the secondary I/O card data and the 
primary I/O card data properties remain blank.  If an I/O card functions as a secondary I/O 
card, the Control System tab displays the primary I/O card data and the secondary I/O card 
data properties remain blank. 

1. Do one of the following: 
 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer and expand the Panels folder. 

2. In the Domain Explorer, do one of the following: 
 Expand the Panels by Category folder, hierarchy and navigate to a wiring item under 

which you want to create a new I/O card. 
 Expand the Panels by Location hierarchy and navigate to a wiring item under which you 

want to create a new I/O card. 
3. Create or select an I/O card under a particular panel, rack, and slot. 
4. Create or select an I/O termination that you want to associate with an I/O card. 
5. In the Wiring Equipment Properties – I/O Termination dialog box, click the Control 

System tab. 
 To open the Wiring Equipment Properties – I/O Termination dialog box, in the 

Domain Explorer, right-click an I/O termination and then on the shortcut menu, click 
Properties. 

6. To associate a primary I/O card, in the Primary I/O card group box, click  next to the I/O 
card select list arrow. 

7. In the Domain Explorer, select an appropriate I/O card and click OK. 

 
 You cannot select an I/O card whose child item is a terminal strip with channels. 
 Note that the I/O type of both the I/O card and the I/O termination must be the same.  If 

the I/O type of the I/O termination differs from the I/O type of the I/O card, the software 
displays a warning. 

8. To associate a secondary I/O card, do the following: 
a. Click the Define a redundant I/O card check box. 

b. In the Secondary I/O card group box, click  next to the I/O card select list arrow. 
9. Click OK. 
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 To be able to effect I/O assignment and make connections, create a terminal strip with 
channels under the I/O termination you are editing. 
 

Apparatus 
Apparatus is a wiring item that pertains to different types of multi-purpose I/O devices.  These 
devices accept wires and signals, for example, barriers, opto-couplers, relays, repeaters, 
isolators, and so forth.  You also use this feature to create a fieldbus termination block whose 
configuration is different from an apparatus configuration. 
SmartPlant Instrumentation allows you to create a group of apparatuses or a single 
apparatus.  An apparatus group constitutes an apparatus strip (that is, a terminal strip) with a 
number of apparatuses created according to a selected apparatus configuration. 
Adding a new apparatus group to a panel or a wiring equipment item starts with configuring the 
new apparatuses: setting the number of apparatuses on an apparatus strip, defining the 
apparatus terminal numbering pattern, signal propagation, and the color of the terminals.  After 
defining an apparatus configuration, you can proceed with the creation of an apparatus 
group.  The software opens the Terminal Strip Properties dialog box so that you can define an 
apparatus strip for the new apparatus group.  After defining the apparatus strip properties in the 
Terminal Strip Properties dialog box, the software creates the apparatus strip and the 
apparatuses according the selected configuration. 
SmartPlant Instrumentation also allows you to add a single apparatus to an apparatus group.  In 
this case, you do not define an apparatus configuration.  Then, you can select the new apparatus 
and add the required terminals. 
Once you have created a new apparatus group or a single apparatus, SmartPlant Instrumentation 
displays it in the Domain Explorer showing the terminals belonging to the apparatus. 
Note that an apparatus is a wiring item .  Therefore, you can define apparatus properties, 
duplicate, or delete an apparatus, and assign it a special symbol.  The software uses this symbol 
in the Enhanced Report Utility. 
 

Define an Apparatus Configuration 
You need to create an apparatus configuration before you can add an apparatus group to a 
selected panel or wiring equipment item.  An apparatus group constitutes an apparatus strip (that 
is, a terminal strip) with a number of apparatuses created according to a selected apparatus 
configuration. 
When defining an apparatus configuration, you define the apparatus profile (name, description, 
manufacturer, and model), the number of apparatuses, the apparatus terminal configuration, and 
the position numbering. 

 To facilitate fast creation of apparatus groups with various configurations, we 
recommend that you create several apparatus configurations in the Reference Explorer so that 
you can create different reference apparatus groups that can be copied to the Domain Explorer. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Do one of the following: 
 In the Domain Explorer, double-click the Panels by Location folder, and select a panel. 
 In the Domain Explorer, double-click the Panels by Category folder, and select a panel. 
 In the Reference Explorer, double-click the Panels folder, and select a panel. 

3. Right-click a panel to which you want to add an apparatus and then on the shortcut menu, 
click New > Apparatus Group. 
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4. In the Apparatus dialog box, click New. 
5. In the Apparatus profile group box, in the Configuration name field, type the name of the 

new apparatus configuration. 
6. Select the Fieldbus apparatus check box if you need to create a configuration for a fieldbus 

brick.  Note that the apparatus configuration for a fieldbus brick differs from the conventional 
one.  For details, see Configure a Fieldbus Apparatus (on page 197). 

7. From the Manufacturer list, select the appropriate apparatus manufacturer.  If the required 

value is not available, click  next to the list arrow to add or edit values for this list. 
8. In the Apparatus numbering group box, type the position name in the Prefix field if required. 

 Position names can be 15-character long.  This name will appear in the Domain 
Explorer within the new strip (only the first four characters), in the Connection window, and 
in the appropriate reports. 

9. Select the Numbered check box to number the positions. 
10. Select the Internal terminator check box if you need to add an internal terminator on the new 

termination block. 
11. In the Description field, type a short description for the new configuration. 
12. From the Manufacturer list, select the appropriate termination block manufacturer.  If the 

required value is not available, click  next to the list arrow to add or edit values for this list. 
13. From the Model list, select the appropriate termination block model.  If the required value is 

not available, click  next to the list arrow to add or edit values for this list. 
14. Use the Number of apparatuses spinner or type the required number of apparatuses to be 

added.  This way you can have a block of more than one apparatuses.  This number will be 
displayed by default when adding a new apparatus to an apparatus strip. 

15. In the Apparatus numbering group box, type the apparatus name in the Prefix field if 
required. 

 Apparatus names can be 15-character long.  This name will appear in the Domain 
Explorer within the new apparatus strip (only the first four characters), in the Connection 
window, and in the appropriate reports. 

16. Select the Numbered check box to number the apparatuses. 
17. In the Apparatus configuration group box, from the Orientation list, select one of the 

following terminal patterns: 
 Left / Right — an apparatus that has two sides: input and output (that is, left and right). 
 Left — an apparatus that has wires on the left side only. 
 Right — an apparatus that has wires on the right side only. 
 Regular — an apparatus that has a conventional terminal that functions as a single unit. 

18. Do the following to define the apparatus terminal name and color: 
a. Click in the left and/or right terminal side text box and type the required terminal name, for 

example 1A: 
 

 
b. Select a color of the terminal side from the list, for example red: 
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19. Repeat steps 17 and 18 for the other terminal side if appropriate.  Note that the line between 
the two terminal list arrows represents the internal relation between the input and output 
terminals. 

20. Click Add Terminal to add another terminal to this apparatus configuration if needed and then 
repeat steps 14 through 16. 

21. Click Delete Terminal if you need to delete a selected terminal from the current configuration. 
22. Click Save and then Close.  You can now add the required apparatus as needed. 
 

Create an Apparatus Group 
SmartPlant Instrumentation allows you to add an apparatus group to a panel or a wiring 
equipment item.  An apparatus group constitutes an apparatus strip (that is, a terminal strip) with 
a number of apparatuses created according to a selected apparatus configuration.  You can add 
an apparatus group to a panel or a wiring equipment item. 
The software adds an apparatus group after selecting an appropriate apparatus 
configuration.  You can add a new apparatus group after creating an apparatus 
configuration.  When adding a new apparatus to a panel, the software also creates a new 
apparatus (terminal) strip on which the apparatus is created. 
You can add an apparatus to a panel or to a wiring equipment item.  It is also possible to add a 
single apparatus to another apparatus. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Do one of the following: 
 In the Domain Explorer, double-click the Panels by Location folder, and select a panel. 
 In the Domain Explorer, double-click the Panels by Category folder, and select a panel. 
 In the Reference Explorer, double-click the Panels folder, and select a panel. 

3. Right-click a panel to which you want to add an apparatus and then on the shortcut menu, 
click New > Apparatus Group. 

4. On the Apparatus Group dialog box, select the desired configuration from the Configuration 
name list. 

5. In the Apparatus profile group box, in the Configuration name field, type the name of the 
new apparatus configuration. 

 If you do not have an appropriate configuration, create one.  For details, see Define an 
Apparatus Configuration (on page 73). 

6. Use the Number of apparatuses spinner or type the required number of apparatuses to be 
added.  This way you can have a block of more than one apparatuses.  This number will be 
displayed by default when adding a new apparatus to an apparatus strip. 

7. Click Create. 
 SmartPlant Instrumentation automatically assigns sequential position numbers to each 

apparatus.  You can edit them later if required.  For details, see Edit Apparatus Terminal 
Properties (on page 76). 

8. In the Terminal Strip Properties dialog box, define the new apparatus strip as required and 
click OK.  For details, see Create a Terminal Strip (on page 85). 

9. Click Close in the Apparatus dialog box. 
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 The new apparatus appears in the Domain Explorer within the new terminal strip. 
10. Connect the apparatus to the appropriate cables.  Right-click the apparatus group you want 

to connect and then on the shortcut menu, click Actions > Connection.  The Connection 
window opens displaying the apparatus terminals in yellow: 
 

 
 

Add an Apparatus to an Apparatus Group 
SmartPlant Instrumentation allows you to add a single apparatus to an apparatus group.  The 
software creates a new apparatus without any terminals and adds it at the bottom of the 
apparatuses in the current apparatus group.  If needed, you can then change apparatus 
sequence within the group and add the required terminals. 
1. In the Domain Explorer or Reference Explorer, right-click an apparatus group. 
2. On the shortcut menu, click New > Apparatus. 
3. In the Apparatus Properties dialog box, enter the apparatus properties as you require and 

click OK. 
 

Edit Apparatus Terminal Properties 
The following procedure explains how to edit the properties of an apparatus terminal. 
1. In the Domain Explorer, select the terminal that you want to edit. 
2. Right-click the selected terminal and click Properties on the shortcut menu. 
3. In the Terminal Properties dialog box, on the General tab, from the Terminal configuration 

list, select the required orientation of the current apparatus terminal. 
4. Define the terminal name by typing values in the Left terminal and Right terminal boxes as 

you require.  The combination of the left and right terminal name will then appear in the 
Domain Explorer. 

5. In the Sequence field, type a unique terminal sequence number. 
 This number designates the physical position of the terminal on the strip.  The software 

assigns this number automatically when you add a new terminal to the selected terminal 
strip.  If you change the sequence number of a terminal, be sure to change the sequence 
numbers of the other terminals on the apparatus strip to avoid duplicate values, which may 
interfere with the termination process. 

6. Define the color as required. 
7. Under Details, from the Manufacturer list, select the required terminal manufacturer.  If the 

required value is not available, click  next to the list arrow to open the Terminal 
Manufacturer dialog box where you can add additional items to the Manufacturer list. 

8. From the Model list, select the required terminal model.  If the required value is not available, 

click  next to the list arrow to open the Terminal Model dialog box where you can add 
additional items to the Model list. 

9. From the Type list, select the appropriate terminal type to which the new terminal belongs.  If 

the required type is not on the list, click  next to the list arrow to open the Terminal Type 
dialog box where you can add additional items to the Type list.  The Terminal Type dialog 
box, also allows you to replace the default image of terminal side icons for single and multiple 
connections. 

10. In the Note text box, type, if required, a brief note or a remark about this terminal. 
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11. Click OK to create the new terminal. 
 

The Plug-and-Socket Group Wizard 
This wizard takes you through the steps required to create a plug-and-socket group for wiring 
equipment. You can then connect cables to this group and display the wiring equipment in a Cable 
Block Diagram. 
To access the wizard, in the Domain Explorer right-click a wiring equipment item and on the 
shortcut menu click New > Plug-and-Socket Group. 
 

Welcome to the Plug-and-Socket Group Wizard 
This page appears when you open the Plug-and-Socket Group wizard. Click Next to continue. 
 

Define the New Ports Group (Plug-and-Socket Group Wizard) 
Type a name for you group. 
 

Define Plug-and-Socket Group Layout (Plug-and-Socket Group 
Wizard) 
On this page you define the number of connectors to be created in the group. 
Create coupled connectors — Select this check box to create coupled connectors (the internal 
links are made automatically). Clear this check box if you want to create the connector couplings 
manually. 

Coupled Layout 
Only available when you select the Create coupled connectors check box. 
Number of connectors — Enter the number of connectors you require for one side of the group. 
The software creates the connectors, and their internal links, on both sides of the group. 

 You can manually change the internal links later if required. 

Non-coupled layout 
(Only available when you clear the Create coupled connectors check box.) 
Number of connectors on the left side — Enter the number of connectors you require on the left 
side of the group. 
Number of connectors on the right side — Enter the number of connectors you require on the 
right side of the group. 

Connector numbering 
Prefix — Type a prefix for the connector numbering, if required. 
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Define the Ports (Plug-and-Socket Group Wizard) 
On this page you can select individual connectors and edit their names if required. 
 

Define the Plug-and-Socket Ports (Plug-and-Socket Group 
Wizard) 
On this page you define the connector type for the connectors in the plug-and-socket group. You 
can define them one-by-one, or define one connector and apply it's definitions to all the 
connectors. 
Port — From the list select the connector you want to define. 
Connector  type — From the list select the type of connector you want to define the selected 

connector. Click  to open the Connector Types dialog box and create a new connector type 
if required. 
Male or Female — From the list select Male or Female. 
Connector type definition display — Displays the Sequence, Name, and Polarity of the 
selected connector type. 
Apply to all — Select the check box to apply the selected connectors definitions to all the 
connectors of the group. Clear the check box if you want to define each connector individually. 
 

Completing the Plug-and-Socket Group Wizard 
(Plug-and-Socket Group Wizard) 
This page appears when the wizard is ready to create the plug-and-socket group from the 
parameters entered in the wizard. 
View and modify the internal links — Select this check box if you want to make changes to the 
internal links before the wizard creates the plug-and-socket group. Clear this check box if you do 
not want to change the internal links. 
Finish — Click Finish to; 
 If you chose to modify the internal links, open the Plug-and-Socket Group Internal Links 

dialog box where you can make your modifications. Clicking OK closes the dialog box and 
completes creating the new group. 

 If you chose not to modify the internal links, the wizard closes and creates the new group in the 
Domain Explorer. 

 

After creating the required plug-and-socket group, you can start connecting cables to the 
plug-and-socket group connectors. 
1. In the Domain Explorer, locate the wiring equipment with the plug and socket group. 
2. Right-click the wiring equipment and on the shortcut menu, click Actions > Connection. 

 
 When you have more than one plug-and-socket group associated with the wiring 

equipment, you can select the specific group from the Panel list in the Plug-and-Socket 
Box Connection screen. 

 You can also right-click on the plug-and-socket group  and on the shortcut menu, click 
Actions > Connection. 

3. In the Cables folder, locate the cable you want to connect to the plug-and-socket group. 
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To connect a cable to the plug-and-socket group, the cable must have a 
plug-and-socket connector on one end of the cable. 

4. Drag the cable from the Domain Explorer to the required connector in the Plug-and-Socket 
Box Connection dialog box. 

5. When you finish connecting all the cables to their connectors, close the Plug-and-Socket 
Box Connection dialog box. 

 

Modify the Internal Links of a Plug-and-Socket Group 
This procedure can be used when creating a plug-and-socket group for wiring equipment or for 
modifying an existing plug-and-socket group. 
1. To open the Plug-and-Socket Internal Links dialog box, do one of the following: 

 When creating a new plug-and-socket group with the Plug-and-Socket Group Wizard, 
on the Completing the Plug-and-Socket Group Wizard, select View and modify the 
internal links and click Finish. 

 On an existing plug-and-socket group, right-click and on the shortcut menu click 
Properties. Click Next until the Completing the Plug-and-Socket Group Wizard page 
appears, select View and modify the internal links and click Finish. 

2. To disconnect a link, do the following: 
a. On the Plug-and-Socket Internal Links dialog box, press the Conn.Mode button to 

release the button. 
b. On the display pane select the link you want to disconnect. 

 
 You can only select one link at a time. 
 The link turns red when selected, click the link again to clear the selection. 

a. Click Disconnect. 
3. To connect a link, do the following: 

a. On the Plug-and-Socket Internal Links dialog box, press the Conn.Mode button to 
select the button. 
 The cursor changes to a dot (•) over the display pane when the connection mode is 

selected. 
b. Click on the empty pin of the left side connector you want to link from. 
c. Click on the empty pin of the second connector (right side) to create the link. 

4. When you have finished your modifications, click OK. 
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S E C T I O N  8  

Terminal Strips and Terminals 
This section deals with the creation and management of terminal strips and terminals. 

In This Section 
Terminal Strips ............................................................................... 81 
Define a Terminal Strip Configuration ........................................... 81 
Modify a Terminal Strip Configuration ........................................... 83 
Terminal Strip Configuration Examples ......................................... 84 
Create a Terminal Strip .................................................................. 85 
Move a Terminal Strip to Another Parent Item .............................. 85 
Add a Terminal to a Terminal Strip ................................................ 86 
Add a Group of Terminals to a Terminal Strip ............................... 87 
Edit the Properties of a Terminal ................................................... 87 
Move a Terminal ............................................................................ 88 
Select a Graphic for a Terminal Connection .................................. 89 
 
 

Terminal Strips 
In SmartPlant Instrumentation, you create terminal strips based on a particular configuration of 
terminals.  This configuration is a repeating numbering pattern that enables logical numbering of 
terminals on a strip.  A strip terminal configuration includes the total number of terminals and the 
terminal numbering system. 
You can create terminal strips either in the Domain Explorer or the Reference Explorer.  If you 
are creating a terminal strip that is going to have a frequently used configuration, we recommend 
that you create it in the Reference Explorer.  Reference terminal strips facilitate fast creation of 
terminal strips in your plant by copying a terminal strip from the Reference Explorer to the 
Domain Explorer.  However, if you want to create a terminal strip that does not have a 
configuration that you intend to use frequently, we recommend that you create it in the Domain 
Explorer and in the <unit> where it is to be physically located.  This is helpful when filtering the 
terminal strips in the current <unit>. 
In the SmartPlant Instrumentation Explorer, terminal strips are child items of panels, racks, 
slots, and various wiring equipment items.  Terminal strips are parent items of channels and 
terminals. 
 

Define a Terminal Strip Configuration 
When creating a terminal strip, you are required to use a basic repeating numbering pattern 
(configuration) to enable logical numbering of terminals.  A numbering pattern identifies the basic 
numbering system, or stepping method used for terminals in a terminal strip.  Set +1,-1,+2,-2, for 
example, has a pattern of two, while the Set 1,2,3SH,4,5,6SH has a pattern of three. 
You can label the terminals on a terminal strip according to any numbering system that you require 
(up to ten characters in length).  To facilitate logical terminal numbering, SmartPlant 
Instrumentation requires you to configure the basic repeating numbering pattern (configuration) 
for the terminals in the new terminal strip before defining that terminal strip. 
When creating a strip in an I/O card or I/O termination, you use configurations that include 
channels.  If you want to create a terminal strip without channels in one of these panels, set the 
number of terminals per channel to zero. 
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1. In the Domain Explorer or Reference Explorer, right-click a panel. 
2. On the short-cut menu, click New > Terminal Strip. 
3. On the Terminal Strip Configuration dialog box, click New. 
4. On the Number of Terminals in Pattern dialog box, type or select a number to define the 

number of terminals to be repeated in the pattern and click OK. 

 
 This number determines the number of rows (terminals) that will constitute the basic 

repeating numbering (naming) pattern. 
 This numbering pattern is shown in the Terminal Numbering Pattern data grid on the 

Terminal Strip Configuration dialog box. 
5. Under Configuration name, type the name of the new configuration. 
6. Under Configuration description, type an optional description of the new configuration. 
7. Type or select the total number of terminals required in the terminal strip. 
8. Select the starting number for the first terminal in the terminal strip. 
9. Select the required number of terminals per channel or segment. 
10. Select the first channel. 

 If the new configuration is to be used to create I/O cards, the value in the Number of 
terminals per channel and First channel fields must be larger than zero.  Otherwise, the 
terminals on the terminal strip are created without channels and you will not be able to create 
an I/O card. 

11. In the Terminal Numbering Pattern data grid, click and type in the Prefix field, click and type 
a value if you want to prefix the names of the terminals. 

12. Select the Incremented check box if you want the terminal number to be incremented within 
the pattern. 

13. Select the Numbered check box if you want the number of the terminal to appear between the 
prefix and the suffix. 

14. In the Suffix field, click and type a value if you want a suffix for the names of the terminals. 
15. From the Orientation list, select the connection orientation to the terminal: 

 Regular — a conventional terminal that functions as a single unit. 
 Left — a terminal that has wires on the left side only. 
 Right — a terminal that has wires on the right side only. 
 Left / Right — a terminal that has wires on the left side only. 

16. Click Save. 

 
 If the required number of terminals is not exactly divisible by the number of terminals in a 

pattern, the remaining terminals are labeled SPARE. 
 For examples of possible terminal strip configurations, see Terminal Strip Configuration 

Examples (on page 84). 
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Modify a Terminal Strip Configuration 
The following procedure explains how to modify an existing configuration of terminals.  Modifying 
a terminal configuration does not affect the existing terminal strips.  They retain their previous 
terminal configuration. 
1. In the Domain Explorer or Reference Explorer, right-click a panel. 
2. On the short-cut menu, click New > Terminal Strip. 
3. On the Terminal Strip Configuration dialog box, select a configuration from the 

Configuration name list. 
4. Click Edit. 

 The software does not allow you to change the terminal numbering pattern of an existing 
configuration.  Therefore, you have to define a new configuration if you need to make such a 
change. 

5. Under Configuration name, type the name of the new configuration. 
6. Under Configuration description, type an optional description of the new configuration. 
7. Type or select the total number of terminals required in the terminal strip. 
8. Select the starting number for the first terminal in the terminal strip. 
9. Select the required number of terminals per channel or segment. 
10. Select the first channel. 

 If the new configuration is to be used to create I/O cards, the value in the Number of 
terminals per channel and First channel fields must be larger than zero.  Otherwise, the 
terminals on the terminal strip are created without channels and you will not be able to create 
an I/O card. 

11. In the Terminal Numbering Pattern data grid, click and type in the Prefix field, click and type 
a value if you want to prefix the names of the terminals. 

12. Select the Incremented check box if you want the terminal number to be incremented within 
the pattern. 

13. Select the Numbered check box if you want the number of the terminal to appear between the 
prefix and the suffix. 

14. In the Suffix field, click and type a value if you want a suffix for the names of the terminals. 
15. From the Orientation list, select the connection orientation to the terminal: 

 Regular — a conventional terminal that functions as a single unit. 
 Left — a terminal that has wires on the left side only. 
 Right — a terminal that has wires on the right side only. 
 Left / Right — a terminal that has wires on the left side only. 

16. Click Save. 

 
 If the required number of terminals is not exactly divisible by the number of terminals in a 

pattern, the remaining terminals are labeled SPARE. 
 For examples of possible terminal strip configurations, see Terminal Strip Configuration 

Examples (on page 84). 
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Terminal Strip Configuration Examples 
Each of the following examples demonstrates how various features of the strip configuration 
operate.  In each case, the terminal strip has a repeating sequence of three terminals, and a total 
of 8 terminals (the last 2 terminals are designated SPARE, and are not shown). 

Input Data and Explanation  Resultant Terminal Configuration 

 
No numbering 

— 

  
The + and – terminals are numbered. 
The numbers are incremented for the  
first terminal of each repeating sequence.

— 

  
The + and – terminals are numbered. 
The numbers are incremented for all  
the numbered terminals. 

— 

  
The + and – terminals are numbered. 
All the numbers are numbered and 
incremented. 
Note the use of the suffix. 

— 
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Create a Terminal Strip 
This procedure explains how to create a terminal strip.  You can add a terminal strip to a panel, 
rack, slot, or a wiring equipment item. 
1. In the Domain Explorer or Reference Explorer, right-click one of the following items: 

 Panel 
 Rack 
 Slot 
 Wiring equipment item, for example an I/O card 

2. On the short-cut menu, click New > Terminal Strip. 
3. On the Terminal Strip Configuration dialog box, select a configuration from the 

Configuration name list. 
 If you do not have an appropriate terminal configuration, click New. 

4. Click Create. 
5. On the Terminal Strip Properties dialog box, on the General tab, under Terminal strip type 

the name of the new terminal strip. 
6. From the Type, Model, and Manufacturer lists, select appropriate values to define the new 

terminal strip as you require.  If any of the lists do not contain the value that you need, click 

 to open the relevant supporting table where you can manage the contents of the select 
lists. 

7. Type a value for mounting, dimensions, and rail if needed. 
8. Under Sequence, enter a number to define the sequence of the current terminal strip in its 

parent item (a panel, rack, slot, or wiring equipment). 
9. To manage the revisions of the terminal strip, click Revisions. 
10. Click the Associate Symbols tab to associate a symbol with the current terminal strip.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

11. Click OK to create the new terminal strip. 
 

Move a Terminal Strip to Another Parent Item 
This option enables you to move a terminal strip with connected cables to another parent item 
(panel, rack, slot, or wiring equipment).  The software retains all the connection definitions after 
moving a terminal strip. 
1. In the Domain Explorer or Reference Explorer, select a terminal strip that you want to 

move. 
2. Expand the hierarchy of the target parent item. 

 You can open another instance of the Domain Explorer or Reference Explorer and 
place it beside the one that is already open to make the drag-and-drop operation easier. 

3. Drag the selected terminal strip to the desired parent item. 
 The following restrictions apply when trying to move a terminal strip with connected cables: 

 The terminal strip is associated with an instrument type. 
 The terminal strip is used by an auto-wiring task. 
 The terminal strip has connected terminals or channels that are associated with control 

system tags. 
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 The terminal strip has not been claimed for a project. 
 The terminal strip is associated with a local or general signal. 
 The target parent item is a plug-and-socket box. 

 

Add a Terminal to a Terminal Strip 
This procedure explains how to add a single terminal to an existing terminal strip. 
1. In the Domain Explorer or Reference Explorer, select a terminal strip to which you want to 

add a terminal. 
2. Right-click the selected terminal strip and then on the shortcut menu, click New > Terminal. 
3. On the General tab of the Terminal Properties dialog box, accept or select the required 

terminal orientation. 
4. Enter the terminal number or numbers in the Left terminal or Right terminal fields. 

 Your selection of the terminal orientation determines whether the Left terminal or Right 
terminal fields are available. If you select Left and right-oriented, the software lets you enter 
a value for both left and right terminals.  If you select Regular, the software lets enter the 
terminal number under Terminal. 

5. Under Sequence, type a unique terminal sequence number. 
 The sequence number designates the physical position of the terminal on the terminal 

strip.  The software assigns a sequence number automatically when you add a new terminal 
to a terminal strip.  If you change the sequence number of a terminal, be sure to change the 
sequence numbers of the other terminals on that terminal strip to avoid duplicate values, 
which may interfere with the termination process. 

6. Select a terminal color as needed. 
7. In the Details group box, enter a channel number. 
8. If the current terminal is in a channel which in turn is a wiring equipment sub-item, enter a 

sequence number with in the current channel. 
9. From the Type, Model, and Manufacturer lists, select appropriate values to define the new 

terminal as you require.  If any of the lists do not contain the value that you need, click  to 
open the relevant supporting table where you can manage the contents of the select lists. 

10. In the Note text box, type, if required, type a brief note or a remark about this terminal. 
11. Click the Associate Symbols tab to associate a symbol with the current terminal.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

12. Click OK to create the new terminal. 
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Add a Group of Terminals to a Terminal Strip 
This procedure explains how to add a new group of terminals to an existing terminal strip. 
1. In the Domain Explorer or Reference Explorer, select a terminal strip to which you want to 

add a group of terminals. 
2. Right-click the selected terminal strip and then on the shortcut menu, click Actions > Add 

Terminal Group. 
3. On the Add Terminals dialog box, select an appropriate terminal configuration from the 

Configuration name list.  The configuration you choose determines the labeling of the 
terminals you are about to create. 

 If the required configuration is not available, close this dialog box and create a new 
terminal configuration. 

4. Do one of the following: 
 If the selected configuration is suitable, click OK to add the terminals. 
 Change the configuration according to your requirements as specified in the steps below. 

5. In the Total number of terminals spin box, enter the total number of new terminals required. 
6. In the First terminal of added group spin box, enter the number of the next incremented 

terminal. 
 To continue the numbered sequence of the existing terminals, you should enter the next 

numerical value of the terminal, and not the ordinal sequence.  For example, if you already 
have 48 terminals arranged in groups of three, where the last 3 terminal labels are +16, -16, 
and SH, the value in the First terminal of added group spin box must be 17 and not 49. 

7. In the Terminal Numbering Pattern group box, do the following: 
a. Type a prefix in the Prefix field if required. 
b. Select the Incremented check box if you want the terminal number to be incremented 

within the pattern. 
c. Select the Numbered check box if you want the number of the terminal to appear between 

the prefix and the suffix. 
d. Type a suffix if required. 

8. Click OK to create the new group of terminals on the terminal strip. 
 This dialog box does not allow you to save the changes you make to an existing terminal 

strip configuration.  The software applies the changes only to the group of terminals you are 
currently adding. 
 

Edit the Properties of a Terminal 
1. In the Domain Explorer or Reference Explorer, select a terminal that you want to edit. 
2. Right-click the selected terminal and then on the shortcut menu, click Properties. 
3. On the General tab of the Terminal Properties dialog box, accept or select the required 

terminal orientation. 
4. Enter the terminal number or numbers in the Left terminal or Right terminal fields. 

 Your selection of the terminal orientation determines whether the Left terminal or Right 
terminal fields are available. If you select Left and right-oriented, the software lets you enter 
a value for both left and right terminals.  If you select Regular, the software lets enter the 
terminal number under Terminal. 

5. Under Sequence, type a unique terminal sequence number. 
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 The sequence number designates the physical position of the terminal on the terminal 
strip.  The software assigns a sequence number automatically when you add a new terminal 
to a terminal strip.  If you change the sequence number of a terminal, be sure to change the 
sequence numbers of the other terminals on that terminal strip to avoid duplicate values, 
which may interfere with the termination process. 

6. Select a terminal color as needed. 
7. In the Details group box, enter a channel number. 
8. If the current terminal is in a channel which in turn is a wiring equipment sub-item, enter a 

sequence number with in the current channel. 
9. From the Type, Model, and Manufacturer lists, select appropriate values to define the new 

terminal as you require.  If any of the lists do not contain the value that you need, click  to 
open the relevant supporting table where you can manage the contents of the select lists. 

10. In the Note text box, type, if required, type a brief note or a remark about this terminal. 
11. Click the Associate Symbols tab to associate a symbol with the current terminal.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

12. Click OK to create the new terminal. 
 

Move a Terminal 
This option enables you to move a terminal from one position to another on a terminal 
strip/channel, or from one terminal strip or channel to another terminal strip or channel. 

 It is possible to move a terminal only if the following is true: 
 The source terminal is not connected to any wiring. 
 When the terminal sequence is changed, even if the terminal is connected. 
 When the terminal is connected and has a signal, and the terminal is being moved to a 

different terminal strip provided the target terminal strip is under wiring equipment that is 
not an I/O card or I/O termination. 

 When the terminal is connected but does not have a signal and is being moved from one 
terminal strip to another. 
It is not possible to move a connected terminal that has a signal or if the target terminal 
strip is under an I/O card or I/O termination. 

1. In the Domain Explorer or Reference Explorer, select a terminal that you want to move. 
2. Expand the hierarchy of the target terminal strip. 

 You can open another instance of the Domain Explorer or Reference Explorer and 
place it beside the one that is already open to make the drag-and-drop operation easier. 

3. Drag the selected terminal to the desired terminal strip. 
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Select a Graphic for a Terminal Connection 
This procedure explains how to replace the default screw head graphic that represents a terminal 
connection of a terminal in the Connection window and various Panel-Strip reports.  You select a 
graphic for a particular terminal type and the number of wires connected to the terminal 
connection.  That is, a specific graphic represents a connector type and whether there is no wire, 
a single wire, or multiple wires, connected on that particular side of the terminal. 
1. On the Wiring Module window menu bar, click Tables > Terminal > Types. 
2. On the Terminal Types dialog box, select a terminal type or create a new one. 
3. Click in the G1 box to select a graphic that will represent a terminal connection with a single 

wire or without any wire. 
4. Click in the G2 box to select a graphic that will represent a terminal connection with a multiple 

wires. 
 

 The selected graphic appears in the G1, G2, or both boxes.  The size of the G1 and G2 boxes 
represents the actual size of the icons that appear in the Connection window. 

 If you do not select anything in the G1 or G2 box, SmartPlant Instrumentation displays the 
default gray screw head  for terminal connections with or without single wires and the 
turquoise screw head  for terminal connections with multiple wires. 
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S E C T I O N  9  

Making Connections in SmartPlant Instrumentation 
SmartPlant Instrumentation employs two methods for implementing cable terminations – direct 
visual connection, and a more advanced technique called connection type.  The connection 
concept behind these methods is based on the simple idea of letting you work as you would in the 
field, meaning that if you install a wire and connect it to a panel, for example, you can do exactly 
the same on the screen. 
The software enables you to make connections by using the drag-and-drop operation in the 
Connection window. 
You can make the following connections: 
 Connect cables and cable sets to terminals in single mode — this option allows you to 

connect cables one by one to the appropriate terminals. 
 Connect cables and cable sets to terminals in batch mode — this option allows you to 

simultaneously connect cables to the appropriate terminals and define their connections. 

 
 You can keep more than one Connection window open at the same time.  This can be useful 

when viewing the wiring routing. 
 Dragging a cable, cable set, or wire to a terminal not currently visible in the Connection 

window makes the screen scroll up or down until the required terminal is displayed. 
 If the width of your computer monitor allows it, you can follow the course of a cable from one 

terminal strip to the other (provided that the cable is connected between two terminal 
strips).  You can view the cable continuation between two terminal strips by resizing the 
Connection window and clicking  (or clicking Actions > Adjacent on the Connection 
window menu bar) to simultaneously display both terminal strips. 

 When connecting the right side of a DCS or PLC panel, the software increases the signal level 
by one. 

 

Define a Connection Type 
This option allows you to select, create, or edit a connection type that facilitates rapid cable set 
connections.  You define a connection type that contains a connection pattern.  A connection 
type contains the definition of the pattern by which wires will be connected on a terminal strip, and 
allows automatic creation and connection of jumpers between successive cable sets.  Once a 
wiring pattern has been defined, it can be selected whenever desired and will determine how the 
connections are made.  
1. Start the Wiring module and then do one of the following: 

 Click Actions > Connection Types. 

 Click  on the Wiring module toolbar. 
2. On the Connection Type dialog box, click New. 
3. On the New Connection Type dialog box, configure the new connection type by selecting the 

number of wires and jumpers that the new connection type will contain. 
4. Click OK to return to the Connection Type dialog box. 
5. In the Connection type text field, type the name of the new connection type. 
6. In the Description text field, type a short description if needed. 
7. In the Skip between sets field, enter the number of terminals that will be skipped between the 

first terminals of each cable set. 
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8. In the Wires group box, do the following: 
a. Click in the Skip text field and type the number of terminals to skip before connecting this 

wire in the cable set.  The skip is always relative to the first terminal to which a wire in the 
cable set is connected.  Enter the number of terminals to be skipped according to your 
needs.  In most cases, this value is incremented for successive wires.  You can accept 
the displayed value if suitable. 

b. In the Side field, click the A — Active or O — Opposite option button to select the 
terminal side to which you want to connect each wire.  The side that is currently active 
depends on the side you start to connect. 

c. Click in the Land field to connect a wire.  A screw head  appears indicating that a 
connection has been configured. 
 The Wire field displays a specific wire in the cable set.  The displayed W00x values 

represent the wire names and are used to illustrate the current connection type 
configuration.  This field is not editable. 

9. To configure a jumper connection, do the following in the Jumpers group box: 
a. From the Type list, select a jumper type from this list.  The values in this list are 

determined in the Wire Type supporting table. 
b. From the Color list, select the required jumper color. 
c. Click in the End 1 and End 2 fields to connect to a jumper.  A screw head  shows up 

indicating that a connection has been configured. 
d. Click in the Skip text field and type the number of terminals to skip for the jumper in the 

cable set for landing.  You can accept the displayed value if appropriate.  Repeat the 
same procedure for the other end. 

e. In the Side fields, click the A – Active or O – Opposite option button to select the terminal 
side where the jumper will be connected.  The side that is currently active depends on 
which side you start to connect. 

 
 The options in the Jumpers group box become available only if you have selected 

jumpers to be configured on the New Connection Type dialog box. 
 The terminals to which the ends of a jumper are connected must reside on the same 

strip.  Both ends of a jumper must be connected for it to appear in the display region.  For 
an illustration, see Connection Type Examples (on page 93). 

10. Click Save. 
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Connection Type Examples 
Example 1: (a two-wire cable set) 
The following connection type example illustrates how the connections are made for a 2-wire 
cable set when the skip between cable sets is 6: 

 
The position of the + wire in each cable set to be connected has been assigned a skip of 0.  The - 
wire of Set 1 has been assigned a skip of 1.  The - wires of Sets 2 and 3 have each been assigned 
a skip of 6. 

Example 2: (two wires with a jumper) 
The following example illustrates how you can connect a single pair to a strip and create a jumper 
on the opposite side between the first and third terminals.  The next pair will be connected to the 
third terminal, if the skip between sets parameter was set to 2. 

 



Wiring in SmartPlant Instrumentation 
 

 
94 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

The outcome of this operation, when terminating multiple pairs, will be pairs connected 
sequentially where every first wire in a set is connected by a jumper to the one that follows, as 
illustrated below: 

 
 

Connect a Cable or a Cable Set to a Terminal Strip 
This procedure explains how to connect a cable or cable set to a terminal strip.  The connection is 
accomplished by dragging a cable or cable set to a terminal in the Connection window.  Then, 
you are required to define the cable connection, which effects the connection.  Note that you can 
connect only plant cables and panels and not reference panels and cables.  However, while the 
Connection window is open, you can copy reference items from the Reference Explorer to the 
Domain Explorer and then drag them to the Connection window. 
1. Press F7 to open the Domain Explorer. 
2. Expand the Cables folder or a panel hierarchy and then right-click one of the following items: 

 A cable 
 A cable set 
 A panel 
 A terminal strip 

3. On the shortcut menu, click Actions > Connection. 
4. In the Connection window, from the Terminal strip list, select an appropriate terminal strip. 

 If the terminal strip that you need does not exist in the Domain Explorer, you can copy a 
reference terminal strip from Reference Explorer to the Domain Explorer while the 
Connection window is open.  (Press F8 to open the Reference Explorer.) 

5. In the Domain Explorer, select the cable or cable set that you want to connect. 
6. Drag the selected cable or cable set to the appropriate terminal in the data window. 
7. Drop the cable or cable set on the required terminal (shown as a screw head ) to open the 

Cable Connection Definition dialog box. 
8. On the Cable Connection Definition dialog box, do the following: 

a. Select End 1 or End 2 for the side of the cable that you want to connect. 
b. To change the terminal number where the first wire is to be connected, from the Start at 

terminal list, select the required terminal. 
c. In the Cable set connection details data window, select the cable sets that you want to 

connect, or choose Select all cable sets. 
d. From the Connection Type list, select the connection type for each cable set that you are 

going to connect. 
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e. Select L (left) or R (right) for the physical side of the terminal where the cable set 
enters.  Note that screw head  indicates that the cable set is already connected on the 
selected cable end. 

f. Click Connect to connect the selected cable sets and return to the Connection window. 

 
 SmartPlant Instrumentation connects the individual wires automatically in accordance with the 

selected connection type. 
 You can double-click a cable, cable set, wire, terminal, or terminal strip header in the 

Connection window to edit it. 
 

Connect Device Cables to a Terminal Strip in Batch Mode 
Use this procedure to connect device cables or cable sets to a terminal strip in batch mode.  Note 
that these are device cables that are already connected to device panels. 
1. Press F7 to open the Domain Explorer. 
2. Expand the Panels by Location or the Panels by Category folder to display the existing 

panels and terminal strips. 
3. Right-click a terminal strip to which you want to connect device cables, and then on the 

shortcut menu, click Actions > Batch Connection. 
4. In the Domain Explorer, select the device cables that you want to connect and drag them to 

the Batch Device Cable Connection window. 

 
 You can only drag those cables that have been connected to device panels on one end 

and unconnected on the other end.  Also, there cannot be any connectors on the 
unconnected end. 

 You can filter the display of cables in the Domain Explorer so that you can easily find the 
device cables that you need.  For details, see Pre-Assign Junction Boxes to Device 
Panels (on page 125). 

 Click  on the lower toolbar to open a pop-up window that displays which terminals are 
connected. 

 The settings displayed under Starting Terminal are determined by the automatic 
implementation of connection type definitions for the cables that you move to the data 
window. 

 You can change the order of cables in the data window by dragging them up or down. 
5. To change the connection type for a given cable set, from the Connection Type list, select an 

appropriate connection type. 
6. When changing the connection type for the first cable set, in response to the 'Do you want to 

change the connection type for all cable sets?' prompt, do one of the following: 
 To change the connection type for all of the cable sets displayed in the data window, click 

Yes.  Note that this also results in automatic renumbering of the starting terminals for all 
of the cable sets. 

 To change the connection type for the given cable set only, click No.  Note that this 
results in no automatic renumbering of starting terminals. 

7. To change the cable set starting terminals, do one of the following: 
 To change the starting terminal for a given cable set, select a value from the Starting 

Terminal list. 
 To automatically renumber starting terminals according to cable type definitions, from the 

selected cable set and below, click Actions > Reassign. 
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8. Under Terminal Side accept the default setting L to connect the device cables to the left side 
of the panel, or select R to connect the cables to the right side. 

9. Under Connect all shields to, do one of the following: 
 Do not select any terminal.  Use this option to connect the shields according to the 

configuration of the active cable types. 
 Select a common terminal to which you connect all of the shields. 

10. Under Connect all overall shields to, do one of the following: 
 Do not select any terminal.  Use this option to connect the overall shields according to the 

configuration of the active cable types. 
 Select a common terminal to which you connect all of the overall shields. 

11. Do one of the following: 
 To prepare for the connection of the all of the device cables displayed in the data window, 

clear Connect selected rows only. 
 To prepare for the connection of some of the device cables displayed in the data window, 

select the rows that you want to connect and then select Connect selected rows only. 
12. To connect the devices cables to the terminal strip according to your settings, do one of the 

following: 
 Click Actions > Connect. 
 On the lower toolbar, click . 

 

Connect a Wire to a Terminal Strip 
This procedure explains how to connect a wire to a terminal strip. 
1. Press F7 to open the Domain Explorer. 
2. Expand the Panels by Category or Panels by Location folder. 
3. Right-click a panel or a terminal strip and then on the shortcut menu, click Actions > 

Connection. 
4. If, in the Domain Explorer,  you selected a panel and not a terminal strip, in the Connection 

window, select one from the Terminal Strip list. 
5. In the Domain Explorer, select a cable and expand its hierarchy to display its wires. 
6. Select a wire and drag it to a terminal (shown as a screw head ) in the Connection window. 

 Click  to find a specific terminal or the next available terminal.  SmartPlant 
Instrumentation marks your terminals with . 

7. On the Wire Connection Options dialog box, select the wire that you require and then click 
OK. 

 
 If you are connecting more than one wire in a cable or cable set to a group of terminals on a 

terminal strip, make sure that the wire end that you connect is the same for all the wires.  This 
is important to ensure that the connections appear correctly in reports. 

 If one end of the wire is already connected, SmartPlant Instrumentation selects the loose end 
by default. 
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Move Cables, Cable Sets, and Wires 
After making initial connections to terminals, SmartPlant Instrumentation lets you relocate cables, 
cable sets, and wires to another terminal on the same terminal strip.  You can move a wiring item 
using the drag-and-drop feature. 
1. In the Connection window, select the appropriate cables, cable sets, or wires. 
2. Drag the selected items to another terminal.  If you are moving a cable or a cable set, the 

Cable Connection Definition dialog box opens.  If you are moving a wire, the Wire 
Connection Options dialog box opens. 

3. Select the required definitions on the Cable Connection Definition dialog box or on the Wire 
Connection Options dialog box and then click Connect or OK respectively. 

 
 The Connection window reopens showing the new connections. 
 You should ensure that there are sufficient terminals to accommodate all the wires that you 

want to move. 
 You can connect any number of wires to a single terminal. 
 If you are connecting more than one wire in a cable or cable set to a group of terminals, make 

sure that the wire end that you connect is the same for all the wires.  This is important to 
ensure that the connections appear correctly in reports. 

 

Disconnect Cables, Cable Sets, and Wires 
This procedure shows how to disconnect a given cable or selected cable sets and wires from a 
terminal strip. 
1. In the Connection window, select the cable, cable sets, or wires you want to disconnect. 

 SmartPlant Instrumentation automatically selects the wiring items in the hierarchy below 
the item that you select. 

2. In the Connection window, do one of the following: 
 Right-click the selected item then click Disconnect on the shortcut menu. 
 On the menu bar, click Connection > Disconnect. 

 Click  on the Connection toolbar. 

 
 If a terminal strip or terminal is connected to more than one cable, only wires which are unique 

to a terminal or which belong to a cable at the top level layer (at the front) will be disconnected 
by SmartPlant Instrumentation. 

 SmartPlant Instrumentation uses  to represent terminals on which multiple wires are 
connected. 

 To ensure disconnection of the correct cables or cable sets, first move the cable you want to 
disconnect to front by selecting it from the Cable name list. 
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Add Jumpers to the Existing Wiring 
SmartPlant Instrumentation enables you to create and connect multiple jumpers in a repetitive 
way.  You can define constant gaps between the jumpered terminals if required.  Also, you can 
jumper the last remaining terminal in the selected terminal pattern if required.  Note that unlike 
regular wires, jumpers do not propagate signals.  You can assign a wire group to a jumper 
manually on the Terminal Connection dialog box. 
1. Press F7 to open the Domain Explorer. 
2. Expand the Panels by Location or the Panels by Category folder to display the existing 

panels and terminal strips. 
3. Right-click a panel or a terminal strip and then on the shortcut menu, click Actions > 

Connection. 
4. In the Connection window, select a wire connected to the terminal that will be the first 

terminal connected to the first jumper. 
 Do not make any selection if you want the terminal connected to the first wire to be the 

connected to the first jumper. 
5. In the Connection window, do one of the following: 

 Right-click the selected wire and then on the shortcut menu, click Connect Jumpers. 
 Click Connection > Connect Jumpers. 

 Click . 
6. On the Connect Jumpers dialog box, do the following: 

a. From the Terminal one – first jumper list, select a terminal and set its Left or Right 
orientation. 

b. From the Terminal two – first jumper list, select a terminal and set its Left or Right 
orientation. 

c. If you need to define a constant gap between the jumpered terminals, enter a value in the 
Interval between jumpers box. 

d. From the Last terminal list, select the last terminal in the pattern that you want to jumper. 
e. Select the Jumper the last terminal check box if you want to jumper the last remaining 

terminal in the terminal pattern. 
f. Select a jumper color. 
g. In the Jumper name box, type the name of the new jumper, or accept the default 

setting.  By default, SmartPlant Instrumentation suggests a name for a new jumper of the 
format J<first terminal name>/<second terminal name>.  You can change the 
preferences so as not to display a suggested jumper name.  For details, see Set 
Preferences for Automatic Naming of Jumpers (on page 99). 

h. Click OK. 
 Your new jumper appears in the Connection window. 
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Set Preferences for Automatic Naming of Jumpers 
1. Click File > Preferences. 
2. Expand the Wiring hierarchy in the tree view and select Jumpers. 
3. Under Automatic naming, select Name jumpers automatically. 
4. Click OK. 
 

Remove a Jumper from the Existing Wiring 
This procedure explains how to remove a jumper. 
1. In the Connection window, select a jumper you want to remove. 
2. Do one of the following: 

 Right-click the selected jumper and then on the shortcut menu, click Disconnect. 
 On the Connection window menu bar, click Actions > Disconnect. 

 Click . 

 
 Jumpers exist in the database as long as they are connected.  Disconnected jumpers are 

deleted from the database. 
 You cannot move a jumper.  Instead, disconnect the jumper that you do not need and then 

add a new jumper as required. 
 

Assigning Wire Designation 
The Terminal Connection dialog box opens when you click a screw head  on the terminal in 
the Connection window.  This dialog box shows the Wire Group, Group Level, and Group 
Sequence of the wires connected to the selected terminal. 
When you click Wire Group, Group Level, or Wire Sequence data, you can reassign the wire 
designation by selecting the required value from the appropriate lists. 
You can assign a new signal name to more than one terminal without having to browse through 
the Wire Group list for each terminal.  You use this feature only with terminals whose Wire Group 
is currently undefined (that is, the Wire Group data field displays asterisks). 
First, you need to assign a new signal name to a terminal whose Wire Group is currently 
undefined.  After assigning the new signal to the current terminal, select another terminal (click 
the up or down arrow or select a terminal in the Terminal name list).  If you now click in the Wire 
Group data field, the list opens with the new signal name selected by default.  Clicking the 
terminal name enables you to navigate quickly. 

 If you want to reassign wire designations on the Terminal Connection dialog box, it is 
advisable to plan your changes in advance on paper, to avoid conflicting Wire Group, Group 
Level, and Group Sequence data. 
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Updating Connection Data 
Multiple users can work on the same module.  In most cases, you may not edit data that is being 
edited by another user, however, under certain circumstances, other users may have made 
changes that affect the data in the Connection window.  For example, another user has added a 
new plant cable.  This cable does not appear in the Domain Explorer until you refresh the 
window display.  Click  to refresh the displayed connection data. 
The Connection window is automatically refreshed only when you open it.  However, SmartPlant 
Instrumentation does not refresh the data in the Connection window, if you have several 
instances of the Connection window open and you switch from one Connection window to 
another. 
 

View Cable Connection Destinations 
This option enables you to view the connection destinations of a cable that you select in the 
Domain Explorer.  When you select this option, you see the junction boxes and terminals that 
the selected cable is connected to. 
1. In the Domain Explorer, double- click the Cables folder. 
2. Right-click a cable. 
3. On the shortcut menu, click Actions > Destination. 

 The Cable Destination pop- up window displays individual connections for the selected 
cable.  Note that each line shows a connection to a different panel. 
 

Display Adjacent Connections of a Cable 
When you are working on wiring connections for a specific panel, you can follow the wiring routing 
to an adjacent panel. 
1. In the Connection window, select a cable, cable set, or wire whose routing you want to trace 

on a particular terminal side. 
 If you select a cable or cable set, SmartPlant Instrumentation displays the adjacent 

connection for the first wire.  You can follow the routing for the other wires by selecting other 
panels from the list. 

2. Do one of the following: 
 On the menu bar, click Actions > Open Adjacent Connection. 
 Right-click the selected item and then on the shortcut menu, click Open Adjacent 

Connection. 

 Click  on the lower toolbar. 
 The Connection window opens, showing the adjacent panel which is the continuation of 

the wiring routing. 
 



 Wiring in SmartPlant Instrumentation 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 101 
 

Display the Farthest Connection of a Cable 
While working in the Connection window, in addition to displaying the adjacent connection of a 
cable or a wire, you can also open the farthest connection.  This means that the software switches 
to the end of the wiring routing of the current wire and displays the last panel on that end.  If a 
signal exists in the direction that you chose to switch to, SmartPlant Instrumentation follows the 
signal to the end.  If there is no signal, the software shows the panel that is connected at the end 
of the wiring routing. 
1. In the Connection window, select a wire whose routing you want to trace on a particular 

terminal side. 
2. Do one of the following: 

 On the menu bar, click Actions > Open Farthest Connection. 
 Right-click the selected item and then on the shortcut menu, click Open Farthest 

Connection. 
 The Connection window opens, showing the farthest panel at the end of the wiring 

routing.  For examples, see Examples of Farthest Connections of Cables (on page 101). 
 

Examples of Farthest Connections of Cables 
While working in the Connection window, in addition to displaying the adjacent connection of a 
cable or a wire, you can also open the farthest connection.  This means that the software switches 
to the end of the wiring routing of the current wire and displays the last panel on that end.  If a 
signal exists in the direction that you chose to switch to, SmartPlant Instrumentation follows the 
signal to the end.  If there is no signal, the software shows the panel that is connected at the end 
of the wiring routing. 
Example 1: 

 
In this example, you selected the left side connections of JB- 2.  Therefore, SmartPlant 
Instrumentation will display the connection of the device panel. 
Example 2: 

 
In this example, you selected the right side connections of JB- 2.  Therefore, the software will 
display the connection of the DCS or the I/O card. 
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Trace a Signal in a Point-to-Point Wiring Diagram 
You can follow a signal along a sequence of wires.  SmartPlant Instrumentation uses wire groups, 
group level and group sequence data to follow a signal along a series of wires and check for any 
discontinuity.  The wire group is the signal name representing the tag number from which the 
signal originates.  The result is displayed in a point-to-point wiring diagram that you can print. 
1. Do one of the following to open the Point-to-Point Wiring Diagram: 

 In the Domain Explorer, right-click a cable, cable set, panel, or a terminal strip and then 
on the shortcut menu, click Actions > Connection. For best results, make sure that the 
connection information is complete for the items that you selected. 

 In the Domain Explorer, right-click a cable, cable set, panel, or a terminal strip and then 
on the shortcut menu, click Actions > I/O Assignment.  For best results, make sure that 
the I/O assignment information is complete for the items that you selected. 

2. In the Connection window, from the Terminal strip list, select the terminal strip to which you 
want to trace the signal path. 

 If you are working in the I/O Assignment window, skip steps 2 and 3. 
3. From the Cable list, select the cable containing the wire for which you want to trace the signal 

path. 
4. Do one of the following: 

 In the Connection window, select the wire for which you want to trace the signal path. 
 In the I/O Assignment window, under Channel Assignment, select a channel associated 

with an instrument tag. 

5. Click  to locate a specific terminal or channel. 
6. Do one of the following to generate the Point to Point Wiring Diagram report: 

 On the module toolbar, click . 
 On the menu bar, click Reports > Point to Point Wiring Diagram. 
 In the Connection window, right-click the selected wire and on the shortcut menu click 

Point to Point Wiring Diagram. 
7. Do one of the following when prompted to preview the report: 

 Click Yes to preview the Point to Point Wiring Diagram. 
 Click No to print the report without displaying it on your computer. 

 
 To view the point-to-point diagram legend, scroll down to the lower part of the preview. 
 To hide the default notation of level and sequence of the signals and tags, click View > Show 

Level/Sequence.  To display the notation, click again. 
 You can resize the fonts of the cable and cable set names in the Point to Point Wiring 

Diagram.  For details, see Change the Font Size of Cable and Cable Set Names (on 
page 103). 
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Change the Font Size of Cable and Cable Set Names 
1. In the Point-to-Point Wiring Diagram, click View > Font Size. 
2. Do one of the following on the Resize Fonts dialog box: 

 In the Size field, type the required font size of the cable and cable set names. 
 Use the spinner to increase or decrease the font size. 

3. Click OK to close the Resize Fonts dialog box and return to the Point to Point Wiring 
Diagram print preview where you see the changes you made to the cable and cable set name 
fonts. 

 

Generate a Connection Report from the Connection Window 
While in the Connection window, you can generate a connection report for the current terminal 
strip.  The report lists all the cables connected to the selected terminal strip and shows all the 
cable-sets within each cable, the wire tags, their color, and terminal number.  This report does not 
show adjacent connections. 
1. In the Connection window, do one of the following: 

 On the menu bar, click Reports > Connection. 

 Click . 
2. In the Print Preview prompt, click Yes to display the report print preview or click No to print 

out the report without displaying its print preview. 
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S E C T I O N  1 0  

I/O Assignment 
The I/O assignment in SmartPlant Instrumentation enables you to assign a channel to a specific 
instrument or a fieldbus segment. 
I/O assignment for an instrument is performed in two stages: 
1. Associating (coupling) an instrument with a control system tag. 
2. Assigning the coupled pair to a channel. 
I/O assignment for a segment is also performed in two stages: 
1. Associating (coupling) each virtual tag with a control system tag. 
2. Assigning the coupled pairs to an I/O channel. 

 The software displays the available instruments according to the current I/O type.  You can 
change the I/O type by setting the appropriate I/O assignment preference.  For details, see Set 
I/O Assignment Instrument Tag Preferences (on page 105). 
 

Set I/O Assignment Instrument Tag Preferences 
Prior to effecting I/O assignment, you can set your I/O assignment preferences for the I/O types of 
the instrument tags.  These preference options enable you to determine the I/O types of the 
instrument tags that become available in the I/O Assignment window.  One setting allows you to 
make all instrument tags be available in the I/O Assignment window regardless of their I/O 
type.  The other setting limits the availability of instrument tags only to those instruments whose 
I/O type is identical to the I/O type of the current I/O card. 
Note that after you effect an I/O assignment and your preference was set to the Same I/O type for 
tag and I/O card, you can still change the I/O type of the I/O card if you need to do so.  The 
software does not verify the compatibility of a changed I/O type with instrument tags already 
associated with I/O cards. 
1. Click File > Preferences. 
2. Expand the Wiring hierarchy in the tree view and select I/O Assignment. 
3. Under I/O assignment validation select one of the following options: 

 Same I/O type for tag and I/O card — limits the I/O type of the instrument tag to be the 
same as the I/O type of the I/O card selected in the I/O Assignment window.  Note that 
the software validates I/O type compatibility also upon connection. 

 All I/O types — allows the selection of all instrument tag I/O types in the I/O Assignment 
window and upon connection. 

4. Click OK. 
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Effect I/O Assignment for an Instrument 
I/O assignment is essentially assigning a control system tag to a free channel.  I/O assignment for 
an instrument is performed in two stages. First you associate (couple) an instrument with a control 
system tag and then assign the coupled pair to a channel. 
1. Press F7 to open the Domain Explorer. 
2. In the Domain Explorer, do one of the following: 

 Select a parent wiring item that contains one or more I/O card child items and whose I/O 
type is Fieldbus FF. 

 Select an I/O card or an I/O termination whose I/O type is Fieldbus FF. 
3. Right-click the selected items and then on the shortcut menu, click Actions > I/O 

Assignment. 
 

 The software allows you to open the I/O Assignment window without selecting anything 
in the Domain Explorer.  On the Wiring Module window toolbar, click . 

 You can also open the I/O Assignment window for an I/O card from the Connection 
window.  On the Connection menu, click I/O Assignment. 

4. On the I/O Assignment Type dialog box, select I/O Assignment. 
 For fieldbus I/O assignment, select Segment I/O assignment.  For details, see 

Configure a Fieldbus Apparatus (on page 197). 
5. If you did not select a panel or an I/O card in the Domain Explorer before opening the I/O 

Assignment window, do one of the following in the I/O Assignment window: 

 Click  to open the Find Channel dialog box, where you find and select channels to 
display in the I/O Assignment window. 

 In the I/O card details pane, click  beside the I/O termination list to open the Domain 
Explorer where you select the required I/O cards, then click OK to add them to the I/O 
card list. 

6. From the I/O termination list, select an item for which you want to effect I/O assignment. 
 The I/O type of the selected I/O card or I/O termination determines the I/O type of the 

initial instrument tag displayed in the I/O type list.  You can select a different I/O type from this 
list if required.  The list of instruments displayed in the Tag list data grid depends on the I/O 
type that you select from the I/O type list.  If the I/O type selection is MIXED, instruments of all 
I/O types are shown.  If any another I/O type is selected, only the instruments of the selected 
I/O type are shown. 

7. If required, select a different I/O type, which enables you to use an instrument tag for the I/O 
assignment whose I/O type is different from the I/O card I/O type.  To do this, do one of the 
following: 
 If the I/O type selection is MIXED, select the required I/O type from the I/O type list. 
 If the I/O type selection is not MIXED, change the definitions to make the I/O type list 

available at all times by selecting the All I/O types preference on the Preferences 
(Wiring – I/O Assignment) dialog box.  For details, see Set I/O Assignment Instrument 
Tag Preferences (on page 105). 

8. Drag an instrument or a control system tag to a free channel in the Channel assignment 
pane to effect I/O assignment. 

 Several assignment options are possible.  For details, see the Assign an Instrument to a 
Channel section in Effecting I/O Assignment Common Tasks. 
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Effect I/O Assignment for a Segment 
I/O assignment for a segment is performed in two stages.  First you associate (couple) each 
virtual tag with a control system tag and then assign the coupled pairs to an I/O channel. 
1. Press F7 to open the Domain Explorer. 
2. In the Domain Explorer, do one of the following: 

 Select a parent wiring item that contains one or more I/O card child items and whose I/O 
type is Fieldbus FF. 

 Select an I/O card or an I/O termination whose I/O type is Fieldbus FF. 
3. Right-click the selected items and then on the shortcut menu, click Actions > I/O 

Assignment. 
 You can also open the Segment I/O Assignment window from the Connection 

window.  On the Connection menu, click I/O Assignment. 
4. On the I/O Assignment Type dialog box, select I/O Assignment. 

 For fieldbus I/O assignment, select Segment I/O assignment.  For details, see 
Configure a Fieldbus Apparatus (on page 197). 

5. If the I/O Assignment Type dialog box opens, select Segment I/O Assignment I/O 
assignment. 

6. From the I/O termination list, select an item for which you want to effect I/O assignment. 
7. From the Segment coupling list, select a required segment type.  This selection determines 

which items are displayed under Segments. 
8. Drag a segment to a free channel in the Channel assignment pane to effect I/O assignment. 

 Several assignment options are possible.  For details, see the Assign an Instrument to a 
Channel section in Effecting I/O Assignment Common Tasks. 
 

Assign an Instrument to a Channel 
The essence of I/O assignment is assigning an instrument to a channel.  SmartPlant 
Instrumentation provides several options for this purpose.  You can choose one of the following 
options for I/O assignment: 
Select an instrument tag coupled with a control system tag and assign both of them to a free 
channel. 

 Couple an instrument tag with an existing control system tag and then assign them to a 
free channel. 

 Assign an uncoupled control system tag to a free channel. 
 Assign an uncoupled instrument tag to a free channel. You will have to create a new 

control system tag in the process and the coupling will be done automatically. 
 Assign an uncoupled instrument tag to a channel to which a control system tag has 

already been assigned. 
1. Open the I/O Assignment window. 
2. In the Tag coupling data grid, select one of the following: 

 An instrument tag coupled with a control system tag. 
 An instrument not coupled with a control system tag. 
 A control system tag not coupled with an instrument. 

3. Drag the selected item to a free channel in the Channel assignment pane. 
4. If you selected an instrument not coupled with a control system tag, do the following: 
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5. On the Control System Tag dialog box, type the name of the control system tag that 
SmartPlant Instrumentation creates automatically. 

6. Click OK on the Control System Tag dialog box to complete the I/O assignment. 
 You can shift the assignment of an instrument to another unassigned channel by simply 

pressing and holding the Ctrl key while dragging the instrument to another unassigned 
channel.  You cannot change the assignment this way if the target channel has already been 
assigned to another instrument.  Note that when changing the assignment, the software retains 
the existing control system data. 
 

Assign a Segment to a Channel 
This option enables to assign a segment to a channel so that you can effect I/O assignment for 
fieldbus segments.  
1. Press F7 to open the Domain Explorer. 
2. In the Domain Explorer, do one of the following: 

 Select a parent wiring item that contains one or more I/O card child items and whose I/O 
type is Fieldbus FF. 

 Select an I/O card or an I/O termination whose I/O type is Fieldbus FF. 
3. Right-click the selected items and then on the shortcut menu, click Actions > I/O 

Assignment. 
4. From the Segments list, select an appropriate segment. 

 The software displays only those segments that contain instruments for which virtual 
tags have been created. 

5. Drag the selected segment to a free channel in the Channel assignment pane. 
 You can shift the assignment of a segment to another unassigned channel by simply 

pressing and holding the Ctrl key while dragging the segment to another unassigned 
channel.  You cannot change the assignment this way if the target channel has already been 
assigned to another segment.  Note that when changing the assignment, the software retains 
the existing control system data. 

 

Create a Channel 
This option allows you to create additional channels to the ones that the software created in a 
particular I/O card or terminal strip. 
1. In the Domain Explorer, select an I/O card, I/O termination, or a terminal strip with channels. 
2. Right-click the item to which you want to add a channel and then on the shortcut menu, click 

New > Channel. 
3. On the Channel Properties dialog box, on the General tab, type a channel name, description 

and sequence as you require. 
4. If you are adding a channel on a terminal strip under an I/O card or I/O termination, click the 

I/O Properties tab. 
5. On the I/O Properties tab, select the channel type, I/O type, and signal type. 
6. Type a value in the Address field as you require. 
7. Type a minimum and maximum range and select a unit of measure for the range values. 
8. Select the Enable for use with external DCS interfaces (DeltaV) check box to make these 

channel property values available for use with a DCS interface such as DeltaV. 
9. Click the Associate Symbols tab to associate a symbol (.sym) file with the new channel.  For 

details, see Associate a Symbol with an Item (on page 23). 
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10. Click OK. 
 

Create a Control System Tag 
This option allows you to create a new control system tag.  Note that control system tag names 
must be unique.  If you are using a DCS, the uniqueness applies per <plant>.  If you are using a 
PLC, the uniqueness applies per cabinet or panel. 
1. On the I/O Assignment window menu bar, click Actions > New Control System Tag. 
2. On the Control System Tag Properties (New) dialog box, type the name of the new control 

system tag and click OK. 
 You can now add an additional control system point configuration if needed. 

3. To document additional DCS/PLC data, on the SmartPlant Instrumentation toolbar click . 
 The Browser Manager opens.  If you have a predefined Wiring default browser and a 

default view, the Browser View opens by default. 
4. Do the following in the Browser Manager: 
5. Expand the Control System browser group by clicking  next to its icon or double-clicking 

the icon. 

6. To view the control system tag data, select the Control System Tag Browser and click  
to create a browser view for this browser. 

7. Define the view style, filter, and sorting sequence as you require. 

8. Click  to view the selected field data in the browser view. 
9. If desired, you can edit the displayed data, sort, change the sequence of, and resize the 

columns.  For more information on how to work with browser views, see Browser Views 
Common Tasks. 

 

Create a Control System Tag in the Instrument Index 
Standard Browser View 

1. In the Instrument Index Module window, do one of the following to open the Instrument 
Index Standard Browser view: 
 On the menu bar, click Actions > Standard Browser View. 

 On the toolbar, click . 
2. Select the desired tag numbers. 
3. Do one of the following: 

 Right-click, and on the shortcut menu, click Apply Profile > Create Control System Tag. 
 On the Actions menu, click Apply Profile > Create Control System Tag. 

4. In the Results dialog box, view the CS tag creation results, and then click Close. 
 To make this feature work, you must select the Create wiring and Control system check 

boxes on the Wiring and Control System tab in the instrument type profile of the selected tag 
number before you attempt to create a new control system tag.  For more details, see Define an 
Instrument Type 
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Rename a Control System Tag 
You can change the name of an existing control system tag, for example, if you replace an existing 
one with a newer model. 
1. In the I/O Assignment window, select the control system tag that you want to rename. 

 You can select the required control system tag in the Tag coupling data window or in 
the Channel assignment pane. 

2. Do one of the following: 
 Click Actions > Control System Tag Properties. 

 Click . 
3. On the Control System Tag dialog box, type the new name of the control system tag. 
4. Click OK. 
 

Couple an Instrument with a Control System Tag 
One of the ways to effect I/O assignment is to assign a control system tag coupled with an 
instrument tag to a free channel. 
1. In the I/O Assignment window, select a free instrument in the Tag Coupling data grid. 
2. Click Actions > Couple Tags. 
3. Select the control system tag you want to couple with the instrument tag you have selected. 
4. Click OK. 

 The instrument tag and the control system tag appear coupled in the Tag coupling data 
grid. 
 

Decouple an Instrument and a Control System Tag 
This procedure explains how to decouple an instrument tag and a control system tag where the 
instrument is no longer connected. 
1. Open the I/O Assignment window. 
2. In the Tag coupling pane, select a coupled instrument tag and control system tag. 
3. Do one of the following: 

 Click Actions > Decouple Tag No. from SC Tag. 

 Click  
 The instrument tag and the control system tag appear separately in the Tag coupling data 

grid. 
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Delete a Control System Tag 
1. In the I/O Assignment window, select the control system tag that you want to delete. 

 You can select the required control system tag in the Tag coupling or in the Channel 
assignment pane.  If, in the Channel assignment pane, you select a CS tag in the that is 
still coupled with an instrument, the software informs you that the I/O assignment for that 
channel will be canceled. 

2. Do one of the following: 

 Click . 
 Click Actions > Delete Control System Tag. 

3. Click Yes to confirm the deletion. 
 

Filter the Display of Data in the I/O Assignment Window 
This feature enables you to filter the data displayed in the I/O Assignment window.  You can 
instruct the software to display only assigned or unassigned instruments.  Furthermore, you can 
display only uncoupled instruments, uncoupled CS tags, or both.  Also, you can select a 
predefined Browser filter for panels. 
1. In the I/O Assignment window, do one of the following to open the I/O Assignment Filter 

dialog box: 

 Click . 
 Click Actions > Filter. 

2. Do one of the following: 
 From the Browser filter for instruments list, select a predefined filter for panels.  Note 

that if you select a predefined filter from this list, it overrides all the other settings in this 
dialog box.  If you do not have a predefined filter, open the Browser Manager and define 
a filter for an appropriate view that contains panels.  For details, see Browser View Filter 
Settings. 

 Define your filter using the options in the Filter for and Definition group boxes. 
3. Under Filter for, select the filter option to determine which instrument tags and control system 

tags will be displayed in the I/O Assignment window.  Select one of the following: 
 Unassigned tags coupled with control system tags — display the instruments that 

have not yet been assigned to channels but have already been coupled with control 
system tags.  Then, you can determine whether to display uncoupled CS tags, uncoupled 
instruments, or both. 

 Assigned tags coupled with control system tags — display only the assigned 
instruments that have already been coupled with control system tags.  Selecting this 
option disables the other three options. 

4. To further filter the display of unassigned instruments, uncoupled instruments, or both, under 
Definition, define an appropriate filter expression.  For details, see Define a View Filter. 

5. To use the current filter settings in subsequent sessions of the I/O Assignment window, 
select the Apply filter settings in all sessions check box. 

6. To display only the instruments that were retrieved from SmartPlant Electrical, select the 
SmartPlant Electrical tags check box. 

7. To limit the display of data to the current lowest plant hierarchy level, select the Display 
current unit data only check box. 

8. Click OK. 
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Cancel I/O Assignment 
Canceling I/O assignment involves a simple procedure of removing the instrument assignment 
(un-assigning) an instrument from a channel. 
1. In the I/O Assignment window, select a channel in the Channel assignment pane. 
2. Do one of the following: 

 Click . 
 Click Actions > Un-assign from channel. 
 The selected channel becomes vacant as the instrument and its control system tag move 

to the Tag list pane. 
 

Generate an I/O Tag Assignment Report 
This option enables you to generate a report showing I/O assignments for an I/O card or I/O 
termination that you select in the I/O Assignment window. 
1. In the I/O Assignment window, under I/O assignment, select an I/O card or an I/O 

termination from the list. 
2. Select the required I/O card from the I/O card name list. 
3. Do one of the following: 

 Click . 
 Click Reports > Tag assignment Report. 

4. Click Yes to open the print preview of the report or click No to send the report to your default 
printer. 
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Control System Tag Propagation 
Propagation of a signal along wires may vary according to whether a field device exists and 
whether a tag number was assigned to an I/O channel.  If the tag number was assigned to an I/O 
device the cables connected to the I/O terminals are also considered during the signal 
propagation.  The method of propagating sequence numbers (within a level) used by SmartPlant 
Instrumentation depends on whether a field device is associated with that tag number, and 
whether the wiring routing is complete (there is a signal continuity between the field device and the 
I/O channel). 

 
Diagram key: 
A — Field device without a channel. 
B — Field device and Control System channel assigned without cables connected to the Control 
System channel. 
C — Field device and Control System channel assigned with cables.  Wiring routing is not 
completed. 
D — Field device and Control System channel assigned.  Wiring routing is completed. 
E — Control System channel assigned without a field device. 
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View and Edit Channel Data 
This option enables you to view the channels of a selected DCS/PLC panel or all DCS/PLC panels 
in the current <plant>.  You can also modify the control system tag names if required. 

 If you are editing items that must be compatible with Emerson DeltaV, see Crucial 
Fields for the DeltaV Interface. 
1. Do one of the following in the I/O Assignment window: 

 Click Actions > Show I/O Data. 

 Click . 
2. To rename a control system tag, do the following: 

a. Select the required row and click Edit CS Tag. 
b. On the Control System Tag dialog box, type a new name as needed and click OK. 

3. To filter the display of data on the I/O Data dialog box, do the following: 
a. Click Filter to open the Filter I/O Data dialog box. 
b. In any data field, type the value according which to filter the channels on the I/O Data 

dialog box. 
Note that you can include any letter or number combination.  You can include letter or 
number combinations, as well as wildcards.  For example, an underscore (_) can 
substitute a single character and percent (%) can substitute multiple characters.  The 
search is not case-sensitive. 

c. From the drop-down lists, select a value according which to filter the channels on the I/O 
Data dialog box. 

d. In the Show channels group box, choose a filtering option to determine which channels 
to display on the I/O Data dialog box. 

e. Select the Save check box to save the criteria specified for the next time you open the I/O 
Data dialog box. 

f. Click OK to accept your filter settings and return to the I/O Data dialog box. 
4. To sort the displayed channels on the I/O Data dialog box, do the following: 

a. Click Sort to open the Sort I/O Data dialog box. 
b. In the Column Name list, select the column according which the channels displayed on 

the I/O Data dialog box will be sorted. 
c. Select Ascending to sort the channels displayed on the I/O Data dialog box in ascending 

order; clear the check box to sort the channels in descending order. 
d. To add a new sorting parameter, select an existing sorting parameter after which you want 

to add the new sorting parameter and then click Insert. 
e. To delete a sorting parameter, select the required sorting parameter and click Delete. 
f. Click Clear to discard all the sorting settings. 
g. Select the Save check box if you want to save the current settings for the next time you 

open the I/O Data dialog box.  Note that deleting or clearing parameters does not affect 
the sorting parameters that you have previously saved (by selecting the Save check box). 

5. Click OK to accept your settings and return to the I/O Data dialog box. 
6. To print out the data on the I/O Data dialog box, click Report. 
7. Click Close to return to the I/O Assignment window. 

 If you open the I/O Assignment window without selecting anything in the Domain 
Explorer, the I/O Data dialog box shows the control system tags of the DCS/PLC cabinet you 
selected the last time you opened the I/O Assignment window. 
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Find I/O Channels for Assignment 
This option enables you to search DCS or PLC panels in the current <plant> for I/O cards and 
individual channels according to required criteria.  SmartPlant Instrumentation then displays 
these channels in the I/O Assignment window, and you can use them to effect an I/O 
assignment. 
1. In the I/O Assignment window, do one of the following to open the Find Channels dialog 

box: 
 Click Actions > Find Channels. 

 Click . 
2. Under Search parameters, type values according to which SmartPlant Instrumentation 

displays channels in the Search results data window.  If you leave a field blank, it will not 
limit the search.  Leave all fields blank in order to display all channels. 
  You can include letter or number combinations, as well as wildcards.  For example, 

an underscore (_) can substitute a single character, and percent (%) can substitute 
multiple characters.  The search is not case-sensitive. 

3. Under Show channels, select one of the following search options: 
 Spares only — show only spare channels in the Search results data window. 
 Exclude spares — do not display any spare channels in the Search results data 

window. 
 All — show all spare and assigned channels in the Search results data window. 

4. To save the current search parameters as the channel search default, select the Save check 
box. 

5. Click Find to search using the current settings. 
6. In the Search results data window, select the I/O cards that you want to be available in the 

I/O Assignment window, and click OK. 
 If you select a channel rather than an I/O card, SmartPlant Instrumentation displays the 

card to which the channel belongs in the I/O Assignment window. 
7. In the I/O Assignment window, under I/O card name, select the required card.  The software 

displays its channels in the Assignment details data window. 
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Cross Wiring 
Cross wiring in SmartPlant Instrumentation allows you to connect two terminal strips by using a 
cross-wiring cable.  You can cross wire two terminal strips that belong to two different panels or 
the same panel. 
The following cross-wiring options are available: 
 Manual Cross Wiring — This is the default cross wiring mode, where you select the terminals 

on the strips to be cross-wired. 
 Semiautomatic Cross Wiring — SmartPlant Instrumentation automatically finds potential 

targets for the signal that it will propagate.  You can accept the suggested terminals and carry 
out the cross wiring or select different terminals to be cross-wired. 

 Automatic Cross Wiring — SmartPlant Instrumentation automatically finds matching signals 
and performs the cross wiring for you. 

 

Perform Manual Cross Wiring 
Manual cross wiring is the default mode for cross wiring.  In this mode, you select the terminals 
that you want to cross wire, select the required cross-wiring cable and then carry out the cross 
wiring.  
1. Press F7 open the Domain Explorer and select one or more terminal strips for potential cross 

wiring.  You can also select a panel or several panels if required. 
2. Right-click the items you selected and then on the shortcut menu, click Actions > Cross 

Wiring. 
3. In the Cross Wiring window, select the required terminal strip from the Primary terminal 

strip list. 

 To add terminal strips that do not appear on the list, click  beside the Primary 
terminal strip list arrow, select the required terminal strips in the Domain Explorer, then click 
OK to add them to the Primary terminal strip list. 

4. Under Primary connection side, click Left or Right to select the appropriate side of the 
secondary terminal s trip that you want to connect. 

 This option is not available if the current secondary terminal strip is a terminal strip with 
channels (belonging to a DCS or PLC panel).  In this case, you can connect the left side only. 

5. From the Secondary terminal strip list, select the required terminal strip that you want to 
cross wire. 

 To cross wire two terminal strips belonging to different panels where you did not select 

one of the panels in Cross Wiring, click  beside the Secondary terminal strip list arrow, 
select the required terminal strip in the Domain Explorer and click OK to add it to the 
Secondary terminal strip list.  Then, select that terminal strip from the Secondary terminal 
strip list for cross wiring. 

6. Under Secondary connection side, click Left or Right to select the appropriate side of the 
secondary terminal strip that you want to connect. 

 This option is not available if the current secondary terminal strip is a terminal strip with 
channels (belonging to a DCS or PLC panel).  In this case, you can connect the left side only. 

7. From the Cross-wiring cable list, select one of the following to define a cross-wiring cable: 
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 Select CROSS WIRE to cross wire the terminals with wires that the software creates 
during the cross-wiring process. 

 Select the required cross- wiring cable.  If the cross wiring cable that you need is not on 

this list, click  beside the list arrow to open the Wiring Explorer.  Select a cable and 
click OK to add it to the list.  Note that you can also create a new cross wiring cable if the 
one you need does not exist in the Domain Explorer. 

8. Select the Prompt for cross operation message check box to be prompted by SmartPlant 
Instrumentation to confirm the cross wiring.  If you do not select this check box, cross wiring 
of the selected terminals proceeds without messages and SmartPlant Instrumentation 
propagates all the existing signals. 

9. In the Primary Terminal Strip pane, click the required terminal to be cross-wired. 
10. In the Secondary Terminal Strip pane, click the required terminal to be cross- wired. 
11. If you selected the Prompt for cross operation message check box, click Yes to confirm the 

cross wiring. 
 

 For an example and information about the conventions used to represent various items and 
connections in the Cross Wiring window, click the Help icon on the main toolbar and then 
click the required link at the bottom of the help page. 

 In the Primary Terminal Strip pane, select the required cross-wired terminal, and then click 
 to open the Point-to-Point Wiring Diagram. 

 Click  to open the Terminal Connection window.  You can also double click  to get the 
same result. 

 Click  to remove the cross wiring between two terminals after selecting the cross- wired 
terminals (shown connected by a solid black line). 

 Click  to generate a report that shows all the wiring connections of the primary strip on both 
sides. 

 

Perform Semiautomatic Cross Wiring 
Semiautomatic cross wiring enables you to find matching signals between two terminal strips 
(primary and secondary).  That is, SmartPlant Instrumentation can find for you a potential target 
for the signal that the software propagates after you perform cross wiring.  You can then use this 
potential target to quickly effect the required cross wiring.  The terminal that SmartPlant 
Instrumentation finds for you in the secondary terminal strip is a recommendation only and you are 
free to accept it or select a different terminal, as you require. 
1. Press F7 open the Domain Explorer and select one or more terminal strips for potential cross 

wiring.  You can also select a panel or several panels if required. 
2. Do one of the following to open the Cross Wiring window: 

 Click Actions > Cross Wiring. 

 Click  
3. In the Cross Wiring window, select the required terminal strip from the Primary terminal 

strip list. 

 To add terminal strips that do not appear on the list, click  beside the Primary 
terminal strip list arrow, select the required terminal strips in the Domain Explorer, then click 
OK to add them to the Primary terminal strip list. 

4. From the Secondary terminal strip list, select the required terminal strip that you want to 
cross wire. 
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 To cross wire two terminal strips belonging to different panels where you did not select 

one of the panels in Domain Explorer, click  beside the Secondary terminal strip list 
arrow, select the required terminal strip in the Domain Explorer and click OK to add it to the 
Secondary terminal strip list.  Then, select that terminal strip from the Secondary terminal 
strip list for cross wiring. 

5. Under Secondary connection side, click Left or Right to select the appropriate side of the 
secondary terminal strip that you want to connect. 

 This option is not available if the current secondary terminal strip is a terminal strip with 
channels (belonging to a DCS or PLC panel).  In this case, you can connect the left side only. 

6. From the Cross-wiring cable list, select one of the following to define a cross-wiring cable: 
 Select CROSS WIRE to cross wire the terminals with wires that the software creates 

during the cross-wiring process. 
 Select the required cross- wiring cable.  If the cross wiring cable that you need is not on 

this list, click  beside the list arrow to open the Domain Explorer.  Select a cable and 
click OK to add it to the list.  Note that you can also create a new cross wiring cable if the 
one you need does not exist in the Domain Explorer. 

7. Select the Prompt for cross operation message check box to be prompted by SmartPlant 
Instrumentation to confirm the cross wiring.  If you do not select this check box, cross wiring 
of the selected terminals proceeds without messages and SmartPlant Instrumentation 
propagates all the existing signals. 

8. In the Primary Terminal Strip pane, click the required terminal to be cross-wired. 
9. Do one of the following to find a matching target signal for potential cross wiring: 

 Click View > Target Signal. 

 Click . 
SmartPlant Instrumentation searches for a matching signal in the current <plant> and 
adds the terminals that it finds in the Secondary Terminal Strip pane.  SmartPlant 
Instrumentation indicates each of the potential terminals by placing an arrow  beside it 
in the Secondary Terminal Strip pane. 

10. Select the required terminal in the Secondary Terminal Strip pane to cross wire with the 
selected terminal in the primary terminal strip. 

 
 For an example and information about the conventions used to represent various items and 

connections in the Cross Wiring window, click the Help icon on the main toolbar and then 
click the required link at the bottom of the help page. 

 In the Primary Terminal Strip pane, select the required cross-wired terminal, and then click 
 to open the Point-to-Point Wiring Diagram. 

 Click  to open the Terminal Connection window.  You can also double click  to get the 
same result. 

 Click  to remove the cross wiring between two terminals after selecting the cross- wired 
terminals (shown connected by a solid black line). 

 Click  to generate a report that shows all the wiring connections of the primary strip on both 
sides. 
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Set Cross Wiring Preferences 
This procedure explains how to create a new cross-wiring cable and use it in your current cross 
wiring operation.  If you do not want to create your own cross-wing cables and let SmartPlant 
Instrumentation create a cable for you, in the Cross Wiring window, select CROSS WIRE from 
the Cross-wiring cable list.  
1. Click File > Preferences. 
2. Expand the Wiring hierarchy in the tree view and select Cross Wiring. 
3. Under Automatic cross wiring, select one of the following options: 

 Different strips, same panel — Automatically cross-wires two signals between two 
different strips belonging to the same panel (this is the default selection). 

 Different panels (no DCS or PLC panels) — Automatically cross-wires signals between 
two strips belonging to two different panels in the current plant, except for strips with 
channels (that is, I/O cards). 

 Different panels including DCS or PLC panels (terminal sequence connection) — 
Automatically cross- wires signals between two strips belonging to two different panels in 
the current plant, including strips with channels where the connection will be done 
according to the terminal sequence that is shown in the dialog box.  Note that we do not 
recommend using the third option unless you are absolutely certain that this option will 
select matching signals.  In any case, do not forget to change the setting back to the 
default (Different strips, same panel) when done. 

4. From the Default wire color list select the required wire color.  Selecting a default wire color 
determines the cross-wire color in the Connection window.  The wire color data in the list is 
retrieved from the Wire Color dialog box. 

5. Click OK. 
 

Perform Automatic Cross Wiring 
Automatic cross wiring enables you to instruct SmartPlant Instrumentation to automatically find 
matching signals for you and cross-wire the relevant terminals in a single operation.  Two signals 
match if: 
 The signals are between two terminal strips belonging to the same panel. 
 Both signals are on the same signal level. 
 The first signal comes to the first terminal from a device panel (the signal sequence is less 

than 50) and the second signal comes from a control system (the signal sequence is greater 
than 50.) 

You can set the default definitions for matching signals by using the Preferences dialog box. 
 You can set the default definitions for matching signals by using the Preferences 

dialog box.  For details, see Set Cross Wiring Preferences (on page 120). 
1. Press F7 open the Domain Explorer and select one or more terminal strips for potential cross 

wiring.  You can also select a panel or several panels if required. 
2. Right-click the selected item and on the shortcut menu, click Actions > Cross Wiring. 
3. n the Cross Wiring window, select the required terminal strip from the Primary terminal 

strip list. 

 To add terminal strips that do not appear on the list, click  beside the Primary 
terminal strip list arrow, select the required terminal strips in the Domain Explorer, then click 
OK to add them to the Primary terminal strip list. 
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4. Under Primary auto cross- wiring side, click Left or Right to select the appropriate side of 
the primary terminal strip that you want to connect. 

5. From the Secondary terminal strip list, select the required terminal strip that you want to 
cross wire. 

 To cross wire two terminal strips belonging to different panels where you did not select 

one of the panels in Domain Explorer, click  beside the Secondary terminal strip list 
arrow, select the required terminal strip in the Domain Explorer and click OK to add it to the 
Secondary terminal strip list.  Then, select that terminal strip from the Secondary terminal 
strip list for cross wiring. 

6. Under Secondary connection side, click Left or Right to select the appropriate side of the 
secondary terminal strip that you want to connect. 

 This option is not available if the current secondary terminal strip is a terminal strip with 
channels (belonging to a DCS or PLC panel).  In this case, you can connect the left side only. 

7. From the Cross-wiring cable list, select one of the following to define a cross-wiring cable: 
 Select CROSS WIRE to cross wire the terminals with wires that the software creates 

during the cross-wiring process. 
 Select the required cross- wiring cable.  If the cross wiring cable that you need is not on 

this list, click  beside the list arrow to open the Domain Explorer.  Select a cable and 
click OK to add it to the list.  Note that you can also create a new cross wiring cable if the 
one you need does not exist in the Domain Explorer. 

8. Select the Prompt for cross operation message check box to be prompted by SmartPlant 
Instrumentation to confirm the cross wiring.  If you do not select this check box, cross wiring 
of the selected terminals proceeds without messages and SmartPlant Instrumentation 
propagates all the existing signals. 

9. Do one of the following to find matching signals: 
 Click Actions > Auto 

 Click . 
SmartPlant Instrumentation finds and selects the matching signals and the terminals that 
it can cross- wire automatically.  The Secondary Terminal Strip pane does not appear 
in the Cross Wiring window. 

10. Do one of the following: 

 Click  to cross wire the selected terminals.  SmartPlant Instrumentation replaces the 
selection with a solid black line indicating that the cross wiring has been done. 

 Click  to discard the selection made by the software and return to manual mode. 

11. After the software cross wired the terminals, click  to return to manual mode. 

 
 For an example and information about the conventions used to represent various items and 

connections in the Cross Wiring window, click the Help icon on the main toolbar and then 
click the required link at the bottom of the help page. 
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 In the Primary Terminal Strip pane, select the required cross-wired terminal, and then click 
 to open the Point-to-Point Wiring Diagram. 

 Click  to open the Terminal Connection window.  You can also double click  to get the 
same result. 

 Click  to remove the cross wiring between two terminals after selecting the cross- wired 
terminals (shown connected by a solid black line). 

 Click  to generate a report that shows all the wiring connections of the primary strip on both 
sides. 

 

Create a Cross Wiring Cable 
1. In the Cross Wiring window, click  beside the Cross-wiring cable list arrow to open the 

Domain Explorer. 
2. Right-click the Cross Cables folder, and on the shortcut menu, click New > Cross Cable. 
3. In the Cable Properties dialog box, enter the required values and then click OK. 
4. Select the new cable in the Domain Explorer and click OK to add this cable to the 

Cross-wiring cable list. 
5. Select the new cable in the Cross-wiring cable list to be used in the cross wiring operation. 
 

Generate a Panel Strip Report from the Cross Wiring Window 
This option enables you to generate a panel - strip report that displays the connections and 
adjacent connections for the terminal strip you selected from the Primary terminal strip list in the 
Cross Wiring window. 
1. Do one of the following in the Cross Wiring window: 

 Click Reports > Panel- Strip. 

 Click  on the module toolbar. 
2. Click Yes to open the print preview or click No to print the report without displaying it on your 

screen. 
 A Panel-Strip report (with adjacent connections, no style), cannot be printed on a portrait 

orientated A4 page. 
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Auto-Wiring 
Auto-wiring allows you to make automatic batch connections between specified terminal 
strips.  This feature facilitates faster and more efficient wiring design especially when working on 
a grass-root project where the required wiring items already exist and you need to connect 
them.  The essence of this feature is that you create an auto-wiring routing task where you define 
a cable that will connect two designated panels. 
You can define an auto-wiring task for two different kinds of connection: 
 A connection between two existing panels. 
 A connection between a panel and a control system that will create cross wires or cross 

cables. 
There are two prerequisites for auto-wiring routing tasks: 
 The required panels and terminal strips must already exist. 
 The required reference cables and connection types must be defined and ready for use. 

Furthermore, for cross wiring auto-wiring routing tasks, you must also ensure the following before 
you start defining your task: 
 The required instrument tags and their device panels already exist and they are connected to 

their junction boxes. 
 There are instrument tags with pre-assigned I/O points – essential for cross-wiring tasks. 
 There are defined reference wiring profiles for the required instrument types. 

 
 For details about various auto-wiring tasks, see Defining and Executing Auto-Wiring Tasks (on 

page 123). 
 You cannot create an auto-wiring task for panels that are defined as Fieldbus or Telecom 

panels. 
 

Defining and Executing Auto-Wiring Tasks 
An auto-wiring task is a list of commands that SmartPlant Instrumentation runs according to 
pre-selected parameters.  You define the End 1 and End 2 connections as well as the cable that 
SmartPlant Instrumentation uses to make the connection.  The cable that the software uses to 
make the connection is automatically created by the software.  The definition of this cable is 
based on the reference cable that you select.  The software checks whether a cable based on the 
selected reference cable exists in the Domain Explorer and whether this cable has a sufficient 
number of unconnected cable sets.  If not, SmartPlant Instrumentation creates a new cable based 
on the selected reference cable to accommodate the required connections.  You can customize 
the cable name as needed or accept the suggested names.  The software proposes cable end 
names based on the names of the panels to be connected to End 1 and End 2.  Any additional 
cables that the software creates have identical names with a numeric suffix that is incremented by 
one for each new cable; for example XYZ.1, XYZ.2, and so forth. 
You can define the following auto-wiring tasks: 
 Connecting two junction boxes or marshaling racks — When defining an auto-wiring task 

for two junction boxes, you need to define the End 1 and End 2 connections as well as the 
cable that SmartPlant Instrumentation uses to connect the two panels. 
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 Connecting a junction box or a marshaling rack to a control system — When defining 
this kind of auto-wiring task, you define the End 1 connection and the auto-wiring cable.  The 
End 2 connection options are not available as SmartPlant Instrumentation checks for available 
DCS or PLC panels with matching signals.  This means that you have to pre-assign the 
required control system tags to the tag numbers (for details, see I/O Assignment (on 
page 105)).  At this point, you also need to select an appropriate cross wiring option to 
connect the control system.  After the software executes the task, open the Connection 
window for the selected junction box and display the adjacent connection to make sure that 
the software has executed the auto-wiring task correctly. 

 Connecting a pre-assigned junction box to another junction box or a control system — 
In this case, you need to make sure that you have carried out the required I/O assignment for 
the control system you are going to connect and that you pre-assigned the necessary junction 
box and its terminal strip to the required field device.  Then, you proceed to define the End 2 
connection or select to connect the pre-assigned junction box to a control system. 

Note that you define and execute auto-wiring tasks in the Auto-Wiring Browser View window. 
For detailed description of the various procedures, see Auto- Wiring Connections Common Tasks. 
 

Flow of Activities for Auto-Wiring 
The following is a suggested flow of auto-wiring activities.  The sequence in which you perform 
these activities depends on your work preferences.  In any case, make sure that you perform the 
first four steps in the following list before proceeding further. 
1. Define a view profile for a new Auto-Wiring Routing Task browser in the Wiring group of 

the Browser Manager.  For details, see Define a View Profile. 
2. Add and define a new view for the Auto-Wiring Routing Task browser.  For details, see Add 

a New View. 
3. If needed, define a view profile for the JB Pre-Assignment browser in the Instrument Index 

group of the Browser Manager and then add and define a new view for the JB 
Pre-Assignment browser. 

4. Pre-assign the required junction boxes to tag numbers.  For details, see Pre-Assign Junction 
Boxes to Device Panels (on page 125). 

5. Connect the junction boxes to the device panels using one of the following methods: 
6. Use the Device Cable Batch Connection feature.  For details, see Connect Device Cables 

to a Terminal Strip in Batch Mode (on page 95). 
 Execute the auto-wiring routing task.  For details, see Defining and Executing 

Auto-Wiring Tasks (on page 123). 
 Connect the junction boxes manually. 

7. Continue connecting the rest of the junction boxes. 
8. Create and run a new auto-wiring routing task to connect the last junction box to the control 

system (or another type of panel). 
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Pre-Assign Junction Boxes to Device Panels 
You use this feature to pre-assign specific junction boxes to selected instruments.  This 
pre-assignment serves several purposes: 

 Pre-assign the required junction boxes to define an Auto-Wiring routing task. 
 Connect multiple pre-assigned device cables in batch mode. 
 Filter the display of cables in the Domain Explorer so that only pre-assigned device 

cables for connection with junction boxes are displayed. 

1. On the main toolbar, click  to open the Browser Manager. 
2. Expand the Instrument Index browser group. 

 You can also click  on the Auto-Wiring Browser View toolbar to open the JB 
Pre-Assignment Browser View window. 

3. Select the JB Pre-assignment browser and add a new browser view to this browser. 
 Make sure that you select the Set as default view check box if you want to use 

the new browser view for auto-wiring. 

4. Click  to open the new view. 
5. In the Browser View window, highlight the required tag number to which you want to assign a 

junction box. 
6. Click in the Junction Box Name field and select an appropriate junction box that will be 

pre-assigned to the highlighted instrument tag. 
 If a junction box has already been connected to a device panel, the Junction Box Name 

field displays the name of the connected junction box and you cannot rename the junction box 
here. 

7. Click in the Strip Name field and select the required strip in the pre-assigned junction box. 
8. Repeat steps 5 through 7 for each device panel to which you want to pre-assign a junction 

box. 
9. Edit the data in the Browser View window as required and close the Browser View 

window.  Save the data when prompted. 

 
 You can now select the appropriate junction boxes and perform batch connection of device 

cables in the Batch Device Cable Connection window. 
 You can define an Auto-Wiring routing task. 
 You can filter the display of device cables in the Domain Explorer.  For details, see Define a 

Filter for Pre-Assigned Device Cables. 
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Auto-Wire Pre-Assigned Junction Boxes 
This procedure explains how to define and execute an auto- wiring task for a pre-assigned 
junction box.  Note that you must pre-assign the required junction box and make all the required 
preparations prior to defining and executing a task. 

 You must pre-assign the required junction boxes and make all the required 
preparations prior to defining and executing a task.  For details, see Pre-Assign Junction Boxes to 
Device Panels (on page 125). 
1. Start the Wiring module. 
2. On the menu bar, click Actions > Auto-Wiring. 
3. In the Browser View – New Auto-Wiring Routing Task window, select the new task and do 

one of the following: 
 Click Actions > Edit Task. 

 Click . 
 The Auto-Wiring Routing Task dialog box opens where all the End 1 connection 

properties except for the Connection type and Overall shield terminal connection have 
been defined.  You can accept the displayed values or modify them as needed. 

4. On the Auto-Wiring Routing Task dialog box, complete the End 1 connection definition as 
follows: 
a. Select the required connection type from Connection type list. 
b. If required, select the appropriate overall shield terminal connection. 

5. In the End 2 connection group box, select one of the following options: 
 Select the Control system check box if you want to connect the pre-assigned junction 

box to a DCS or PLC cabinet.  (For details, see Define and Execute an Auto-Wiring Task 
for Control Systems (see "Auto-Wire Control Systems" on page 128). 

 Do not select the Control system check box to connect the pre-assigned junction box to 
another junction box or marshaling rack. 

6. If you did not select the Control system check box, define the end 2 connection of the 
auto-wiring cable as follows: 

a. Click  next to the Panel field to select the required panel. 
b. In the Domain Explorer, select a panel that contains at least one terminal strip with 

unconnected terminals and then click OK. 
c. Select a terminal strip from the Strip list. 
d. Select a terminal that will serve as the first terminal. 
e. Select a terminal side. 
f. Select a connection type. 
g. If required, select an appropriate overall shield terminal connection. 
h. Use the options in the Cable group box to define the cable that SmartPlant 

Instrumentation will use to connect the two panels: 
i. From the Reference cable list, select the appropriate reference cable that SmartPlant 

Instrumentation will use as the source for the creation of a cable that will connect the two 
panels.  The software duplicates the new cable in the Domain Explorer. 

j. In the Cable name data field, accept or type the name of the cable that SmartPlant 
Instrumentation will create to connect the two panels.  The cable names suggested by the 
software are composed of the End 1 and End 2 panel names.  Additional cables have 
their names incremented by one, for example XYZ.1, XYZ.2, and so forth. 
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k. Click OK to complete the task definition and return to the Auto-Wiring Browser View – 
New Auto-Wiring Routing Task window. 

7. In the Browser View – New Auto-Wiring Routing Task window, click . 

 
 After notifying you that the task has been executed successfully, the task status changes to 

Done.  For details, see Auto-Wiring Task Statuses (on page 131). 
 You can open the Connection window for the selected junction box to display the adjacent 

connection to make sure that the auto-wiring task has been executed correctly. 
 

Auto-Wire Two Panels 
This procedure explains how to define and execute an auto- wiring task for two panels (regardless 
of their signals).  Note that you must make all the required preparations prior to defining and 
executing a task. 

 Make sure that you have made all the required preparations that are specified in 
Auto- Wiring (see "Auto-Wiring" on page 123). 
1. Start the Wiring module. 
2. On the menu bar, click Actions > Auto-Wiring. 
3. In the Browser View – New Auto-Wiring Routing Task window, select the new task and do 

one of the following: 
 Click Actions > New. 

 Click . 
4. On the Auto-Wiring Routing Task dialog box, define the End 1 connection as follows: 

a. Click  next to the Panel field to select the required panel. 
b. In the Domain Explorer, select a panel that contains at least one terminal strip with 

unconnected terminals and then click OK. 
c. Select a terminal strip from the Strip list. 
d. Select a terminal that will serve as the first terminal. 
e. Select a terminal side. 
f. Select a connection type. 
g. If required, select an appropriate overall shield terminal connection. 

5. In the End 2 connection group box, do the following: 

a. Click  next to the Panel field to select the required panel. 
b. In the Domain Explorer, select a panel that contains at least one terminal strip with 

unconnected terminals and then click OK. 
c. Select a terminal strip from the Strip list. 
d. Select a terminal that will serve as the first terminal. 
e. Select a terminal side. 
f. Select a connection type. 
g. If required, select an appropriate overall shield terminal connection. 
h. Use the options in the Cable group box to define the cable that SmartPlant 

Instrumentation will use to connect the two panels: 
i. From the Reference cable list, select the appropriate reference cable that SmartPlant 

Instrumentation will use as the source for the creation of a cable that will connect the two 
panels.  The software duplicates the new cable in the Domain Explorer. 
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j. In the Cable name data field, accept or type the name of the cable that SmartPlant 
Instrumentation will create to connect the two panels.  The cable names suggested by the 
software are composed of the End 1 and End 2 panel names.  Additional cables have 
their names incremented by one, for example XYZ.1, XYZ.2, and so forth. 

k. Click OK to complete the task definition and return to the Auto-Wiring Browser View – 
New Auto-Wiring Routing Task window. 

6. In the Browser View – New Auto-Wiring Routing Task window, click . 

 
 After notifying you that the task has been executed successfully, the task status changes to 

Done.  For details, see Auto-Wiring Task Statuses (on page 131). 
 You can open the Connection window for the selected junction box to display the adjacent 

connection to make sure that the auto-wiring task has been executed correctly. 
 

Auto-Wire Control Systems 
You use this procedure to define and execute an auto-wiring task for a control system.  Note that 
prior to defining such a task, you must assign the required control system I/O channels to specific 
tag numbers. 

 
 Prior to defining such an auto- wiring task for a control system, you must assign the 

required control system I/O channels to specific tag numbers.  For details, see I/O 
Assignment (on page 105). 

 Make sure that you have made all the required preparations that are specified in Auto- 
Wiring (see "Auto-Wiring" on page 123). 

 For auto-wiring tasks that connect pre-assigned junction boxes to control systems, see 
Auto-Wire Control Systems Connected to Pre-Assigned Junction Boxes (on page 130). 

1. Start the Wiring module. 
2. On the menu bar, click Actions > Auto-Wiring. 
3. In the Browser View — New Auto-Wiring Routing Task window, select the new task and do 

one of the following: 
 Click Actions > New. 

 Click . 
4. On the Auto-Wiring Routing Task dialog box, define the End 1 connection as follows: 

a. Click  next to the Panel field to select the required panel. 
b. In the Domain Explorer, select a panel that contains at least one terminal strip with 

unconnected terminals and then click OK. 
c. Select a terminal strip from the Strip list. 
d. Select a terminal that will serve as the first terminal. 
e. Select a terminal side. 
f. Select a connection type. 
g. If required, select an appropriate overall shield terminal connection. 
h. In the End 2 connection group box, select the Control system check box. 

 Selecting the Control system check box disables all the options in the End 2 
connection group box (except for Connection type) so that SmartPlant Instrumentation 
can search for an available DCS or PLC panel with a matching signal. 

i. From the Connection type list, select the required End 2 connection type. 
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5. In the Cross wiring group box, select an appropriate cross wiring option to connect the 
control system to the junction box: 
 Single cross wires — Connects the control system using a single wire created by 

SmartPlant Instrumentation automatically during the auto-wiring process. 
 Cables created from reference — Connects the control system using a cable that 

SmartPlant Instrumentation creates by duplicating the reference cable that you select 
from the Reference cable list in the Cable group box.  The software checks whether 
such a cable exists in the Domain Explorer and if so, whether this cable is connected to 
the panel selected in the End 1 connection group box.  If this cable has unconnected 
cable sets, the software connects them and then creates additional cables so that all the 
terminals are connected.  Note that in this case, the software connects all the cable sets 
whether they are required or not.  Therefore, for this option to work properly, you must 
create appropriate reference cables and connection types before starting auto- wiring. 

 One cable per tag — Connects the control system using a separate cable for each tag 
number.  The software creates each cable by duplicating the reference cable that you 
select from the Reference cable list in the Cable group box.  SmartPlant Instrumentation 
creates the required number of cables according to the number of tag signals it 
detects.  The software names each cable according to the signal name.  You can add a 
prefix and a suffix to the cable name by typing the required string in the Cable name 
prefix and Cable name suffix fields. 

6. Use the options in the Cable group box to define the cable for connecting the pre- assigned 
junction box to the control system (not available if you selected the Single cross wires 
option): 
a. From the Reference cable list, select an appropriate reference cable that SmartPlant 

Instrumentation uses as a source for the creation of a cable that will connect the two 
panels.  The software duplicates the new cable in the Domain Explorer. 

b. In the Cable name data field, the software suggests a cable name composed of the End 1 
and End 2 panel names.  Accept this name or type a name of your choice for the cable 
that SmartPlant Instrumentation will create to connect the two panels.  Any additional 
cables that the software creates have identical names with a numeric suffix that is 
incremented by one for each new cable; for example XYZ.1, XYZ.2, and so forth. 

c. Click OK to complete the task definition and return to the Browser View — New 
Auto-Wiring Routing Task window. 

7. Click . 

 
 After notifying you that the task has been executed successfully, the task status changes to 

Done.  For details, see Auto-Wiring Task Statuses (on page 131). 
 You can open the Connection window for the selected junction box to display the adjacent 

connection to make sure that the auto-wiring task has been executed correctly. 
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Auto-Wire Control Systems Connected to Pre-Assigned 
Junction Boxes 

This procedure explains how to define and execute an auto- wiring task for a control system that is 
to be connected to a pre-assigned junction box.  Note that prior to defining such a task, you must 
assign the required control system to specific tag numbers. 

 
 You must pre-assign the required junction boxes and make all the required preparations 

prior to defining and executing a task.  For details, see Pre-Assign Junction Boxes to 
Device Panels (on page 125). 

 Assign the required control system I/O channels to specific tag numbers.  For details, see 
I/O Assignment (on page 105). 

 Make sure that you have made all the required preparations that are specified in Auto- 
Wiring (see "Auto-Wiring" on page 123). 

 For auto-wiring tasks involving a connection to a junction box that has not been pre- 
assigned, see Auto-Wire Control Systems (on page 128). 

1. Start the Wiring module. 
2. On the menu bar, click Actions > Auto-Wiring. 
3. In the Browser View — New Auto-Wiring Routing Task window, select the new task and do 

one of the following: 
 Click Actions > Edit Task. 

 Click . 
 The Auto-Wiring Routing Task dialog box opens where all the End 1 connection 

properties except for the Connection type and Overall shield terminal connection have 
been defined.  You can accept the displayed values or modify them as needed. 

4. On the Auto-Wiring Routing Task dialog box, complete the End 1 connection definition as 
follows: 
a. Select the required connection type from Connection type list. 
b. If required, select the appropriate overall shield terminal connection. 
c. In the End 2 connection group box, select the Control system check box. 

 Selecting the Control system check box disables all the options in the End 2 
connection group box (except for Connection type) so that SmartPlant Instrumentation 
can search for an available DCS or PLC panel with a matching signal. 

d. From the Connection type list, select the required End 2 connection type. 
5. In the Cross wiring group box, select an appropriate cross wiring option to connect the 

control system to the junction box: 
 Single cross wires — Connects the control system using a single wire created by 

SmartPlant Instrumentation automatically during the auto-wiring process. 
 Cables created from reference — Connects the control system using a cable that 

SmartPlant Instrumentation creates by duplicating the reference cable that you select 
from the Reference cable list in the Cable group box.  The software checks whether 
such a cable exists in the Domain Explorer and if so, whether this cable is connected to 
the panel selected in the End 1 connection group box.  If this cable has unconnected 
cable sets, the software connects them and then creates additional cables so that all the 
terminals are connected.  Note that in this case, the software connects all the cable sets 
whether they are required or not.  Therefore, for this option to work properly, you must 
create appropriate reference cables and connection types before starting auto- wiring. 
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 One cable per tag — Connects the control system using a separate cable for each tag 
number.  The software creates each cable by duplicating the reference cable that you 
select from the Reference cable list in the Cable group box.  SmartPlant Instrumentation 
creates the required number of cables according to the number of tag signals it 
detects.  The software names each cable according to the signal name.  You can add a 
prefix and a suffix to the cable name by typing the required string in the Cable name 
prefix and Cable name suffix fields. 

6. Use the options in the Cable group box to define the cable for connecting the pre- assigned 
junction box to the control system (not available if you selected the Single cross wires 
option): 
a. From the Reference cable list, select an appropriate reference cable that SmartPlant 

Instrumentation uses as a source for the creation of a cable that will connect the two 
panels.  The software duplicates the new cable in the Domain Explorer. 

b. In the Cable name data field, the software suggests a cable name composed of the End 1 
and End 2 panel names.  Accept this name or type a name of your choice for the cable 
that SmartPlant Instrumentation will create to connect the two panels.  Any additional 
cables that the software creates have identical names with a numeric suffix that is 
incremented by one for each new cable; for example XYZ.1, XYZ.2, and so forth. 

c. Click OK to complete the task definition and return to the Browser View — New 
Auto-Wiring Routing Task window. 

7. Click . 

 
 After notifying you that the task has been executed successfully, the task status changes to 

Done.  For details, see Auto-Wiring Task Statuses (on page 131). 
 You can open the Connection window for the selected junction box to display the adjacent 

connection to make sure that the auto-wiring task has been executed correctly. 
 

Auto-Wiring Task Statuses 
After you define an auto-wiring task, SmartPlant Instrumentation assigns it a status.  Tasks can 
have different statuses that are set according to the task definitions.  You can change certain task 
statuses if needed. 
The following table defines the various task statuses and explains which statuses you can 
change. 

Status Description Can Be Changed To 

New A newly created task that has not yet been 
executed. 

Hold 

Hold A task that has been put on hold. 
This task cannot be executed until you change its 
status to Execute. 

Execute 

Execute A task whose status has been changed from 
Hold. 
This task can be executed. 

Cannot be changed 

Done A task that has already been executed. 
Such a task cannot be executed again. 

Cannot be changed 
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Change an Auto-Wiring Task Status 
After you define an auto-wiring task, SmartPlant Instrumentation assigns it a status.  Tasks can 
have different statuses that are set according to the task definitions.  You can change certain task 
statuses if needed. 
1. In the Auto-Wiring Browser View window, right-click a task. 
2. On the shortcut menu, click Task Status. 
3. Click the option that you require. 
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S E C T I O N  1 3  

Signal Propagation 
Signal propagation is a method used in SmartPlant Instrumentation to associate wires with 
instruments.  A signal or a tag signal is a software identifier that is associated with a particular 
instrument tag, and is generated in a device panel or locally within other types of panels.  A tag 
signal can also be created as a result of I/O assignment. 
When you connect or disconnect a cable, cable set, or wire, SmartPlant Instrumentation 
automatically updates the wire tags and the signals that are carried by the wires.  Tag signal 
propagation takes place automatically, with consequent updating of wire names, and signal 
sequences.  Signal sequence values are sequential numbers assigned consistently to all the 
wires within a given wire group along the signal path of that wire group.  Automatic tag signal 
propagation also takes place after you effect I/O assignment.  For details of various tag signal 
propagation results, see Possible Cases of Signal Propagation (on page 133). 
However, there may be situations in which tag signal propagation does not occur 
automatically.  In this case, SmartPlant Instrumentation offers you two options for semiautomatic 
propagation of a selected tag signal.  You can re-propagate a tag signal or force tag signal 
propagation.  For details, see Force Signal Propagation (on page 135) and Re-Propagate a Tag 
Signal (on page 135). 
Also, you can effect signal propagation at terminal strip level by manually entering or changing a 
signal or its level at any point along the wiring path. 

 
 Unlike wires, jumpers do not propagate signals.  You can assign a wire group to a jumper 

manually on the Terminal Connection dialog box. 
 Tag signal propagation for a shield takes place automatically without the need to connect that 

shield to a device panel terminal. 
 Tag signal propagation stops if it reaches a point where multiple optional paths exist. 
 You can re-propagate or force propagation of tag signals if this is required. 
 You can intervene at any point of the wire path and change tag number propagation manually. 

You can generate a point-to-point wiring diagram and view the signal path after you finish 
assigning an instrument tag to a channel in an I/O card.  For information about point-to-point 
diagrams, see Trace a Signal in a Point-to-Point Wiring Diagram (on page 102). 
 

Possible Cases of Signal Propagation 
After you effect I/O assignment, the software automatically propagates the tag signals.  Four 
situations can exist: 



Wiring in SmartPlant Instrumentation 
 

 
134 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

Case 1 
In this example, the signal sequence is from the device panel up to the PLC cabinet with all the 
wiring: 

 

Case 2 
In this case the connection sequence starts from the device panel and continues to the PLC 
cabinet, however, there is a discontinuity between Strip 1 and Strip 2 of the marshaling rack: 

 
Note that the wiring sequence can be different depending on the completeness of the connection: 
 From 1 to 8 (as in the first case) — connected from the device panel to the PLC. 
 From 1 to 4 and from 99 to 100 (as in the second case) — there is a break in the middle of the 

connection. 

Case 3 
The signal sequence is from the device panel to the PLC cabinet however, there is a discontinuity 
between the marshaling rack and the PLC cabinet. 

 



 Wiring in SmartPlant Instrumentation 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 135 
 

Case 4 
The connection sequence starts from the PLC cabinet and continues to the junction box.  The 
device panel is absent. 

 
 

Re-Propagate a Tag Signal 
You use this feature when the software does not fully complete the automatic propagation of a tag 
signal.  This procedure explains how to propagate a tag signal from a selected device panel, 
through all the connected cables and panels, until it encounters a different signal.  After it 
encounters a different signal, the software does not make any further changes in the propagation. 
1. Press F7 to open the Domain Explorer. 
2. Right-click a device panel from which a signal originates. 
3. On the shortcut menu, click Actions > Re-Propagate Signal. 
 

Force Signal Propagation 
You use this feature when the software does not fully complete the propagation of a tag signal 
automatically.  This procedure explains how to force the propagation of a tag signal from a 
selected device panel, through all the connected cables and panels so that the re-propagated 
signal overrides all the existing signals that it encounters. 
1. Press F7 to open the Domain Explorer. 
2. Right-click a device panel from which a signal originates. 
3. On the shortcut menu, click Actions > Force Signal Propagation. 
 

Propagate a Tag Signal Manually 
During your wiring design, situations can arise in which the propagation of a tag signal does not 
occur automatically.  SmartPlant Instrumentation lets you effect signal propagation at terminal 
strip level by manually entering or changing a signal or its level at any point along the wiring 
path.  You need to propagate tag signals manually when: 

 There is a split in the wiring path. 
 There are terminal strips that emulate barriers. 
 You cross-wire two terminals, one of which already receives a signal. 
 You remove a signal that is stopping tag signal propagation. 
 You add another signal level at an exit point of one of the terminal strips. 

1. Do one of the following: 
 In the Connection window, from the Terminal Strip list, select the terminal strip for which 

you want to effect signal propagation manually. 
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 In the Cross Wiring window, from the Primary terminal strip list, select the terminal strip 
for which you want to effect signal propagation manually. 

2. Double-click  next to the required wired terminal. 
3. On the Terminal Connection dialog box, under Signal, click and then select from the list the 

signal that you want to propagate. 
4. Under Signal Level, click and select from the list, a value for the signal level. 

 You can also select zero to indicate that a signal does not have a signal level 
setting.  This means that all the wires in the current wire group are propagated on the same 
level. 

5. Under Sequence, click and select from the list a connection sequence. 
6. Click Save to propagate the signal. 
7. To navigate to other terminals for which you need to change propagation settings, do one of 

the following: 
 Click Next or Previous. 
 Under Terminal number, select a terminal that you require. 

 
 Repeat the above procedure for each terminal strip that requires manual signal propagation. 
 If you remove a signal at any point of the wiring path, SmartPlant Instrumentation stops the 

signal propagation at that point.  However, if there is an I/O card at the other end of that signal 
path, the SmartPlant Instrumentation stops the tag signal propagation at the break point and 
assigns a new connection sequence (100, 99, 98 …) starting from the I/O card. 

 If you replace one signal with another at any point along the wiring path, the software stops the 
propagation of the old signal at the point where you made the change and propagates a new 
signal from that point onward to the end of the signal path. 

 

Automatically Propagate a Signal from a Non-Wiring 
Instrument 

This feature makes it possible to associate a conventional or electrical non-wiring instrument with 
a connected wire, cable set, or cable.  Dragging such an instrument from the Instruments folder 
of the Domain Explorer to a connected wire, cable set, or cable in the Connection window 
automatically creates a signal from that instrument and propagates this signal along the 
connected wiring path.  Note that non-wiring instruments are instruments that were created based 
on instrument type profiles that have no wiring. 
1. In the Instruments folder of the Domain Explorer, select a conventional or electrical 

non-wiring instrument. 
 Non-wiring instruments are instruments that were created based on instrument type 

profiles that have no wiring or control system selections but have the Include wiring check 
box selected. 

2. Drag the selected instrument to a connected wire, cable set or cable in the Connection 
window. 

 
 SmartPlant Instrumentation propagates a signal from the selected instrument along the wiring 

path based on whether you drag the instrument to a cable, cable set or wire: 
 Dragging an instrument to a cable or a cable set — a signal will be propagated through 

each of the wires of the cable or the cable set.  Each wire will get a different signal level. 
 Dragging an instrument to a single wire — a signal will be propagated only through that 

wire. 
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 If the current panel in the Connection window is a device panel, the software associates the 
instrument with the target device panel. 

 If the target wires already carry other signals, the software stops these signals and propagates 
new ones instead. 

 The software automatically updates the signal levels based on whether you dragged the 
instrument to a single wire, a cable, or a cable set.  The signal will start at level one and 
sequence one.  However, if level one and sequence one are occupied, the software will 
automatically look for the next available signal level and sequence. 

 

Create a Local Tag Signal 
A local signal is a user-defined signal that does not originate from a device panel or an I/O 
channel.  You create a local signal within any other kind of panel.  For example, in an 
instrumentation electrical interface cabinet, a local signal starts at a terminal relay or in a junction 
box, it starts at a terminal strip.  Note that you can apply tag signals (level and sequence) to wires 
when no device panel is connected.  You can use local signals as follows: 

 You can create a local tag signal by assigning a local signal to a wiring tag that does not 
yet have a signal of its own. 

 You can create a general signal and link it to the signals that are wired into the terminal 
strip. 

1. Do one of the following: 
 In the Connection window, click Actions > Local Signal. 

 In the Connection window, click  
 On the Terminal Connection dialog box, click Signal. 

2. On the Local Signal dialog box, select a wiring tag that has not been associated with a signal 
(that is, a tag that has no signal name next to it.) 

3. Click Create. 
4. Click Close to create and propagate the new local tag signal. 

 
 All propagation rules apply to local tag signals. 
 For cross wiring with independent wiring from the local terminal strip and I/O card ends, create 

local tag signals before assigning I/O channels. 
 You can apply tag signals (level and sequence) to wires when no device panel is connected. 

 

Filter the Local Signal Dialog Box 
This procedure enables you to filter the data window in the Local Signal dialog box determining 
the tag numbers that SmartPlant Instrumentation displays in the Tag Number column.  This 
makes it easier to select the tag numbers that you can assign to local signals. 
1. On the Local Signal dialog box, click Filter to open the Signal Filter dialog box. 
2. Define a conditional expression as follows: 

a. From the Column Name list, select the appropriate tag number attribute according to 
which you want to filter the data. 

b. From the Operator list, select the required comparison operator to determine how the tag 
number attribute selected in the Column Name field will relate to the expression you enter 
in the Value field. 

c. From the Value data list, select or type the required value to determine how the tag 
number attribute selected in the Column Name field will be specified.  You can use 
wildcards such as % (percent) and _ (underscore) to set the value. 
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d. From the Logical list, select the required logical operator to determine how the next filter 
expression will relate to the current one (if applicable). 

3. Click New to add another data row for an additional filter expression if needed.  Make sure 
you select the appropriate logical operator ( And, Or) at the end of the previous row. 

4. To retrieve tag numbers that were imported from SmartPlant Electrical, select SmartPlant 
Electrical signals only. 

5. To retrieve tag numbers that were imported from SmartPlant Electrical and that already have 
an association with a specified power distribution board (PDB) in SmartPlant Electrical, select 
Pre-assigned signals only.  This option is available only when you select SmartPlant 
Electrical signals only. 

6. To save the filter condition settings so that the next time you open the Signal dialog box 
SmartPlant Instrumentation filters the data accordingly, select Save filter. 

 Click Restore to revert to the filter condition that you saved the last time. 
7. Click Verify to check the correctness of your filter. 
8. Click OK. 
 

Create a General Signal 
A general signal is a user-defined signal which is not characterized by any existing process 
function and which does not carry any information from an instrument.  You link a general signal 
with tag signals and other general signals.  You can use a general signal to treat several tag 
signals as a group that share common wires.  You can use general signals for the following 
purposes: 

 Combine signals into a wire group for transmitting multiple signals that are multiplexed or 
de-multiplexed through it. 

 Represent the common connection for single or multiple loop power supply. 
1. Do one of the following: 

 In the Connection window, click Actions > Local Signal. 

 In the Connection window, click  
 On the Terminal Connection dialog box, click Signal. 

2. On the Local Signal dialog box, under General signal, click New in the group box. 
3. On the New General Signal dialog box, under Signal name, type a unique name. 
4. To associate the new general signal with all the tag signals in the current terminal strip, select 

Apply to all tag signals of the current strip. 
5. Click OK to create and propagate the new general signal. 

 
 The new general signal name appears in the Signal column with no tag next to it.  This 

indicates that this is a general signal that originated in the current terminal strip. 
 You can change the general signal name at any time by clicking Edit after selecting the 

required general signal. 
 If this general signal is used in a loop drawing, make sure that the general signal name is 

changed in the loop macro definitions too. 
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 Macros in a CAD application, that you want to solve with a general signal in SmartPlant 
Instrumentation, must have the general signal name (as defined in the SmartPlant 
Instrumentation Local Signal dialog box) added as a prefix to the CAD application macro.  
For example, for the CAD macro PNL_NAME.1.4, to be recognized by SmartPlant 
Instrumentation and solved with the general signal called GENERALSIG1, you add the 
general signal name to the CAD macro as a prefix in the CAD application: 
GENERALSIG1.PNL_NAME.1.4. 

 

Link Tag Signals to a General Signal 
This procedure allows you to link tag signals to a general signal that you create on a given 
strip.  You need this functionality to: 

 Use a power supply to power tag signal circuits. 
 Multiplex tag signals into a general signal. 

1. Recombine tag signals that you previously multiplexed. 
2. Do one of the following: 

 In the Connection window, click Actions > Local Signal. 

 In the Connection window, click  
 On the Terminal Connection dialog box, click Signal. 

3. On the Local Signal dialog box, under Signal, select the general signal to which you want to 
link tag signals. 

4. Click Link. 
5. On the Link Tag Signals to General Signal dialog box, under Link, select the check boxes 

for the tag signals that you want to link to the general signal. 
6. Click Close to return to the Local Signal dialog box. 

 Since a general signal does not directly connect to a tag, you need a different way to find 
the data for the signal's tag numbers.  In the drawing block, the macros (tags / attributes) that 
contain the data for these signals should start with a prefix that reflects the name of the signal. 
 

Multiplex Tag Signals 
SmartPlant Instrumentation enables you to multiplex tag signals.  That is, you can combine tag 
signals into a general signal that you propagate.  Also, you can combine signals from incoming 
general signals with independent tag signals into a new general signal that you propagate. 

 
 Before you manage the signals within a given terminal strip, create and connect the 

cables that serve the terminal strip. 
 You can only multiplex tag signals that are wired into the terminal strip. 

1. In the Domain Explorer, right- click a panel or a terminal strip. 
2. On the shortcut menu, click Actions > Connection. 
3. In the Connection window, click  next to a terminal in the wire group into which you want to 

multiplex a signal. 
4. On the Terminal Connection dialog box, click Signal to open the Local Signals dialog box. 
5. Create a unique general signal.  For details, see Create a General Signal (on page 138). 
6. Link the general signal to the signals that you want to multiplex.  For details, see Link Tag 

Signals to a General Signal (on page 139). 
7. Do the following for each terminal in the wire group that you are associating with the general 

signal: 
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a. Under Signal, select the general signal that you want to propagate. 
b. Select a sequence and a signal level. 

8. To navigate to other terminals for which you need to change propagation settings, do one of 
the following: 
 Click Next or Previous. 
 Under Terminal number, select the terminal that you want to edit. 

9. Click Save. 
 

De-Multiplex Tag Signals 
SmartPlant Instrumentation enables you to separate tag signals from a general signal.  This is 
called de-multiplexing.  Then, you can propagate the independent signals manually. 

 Before you manage the signals within a given terminal strip, create and connect the 
cables that serve the terminal strip. 
1. In the Domain Explorer, right- click a panel or a terminal strip. 
2. On the shortcut menu, click Actions > Connection. 
3. In the Connection window, click  next to a terminal in the wire group into which you want to 

de-multiplex a signal. 
4. On the Terminal Connection dialog box, do the following for each terminal in the wire group 

that you are associating with one of the of the de- multiplexed signals: 
a. Under Signal, select the tag signal that you want to propagate. 
b. Select a sequence as you require.  Note that you should increment the sequence 

according to the original tag signal, rather than according to the general signal with which 
it was linked. 

c. Select a signal level. 
5. To navigate to other terminals for which you need to change propagation settings, do one of 

the following: 
 Click Next or Previous. 
 Under Terminal number, select the terminal that you want to edit. 

6. Click Save. 
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S E C T I O N  1 4  

Intrinsic Safety 
This section describes the procedures for calculating intrinsic safety in SmartPlant 
Instrumentation. 

In This Section 
Create an Intrinsically Safe Circuit Type ....................................... 141 
Manage Intrinsic Safety Circuit Types ........................................... 141 
Calculate Intrinsic Safety ............................................................... 142 
Define Tag Numbers for Intrinsic Safety Loop Calculation ............ 143 
Define Circuit Cables for Intrinsic Safety Loop Calculation ........... 143 
Calculate Intrinsic Safety for a Loop .............................................. 144 
 
 

Create an Intrinsically Safe Circuit Type 
The first step in making an intrinsically safe calculation is to define a circuit type. 
1. Start the Wiring module and do one of the following: 

 Click Actions > Intrinsic Safety. 

 Click . 
2. On the Intrinsically Safe Circuit dialog box, click New. 
3. Enter the following information: 

a. Type the required circuit type in the Circuit Type data field and the circuit type description 
in the Circuit Description data field. 

b. From the I/O Type list, select the appropriate area I/O type. 
c. From the Area Classification list, select the appropriate area classification. 

4. Click Save. 
5. On the Drawing Number dialog box, enter an appropriate drawing number name. 
6. Click OK. 

 The new circuit type is saved and the Intrinsically Safe Circuit dialog box opens.  You 
can now select the newly created type from the Circuit Type list. 
 

Manage Intrinsic Safety Circuit Types 
This option shows you how to maintain the contents of the IS (intrinsic safety) circuit type 
supporting table from the Instrument Index module.  You can also maintain this supporting table 
from the Wiring module. 
1. Open the Instrument Index module by doing one of the following: 

 Click Module > Instrument Index. 

 Click . 
2. Click Tables > Intrinsically Safe Circuit Types. 
3. Click New, to create a new IS circuit type. 
4. Under Intrinsically Safe Circuit Type, type the unique and required type name. 
5. Under Intrinsically Safe Circuit Description, type the description. 
6. Under Drawing Name, type the drawing name. 
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7. From the Area Classification list, select the area classification. 
8. Click Properties. 
9. On the Intrinsically Safe Data Input dialog box, under Non-hazardous area loop 

components, enter the relevant data for the non- hazardous devices, such as barrier, 
isolator, and so forth.  You must define the R1, C1, and L1 values. 

10. Under Hazardous area loop components, enter the relevant data for the hazardous 
devices, such as transmitters, I/P converters, and so forth.  You must define the R2, C2, and 
L2 values. 

11. Click OK to close the Intrinsically Safe Data Input dialog box. 
12. Click OK to finish. 
 

Calculate Intrinsic Safety 
Intrinsic safety calculation in SmartPlant Instrumentation allows you to calculate the maximum 
permissible cable length between the hazardous and non-hazardous areas based on three main 
criteria: 
 Resistance 
 Capacitance 
 Inductance 

The calculations are made at the domain level. 
1. Start the Wiring module and do one of the following: 

 Click Actions > Intrinsic Safety. 

 Click . 
2. On the Intrinsically Safe Circuit dialog box, from the Circuit type list, select the appropriate 

circuit type. 

 
 The remaining fields on the dialog box are filled in automatically with the data for the 

circuit type you select. 
 If the required circuit type is not on the list, create a new one or edit an existing circuit 

type.  For more information, see Calculate Intrinsic Safety for a Loop (on page 144). 
3. Click OK. 
4. On the Intrinsically Safe Data Input dialog box, under Non-hazardous area loop 

components, enter the relevant data for the non-hazardous devices, such as barrier, isolator, 
and so forth.  You must define the R1, C1, and L1 values. 

5. Under Hazardous area loop components, enter the relevant data for the hazardous 
devices, such as transmitters, I/P converters, and so forth.  You must define the R2, C2, and 
L2 values. 

6. Define the cable parameters between the junction box and the marshaling rack. 
7. Define the cable parameters between the device panel and the junction box (if the cable 

exists).  If the field instrument is connected directly to the marshaling rack, specify the cable 
length (B) = 0. 

8. Click Calculate to calculate the limit criteria (resistance, inductance, or capacitance) and the 
maximum permissible cable length between the junction box and the marshaling rack (Cable 
A) based on the values you entered. 

 
 The Intrinsically Safe Calculation Results dialog box opens where you can view the 

calculation results, change the units of measure, and save the results with the different 
units. 
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 The maximum permissible length must be less than the actual length of the cable used 
(Cable “A” – connecting the hazardous and non-hazardous areas). 

9. Click OK to return to the Intrinsically Safe Data Input dialog box. 
10. If desired, you can do any of the following: 

 View and enter revisions. 
 Enter intrinsic safety notes. 
 Click Print to generate and print a report that shows all the data that you entered and the 

calculation results. 
 

Define Tag Numbers for Intrinsic Safety Loop Calculation 
When calculating intrinsic safety for a loop, you need to define the tag numbers that belong to the 
relevant loop.  You have to repeat this procedure for each and every tag number in the loop. 
1. In the Domain Explorer, right- click an instrument, and on the short-cut menu, click 

Properties. 
2. On the Tag Number Properties dialog box, beside the Intrinsically safe circuit type list, 

click . 
3. On the Intrinsically Safe Circuit Types dialog box, select the required row, and then click 

Properties. 
 You can also create a new intrinsically safe circuit type. 

4. On the Intrinsically Safe Data Input dialog box, in both group boxes, make sure that you 
express the following parameters in the following units of measure: 
 Resistance — ohm 
 Inductance — mH 
 Capacitance — μF (microFarad) 
 L/R — mH/ohm 

5. Click OK to close the Intrinsically Safe Data Input dialog box. 
6. Make sure that the row that you require is selected and then click OK to close the Intrinsically 

Safe Circuit Types dialog box. 
7. On the Tag Number Properties dialog box, click OK. 
 

Define Circuit Cables for Intrinsic Safety Loop Calculation 
Before calculating intrinsic safety for a loop, you must perform this procedure for each cable in the 
circuit. 
1. In the Domain Explorer, right- click a cable, and on the short-cut menu, click Properties. 

2. On the Cable Properties dialog box, beside the Type list, click . 
3. On the Cable Types dialog box, select the required row, and then click Properties. 

 You can also create a new intrinsically safe circuit type. 
4. On the Cable Type Properties dialog box, make sure that you express the following 

parameters in the following units of measure: 
 Capacitance — nF (nanoFarad) / km 
 Resistance — Ohm/km 
 Inductance — mH/km 

5. Click OK to close the Cable Type Properties dialog box. 
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6. Make sure that the row that you require is selected and then click OK to close the Cable 
Types dialog box. 

7. On the Cable Properties dialog box, under Unit of measure, select meter. 
8. Under Length, define the cable length. 
9. Select the Set as intrinsically safe check box, and then click OK. 
 

Calculate Intrinsic Safety for a Loop 
After defining loop tags and circuit cables as required, use this procedure to perform the loop 
intrinsic safety calculation. 
1. Start the Wiring module and click Actions > Intrinsic Safety Loop Calculation. 
2. On the Enter Loop Number dialog box, do one of the following: 

 Type the loop number in the data field. 
 Click Find to search for a loop that requires intrinsic safety calculation. 

3. Click OK to open the Intrinsically Safe Loop Data dialog box. 

 
 In the data window, if you select a tag for which you did not define an intrinsically safe 

circuit type, nothing is displayed in the lower group box. 
 If you select a tag number for which you defined an intrinsically safe circuit type, 

SmartPlant Instrumentation displays non-hazardous area and hazardous area loop 
components below the data window. 

4. On the Intrinsically Safe Loop Data dialog box, click Calculate. 
5. In the Intrinsically Safe Calculation Results dialog box, select each tag number for which 

you want to display intrinsic safety data. 
6. To preview reports for all of the tags in the current loop, click Print. 
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S E C T I O N  1 5  

Cable Routing 
The cable routing feature provides the ability to set up a flexible, modular model of the cable 
routing in your <plant>.  Cable routing sections are divided into several categories that enable you 
to set up a complete cable routing sequence.  These categories match the different <plant> 
regions as follows: 

Category Category Description and Location in the <Plant> 

Trunk Standard sections that include all the cable routing that does 
not pass through a built area.  These sections are actually 
legs passing through the <plant> junction points that 
function as ports, where cables enter and exit the 
routing.  Trunks contain trays conveying the positions 
through which the cables pass. 

Building Sections that pass through a built area.  Building sections 
do not contain trays or positions. 

Panel – Routing 
Distance 

This in fact, is not a section category but a variable distance 
added to the total cable routing length.  It is the distance 
between an instrument and the routing starting point. 

In an Owner Operator domain (As-Built), it is possible to claim cables and their cable routing data 
to a project. Once claimed to a project, the routing data is no longer available to work within 
As-Built, until the data is merged back. You can only work on cable routing in one project at a time. 
Reports and validations are carried out on the plant and projects as if they were one. To work with 
cable routing in another project, you must first merge the project with the routing data back to the 
plant, this removes the routing data from the project and replaces the data in the As-Built. Then 
reclaim making sure that the first project you claim to is the project that you want to work with cable 
routing. 
In an Owner Operator plant you can create Cable Routing Reports that contain all the cable 
routing data from the As-Built and all projects. 
 
 

Cable Routing Flow of Activities 
The cable routing feature allows you to create modular cable routing sections.  The sections 
convey the cables in your <plant>, and they subdivide into two main categories: 
 A Trunk is a standard section that can be utilized in all non-enclosed plant areas.  Trunks 

contain positions, fixed on trays. 
 A Building is a section that passes through an enclosed area, and does not contain positions 

You plan your cable routing system according to the following flow of activities: 
1. Set the cable routing options, such as cable length and position width units of measure, cable 

spare length, and so forth.  For details, see Set Cable Routing Options (on page 146). 
2. Create named standard widths.  You will use these later to create positions in the trunk 

section.  For details, see Manage Standard Widths (on page 147). 
3. Create standard positions.  Positions convey the cables within the trunk sections.  For 

details, see Manage Standard Positions (on page 147). 
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4. Define the maximum number of cables for each standard position, according to the position 
width.  This is how you assure that the number of cables does not exceed the position cable 
capacity.  For details, see Set the Maximum Number of Cables for the Standard Positions (on 
page 148). 

5. Create the routing sections.  For details, see Create a Routing Section (on page 148). 
6. Associate cables with sections.  The association can be performed in single or batch 

mode.  The association includes the following activities: 
 Selecting the cables to which you add the cable routing. 
 Setting the order of the routing sections per cable. 
 Selecting the active positions for each section. 

 

Set Cable Routing Options 
Use this procedure to set the options for the cable routing throughout a specific 
<plant>.  SmartPlant Instrumentation applies your selections to existing cables and sections and 
to all future routing elements.  When you change the Length unit of measure, the software 
automatically recalculates values of routing elements that currently exist in your plant and 
expresses them in the new units of measure.  The routing elements that SmartPlant 
Instrumentation recalculates after a change in the Cable Routing Options dialog box are cable 
length, panel-routing distance, and section length. 
1. In the Wiring Module window, click Actions > Cable Routing Options. 
2. On the Cable Routing Options dialog box, from the Length unit of measure list, select a 

unit of measure. 
3. In the message box that opens, click OK to confirm calculation in the new unit of measure. 
4. From the Position width unit of measure list, select the required unit of measure. 

 Set the Position width unit of measure at initialization, and do not change it.  Although 
changing the length unit of measure recalculates length values in the new unit of measure, 
changing the position width unit of measure changes the label without recalculating the value 
of the position width. 

5. In the message box that opens, click OK to confirm the position width unit of measure. 
6. In the Cable spare length group box, to calculate the spare cable length for all the cables in 

the <plant>, do one of the following: 
 Select Fixed length and type its value in the box to the right. 
 Select Fixed percentage, and type or select a percent value in the box to the right. 

7. Under Panel to routing distance, type the distance from a junction box or marshaling rack to 
the beginning of a routing section. 

8. To customize cable routing terminology, next to Customize terminology, select the check 
box and then click the Terminology command button.  For details, see Customize Cable 
Routing Terminology (on page 147). 

 For cable drums with status Design or Purchased, if you change cable spare length, 
SmartPlant Instrumentation recalculates the cable length, but not for drums with status Locked. 
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Customize Cable Routing Terminology 
Use this procedure to change cable routing terminology to terms that you define.  You can change 
any or all of the following terms: trunk section, building section, position, section, and 
tray.  Changes that you make are implemented in all relevant dialog boxes and reports. 
1. In the Wiring Module window, click Actions > Cable Routing Options. 
2. On the Cable Routing Options dialog box, select Customize terminology and then click 

Terminology. 
3. On the Cable Routing Custom Terminology dialog box, for each term that you want to 

customize, under Custom Heading (Singular) and Custom Heading (Plural), type the 
desired values. 

4. Click OK to close the Cable Routing Custom Terminology dialog box. 
5. Click OK to close the Cable Routing Options dialog box. 
 

Manage Standard Widths 
The standard width is a value that you enter and which SmartPlant Instrumentation uses to define 
the width of the routing positions that the sections comprise.  This procedure explains how to add 
a standard width to your current <plant>, edit, or delete an existing one.  Note that a standard 
width is not necessarily associated with a position.  It only provides the ability to associate the 
width with positions. 
1. In the Wiring Module window, click Tables > Cable Routing > Standard Widths. 
2. On the Standard Widths dialog box, do one of the following: 

 To add a new standard width, click New. 
 To edit an existing standard width, click the field that you want to edit. 
 To delete a standard width, highlight the required standard width or in the Find field, type 

the width that you want to delete, and click Delete. 
3. Type the required standard width value. 
4. Click OK to save your changes and close the dialog box. 
 

Manage Standard Positions 
Routing positions are the wiring elements that convey the cables in your <plant> and separate the 
different cable groups inside the routing sections.  You associate the standard routing positions 
with the trunk sections in your <plant> and adjust their widths to fit those positions.  This way you 
do not have to define new positions for every new trunk that you add. 
1. In the Wiring Module window, click Tables > Cable Routing > Standard Routing 

Positions. 
2. On the Standard Routing Positions dialog box, do one of the following: 

 To add a new standard position, click New. 
 To edit an existing standard position, click the field that you want to edit. 
 To delete a standard position, highlight the required standard position or in the Find field, 

type the position that you want to delete, and click Delete. 
3. Type the position name and description as required.. 
4. Repeat steps 1-3 for all the standard positions you want to enter. 
5. Click OK to save your changes and close the dialog box. 
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Set the Maximum Number of Cables for the Standard 
Positions 

The maximum number of cables is a value that you define to limit the number of cables that you 
can associate with a position within a trunk section.  You can add positions to trunks only if you 
predefined a maximum number of cables per position.  That is, you define the number of cables 
for a standard position and only then the position becomes available to include in a trunk. 
1. In the Wiring Module window, click Tables > Cable Routing > Maximum Number of 

Cables. 
2. On the Maximum Number of Cables dialog box, click a field and type the maximum number 

of cables in the width column of the required position. 
 The Maximum Number of Cables dialog box comprises a grid.  The grid displays the 

standard positions and standard widths that you have added to your current <plant>. 
3. Click OK to save your changes and close the dialog box. 
 

Create a Routing Section 
Routing sections are the wiring elements that convey the cables in your <plant>.  They subdivide 
into two main categories: 
 Trunk — a standard section that can be utilized in all non-enclosed <plant> areas.  Trunks 

contain positions. 
 Building — a section that passes in an enclosed area and does not contain positions. 

You define a standard position with a standard width to fit the section that includes it. 
1. In the Wiring Module window, click Tables > Cable Routing > Routing Sections. 
2. On the Routing Sections dialog box, do one of the following: 

 To base the new routing section on an existing routing section, click Duplicate. 
 To create a new routing section not based on an existing section, click New. 

3. In the Routing Section Properties dialog box, type the new section name or accept the 
default in the Routing section field. 

 The initial All or Trunk default is T-1, and the initial Building default is B-1.  Defaults for 
succeeding entries revise the previous name in a given category by adding a 1 or 
incrementing the previous suffix by 1. 

4. In the Length field, type the section length.  To change the unit of measure, see Set Cable 
Routing Options (on page 146). 

5. From the Routing category list, select Trunk or Building. 
6. If you selected Trunk, SmartPlant Instrumentation displays the Position and widths 

grid.  Select a defined width for each active position. 
 When you define a maximum number of cables for a standard position, the position at 

the specific defined width becomes available for association with sections.  In the 
Position-Width grid of the New Section dialog box, the available positions and widths are 
marked with a check box.  Although a position can have more than one available standard 
width, you can select only one standard width per position. 

7. Click OK to enter the new section and close the dialog box. 
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Edit a Routing Section 
This procedure explains how to edit the properties of a routing section. 
1. In the Wiring Module window, click Tables> Cable Routing > Routing Sections. 
2. On the Routing Sections dialog box, filter the routing sections by selecting Trunk or 

Building, or accept the default All. 
3. Highlight a routing section and click Properties. 
4. On the Routing Section Properties dialog box, you have the following options: 

 To modify the routing section name. 
 To modify the length (unless the cable assigned to this section is on a locked drum). 
 To change the section category, from the Routing category list, if the section is not in 

use. 
 For routing category Trunk, to select a width for each position from the Position and 

widths grid (unless the cable assigned to this section is on a locked drum). 
5. Click OK to save your changes and close the Routing Section Properties dialog box. 
 

Associate a Routing Section with Cables 
The last stage in setting up cable routing is associating the different sections that you have 
created with the cables in your <plant>.  Once the association is completed, SmartPlant 
Instrumentation calculates and sets the total length of the routing, and the cable routing of your 
<plant> is ready. 
1. In the Domain Explorer, highlight the cables with which you want to associate cable routing 

sections. 
2. Right-click the highlighted cables, and then on the shortcut menu, click Actions > Cable 

Routing. 
3. On the Cable Routing dialog box, from the Cable list, select a cable. 
4. In the Available Sections window, highlight the available sections that you want to associate 

with the selected cable, and do one of the following: 

 Click  
 Drag the sections to the Assigned sections pane. 

5. From the Routing Position list of the required section, select the position that will hold the 
cable. 

 Change the order of the assigned sections by highlighting an assigned section and 
clicking Move Up or Move Down. 

6. Type the panel-routing distance, or accept the default. 
7. Repeat steps 2 through 5 for each cable in the Cable list. 
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Edit a Cable Routing 
This feature allows you to change the sections associated with a cable, change their order, or 
change the panel-routing distance. 
1. In the Domain Explorer, highlight the cables whose routing you want to edit. 
2. Right-click the highlighted cables, and then on the shortcut menu, click Actions > Cable 

Routing. 
3. On the Cable Routing dialog box, from the Cable list, select a cable. 
4. To add additional sections to the selected cable, under Available sections, highlight the 

available sections that you want to associate with the cable, and do one of the following: 

 Click  
 Drag the sections to the Assigned sections pane. 

5. To remove sections from the selected cable, under Assigned sections, highlight the sections 
that you want to remove, and do one of the following: 

 Click  
 Drag the sections from the Assigned sections pane to the Available sections pane. 
 Click Un-assign, to remove all the sections from the Assigned sections pane. 

6. Change the position of a section, as necessary, from the Routing Position list. 
7. Change the order of assigned sections, as necessary, by highlighting a section and clicking 

Move Up or Move Down. 
8. Edit the panel-routing distance, as necessary, by changing the value in the Panel- routing 

distance box. 
9. Repeating steps 3 through 7 for each cable in the Cable Name list. 
 

Copy Routing Data to Another Cable 
After you create a cable routing, you can copy the routing data to other cables, thus saving 
redefinition time for similar cables.  Note that if you copy routing data to a cable with existing 
routing, the new routing overwrites the existing routing data. 
1. In the Domain Explorer, select the cables from which you want to copy routing data. 
2. Right-click the highlighted cables, and then on the shortcut menu, click Actions > Copy 

Cable Routing. 
3. On the Copy Cable Routing dialog box, select a cable from the Wiring Explorer list. 

 A source cable is a trunk cable for which you have already defined cable routing options, 
created the routing sections, and associated cables with these sections.  SmartPlant 
Instrumentation displays the routing data for the source cable you select in the Source 
routing data grid. 

4. From the Wiring Explorer, highlight target cables, and drag them to the Destination cables 
group box. 

5. Select the cables to which you want to copy the routing data of the source cable in one of the 
following ways: 
 Select the check box to the left of each cable. 
 Choose Select all cables without routing.  Use this option to avoid overwriting existing 

routing data. 
 Choose Select all to enable overwriting of existing routing data on the destination cables. 

6. Click Copy. 
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 To copy routing data to additional cables, repeat steps 3 through 6. 
 

Append Routing Data to a Cable 
You can append the routing properties of an existing source cable to a destination cable or 
cables.  This can be an efficient way of adding sections to an existing routing. 

 A source cable is a trunk cable for which you have already defined cable routing options, 
created the routing sections, and associated cables with these sections. 

 A destination cable is a trunk cable to which you want to add the routing data of the source 
cable. 

1. In the Domain Explorer, select the cables that will be your source for appending. 
2. Right-click the highlighted cables, and then on the shortcut menu, click Actions > Append 

Cable Routing. 
3. On the Append Cable Routing dialog box, select a cable from the Wiring Explorer list. 

 In the Source routing data group box, SmartPlant Instrumentation displays the routing 
data for the selected cable. 

4. In Wiring Explorer, highlight target cables, and drag them to the Destination cables group 
box. 

5. Select the cables to which you want to append the routing data of the source cable in one of 
the following ways: 
 Select the check box to the left of each cable. 
 Choose Select all cables without routing.  Use this option to avoid overwriting existing 

routing data. 
 Choose Select all to enable overwriting of existing routing data on the destination cables. 

6. Click Append. 

 
 To append routing data to additional cables, repeat steps 3 through 6. 
 SmartPlant Instrumentation appends the new sections after the original sections of the 

destination cable, if there were any.  You can change the order of these sections by opening 
the destination cable in the Cable Routing dialog box.  For details, see Edit a Cable Routing 
(on page 150). 
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S E C T I O N  1 6  

Cable Drums 
 It is recommended that any cables in the As-Built, that have been assigned to cable 

drums, are un-assigned from their drums before you claim them to the project. Failure to do so, will 
result in inconsistencies in the As-Built drum data when merging the cables back to the As-Built. 
The cable drum feature allows you to efficiently use cable drums, and setup an organized method 
of cable drum assignment.  The cable drum feature handles both the optimization of existing 
cable drum allocations (purchased drums) and the assignment of new cable drums when 
necessary (Design drums).  The cable drum feature allows you to perform cable drum 
assignment both automatically and manually.  The cable drum feature requires that you define 
pulling areas in your <plant> where the cable drums are concentrated. This can be done in an 
Engineering plant, Owner Operator plant (As-Built), or project. From these areas you perform the 
assignment of cable drums for the cables. 
The pulling area that you define here does not have the same functionality as the <area> in 
SmartPlant Instrumentation plant hierarchy.  The pulling area is designated for cables and cable 
drums only. 
The steps required to set up a fully functional cable drum assignment are as follows: 
1. Define the pulling areas where the cable drums are placed. 
2. Associate cables with the predefined pulling areas. 
3. Define drum attributes for cable types. 
4. Create the cable drums that will eventually be assigned to your cables.  This includes both 

adding the cable drums that already exist in your <plant> and adding the cable drums that you 
need to purchase to complete your required cable drum inventory.  You can also perform this 
automatically in a cable drum assignment. 

5. Select the cables that you want to assign to the cable drums that you have created (even if the 
drums have not been purchased yet). 

6. The last stage is to assign cables to cable drums.  At this stage the cable drum feature 
automatically adds new cable drums as required. 

 
 It is recommended that when working in an As-Built plant with projects, you carry out the 

workflow for creating cable drums from within the project. 
 Pulling areas are common to the As-Built and all its projects. 

 

Create and Manage a Pulling Area 
The pulling area is the plant area where you concentrate cable drums.  This procedure explains 
how to add a new pulling area to your <plant>.  Use this procedure to edit existing pulling area 
data. 
1. In the Wiring Module window, click Tables > Pulling Areas. 
2. On the Pulling Areas dialog box, do one of the following: 

 To create a new pulling area, click New. 
 To edit a pulling area, click the field that you want to edit. 
 To delete a pulling area, select a row and click Delete. 

3. Type the pulling area name (required) and description in the respective fields. 
4. Click OK. 
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 The pulling area that you define here does not have the same functionality as the <area> in 
SmartPlant Instrumentation plant hierarchy.  The pulling area is designated for cables and cable 
drums only. 
 

Associate Cables with a Pulling Area 
Prior to assigning cables to drums, you have to associate your cables with a pulling area. 
1. In the Domain Explorer window, select and right click the cable that you want to associate 

with a pulling area. 
2. On the shortcut menu, click Properties. 
3. On the Cable Properties dialog box, from the Pulling Areas list, select the pulling area that 

you want the selected cable to be associated with. 
 You can use the Pulling Areas dialog box to add new pulling areas or edit existing. 

4. Click OK to save your changes and close the Cable Properties dialog box. 
 

Define Cable Drum Attributes for Cable Types 
This procedure explains how to define cable drum attributes for cable types.  This is required 
because each cable type has its minimum and maximum length.  The cable drums that you will 
create will then be based on the cable drum attributes that you define here. 
1. In the Wiring Module window, click Tables > Cable > Types. 
2. On the Cable Types dialog box, select a cable type and click Properties. 
3. On the Cable Type Properties dialog box, type the appropriate data in the following fields: 

 Maximum drum length — type the maximum cable drum length for this cable type. 
 Minimum drum length — type the minimum cable drum length for this cable type. 
 Length UOM — select the length unit of measure. 
 Drum spare length percent — enter the percent of the used cable drum length to 

allocate to spare cable length.  (The spare and the used length combine to the total 
length.) 

4. Click OK to save your changes and close the Cable Type Properties dialog box. 
5. Click OK to close the Cable Types dialog box. 
 

Manage Cable Drums Manually 
This procedure explains how to create cable drums manually and set their attributes.  There are 
three categories of cable drums: 

 Design — Cable drums that you intend to purchase in the future and you want to design 
to fit your cables. 

 Purchased — Existing cable drums that you want to include in a cable-drum optimization. 
 Locked — Existing cable drums that you do not want to include in a cable-drum 

optimization. 
1. In the Wiring Module window, click Tables > Cable Drums. 
2. On the Cable Drums dialog box, select a cable type to filter the data window. 
3. Do one of the following: 

 Click New to add a new cable drum. 
 Select a cable drum row and click in the appropriate fields to edit the data. 
 Select a cable drum row and click Delete. 
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4. In the data window, type the data in the fields or select the data from the lists according to the 
following table: 

Column Name Column Description  

Name Type the cable drum name. 

Description Type the cable drum description if required. 

Pulling Area Select the pulling area where the cable drum is located. 

Length Type the total cable drum length (utilized + spare). 

Utilized Length Displays the utilized cable length of the total drum length. 

Length UOM Select the unit of measure used to measure the drum 
length. 

Drum Status Select one of the following: 

Design — cable drum in the design stage (not 
purchased yet); available for cable-drum optimizations. 

Purchased — a purchased cable drum of defined length 
that you want to include in cable-drum optimizations. 

Locked — a purchased cable drum that is assigned to a 
cable and locked against reassignment (cable drum 
optimizations). 

Spare Length 
Percent  

Type the percent of the used cable drum length to 
allocate to spare cable length. 

5. Click OK to save your changes and close the Cable Drums dialog box.  
 SmartPlant Instrumentation creates cable drums automatically when you assign cables to 

cable drums and additional cable drums are required. 
 

Assign Cables to Drums Automatically (with Optimization) 
When assigning cables to cable drums, SmartPlant Instrumentation creates cable drums 
automatically.  You can perform this assignment and optimization in single or in batch 
mode.  The optimization process matches cables and the cable drums that fit them with minimum 
waste of cable drum length, using the following algorithm: 
 The highest priority is to utilize cable drums that are purchased but not yet 

locked.  Optimization may assign new cables to these drums. 
 The second priority is to optimize the drum cable length for drums whose status is 

design.  The guiding parameters are minimum drum length and maximum drum length. 
 The third priority is to create new cable drums of a given cable type. 

 The procedure below only works if you created a cable and assigned a pulling area. 
1. In the Wiring Module window, click Actions > Cable-Drum Assignment. 
2. On the Cable-Drum Assignment dialog box, select the following filtering criteria: 

 Cable type 
 Pulling area 

3. Do one of the following: 
 Select Include assigned cables to display cables that are already assigned to cable 

drums, in addition to those not yet assigned. 
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 Clear Include assigned cables not to display assigned cables. 
4. Click Find. 
5. Select the cables that you want to include in the cable drum assignment. 

 If you selected Include assigned cables in step 3 above, optimizing can change 
existing cable assignments. 

6. Click Optimize. 
 

Assign Cables to Drums Manually (Without Optimization) 
This procedure explains how to assign a cable to a cable drum manually.  This action requires 
that you predefine the following for this cable: 
 A cable type. 
 At least one pulling area. 
 A cable drum associated with the cable type and with the pulling area. 

The manual cable drum assignment is performed without optimization, which means that the 
designated cable drum is not necessarily the optimum for the selected cable. 
1. In the domain Explorer, right- click a cable and then click Properties. 
2. On the Cable Properties dialog box, do the following: 

a. From the Pulling area list, select the pulling area that the designated cable drum is 
associated with. 

b. Make sure that the cable type is selected from the Type list. 
c. From the Cable Drum list, select the cable drum to which you want to assign the selected 

cable.  Click  to add a y required items that are not on the list. 
d. Click OK to save your changes and close the Cable Properties dialog box. 
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Managing Panel Locations 
Panel location is a panel property that you define when creating or editing the properties of a 
panel.  You can set multiple location levels, for example, building — floor — room.  You can use 
each level to define a panel location. 

In This Section 
Define a New Panel Location ........................................................ 157 
Modify Panel Location Properties .................................................. 157 
Change the Location of a Panel .................................................... 158 
Dissociate a Panel from a Location ............................................... 158 
Delete a Panel Location ................................................................. 158 
 
 

Define a New Panel Location 
This option allows you to define a new panel location.  You can then select this location when 
defining panel properties.  Since panel location is defined per plant, all the panel location 
definitions that have been made in the Administration module are available throughout the plant. 
1. Do one of the following to open the Location Manager dialog box: 

 In the Wiring module, click View > Location Manager. 

 Click  next to the Location list arrow in any appropriate Properties dialog box. 
2. Do one of the following in the Location Manager: 

 To define a location on the highest hierarchy level, right-click Location, and then on the 
shortcut menu, click New. 

 To define a location under an existing location definition, expand one of the existing 
location levels, then right-click a location and on the shortcut menu, click New. 

3. On the Location Properties dialog box, type the location name and description as desired. 
 You can define a new location on the highest hierarchy level directly from the Domain 

Explorer.  Right-click the Panels by Location folder, and then on the shortcut menu, click New > 
Location. 
 

Modify Panel Location Properties 
This option allows you to modify the properties of a panel location.  You can rename a location 
and change its description. 
1. Do one of the following to open the Location Manager dialog box: 

 In the Wiring module, click View > Location Manager. 

 Click  next to the Location list arrow in any appropriate Properties dialog box. 
2. Right-click a location and then on the shortcut menu, click Properties. 
3. On the Location Properties dialog box, type the location name and description as you 

require. 
4. Click OK. 
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Change the Location of a Panel 
You can change the location of a panel either in the Domain Explorer by dragging a panel to 
another location in the Panels by Location folder or in the Location Manager. 

1. On the Properties dialog box of a panel, click  next to the Location list arrow. 
2. In the Location Manager, select a location and click OK. 

 To dissociate a panel from a location without assigning another location, click 
Dissociate. 

3. Click OK on the Panel Properties dialog box. 
 Also, you can change the location of a panel in the Domain Explorer without opening the 

Properties dialog box for a panel.  Expand the Panels by Location folder and select a 
panel.  Drag it to another location, as you require. 
 

Dissociate a Panel from a Location 
While defining panel properties, you can dissociate a panel from a location. 
1. In the Domain Explorer, right- click a panel. 
2. On the shortcut menu, click Properties. 

3. Click  next to the Location list arrow. 
4. In the Location Manager, click Dissociate. 
 

Delete a Panel Location 
This procedure explains how to delete a panel location in the Location Manager. 
1. Do one of the following to open the Location Manager dialog box: 

 In the Wiring module, click View > Location Manager. 

 Click  next to the Location list arrow in any appropriate Properties dialog box. 
2. Right-click a location. 
3. On the shortcut menu, click Delete. 

 You can delete a location directly from the Domain Explorer without opening the Location 
Manager.  In the Domain Explorer, expand the Panels by Location folder.  Then, right-click a 
location and then on the shortcut menu, click Delete. 
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Cable Block Diagrams 
Cable Block Diagrams (CBDs) provide a graphical representation of the interconnection of the 
cables and the various junction boxes, marshaling racks, cabinets, wiring equipment, and so forth 
in your project.  They show the project cable flow between the various cables, cabinets, and 
wiring equipment of your project. 
Cable Block Diagrams are ideal for use in the preliminary planning stages of your plant to verify 
the destination panels for cables as no wiring connections or terminations are needed at this early 
stage of your project.  A CBD is also used for ordering made to order (MTO) cables at the feed 
stage of your project, and later after completion of your project, as part of the maintenance 
program to show the location of all major cables, panels, junction boxes, and so forth. 
SmartPlant Instrumentation allows you to drag and drop panels and wiring equipment from the 
Domain Explorer to your drawing and position them exactly where you want.  The software 
creates a representation of existing cables on the fly, or you can manually connect cables 
between item connection points. 

 When dragging 2 connected panels or wiring equipment to a CBD, the connecting cable is 
not displayed in the CBD folder under the CBD drawing, until you save the CBD using the File > 
Save Custom Changes command. 
 

Create a Cable Block Diagram 
This procedure shows you how to create a new cable block diagram, add items, show already 
connected cables, and connect cables between the items.  Using symbols supplied with the 
software, or symbols created in the Symbol Editor, you drag and drop items where you want to 
position them within the drawing.  When you connect cables between the different items of 
equipment, the software checks that the connection point is valid, and makes the connection.  If 
no connection point is available the software does not allow the cable to be connected. 

 You must associate panels and other items with a symbol to display them on the 
CBD,. For more information, see Associate a Symbol with an Item (on page 23). 
1. On the Domain Explorer, locate the Drawings folder. 
2. In the Drawings folder, locate the Cable Block Diagram folder. 
3. Right-click the Cable Block Diagram folder, and from the shortcut menu select New > Block 

Diagram. 
4. On the Document Properties (New) dialog box, type a value for the Document number and 

Description fields. 
5. Click OK. 
6. In the Cable Block Diagram folder, right-click your new document, and from the shortcut 

menu select Reports > Generate Cable Diagram. 
7. At the prompt, click Yes to preview your drawing, a new blank drawing opens in the Enhanced 

Report Utility. 
8. In the Enhanced Report Utility, open the Domain Explorer by doing one of the following: 

 Press F7 
 Click Tools > Domain Explorer 

 Click  
9. From the Domain Explorer in the Enhanced Report Utility drag the panels you require, and 

position them on the drawing. 
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 The order that you drag the panels onto the drawing will define the sorting order that will 
be used in the generation process of the connection, for example; if you drag the DCS panel 
first, then the JB, and finally the device panel, the software will connect the DCS to the JB and 
then the JB to the device panel. 

10. Click  to allow the software to automatically regenerate your drawing, and show any 
cables and there connections between the physically wired items. 

 This applies to panels and cables that have already been associated together. For 
more information, see Associate a Cable with a Panel (on page 161). 

11. To make the connections between the items manually, do the following: 
12. Select any item on the drawing and do one of the following: 

 Click Activate Connection Mode . 
 Click Edit > Activate Connection Mode. 

13. On the Domain Explorer select the cable you want to connect between two items. 
14. Move the cursor over the drawing to view the available, valid connect points of the items and 

cable category on your drawing. 
15. Click the connect point of the item you want the cable to connect 'From'. 
16. Click the connect point of the item you want the cable to connect 'To'. 
17. Select another cable or click View > Refresh to view the drawing with the cable attached. 
 
 

Add Cables and Objects to an Existing Cable Block Diagram 
This procedure shows you how to add cables and items to an existing cable block diagram. 

 You must associate panels and other items with a symbol to display them on the 
CBD,. For more information, see Associate a Symbol with an Item (on page 23). 
1. Open the CBD that you want to add items to.  For further details, see View an Existing Cable 

Block Diagram (on page 161). 
2. In the Enhanced Report Utility, open the Domain Explorer by doing one of the following: 

 Press F7 
 Click Tools > Domain Explorer 

 Click  
3. From the Domain Explorer in the Enhanced Report Utility drag the objects you want to add to 

the drawing, and position them on the drawing. 

4. Click  to allow the software to automatically regenerate your drawing, and show any 
cables and there connections between the physically wired items. 

 This applies to panels and cables that have already been associated together. For 
more information, see Associate a Cable with a Panel (on page 161). 

5. To make the connections between the items manually, do the following: 
a. Select any item on the drawing and do one of the following: 

 Click Activate Connection Mode . 
 Click Edit > Activate Connection Mode. 

b. On the Domain Explorer select the cable you want to connect between two items. 
c. Move the cursor over the drawing to view the available, valid connect points of the items 

and cable category on your drawing. 
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d. Click the connect point of the item you want the cable to connect 'From'. 
e. Click the connect point of the item you want the cable to connect 'To'. 

6. Select another cable or click View > Refresh to view the drawing with the cable attached. 
 

View an Existing Cable Block Diagram 
This procedure shows you how to view an existing cable block drawing. 
1. On the Domain Explorer, locate the Drawings folder. 
2. In the Drawings folder, locate the Cable Block Diagram folder. 
3. In the Cable Block Diagram folder, right-click the drawing you want to view, and from the 

shortcut menu select Reports > Generate Cable Diagram. 
4. At the prompt, click Yes to preview your drawing, the drawing opens in the Enhanced Report 

Utility. 
 

Disconnect Cables from Items in a Cable Block Diagram 
This procedure shows you how to disconnect cables from items on your drawing. 
1. Open the CBD that you want to disconnect cables from.  For further details, see View an 

Existing Cable Block Diagram (on page 161). 
2. Select the cable you want to disconnect. 
3. Do one of the following: 

 Click . 
 Click Edit > Disconnect. 
 Right-click, and on the shortcut menu, click Disconnect Items. 

4. At the prompt, select the required check box, and click OK. 

 
 If the cable for disconnection is only connected to one item, no prompt will appear and the 

cable is disconnected automatically. 
 Disconnecting both sides of the cable results in the loss of any wiring associated with the 

connection. 
 

Associate a Cable with a Panel 
You use the Associate Cable with Panels feature in conjunction with cable block diagrams, to 
associate a specific cable to specific panels.  When you use the cable in your cable block diagram 
the panels that are associated with the cable are automatically placed on your drawing along with 
the cable. 
By dragging panels from the Domain Explorer to the Associate Cable with Panels window you 
can associate the panel with either side of the cable.  You can see which panels are already 
associated or connected to the cable and to what side of the cable the panel is associated.  Also 
you can move a panel from one side of the cable to the other. 
1. In the Domain Explorer, navigate to the Cables folder. 
2. Open the Cables folder, and select the cable you want to associate with a panel. 

 You can choose more than one cable at the same time by clicking the required cables in 
the Items pane in the Domain Explorer.  In the Associate Cable with Panels window, you 
choose the cable that you want to associate to a panel from the Cable pick list in the window. 

3. Right-click the cable, and from the shortcut menu, click Actions > Associate Panels, the 
Associate Cable with Panels window opens. 



Wiring in SmartPlant Instrumentation 
 

 
162 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

 The Associate Cable with Panels window shows the physically connected panels as 
well as the associated panels.  A cable that is already associated to a panel, displays 

 next to the panels name.  A cable that is physically connected to a panel, displays 
 next to the panels name. 

4. In the Domain Explorer, navigate to the Panels by Category folder. 
5. Locate the required panel you want to associate with the cable. 
6. From Panels by Category folder, drag the required panel icon on to the Cable End One or 

Cable End Two column of the Associate Cable with Panels window. 

 
 You can drag the same panel into the window a number of times, providing that it is to the 

same Cable End each time. 
 You can also select an item in the Associate Cables with Panels window, right/click, 

and from the shortcut menu use the Copy/Paste commands to copy and paste an item 
into a new row. 

 To change a panels cable end association, drag the panel from one cable end column to 
the other cable end column. 

7. Close the Associate Cable with Panels window, click Yes at the prompt to save the 
associations. 

 
 A cable must have a panel associated at each end to save the associations. 
 Cable relationships which were manually associated with panels are not removed or deleted 

by the software when physically connected with the panels. 
 The relationship between the physically connected panels and the cable shown in the 

Associate Cable with Panels window cannot be deleted.  They are removed when the cable 
is disconnected. 

 The Associate Cable with Panels window does not display, or take into consideration, 
pre-assigned panels or junction boxes that were assigned using instrument connection 
pre-assignment browsers. 

 

Creating Wiring Equipment for Cable Block Diagrams 
To create wiring equipment for a cable block diagram, you must carry out the following 
procedures: 
1. Create a symbol containing the connectors, macros, and so forth for the required wiring 

equipment. For more information, see Creating a Wiring Equipment Symbol Assembly in the 
Enhanced Report Utility help or Symbol Editor help. 

2. Create the wiring equipment in the Domain Explorer and associate the wiring equipment 
assembly symbol with the wiring equipment. For more information, see: 
 Create a Wiring Equipment Item (on page 64). 
 Associate a Symbol with an Item (on page 23). 

3. Right-click the wiring equipment, and on the shortcut menu, click New > Plug-and-Socket 
Group. 

4. Follow the instructions on the Plug-and-Socket Group wizard, to create the connector 
groups. For more information, see Plug and Socket Group Wizard (see "The Plug-and-Socket 
Group Wizard" on page 77). 

 At the end of the process, under the wiring equipment, the Plug-and-Socket Group 
icon  appears. 
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5. Connect the required cables to the wiring equipment. For more information, see Connect a 
Cable to a Plug and Socket Group (on page 78). 

To connect a cable to the plug-and-socket group, the cable must have a 
plug-and-socket connector on one end of the cable. 

See also 
Create a Cable Block Diagram (on page 159) 
 

Filtering Items on a Cable Block Diagram 
You can filter items on a Cable Block Diagram by creating a filter in the Filter Definition dialog 
box for the specific CBD. 
1. In the Domain Explorer, open the Cable Block Diagrams folder located in the Drawings 

folder. 
2. Right-click on the CBD that you want to apply a filter to, and from the shortcut menu select 

Filter. 
3. On the Filter Definition dialog box, under Filter name, type a name for your filter. 
4. In the Filter Scope group box, under Item type, select the item type you want to filter, for 

example Cable. 
 If you are applying a filter to all the CBDs (by right-clicking on the Cable Block 

Diagrams folder) then only Item type: Block Diagram is available. 
5. In the Filter definition group box, do the following: 

a. From the Property list select the required property, for example Cable Type (Cable). 
b. From the Operator list select an operator, for example =. 
c. From the Value list select a value, for example Type A. 

 The Operators and Values available, vary depending on the property chosen from 
the Property list. 

6. To add another definition to your filter, do one of the following: 
 If you want to use the same Item type, from the Logic list select an operator, click 

Add and then enter the next filter definition. 
 If you want to add a filter for a different item type, then select the item type from the Item 

type list, and then enter the next filter definition. 
7. When you have finished adding filter definitions, click OK. 

 To clear a filter from the CBD, select the CBD in the Cable Block Diagrams folder, 
right-click and from the shortcut menu select Clear Filter. 
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SmartPlant Instrumentation supports the creation and maintenance of Foundation Fieldbus and 
Profibus systems.  Note that whenever fieldbus is mentioned in the subsequent topics of the 
documentation, we refer to Foundation Fieldbus. 
 
 

Foundation Fieldbus Design 
Foundation Fieldbus technology has rapidly established itself as a viable process industry 
networking methodology.  Of the different protocols available currently on the market, Foundation 
Fieldbus is the leading product in the process industry.  The SmartPlant Instrumentation fieldbus 
solution is based on H1 Intrinsically Safe Low Speed, 31.25 kb/sec Fieldbus, and supports 
topologies such as star, trunk/drop, and daisy chain. 
The software provides the following features for creating and managing fieldbus projects: 
 Fieldbus device tags, which you create in the Instrument Index module, include fieldbus 

properties such as identification references, address, electrical properties, associated function 
blocks, and so forth. 

 The Fieldbus Segment Manager, where you create and manage fieldbus instruments and 
associate them with appropriate segments.  Also, you can generate a validation report for a 
selected segment. 

 Fieldbus connection apparatus and fieldbus bricks, which you create in the Wiring 
module.  You can quickly and easily create fieldbus junction boxes and device panels using 
the Plug-and- Socket Box Wizard. 

 As you build segments, the software verifies that you are following basic connection 
rules.  Later, you can generate reports to verify that you built the segments according to 
further connection rules, and according to the segment-wide parameter profiles that you 
applied to each segment. 

 Segment wiring diagrams and Fieldbus Loop enhanced reports. 
 Whenever fieldbus is mentioned in the subsequent topics of the documentation, we refer to 

Foundation Fieldbus. 

See Also 
Profibus Design (on page 211) 
 

Foundation Fieldbus and Profibus 
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Flow of Activities for Foundation Fieldbus Design 
The following is a suggested flow of activities for Foundation Fieldbus design in SmartPlant 
Instrumentation.  Note that you can carry out some of the procedures in a different order, 
depending on your preferences or requirements. 
1. Define the Segment-Wide Parameters for the current site 

Segment-wide parameters allow you to define default settings that serve as design rules and 
limitations for the various Foundation Fieldbus and Profibus PA segments.  These 
parameters affect the function and performance of your fieldbus system in the following ways: 
 If you exceed cable lengths, or hook too many devices to the same pair of wires, this can 

cause attenuation and reduction in the voltage reaching the instruments.  These voltage 
drops can result in instrument malfunction and bandwidth problems. 

 If you create a spur cable that is too long, the signal propagated along that spur cable can 
become attenuated and too weak for the DCS to read. 

 If you create a segment whose total capacitance exceeds the maximum, you may reduce 
effective bandwidth. 

For more information, see Define Segment-Wide Parameters (on page 170). 
2. Define Foundation Fieldbus instrument type profiles 

 Prior to creating new fieldbus instruments, you need to customize wiring reference items 
and then define appropriate instrument type profiles in the Instrument Index module so 
that new tag numbers acquire fieldbus properties.  This results in automatic assignment 
of the required properties to the new tag numbers.  For more information, see Define 
Foundation Fieldbus and Profibus Instrument Type Profiles (on page 176). 

3. Add a new browser view 
 In the Browser module, create a browser view with the required fields for the Fieldbus 

Segment Manager.  This facilitates the assignment of tag numbers to segments.  You 
can create multiple Browser views with different Style, Sort, and Filter functions.  For 
example, by using the filter function you may create independent views for each segment, 
so that only tags of that segment will be displayed in its corresponding view.  For more 
information, see Add a New View. 

4. Create user-defined function blocks 
 Since the software does not allow you to modify or delete the shipped function blocks, you 

can create your own function blocks which you can modify or delete as you see fit.  The 
function blocks that you define here are available for the current site.  You can define 
function blocks as multiple with or without execution time.  Instruments can be associated 
with several function blocks of the same type if that function block is defined as 
Multiple.  Using the Execution Time feature allows you to set the time for the function 
block execution.  You set the number of function blocks and the execution time in the 
Function Block - Instrument Type Association dialog box.  You can create a virtual 
tag and associate it with an existing function block.  Only one virtual tag can be 
associated with a function block.  For more information, see Create a User-Defined 
Function Block (on page 172). 

5. Associate function blocks with instrument types 
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 Associating function blocks with instrument types enables you to instruct the software to 
create and associate a particular function block when creating a fieldbus 
instruments.  When you create a fieldbus instrument tag, SmartPlant Instrumentation 
automatically assigns the function blocks associated with the instrument type that you 
select for the new tag.  Note that you can associate a function block with as many 
instrument types as required.  For more information, see Associate Function Blocks with 
Instrument Types (on page 173). 

6. Create Foundation Fieldbus instruments 
 Create your fieldbus device tags based on the instrument types that you defined, and edit 

the tag number properties as required, including function block properties.  The software 
allows you to create various types of instruments that can be associated with the 
Foundation Fieldbus system in your plant.  In other words, you can create instruments 
that are compatible with Foundation Fieldbus, Profibus DP, and Profibus PA 
segments.  You add new instruments in the Instrument Index module, exactly the same 
way that you create other tags.  Once you define an instrument type for the new tag 
number and associate a function block with the new tag's instrument type, the new 
instrument automatically acquires all of the appropriate properties that you set for that tag 
number.  You can then create virtual tags for this instrument.   
For more information, see Create Foundation Fieldbus and Profibus Instruments (on 
page 176). 

7. Associate your function blocks with fieldbus instruments 
 This feature enables you to associate a function block with a particular instrument.  You 

use this feature if for some reason, the current tag number has not been associated with 
any function block through the tag's instrument type or if you need to change some of the 
associations.  Note that the association or any changes made to the association will 
affect the current tag number only.  For more information, see Associate Function Blocks 
with Instruments (on page 179). 

8. Create your fieldbus segments and associate them with fieldbus instruments 
 Now you are ready to create your fieldbus segments, associate the appropriate 

instruments with their respective segments, and create the necessary virtual tags.  For 
more information, see the following: 
 Create a Foundation Fieldbus Segment (on page 182) 
 Associate an Instrument with a Segment (on page 183) 
 Enable a Function Block for I/O Assignment (on page 184) 

9. Design your wiring and termination equipment 
 At this stage you need to create your fieldbus I/O cards and if you are going to use the 

plug-and-socket communication system, create your fieldbus plug-and-socket 
boxes.  For more details, see the following: 
 Create a Fieldbus I/O Card (see "Create a Foundation Fieldbus Segment" on 

page 182) 
 Fieldbus Plug-and- Socket Boxes (see "Fieldbus Plug-and-Socket Boxes (Panels)" 

on page 186) 
10. Add your home-run cables and spurs. 

 For details, see Managing Fieldbus Cables Common Tasks (see "Fieldbus Cables 
Common Tasks" on page 185). 



Foundation Fieldbus and Profibus 
 

 
168 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

11. Make the required connections and associations 
 At this stage you are ready to make the required connections and 

associations.  However, before you can associate a segment with a home-run cable or 
connect a home-run cable to a plug-and-socket box, you need to configure various 
connector types assign connector pins to wires.  For more information, see Making 
Connections and Associations for Fieldbus Common Tasks (see "Making Connections 
and Associations for Fieldbus" on page 199). 

12. Effect the I/O assignment 
 For details, see Effect Fieldbus I/O Assignment (on page 206). 

13. Generate fieldbus validation reports 
 As you build the segments, and make connections and effect I/O assignments, the 

software verifies that you are following basic fieldbus rules.  Later, you can generate 
reports to verify that you built the segments according to additional connection rules and 
according to the segment-wide parameter profiles that you applied to each segment.  For 
details, see Fieldbus Validation (on page 207). 

14. Generate a segment wiring report 
 You can generate an enhanced segment wiring drawing to view the completed 

segment.  For details, see Generate a Segment Wiring Report (on page 210). 
15. Generate a specification 

 In the Specifications module you can associate tags with fieldbus forms to generate 
specifications.  For details, see Principles of Generating Specifications. 

 If you encounter difficulty in activating a library form for fieldbus, you should restore the 
form.  For details, see Restore Library Forms. 

 Also, you can add function block custom fields to fieldbus specifications.  For details, see 
Add Function Block Custom Fields to a Fieldbus Spec. 

16. Generate a hook-up drawing 
 You can also generate a hook-up drawing for your fieldbus instruments just like for 

conventional instruments.  For details see Hook-Up Drawing Generation (on page 331). 
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Preliminary Definitions for Foundation Fieldbus 
Common Tasks 

The following tasks are used frequently when you make preliminary Foundation Fieldbus 
definitions. 

Define Segment-Wide Parameters 
Segment-wide parameters allow you to define default settings that serve as design rules and 
limitations for the various Foundation Fieldbus and Profibus PA segments.  These parameters 
affect the function and performance of your fieldbus system in the following ways: 
 If you exceed cable lengths, or hook too many devices to the same pair of wires, this can 

cause attenuation and reduction in the voltage reaching the instruments.  These voltage 
drops can result in instrument malfunction and bandwidth problems. 

 If you create a spur cable that is too long, the signal propagated along that spur cable can 
become attenuated and too weak for the DCS to read. 

 If you create a segment whose total capacitance exceeds the maximum, you may reduce 
effective bandwidth. 

For more information, see Define Segment-Wide Parameters (on page 170). 

Create a User-Defined Function Block 
You use this feature to add new user-defined function blocks, delete redundant ones, or modify 
the definition of existing user-defined function blocks.  The function blocks that you define here 
are available for the current site.  You can define function blocks as multiple with or without 
execution time.  Instruments can be associated with several function blocks of the same type if 
that function block is defined as Multiple.  Using the Execution Time feature allows you to set the 
time for the function block execution.  You set the number of function blocks and the execution 
time in the Function Block - Instrument Type Association dialog box.  You can create a virtual 
tag and associate it with an existing function block.  Only one virtual tag can be associated with a 
function block. 
For more information, see Create a User-Defined Function Block (on page 172). 

Associate Function Blocks with Instrument Types 
Associating function blocks with instrument types enables you to instruct the software to create 
and associate a particular function block when creating a fieldbus instruments.  When you create 
a fieldbus instrument tag, SmartPlant Instrumentation automatically assigns the function blocks 
associated with the instrument type that you select for the new tag.  Note that you can associate a 
function block with as many instrument types as required. 
For more information, see Associate Function Blocks with Instrument Types (on page 173). 

Manage the Function Blocks Supporting Table 
This option shows you how to use this supporting table to add new user-defined function blocks to 
your instrument index, delete the redundant ones, or modify the definition of existing user-defined 
function blocks.  You can also enable the Multiple and Execution Time features for any existing 
function block.  For more information, see Manage the Function Blocks Supporting Table (on 
page 174). 
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Define Segment-Wide Parameters 
1. Start the Wiring module. 
2. On the main menu bar, click Tables > Segment-Wide Parameter Profiles. 
3. In the Segment-Wide Parameter Profiles dialog box, click New. 
4. In the Segment-Wide Parameter Profiles Properties dialog box, click the General tab, and 

do the following: 
a. In the Name box, type a unique name for the profile. 
b. In the Description box, type a description for the profile. 
c. Select the profile as Default, or leave it unselected. 

 If selected, when you add a new segment, this profile will be the default setting 
associated with the new segment. 

5. In the Maximum number of devices group box, do the following: 
a. Per spur — Type the maximum number of tag numbers that can be connected with one 

spur. 
b. Per segment — Type the maximum number of tag numbers that can be associated with 

one segment. 
c. Per intrinsically safe (IS) segment — Type the maximum number of tag numbers that 

can be associated with one intrinsically safe segment. 
6. In the Maximum number of assigned function blocks group box, do the following: 

a. Per I/O card — Type the maximum number of function blocks that can be associated with 
one I/O card. 

b. Per segment — Type the maximum number of function blocks that can be associated 
with one segment. 

7. In the Electrical parameters group box, do the following: 
a. Power supply — Type the available voltage source value, in volts. 
b. Minimum receiver voltage — Type the minimum receiver voltage value that can be read 

by a DCS, in volts. 
c. Allowable current per non IS segment — Type the maximum allowable value for the 

current consumption in the non-intrinsic safety segments, in milliamperes. 
d. Allowable current per IS segment — Type the maximum allowable value for the current 

consumption in the intrinsic safety segments, in milliamperes. 
e. Maximum capacitance — Type the maximum allowable segment capacitance in the unit 

of measure selected at right. 
8. Click the Cable Lengths tab. 
9. In the Recommended spur cable lengths group box, define the rules for spur cables 

connecting instruments to home-run cables.  Do the following: 
a. Select the required unit of measure (meters or feet). 
b. In the Number of devices per segment columns, type the number of devices per 

segment for which you want to set the spur lengths.  Make sure that you do not exceed 
the number of devices that you defined in the Maximum number of devices group box. 

c. In the Number of devices per spur columns, type the maximum allowable length of the 
spur cables for each definition. 

d. You can click New to add a row, or Delete to delete the row marked by . 
e. See Spur Cable Lengths Example (on page 171). 
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10. Click OK to confirm your creation of this profile and return to the Segment-Wide Parameter 
Profiles dialog box. 

 You can return to Step 3 to create an additional segment-wide parameter profile. 
11. Click OK to close the Segment- Wide Parameter Profiles dialog box and return to the main 

window of the Wiring module. 

See Also 
Profibus Design (on page 211) 
Fieldbus Validation (on page 207) 
 

Spur Cable Lengths Example 
The following example shows the rules that are set for the lengths of individual spur cables 
connecting a junction box to instruments in a variety of fieldbus topologies.  For example, as 
shown in row 3, where 15 to 18 devices are associated per segment, and one instrument is 
associated per spur, the cable can be up to 60 meters long.  If we allow 2 instruments per spur 
with the same number of associated devices per segment, each cable can run up to 30 meters, 
and so forth. 

 
In this example, the recommended spur cable lengths are: 
 120 meters for 1 to 12 devices per segment and one device per spur; 
 90 meters for 1 to 12 devices per segment and two devices per spur; 
 60 meters for 1 to 12 devices per segment and three devices per spur; 
 30 meters for 1 to 12 devices per segment and four devices per spur; 
 90 meters for 13 to 14 devices per segment and one device per spur; and so forth. 
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Working with Function Blocks 
Function blocks are smart devices that hold control software on fieldbus instruments.  These 
smart devices or microprocessors enable Foundation Fieldbus and Profibus PA instruments to 
perform control functions independently of a DCS.  There are many types of function 
blocks.  Each function block has a specific purpose.  SmartPlant Instrumentation provides a set 
of the most common function blocks, with properties defined by Fieldbus Foundation.  You cannot 
delete these shipped function blocks or rename them, but you can modify their definitions if 
needed.  You can, however, create your own user-defined function blocks for both Fieldbus 
Foundation and Profibus PA instruments.  You can modify and delete these function blocks as 
you need. 
Function blocks are associated with particular instrument types.  When creating a new instrument 
based on an instrument type that has been associated with a function block, the software creates 
that instrument and automatically associates it with the function block have been set for pertinent 
instrument type.  The software allows you to associate multiple function blocks with a single 
instrument type.  For example, a basic flow transmitter will have one AI (analog input) block 
associated with it.  However, a similar instrument may be used to measure also pressure and 
temperature (required for gas flow compensation), and may be further equipped with one or more 
alarm functions.  An AI function block is required for each additional process measurement and 
an AA (analog alarm) block for each alarm function.  You can also associate existing instruments 
with function blocks, or modify associations as needed. 

 
 You cannot create virtual tags for an instrument that is not associated with at least one 

function block. 
 A number of Foundation Fieldbus and Profibus PA function blocks are shipped with the 

software.  You cannot add, delete or modify any of them.  You can see all the available 
function block types on the Function Block – Instrument Type Association dialog box (for 
details, see Associate Function Blocks with Instrument Types (on page 173)). 

See Also 
Create Foundation Fieldbus and Profibus Instruments (on page 176) 
Associate Function Blocks with Instruments (on page 179) 
Profibus Design (on page 211) 
 

Create a User-Defined Function Block 
1. Start the Instrument Index module. 
2. On the Instrument Index module menu bar click Tables > Function Blocks. 
3. In the Function Blocks dialog box, do one of the following: 

 To add a new function block, click New. 
 To modify the definition of a highlighted function block, click the field that want to modify. 

4. In the Function Block field, type the function block name. 
5. In the Description field, type a short description as appropriate. 
6. To define the function block as a multiple function block, select Multiple. 

 This will enable you to associate multiple copies of a given functional block with an 
instrument type or a specific instrument. 

7. To enable entry of an execution time value, select Execution Time. 
8. Click OK. 



 Foundation Fieldbus and Profibus 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 173 
 

 

Associate Function Blocks with Instrument Types 
1. Start the Instrument Index module. 
2. On the Instrument Index module menu bar click Tables > Instrument Types. 
3. In the Instrument Types dialog box, select a process function type and an instrument type. 
4. Click Profile. 
5. On the Instrument Type Profile dialog box, on the General tab, select the Include I/O type 

check box. 
6. From the Include I/O type list, select one of the following: 

 FieldbusFF Foundation Fieldbus 
 Profibus PA 

7. In the Function Block - Instrument Type Association dialog box, to assign a function block 
to an instrument type, do one of the following: 
 In the Unassociated function blocks data window, select the function block that you 

want to associate, and click Associate. 
 Drag the required function block from the Unassociated function blocks data window to 

the Associated function blocks data window. 
8. If the required function block is not available in the Function Block - Instrument Type 

Association dialog box, add or modify the function blocks in the Function Blocks dialog 
box.  For details, see Manage the Functions Blocks Supporting Table (see "Manage the 
Function Blocks Supporting Table" on page 174). 

9. If you customized a given function block in the Function Blocks dialog box, do the following 
as needed: 

10. To set the maximum number of instruments that can be associated with the current function 
block, in the Associated function blocks data window, under Multiple, type the value. 

11. To set the execution time, under Execution Time, type the time value (in milliseconds). 
12. Click OK. 

See Also 
Define Foundation Fieldbus and Profibus Instrument Type Profiles (on page 176) 
Associate Function Blocks with Instruments (on page 179) 
Profibus Design Common Tasks (on page 213) 
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Manage the Function Blocks Supporting Table 
1. On the Instrument Index module menu bar, click Tables > Function Blocks. 
2. Click New to append a new data row or click in a field of a selected row to edit the data. 
3. Type the function block values in the appropriate fields as follows: 

 Function Block — Enter the required function block name. 
 Description — Type a description for the function block if required. 
 Multiple — Select the check box to define this function block as a multiple function 

block.  This will enable you to create multiple function blocks of the same type when 
adding or editing a instrument associated with this function block. 

 Execution Time — Select the check box to enable execution time definition for the 
current function block.  You will be able to set the execution time when associating this 
function block with an instrument type or an instrument tag. 

4. Click OK. 
 You cannot delete or rename shipped function blocks. 
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Fieldbus Instruments Common Tasks 
The following tasks are used frequently when you manage instruments for your Foundation 
Fieldbus and Profibus systems. 

Define Foundation Fieldbus and Profibus Instrument Type Profiles 
Prior to creating new fieldbus instruments, you need to customize wiring reference items and then 
define appropriate instrument type profiles in the Instrument Index module so that new tag 
numbers acquire fieldbus properties.  This results in automatic assignment of the required 
properties to the new tag numbers.  For more information, see Define Foundation Fieldbus and 
Profibus Instrument Type Profiles (on page 176). 

Create Foundation Fieldbus and Profibus Instruments 
Create fieldbus device tags based on the instrument types that you defined, and edit the tag 
number properties as required, including function block properties. 
The software allows you to create various types of instruments that can be associated with the 
Foundation Fieldbus or Profibus system in your plant.  In other words, you can create instruments 
that are compatible with Foundation Fieldbus, Profibus DP, and Profibus PA segments.  You add 
new instruments in the Instrument Index module, exactly the same way that you create other 
tags.  Once you define an instrument type for the new tag number and associate a function block 
with the new tag's instrument type, the new instrument automatically acquires all of the 
appropriate properties that you set for that tag number.  You can then create virtual tags for this 
instrument. 
For more information, see Create Foundation Fieldbus and Profibus Instruments (on page 176). 

Associate Function Blocks with Instruments 
This feature enables you to associate a function block with a particular instrument.  You use this 
feature if for some reason, the current tag number has not been associated with any function block 
through the tag's instrument type or if you need to change some of the associations.  Note that the 
association or any changes made to the association will affect the current tag number only.  For 
more information, see Associate Function Blocks with Instruments (on page 179). 
 
 

Working with the Fieldbus Tag Numbers Browser 
The Fieldbus Segment Manager provides for the creation and management of fieldbus 
instrument tags and their association with appropriate segments.  Also, you can generate a 
validation summary report for a selected segment. 
The manager displays all the instruments that exist in your fieldbus system.  The instrument 
properties are displayed in various columns, such as Tag Number, Loop Number, Service, 
Segment Name, and so forth.  The columns, their sequence, and row sorting in this pane depend 
on the Browser view currently selected in the Browser Manager.  The default display is the New 
Fieldbus Tag Number List view in the Browser Manager. 
To open the Fieldbus Segment Manager browser, do the following: 
1. In the Domain Explorer, expand the Fieldbus Segments folder. 
2. Right-click a segment. 
3. On the shortcut menu, click Actions > Fieldbus Segment Manager. 
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Define Foundation Fieldbus and Profibus Instrument Type 
Profiles 

1. On the Instrument Index module menu bar, click Tables > Instrument Types. 
2. In the Instrument Types dialog box, from the Process function list, select an appropriate 

process function. 
3. Do one of the following: 

 Click New to create a new instrument type.  For details, see Define an Instrument Type. 
 In the data window, select an existing instrument type. 

4. Click Profile. 
5. In the Instrument Type Profile dialog box, on the General tab, under Specification, select 

an appropriate fieldbus specification. 
6. Select Include I/O type, and then from the list, select one of the following: 

 Foundation Fieldbus 
 Profibus DP 
 Profibus PA 

7. On the Wiring and Control System tab, select the appropriate reference device panel and 
reference cable.  For details, see Define a Wiring and Controls System Instrument Type 
Profile. 

8. Click the Fieldbus tab. 
 This tab is available only when you select Foundation Fieldbus from the Include I/O 

type list.   For Profibus instruments, click OK to complete the procedure. 
9. On the Fieldbus tab, select the Include fieldbus check box. 
10. Type a fieldbus tag name. 
11. Type a fieldbus device address. 
12. Type a device identification. 
13. Type a DC consumption value in milliamperes. 
14. Enter a capacitance setting and select the required unit of measure. 
15. Enter a minimum transmit level value. 
16. Set a default operating voltage value. 
17. Select the Backup link master check box to set new fieldbus instruments as backup link 

masters that will take over control functions for the loop in case of DCS failure. 
18. Click Function Block to associate function blocks with instrument types.  For details, see 

Associate Function Blocks with Instrument Types (on page 173). 
19. Click OK in the Instrument Type Profile dialog box. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Create Foundation Fieldbus and Profibus Instruments 
 The current procedure allows you to create fieldbus and profibus instruments from 

scratch.  If you already have such instruments, you can create new ones by duplicating the 
existing instruments.  In this case, the new fieldbus and profibus tags inherit the source 
segments. 
1. Press F7 to open in the Domain Explorer. 
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2. Expand the plant hierarchy to display the Instruments and Loops folders. 
3. Do one of the following: 

 To create an instrument unassociated with a loop number, right-click the Instruments 
folder, and then click New > Instrument. 

 To create an instrument that is associated with a specific loop number, expand the Loops 
folder, right-click a loop, and then click New > Instrument. 
 To create new fieldbus tag numbers from the Fieldbus Tag Numbers browser, 

right-click somewhere in the browser, and then click New Fieldbus Tag.  Continue as 
described below. 

4. On the New Tag Number dialog box, from the Tag class list select one of the following: 
 Foundation Fieldbus — an instrument that can be associated with a Foundation 

Fieldbus segment. 
 Profibus DP — an instrument that can be associated with a Profibus DP segment. 
 Profibus PA — an instrument that can be associated with a Profibus PA segment. 

5. Under Tag number, type the name of the new tag number, and then, click OK. 
6. On the Select Instrument Type dialog box, select the instrument type you want to associate 

with the current tag number, and then, click OK. 
7. Click OK. 

 
 If the tag number does not correspond to an existing loop name, SmartPlant 

Instrumentation prompts you to enter a loop name based on the tag number you have 
entered.  If the loop identifier already matches an existing loop, the software will 
automatically associate the new tag number with the loop. 

 If the loop convention includes the loop function parameter, the prompt will always 
appear.  In this case, you have to complete the loop number. 
If a profile exists for the selected instrument type, any new tags for that instrument type 
will be created with the selected reference items. 

 For DeltaV compatibility, you must select an instrument type that you associated with a 
DeltaV device type during the downloading process.  To display the Associate 
Foundation Fieldbus Device Types with Instrument Type supporting table of 
associations that you built among DeltaV device types, instrument manufacturers, and 
SmartPlant Instrumentation instrument types, see Associate Device Types for DCS 
Vendors. 

8. On the Loop Name dialog box, do one of the following: 
 Type the loop number that the new tag is associated with. 
 Accept the displayed loop number. 
 Click Cancel to create the tag number without a loop association.  Note that if a loop with 

the same name exists, the tag number is automatically associated with it, without creating 
a new loop. 

9. Click OK to create the loop number. 
10. On the Loop Number Properties dialog box, accept the loop number properties or modify 

them as you require and then click OK. 
11. On the Tag Number Properties dialog box, on the General tab, enter the tag number 

attributes that you require. 
 For DeltaV compatibility, make sure that the value that you select from the Manufacturer 

list is among the acceptable values for the instrument type that you selected for the current 
tag.  For details, see Crucial Fields for the DeltaV Interface. 
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12. On the Fieldbus tab, to define the fieldbus properties for the new instrument, type the fieldbus 
tag name. 

13. Type the field device address if necessary. 
14. Type the device ID if necessary. 
15. If the new tag functions as a backup that takes over DCS functions in case of DCS failure in 

the current segment, select Backup link master. 
16. Type the manufacturer's fieldbus device revision number if necessary. 

 
 If your DeltaV interface preferences are set for fieldbus mode, the Fieldbus device 

revision field is a list, from which you must select a revision. 
 SmartPlant Instrumentation uses the values that you enter below to validate fieldbus 

segments.  For details, see Generate a Validation Report for One Segment (on 
page 209). 

17. Type the DC current consumption of the current instrument, for example, 35 mA. 
18. Type the capacitance and the capacitance unit of measure, for example 5 pF. 
19. Type the minimum transmit level of the current instrument, for example, 2.5 volts. 
20. Type the operating voltage range, for example, 9 - 35 volts. 
21. To modify the function block association of the new instrument, in the Function blocks 

association group box, under Unassociated function blocks, select a function block that 
you want to associate with the instrument, and click Associate. 

  If your DeltaV interface preferences are set for fieldbus mode, your selection of 
manufacturer and of fieldbus device revision determine function block association for the 
current tag. 

22. To change the number of copies of the function block, in the Associated function blocks 
data window, under Multiple, type the value. 

  This option is available only if you enabled it in the Function Blocks dialog box. 
23. To set the execution time, under Execution Time, type the time value (in milliseconds). 

  This option is available only if you enabled it in the Function Blocks dialog box. 
24. To enter power supply properties, see Enter Power Supply Data for Panels and Instrument 

Tags (on page 45). 
25. Click OK. 

 If you are creating items that must be compatible with Emerson DeltaV, see Crucial 
Fields for the DeltaV Interface. 

See Also 
Working with Function Blocks (on page 172) 
Associate Function Blocks with Instrument Types (on page 173) 
Profibus Design Common Tasks (on page 213) 
 



 Foundation Fieldbus and Profibus 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 179 
 

Associate Function Blocks with Instruments 
1. In the Domain Explorer, expand the Instruments folder and then right-click a tag number. 
2. On the shortcut menu, click Properties. 
3. On the Tag Number Properties dialog box, click the Fieldbus tab. 
4. Under Unassociated function blocks, select the function block that you want to associate, 

and click Associate. 
5. To set the maximum number of instruments that can be associated with the current function 

block, in the Associated function blocks data window, under Multiple, type the value. 
 The Multiple field is editable only if it was enabled on the Function Blocks dialog box. 

6. To set the execution time, under Execution Time, type the time value in milliseconds. 
 The Execution Time field is editable only if it was enabled on the Function Blocks 

dialog box. 
7. Click OK. 

See Also 
Define Foundation Fieldbus and Profibus Instrument Type Profiles (on page 176) 
Working with Function Blocks (on page 172) 
Create a User-Defined Function Block (on page 172) 
Associate Function Blocks with Instrument Types (on page 173) 
Profibus Design Common Tasks (on page 213) 
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Fieldbus and Profibus Segments Common Tasks 
The following tasks are used frequently when you manage segments for your Foundation 
Fieldbus and Profibus systems. 

Create a Foundation Fieldbus Segment 
A Foundation Fieldbus segment is a group of devices physically connected by a single pair of 
wires to a host control device.  This procedure explains how to add a new segment to your 
fieldbus system.  For more information, see Create a Foundation Fieldbus Segment (on 
page 182). 

Edit the Properties of a Foundation Fieldbus Segment 
This feature allows to edit the properties of a Foundation Fieldbus segment.  You can rename a 
segment, select another segment-wide parameter profile, and set the segment as intrinsically 
safe.  For more information, see Edit the Properties of a Foundation Fieldbus Segment (on 
page 182). 

Delete a Fieldbus Segment 
Use this feature to delete a segment.  For more information, see Delete a Fieldbus Segment (on 
page 184). 

Associate an Instrument with a Segment 
This feature enables you to associate a segment with a particular instrument.  You use this 
feature if for some reason, the current tag number has not been associated with any segment or if 
you need to change some of the associations.  Note that the association or any changes made to 
the association will affect the current tag number only.  For more information, see Associate an 
Instrument with a Segment (on page 183). 

Dissociate an Instrument from a Segment 
You use this procedure when you need to dissociate a particular instrument from its 
segment.  For more information, see Dissociate an Instrument from a Segment (on page 183). 

Change Instrument / Segment Association 
You use this procedure when you need to dissociate a particular instrument from its 
segment.  For more information, see Change Instrument / Segment Association (on page 183). 

Enable a Function Block for I/O Assignment 
This procedure shows how to enable a function block for I/O assignment.  You can do this after 
associating an instrument with a segment.  Note that without enabling function blocks, segment 
I/O assignment cannot be effected.  For more information, see Enable a Function Block for I/O 
Assignment (on page 184). 



Foundation Fieldbus and Profibus 
 

 
182 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

Change the View in the Fieldbus Tag Numbers Browser 
This option allows you to change the current view of the Fieldbus Tag Numbers browser.  The 
view, (that is, the available fields)  depends on the current view in the Fieldbus Tag Number List 
browser.  For more information, see Change the View in the Fieldbus Tag Numbers Browser (see 
"Change the Fieldbus Tag Number List Browser View for Segments" on page 184). 
 
 

Create a Foundation Fieldbus Segment 
1. In the Domain Explorer, right-click the Fieldbus Segments folder and from the shortcut 

menu, click New > Fieldbus Segment. 
2. On the Foundation Fieldbus Segment Properties dialog box, under Segment, type a 

unique name for the new segment. 

3. Select a profile from the Segment-wide parameter profile list.  If necessary, click  to 
open the Segment-Wide Parameter Profile dialog box to edit or define a new segment- wide 
parameter profile.  For details, see Define Segment-Wide Parameters (on page 170). 

4. Do one of the following: 
 Select Intrinsically safe for this segment.  SmartPlant Instrumentation warns you if any 

instruments currently associated with this segment are not intrinsically safe.  The 
software also warns you if an instrument you try to associate with this segment in the 
future is not intrinsically safe. 

 Clear Intrinsically safe.  SmartPlant Instrumentation warns you if any instruments 
currently associated with this segment are intrinsically safe.  The software will also warn 
you if an instrument you try to associate with this segment in the future is intrinsically safe. 

5. Click OK to create the new segment. 

See Also 
Connect a Home-Run Cable to a Plug-and-Socket Box (on page 202) 
 

Edit the Properties of a Foundation Fieldbus Segment 
1. In the Domain Explorer, double-click the Fieldbus Segments folder. 
2. Right-click a segment and then on the shortcut menu, click Properties. 
3. In the Foundation Fieldbus Segment Properties dialog box, under Segment, type a unique 

name for the new segment. 

4. Select a profile from the Segment-wide parameter profile list.  If necessary, click  to 
open the Segment-Wide Parameter Profile dialog box to edit or define a new segment- wide 
parameter profile.  For details, see Define Segment-Wide Parameters (on page 170). 

5. Do one of the following: 
 Select Intrinsically safe for this segment.  SmartPlant Instrumentation warns you if any 

instruments currently associated with this segment are not intrinsically safe.  The 
software also warns you if an instrument you try to associate with this segment in the 
future is not intrinsically safe. 

 Clear Intrinsically safe.  SmartPlant Instrumentation warns you if any instruments 
currently associated with this segment are intrinsically safe.  The software will also warn 
you if an instrument you try to associate with this segment in the future is intrinsically safe. 

6. Click OK to create the new segment. 
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Associate an Instrument with a Segment 
1. On the Wiring module menu bar, click Actions > Fieldbus Segment Manager. 
2. In the Fieldbus Segment Manager, select an appropriate tag number. 
3. Drag the highlighted instrument to the required segment in the Fieldbus Segments folder of 

the Domain Explorer. 
 

 The associated instrument appears under the selected segment in the Fieldbus Segments 
folder of the Domain Explorer. 

 A fieldbus instrument can be associated only with one fieldbus segment.  However, you can 
associate multiple tag numbers with a given fieldbus segment. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Dissociate an Instrument from a Segment 
1. In the Domain Explorer, double- click the Fieldbus Segments folder. 
2. Expand the hierarchy of a segment. 
3. Right-click an instrument and then on the shortcut menu, click Actions > Dissociate Item. 

 The Segment Name field in the Instruments pane displays **** for dissociated 
instruments. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Change Instrument / Segment Association 
1. On the Wiring module menu bar, click Actions > Fieldbus Segment Manager. 
2. In the Domain Explorer, double- click the Fieldbus Segments folder and expand the 

appropriate segments. 
3. Right-click an instrument tag, and then, on the shortcut menu, click Actions > Dissociate 

Item from Segment. 
4. In the Fieldbus Segment Manager, select the dissociated tag and drag it to the target 

segment in the Fieldbus Segments folder. 

 
 You cannot change the segment association of a connected instrument before disconnecting 

its wiring. 
 The Segment Name field in the Fieldbus Segment Manager displays **** for dissociated 

instruments. 

See Also 
Profibus Design Common Tasks (on page 213) 
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Delete a Fieldbus Segment 
1. In the Domain Explorer, double-click the Fieldbus Segments folder. 
2. Select a segment you want to delete, and do one of the following: 

 Press the Delete key. 
 Right-click a segment and then on the shortcut menu, click Delete. 

3. Click Yes to confirm the segment deletion. 
 After deleting a segment, the software dissociates all the associated instruments and 

deletes the relevant virtual tags. 
  
 

Enable a Function Block for I/O Assignment 
1. In the Domain Explorer, under Fieldbus Segments, expand a segment  to display its 

associated instruments. 

2. Right-click the desired function block  under the highlighted tag number. 
3. On the shortcut menu, click Actions > Enable. 
 

Change the Fieldbus Tag Number List Browser View for 
Segments 

1. In the Instrument Index Browser Group of the Browser Manager, define a view under the 
Fieldbus Tag Number List Browser, for use in the Fieldbus Segment Manager.  For 
details of how to define a view, see Add a New View. 

2. In the Fieldbus Segment Manager, do one of the following: 
 Click Actions > Select Browser View for Segments. 

 Click  
3. On the Segment Views dialog box, select the desired view and then click OK. 
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Fieldbus Cables Common Tasks 
The following tasks are used frequently when you manage fieldbus cables for your Foundation 
Fieldbus and Profibus systems. 

Create a Home-Run Cable 
A home-run cable is the main communication highway between devices on a fieldbus network.  A 
home-run cable serves the spurs in a given segment, and has a terminator at either end.  For 
more information, see Create a Home-Run Cable (on page 185). 

Create a Spur Cable 
A spur is a part of a segment that drops off from the main segment (home-run) trunk.  A spur may 
contain one or more instruments and cables that connect them to the home-run segment.  For 
more information, see Create a Spur Cable (on page 186). 
 

Create a Home-Run Cable 
1. Press F7 to open the Domain Explorer. 
2. Right-click the Cables folder and then on the shortcut menu, click New > Home-Run Cable. 
3. In the Cable Configuration dialog box, do one of the following: 

 From the Cable configuration list, select an appropriate cable configuration (for 
example, Fieldbus cable). 

 Define a new cable configuration.  For details, see Define a Cable Configuration (on 
page 26). 

4. Click Create. 
5. In the Cable Properties dialog box, under Cable, type a unique name. 

 In the Cable Properties dialog box, make sure that you select Fieldbus home-run from 
the Cable class list. 

6. Complete the creation of the home-run cable using the general procedure for creating a new 
cable.  For details, see Create a Cable (on page 28). 

See Also 
Foundation Fieldbus Design (on page 165) 
Associate a Segment with a Home-Run Cable (on page 203) 
Profibus Design Common Tasks (on page 213) 
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Create a Spur Cable 
1. Press F7 to open the Domain Explorer. 
2. Right-click the Cables folder and then on the shortcut menu, click New > Cable. 
3. In the Cable Configuration dialog box, do one of the following: 

 From the Cable configuration list, select an appropriate cable configuration (for 
example, Fieldbus cable). 

 Define a new cable configuration.  For details, see Define a Cable Configuration (on 
page 26). 

4. Click Create. 
5. In the Cable Properties dialog box, under Cable, type a unique name. 

 In the Cable Properties dialog box, make sure that you select Conventional from the 
Cable class list. 

6. Complete the creation of the home-run cable using the general procedure for creating a new 
cable.  For details, see Create a Cable (on page 28). 

See Also 
Foundation Fieldbus Design (on page 165) 
Profibus Design Common Tasks (on page 213) 
 

Fieldbus Plug-and-Socket Boxes (Panels) 
You need plug-and-socket boxes to connect Foundation Fieldbus instruments to a spur or a 
home-run cable that has a plug-and-socket connection. 
SmartPlant Instrumentation supports active plug-and-socket junction boxes, that is, 
plug-and-socket junction boxes that require power supply.  You can define the current 
consumption, open circuit voltage, and short-circuit protection for an active plug-and-socket 
junction box.  When generating a segment validation report, the software takes these values into 
account when calculating the total segment current consumption and voltage drop for a particular 
segment. 
You use the Plug-and-Socket Box Wizard to create the required plug-and-socket boxes or 
reconfigure the existing ones. 
Plug-and-socket boxes can be device panels or junction boxes. 
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Managing Fieldbus Panels (Plug-and-Socket Boxes) 
Common Tasks 

The following tasks are used frequently when you manage panels for your Foundation Fieldbus 
and Profibus systems. 
You can create new panels either in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the panels in the 
current <unit>. 

Create a Plug-and-Socket Device Panel 
This procedure explains how to create a new plug-and-socket device panel.  For more 
information, see Create a Plug-and- Socket Device Panel (see "Create a Plug-and-Socket Device 
Panel" on page 187). 

Edit the Properties of a Plug-and-Socket Device Panel 
This procedure explains how to modify the properties of a plug-and-socket device panel.  For 
more information, see Edit the Properties of a Plug-and-Socket Device Panel (see "Create a 
Plug-and-Socket Device Panel" on page 187). 

Create a Plug-and-Socket Junction Box 
This feature allows to create a plug-and-socket junction box.  For more information, see Create a 
Plug-and-Socket Junction Box (on page 188). 

Edit the Properties of a Plug-and-Socket Junction Box 
This feature explains how to modify the properties of a plug- and-socket junction box.  For more 
information, see Edit the Properties of a Plug-and-Socket Junction Box (on page 189). 
 
 

Create a Plug-and-Socket Device Panel 
This procedure explains how to create a new plug-and-socket device panel. 
1. Press F7 to open the Domain Explorer. 
2. Do one of the following: 

 Double-click the Panels by Location folder, right-click a location and then on the shortcut 
menu click New > Device Panel (Plug- and-Socket). 

 Double-click the Panels by Category folder, right-click the Device Panels folder and 
then on the shortcut menu click New > Device Panel (Plug-and-Socket). 
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3. In the Plug-and-Socket Box wizard, follow all the instructions carefully and then click Next 
until you complete the wizard. 

 

 You can click  next to a list arrow to access the appropriate supporting table.  This allows 
you to add, edit, or delete select list items. 

 When defining the plug-and- socket box connectors, under Connector type definition 
display, SmartPlant Instrumentation displays the connector sequence, the appropriate pin 
number, and the pin polarities according to the configuration of the connector than you 
selected. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Create a Plug-and-Socket Junction Box 
1. Press F7 to open the Domain Explorer. 
2. Do one of the following: 

 Double-click the Panels by Location folder, right-click a location and then on the shortcut 
menu click New > Device Panel (Plug- and-Socket). 

 Double-click the Panels by Category folder, right-click the Device Panels folder and 
then on the shortcut menu click New > Device Panel (Plug-and-Socket). 

3. In the Plug-and-Socket Box wizard, follow all the instructions carefully and then click Next 
until you complete the wizard. 

 

 You can click  next to a list arrow to access the appropriate supporting table.  This allows 
you to add, edit, or delete select list items. 

 When defining the plug-and- socket box connectors, under Connector type definition 
display, SmartPlant Instrumentation displays the connector sequence, the appropriate pin 
number, and the pin polarities according to the configuration of the connector than you 
selected. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Edit the Properties of a Plug-and-Socket Device Panel 
1. Press F7 to open the Domain Explorer. 
2. Do one of the following: 

 Double-click the Panels by Location folder, right-click a device panel and then on the 
shortcut menu click Properties. 

 Double-click the Panels by Category folder, right-click a device panel and then on the 
shortcut menu click Properties. 

3. In the Plug-and-Socket Box wizard, follow all the instructions carefully and click Next until 
you complete the wizard. 

 
 The software does not allow you to modify port and connector configurations of an existing 

plug-and-socket device panel. 



 Foundation Fieldbus and Profibus 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 189 
 

 You can click  next to a list arrow to access the appropriate supporting table.  This allows 
you to add, edit, or delete select list items. 

 When defining the plug-and- socket box connectors, under Connector type definition 
display, SmartPlant Instrumentation displays the connector sequence, the appropriate pin 
number, and the pin polarities according to the configuration of the connector than you 
selected. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Edit the Properties of a Plug-and-Socket Junction Box 
1. Press F7 to open the Domain Explorer. 
2. Do one of the following: 

 Double-click the Panels by Location folder, right-click a junction box and then on the 
shortcut menu click Properties. 

 Double-click the Panels by Category folder, right-click a junction box and then on the 
shortcut menu click Properties. 

3. In the Plug-and-Socket Box wizard, follow all the instructions carefully and click Next until 
you complete the wizard. 

 
 The software does not allow you to modify port and connector configurations of an existing 

plug-and-socket junction box. 

 You can click  next to a list arrow to access the appropriate supporting table.  This allows 
you to add, edit, or delete select list items. 

 When defining the plug-and- socket box connectors, under Connector type definition 
display, SmartPlant Instrumentation displays the connector sequence, the appropriate pin 
number, and the pin polarities according to the configuration of the connector than you 
selected. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Working with Terminators 
Terminators are used to terminate and provide impedance compensation at a segment end.  Two 
terminators are needed for each segment — one on the DCS/PLC terminal side (beginning of the 
segment) and the other on its other end. 
There are two types of terminators — internal terminators (in relation to a terminating block) and 
external (fitted on as a separate accessory). 
You can create internal or external terminators as required, whether it is a terminal apparatus strip 
or a plug-and-socket termination block. 
You create internal terminators using the configuration tools when creating plug-and-socket boxes 
or termination blocks.  External terminators are added to the termination block (an apparatus or a 
plug-and-socket box) during the wiring design phase. 

See Also 
Profibus Design Common Tasks (on page 213) 
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Managing Terminators Common Tasks 
The following tasks are used frequently when you manage terminators for your Foundation 
Fieldbus and Profibus systems. 

Create an External Terminator in a Plug- and-Socket Box 
This feature enables you to create an external terminator in an existing plug-and-socket box.  For 
more information, see Create an External Terminator in a Plug-and-Socket Box (on page 192). 

Create an External Terminator on a Terminal Strip 
You can place an external terminator on a terminal in an apparatus or a conventional terminal 
strip, i.e., a junction box, marshaling rack, and so forth.  For more information, see Create an 
External Terminator on a Terminal Strip (on page 192). 

Move an External Terminator to Another Port in a Plug-and-Socket Box 
Usually, an external terminator is added when you create a plug-and-socket box.  You can 
disconnect a terminator or move it to another port in a plug-and-socket box if required.  For more 
information, see Move an External Terminator to Another Port in a Plug-and-Socket Box (on 
page 193). 

Create an Internal Terminator 
Internal terminators are usually added when creating plug- and-socket boxes and termination 
blocks.  You can also add an internal terminator to an existing plug-and-socket box or termination 
block if it has not been done during the creation process.  If a plug-and-socket box does not 
contain an internal terminator, edit the properties of the required box in the Plug-and-Socket Box 
wizard.  For more information, see Create an Internal Terminator (on page 192). 

Terminator (Plug-and-Socket Box) — Segment Association 
After creating an external terminator, you need to associate it with an existing segment.  This 
option enables you to associate an external terminator with an existing segment where the 
terminator is located in a plug-and-socket box.  For more information, see Terminator 
(Plug-and-Socket Box) - Segment Association (on page 193). 

Terminator (Terminal Strip) — Segment Association 
After creating an external terminator, you need to associate it with an existing segment.  This 
option enables you to associate an external terminator with an existing segment where the 
terminator is located on a terminal strip.  For more information, see Terminator (Terminal Strip) - 
Segment Association (on page 193). 
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Create an External Terminator in a Plug-and-Socket Box 
1. In the Domain Explorer select a plug-and-socket box. 
2. Right-click the selected plug-and-socket box and then on the shortcut menu, click Actions > 

Connection. 
3. In the Plug-and-Socket Box Connection window, right-click the required port and then on 

the shortcut menu, click New Terminator. 
4. In the Plug-and-Socket Box Terminator dialog box, make sure the correct port is displayed 

in the Port list.  Select the required port if needed. 
5. Click Create to add the new terminator and close the dialog box. 

 You can now associate this terminator with a segment.  Right-click the selected terminator 
and then on the shortcut menu, click Associate Segment. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Create an External Terminator on a Terminal Strip 
1. In the Domain Explorer, select a panel. 
2. Right-click the selected panel and then on the shortcut menu, click Actions > Connection. 
3. In the Connection window, make sure that the required terminal strip is selected in the 

Terminal Strip list. 
4. Right-click the required terminal and then on the shortcut menu, click New Terminator. 
5. In the New Terminator dialog box, make sure the correct first terminal is displayed in the 

First terminal list. 
Select the required first terminal if needed. 

6. Select an appropriate terminal side. 
7. Enter the required number of terminals that you want to terminate. 
8. Click Create to add the new terminator and close the dialog box. 

The new terminator appears in pink next to the selected terminal.  You can now associate the 
terminal with a segment. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Create an Internal Terminator 
1. In the Domain Explorer, select a plug-and-socket box. 
2. Right-click the selected plug-and-socket box and then on the shortcut menu, click Properties. 
3. In the Plug-and-Socket Box wizard, click Next twice till you open the Modify the 

Plug-and-Socket Layout page in the Plug-and-Socket Box wizard. 
4. Select the Internal Terminator check box and click Next. 
5. Continue configuring the plug- and-socket box as needed. 

See Also 
Profibus Design Common Tasks (on page 213) 
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Move an External Terminator to Another Port in a 
Plug-and-Socket Box 

1. In the Domain Explorer, select a plug-and-socket box. 
2. Right-click the selected plug-and-socket box and then on the shortcut menu, click Actions > 

Connection. 
3. In the Plug-and-Socket Box Connection window, right-click the required port and then on 

the shortcut menu, click Disconnect Selected Items. 
4. Right-click the required port and on the shortcut menu, click New Terminator. 
5. In the Plug-and-Socket Box Terminator dialog box, make sure the correct port is displayed 

in the Port list.  Select the required port if needed. 
6. Click Create to add the new terminator and close the dialog box. 

 You can now associate this terminator with a segment.  Right-click the selected terminator 
and then on the shortcut menu, click Associate Segment. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Terminator (Plug-and-Socket Box) - Segment Association 
1. In the Domain Explorer, select a plug-and-socket box. 
2. Right-click the selected plug-and-socket box and then on the shortcut menu, click Actions > 

Connection. 
3. In the Plug-and-Socket Box Connection window, click the required connected home-run 

cable to select it. 
4. Right-click the highlighted home- run cable and on the shortcut menu, click Associate 

Segment to open the Segment Association dialog box. 
5. From the Associate segment list, select a segment with which you want to associate the 

current terminator. 
 If the required segment is not available on the Associate segment list, select the 

Include all segments option button in the Segment filter group box. 
6. Click OK to make the association. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Terminator (Terminal Strip) - Segment Association 
1. In the Domain Explorer, expand the hierarchy of a panel. 
2. Right-click an appropriate fieldbus strip and then on the shortcut menu, click Actions > 

Connection. 
3. In the Connection window, make sure that the required terminal strip is selected in the 

Terminal strip list. 
4. Right-click the required terminator and on the shortcut menu, click Associate Segment to 

open the Segment Association dialog box. 
5. From the Associate segment list, select a segment with which you want to associate the 

current terminator. 
 If the required segment is not available on the Associate segment list, select the 

Include all segments option button in the Segment filter group box. 
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6. Click OK to make the association. 

See Also 
Profibus Design Common Tasks (on page 213) 
 

Fieldbus Bricks 
When designing your Foundation Fieldbus or Profibus system, you need to create a Fieldbus brick 
assembly.  A fieldbus brick assembly is a composite object that consists of a wiring equipment 
item (fieldbus brick) and an apparatus group.  An apparatus group constitutes an apparatus strip 
(that is, a terminal strip) with a number of apparatuses created according to a selected apparatus 
configuration. 
When creating a fieldbus brick, you can define power supply requirements and current 
consumption.  Adding an apparatus to a fieldbus brick, entails the definition of an apparatus 
configuration and the number of apparatuses that you need.  Note that the power supply 
requirements and current consumption values are common to all the existing apparatuses 
belonging to the apparatus group that exists under a fieldbus brick.  Therefore, changing an 
electric property values affects all the apparatuses that exist under that fieldbus brick.  For more 
details about wiring equipment and apparatuses, see Wiring Equipment (on page 61). 
When generating a segment validation report, the software takes into account the fieldbus brick 
electric properties and validates the total current of a segment. 
We recommend that first you create your equipment in the Reference Explorer so that you have 
as many typical configurations as possible.  Then, you can copy these typical configurations to 
the Domain Explorer and this way create numerous fieldbus bricks on the fly. 

See Also 
Profibus Design Common Tasks (on page 213) 
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Managing Fieldbus Brick Assemblies and 
Apparatuses Common Tasks 

The following tasks are used frequently when you manage fieldbus brick assemblies and 
apparatuses for your Foundation Fieldbus and Profibus systems. 

Create a Fieldbus Brick Assembly 
When designing your Foundation Fieldbus or Profibus system, you need to create a fieldbus brick 
assembly.  A fieldbus brick assembly is a composite object that consists of a wiring equipment 
item (fieldbus brick) and an apparatus group.  An apparatus group constitutes an apparatus strip 
(that is, a terminal strip) with a number of apparatuses created according to a selected apparatus 
configuration.  When creating a fieldbus brick, you can define power supply requirements and 
current consumption.  Note that if there are several apparatuses under a fieldbus brick, the power 
supply requirements and current consumption values are common to all the existing apparatuses 
belonging to that fieldbus brick.  Therefore, changing an electric property values affects all the 
apparatuses that exist under that fieldbus brick. 
We recommend that first you create your equipment in the Reference Explorer so that you have 
as many typical configurations as possible.  Then, you can copy these typical configurations to 
the Domain Explorer and this way create numerous fieldbus bricks on the fly. 
For more information, see Create a Fieldbus Brick Assembly (on page 195). 

Configure a Fieldbus Apparatus 
To create a fieldbus brick assembly, you must have a predefined apparatus group 
configuration.  An apparatus group constitutes an apparatus strip (that is, a terminal strip) with a 
number of apparatuses created according to a selected apparatus configuration.  When defining 
an apparatus configuration, you define the apparatus profile (name, description, manufacturer, 
and model), the number of apparatuses, the apparatus terminal configuration, and the position 
numbering.  For more information, see Configure a Fieldbus Apparatus (on page 197). 
 

Create a Fieldbus Brick Assembly 
1. Press F8 to open the Reference Explorer. 
2. Double-click the Panels folder, and select a panel. 
3. Right-click the selected panel and then on the shortcut menu, click New > Wiring 

Equipment. 
4. On the New Wiring Equipment dialog box, from the Category list, select Fieldbus Brick. 
5. Under Name, type the name of the new fieldbus brick and click OK. 
6. In the Wiring Equipment Properties – Fieldbus Brick dialog box, on the General tab, type 

the name of the new fieldbus brick. 
7. Select the Double width check box if the fieldbus brick occupies a double width slot or 

position. 
8. In the Details group box do the following as you require: 

a. Type a description. 
b. Select a type, model, and manufacturer.  If the required value is not available on the list, 

click  to define a new one. 
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c. Enter a sequence if you need to define the card sequence. 
9. Click the Category Properties tab to enter the power supply requirement and current 

consumption values for the reference fieldbus brick. 
 Fieldbus brick is a wiring equipment category that is shipped with SmartPlant 

Instrumentation.  You cannot delete or rename any of the category properties that have been 
shipped with the software.  However, you can add user-defined properties which you can 
rename or delete as you wish.  For details, see Add User-Defined Wiring Equipment 
Category Properties (on page 63).  Note that the software uses the Current consumption 
and the User-defined current consumption values in segment validation reports. 

10. Click the Associated Symbols tab to associate a symbol with this item .  The software will 
use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item  (on page 23). 

11. Click OK to accept your settings and close the dialog box. 
12. In the Reference Explorer, right-click the new fieldbus brick, then on the shortcut menu, click 

New > Apparatus Group. 
13. On the Apparatus Group dialog box, select the desired configuration from the Configuration 

name list.  Make sure that this is configuration is compatible with fieldbus and that the 
Fieldbus apparatus check box is selected. 

 If you do not have an appropriate apparatus configuration, create one.  (For details, see 
Configure a Fieldbus Apparatus (on page 197)). 

14. Enter the number of apparatuses that you require. 
15. Click Create. 

 SmartPlant Instrumentation automatically assigns sequential position numbers to each 
apparatus.  You can edit them later if required.  For details, see Edit Apparatus Terminal 
Properties (on page 76). 

16. On the Terminal Strip Properties dialog box, define the new apparatus strip as required click 
OK.  (For details, see Create a Terminal Strip (on page 85)). 

17. Click Close in the Apparatus dialog box. 
 The new apparatus appears in the Reference Explorer under the current fieldbus 

brick. 
18. Drag the new fieldbus brick to a panel in the Domain Explorer. 

 The software copies the fieldbus brick assembly that includes the fieldbus brick and the 
apparatus. 

19. On the Terminal Strip Properties dialog box, rename the fieldbus brick, modify the other 
properties as you require, and then click OK. 

20. Connect the apparatus to the appropriate cables.  Right-click the apparatus strip you want to 
connect and then on the shortcut menu, click Actions > Connection.  The Connection 
window opens displaying the apparatus terminals in yellow: 
 

 

See Also 
Profibus Design Common Tasks (on page 213) 
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Configure a Fieldbus Apparatus 
To create a fieldbus brick assembly, you must have a predefined apparatus group 
configuration.  An apparatus group constitutes an apparatus strip (that is, a terminal strip) with a 
number of apparatuses created according to a selected apparatus configuration.  When defining 
an apparatus configuration, you define the apparatus profile (name, description, manufacturer, 
and model), the number of apparatuses, the apparatus terminal configuration, and the position 
numbering. 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Do one of the following: 
 In the Domain Explorer, double-click the Panels by Location folder, and select a panel. 
 In the Domain Explorer, double-click the Panels by Category folder, and select a panel. 
 In the Reference Explorer, double-click the Panels folder, and select a panel. 

3. Right-click a panel to which you want to add a fieldbus termination block and then on the 
shortcut menu, click New > Apparatus Group. 

4. In the Apparatus dialog box, click New. 
5. In the Apparatus profile group box, in the Configuration name field, type the name of the 

new apparatus configuration. 
6. Select the Fieldbus apparatus check box. 
7. Select the Internal terminator check box if you need to add an internal terminator on the new 

termination block. 
8. In the Description field, type a short description for the new configuration. 
9. From the Manufacturer list, select the appropriate termination block manufacturer.  If the 

required value is not available, click  next to the list arrow to add or edit values for this list. 
10. From the Model list, select the appropriate termination block model.  If the required value is 

not available, click  next to the list arrow to add or edit values for this list. 
11. Use the Number of apparatuses spinner or type the required number of termination blocks to 

be added.  This way you can have a block of more than one apparatuses.  This number will 
be displayed by default when adding a new termination block to a strip. 

12. In the Apparatus numbering group box, type the apparatus name in the Prefix field if 
required. 

 Apparatus names can be 15-character long.  This name will appear in the Domain 
Explorer within the new strip (only the first four characters), in the Connection window, and 
in the appropriate reports. 

13. Select the Numbered check box to number the apparatuses. 
14. In the Apparatus configuration group box, from the Orientation list, select one of the 

following apparatus terminal patterns: 
 Left / Right — A termination block that has two sides: input and output (that is, left and 

right). 
 Left — A termination block that has wires on the left side only. 
 Right — A termination block that has wires on the right side only. 
 Regular — A termination block that has a conventional terminal that functions as a single 

unit. 
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15. Do the following to define the apparatus terminal name and color: 
a. Click in the left and/or right terminal side text box and type the required terminal name, for 

example 1A: 
b. Select a color of the terminal side from the list, for example red: 

16. Repeat steps 17 and 18 for the other terminal side if appropriate.  Note that the line between 
the two terminal list arrows represents the internal relation between the input and output 
terminals. 

17. Click Add Terminal to add another terminal to this apparatus configuration if needed and then 
repeat steps 14 through 16. 

18. Click Delete Terminal if you need to delete a selected terminal from the current configuration. 
19. Click Save and then Close.  You can now add the required termination block as needed. 

See Also 
Profibus Design Common Tasks (on page 213) 
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Making Connections and Associations for Fieldbus 
This section deals with making connections and associations in you fieldbus system.  Before you 
can associate a segment with a home-run cable or connect a home-run cable to a plug-and-socket 
box, you need to configure various connector types assign connector pins to wires. 
 

In This Section 
Define or Edit a Connector Type ................................................... 199 
Define or Edit a Connector Type Pin Configuration ...................... 200 
Delete a Connector Type ............................................................... 200 
Create a Connector ....................................................................... 200 
Assign Connector Pins to Cable Wires .......................................... 201 
Associate a Pin or a Terminal with a Channel ............................... 201 
Delete a Connector ........................................................................ 202 
Connect a Home-Run Cable to a Plug-and-Socket Box ............... 202 
Associate a Segment with a Home-Run Cable ............................. 203 
 
 

Define or Edit a Connector Type 
A connector type contains pin configuration and other properties for a connector model of a 
specific manufacturer.  When you create a connector for a specific cable, selecting a connector 
type copies these properties for the cable connector. 
1. On the Wiring module menu bar, click Tables > Connector > Types. 
2. In the Connector Types dialog box, do one of the following: 

 To create a new connector type, click New. 
 To edit an existing connector type, click in the field that you want to edit. 

3. Under Connector Type, type a unique name. 
4. To specify the connector type for a specific manufacturer, model, and part number, do any of 

the following: 
 Under Manufacturer, select an appropriate connector manufacturer. 
 Under Model, select an appropriate model. 
 Under Part Number, type the part number you require. 

 You can now define a pin configuration for this connector type.  For details, see Define 
or Edit a Connector Type Pin Configuration (on page 200). 

See Also 
Profibus Design Common Tasks (on page 213) 
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Define or Edit a Connector Type Pin Configuration 
This topic explains how to define or edit a pin configuration for a connector type. 
1. On the Wiring module menu bar, click Tables > Connector > Types. 
2. In the Connector Types dialog box, select the connection type that you want to configure, 

and click Configure. 
3. In the Connector Type Configuration dialog box, do one of the following for each pin that 

you want to configure: 
 To add a new pin, click New. 
 To delete a pin, select the row that you want to delete and click Delete. 
 To edit a pin field, click the field. 

4. To change the displayed pin sequence, under Sequence, type the new unique number. 
5. To set the pin name, under Name, type the unique name. 
6. To set the pin polarity, under Polarity, select the value that you require. 

See Also 
Flow of Activities for Profibus Design (on page 211) 
 

Delete a Connector Type 
This topic shows how to delete a connector type. 
1. On the Wiring module menu bar, click Tables > Connector > Types. 
2. In the Connector Types dialog box, select the connector type that you want to delete. 
3. Click Delete. 

 SmartPlant Instrumentation removes the item that you delete from the Connector Types 
dialog box from the Connector type list. 
 

Create a Connector 
Connectors are needed for fieldbus home-run cables, telecom cables, and other cables that 
require connectors.  SmartPlant Instrumentation allows you to build your wiring system with any 
of the following connector implementations: 

 Connector at one or both cable ends 
 Connector at end of a single cable set 
 Connector at end of wires from different cable sets 

1. In the Domain Explorer or Reference Explorer, do one of the following: 
 To create a new cable, right-click the Cables folder and on the shortcut menu click New > 

Cable. 
 Right-click an existing cable, and on the shortcut menu click Properties. 

2. Modify cable properties as needed.  For details, see Create a Cable (on page 28). 
3. Click Connectors. 
4. In the Connector Assignments dialog box, do one of the following: 

 To manage connector-wire associations for end 1 of the cable, click the End 1 tab. 
 To manage connector-wire associations for end 2 of the cable, click the End 2 tab. 

5. In the Connector Assignments dialog box, click New. 
6. In the Connector Properties dialog box that opens, under Connector, type the name of the 

new connector. 
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 From the list, select a connector type as configured. 

 To modify or create a connector type, click .  For details, see Define or Edit a 
Connector Type (on page 199). 

7. Under Male/female select Male or Female as needed. 
8. Click OK to return to the Connector Assignments dialog box. 
 

Assign Connector Pins to Cable Wires 
This procedure shows how to assign connector pins to cable wires. 
1. In the Domain Explorer or Reference Explorer, do one of the following: 

 To create a new cable, right-click the Cables folder and on the shortcut menu click New > 
Cable. 

 Right-click an existing cable, and on the shortcut menu click Properties. 
2. Modify cable properties as needed.  For details, see Create a Cable (on page 28). 
3. Click Connectors. 
4. In the Connector Assignments dialog box, do one of the following: 

 To manage connector-wire associations for end 1 of the cable, click the End 1 tab. 
 To manage connector-wire associations for end 2 of the cable, click the End 2 tab. 

5. Do one of the following: 
 To validate that pin polarities that you set for this cable end are consistent with wire 

polarities, select the Polarity validation check box. 
 To skip polarity validation, clear the Polarity validation check box. 

6. For each connector pin, under Wires per Pin, select the number of wires that you want to 
assign to the pin. 

7. Under Cable Set, select the Cable Set from which you are assigning a wire to the current 
pin.  (Repeat this for each connector pin.) 

8. Under Wire, select the wire that you assign to the pin.  (Repeat this for each connector pin.) 

 
 The value that you enter under Wires per Pin determines the number of rows displayed for a 

given pin. 
 The software does not allow you to edit pin-wire assignment properties of a connector that is 

connected (in the Connection window). 
 

Associate a Pin or a Terminal with a Channel 
SmartPlant Instrumentation enables you to associate terminals and pins with wiring equipment 
channels.  Note that these terminals and the terminal strip must belong to the same parent wiring 
equipment.  Also, if you want to associate pins, the pins must belong to a connector which is a 
child item of the parent wiring equipment. 
After you drag a terminal or a pin to a wiring equipment channel, the software retains it in its 
original place from which you dragged it.  However, after expanding the destination hierarchy, the 
software also shows the terminal or pin that you dragged.  This means that the terminal or pin is 
physically located in its original place but it is associated with the item to which it was dragged. 

 When dragging a terminal or pin to a wiring equipment channel, the software retains 
it in its original place from which you dragged it.  However, after expanding the destination 
hierarchy, the software also shows the terminal or pin that you dragged.  This means that the 
terminal or pin is physically located in its original place but it is associated with the item to which it 
was dragged. 
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1. Do one of the following: 
 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. Expand a hierarchy to display the terminal or pin that you want to associate. 
3. Drag your selection to the required wiring equipment channel. 
 

Delete a Connector 
This topic shows how to delete a connector. 
1. In the Domain Explorer or Reference Explorer, right-click a cable, and on the shortcut menu 

click Properties. 
2. In the Cable Properties dialog box, click Connectors. 
3. In the Connector Assignments dialog box, do one of the following: 

 To manage connector-wire associations for end 1 of the cable, click the End 1 tab. 
 To manage connector-wire associations for end 2 of the cable, click the End 2 tab. 

4. In the Connector Assignments dialog box, select the connectors that you want to delete. 
5. Click Delete. 
6. Click OK to return to the Connector Assignments dialog box. 

 The software does not allow you to delete a connector that is already connected (in the 
Connection window). 
 

Connect a Home-Run Cable to a Plug-and-Socket Box 
After creating the required plug-and-socket boxes and home-run cables with connectors, you can 
start connecting the your home-run cables to plug-and socket boxes. 
1. Press F7 to open the Domain Explorer. 
2. Expand the Cables folder and select a home-run cable. 
3. Right-click the selected cable and then on the shortcut menu, click Actions > Connection. 
4. In the Domain Explorer, expand the hierarchy of the fieldbus cable that you want to connect 

to the current plug-and-socket box. 
5. Drag the connectors to their ports in the current plug-and-socket box in the Plug-and- Socket 

Box Connection window. 
 Before you start dragging a connector, make sure that the cable connector matches the 

port type on the plug-and-socket box. 
6. In the Cable Connection Options dialog box, select the cable end that you want to connect 

and click OK. 
7. Repeat the above to connect other cables as needed. 

 To disconnect a home-run cable from the current plug-and-socket box, highlight the cable 
that you want to disconnect and click . 

See Also 
Terminator (Terminal Strip) ” Segment Association (see "Terminator (Terminal Strip) - Segment 
Association" on page 193) 
Terminator (Plug-and-Socket Box) ” Segment Association (see "Terminator (Plug-and-Socket 
Box) - Segment Association" on page 193) 
Create a Home-Run Cable (on page 185) 
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Associate a Segment with a Home-Run Cable 
After connecting a home-run-cable to a plug and socket box or a fieldbus brick, you can associate 
the home-run cable or its cable-set with a segment. 
1. Press F7 to open the Domain Explorer. 
2. Select and then right-click a fieldbus plug-and-socket box or a fieldbus brick. 
3. On the shortcut menu, click Actions > Connection. 
4. In the Connection or the Plug- and-Socket Box Connection window, click the required 

connected home-run cable or a home-run cable-set to select it.  For example: 

 
5. Right-click the highlighted home- run cable and on the shortcut menu, click Associate 

Segment to open Segment Association dialog box. 
6. From the Associate segment list, select the segment with which you want to associate the 

current home-run cable. 
 If the required segment is not available in the Associate segment list, select the 

Include all segments option button in the Segment filter group box. 
7. Click OK to make the association. 

 The name of segment you just associated is propagated along the entire home-run cable. 

See Also 
Create a Home-Run Cable (on page 185) 
Create a Foundation Fieldbus Segment (on page 182) 
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Managing Fieldbus I/O Cards and I/O Assignment 
Common Tasks 

The following tasks are used frequently when you manage fieldbus I/O cards and effect I/O 
assignment for your Foundation Fieldbus and Profibus systems. 

Create a Fieldbus I/O Card 
You need to create fieldbus I/O cards so that you can associate segments and effect I/O 
assignment. 
You can create new I/O cards either in the Domain Explorer or the Reference Explorer.  If you 
are creating an I/O card that is going to have a frequently used configuration, we recommend that 
you create it in the Reference Explorer.  Reference I/O cards facilitate fast creation of plant I/O 
cards by copying an existing I/O card configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create an I/O card that does not have a configuration that you 
intend to use frequently, we recommend that you create this card in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the I/O cards in the 
current <unit>. 
For more information, see Create a Fieldbus I/O Card (on page 205). 

Effect Fieldbus I/O Assignment 
You can effect I/O assignment after you make the required connections.  For more information, 
see Effect Fieldbus I/O Assignment (on page 206). 
 

Create a Fieldbus I/O Card 
1. In the Domain Explorer or Reference Explorer, right-click a DCS or PLC panel where you 

want to create a fieldbus I/O card. 
2. On the shortcut menu, click New > Wiring Equipment. 
3. In the New Wiring Equipment dialog box, under Category, select I/O card. 
4. In the Wiring Equipment Properties – I/O Card dialog box, on the General tab, do one of 

the following to name the new I/O card: 
 Select the Apply naming convention check box selected if you want the software to 

name the new card automatically according to the naming conventions that are set for this 
type of equipment in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

 Clear the Apply naming convention check box and under Name, type the name of the 
new card.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Name. 

5. Select the Double width check box if the card occupies a double width slot or position. 
6. In the Details group box, type a description as needed. 
7. Select an I/O card type, model, and manufacturer.  If the required value is not available on the 

list, click  to define a new one. 
8. Enter a sequence if you need to define the card sequence. 
9. Click the Control System tab. 
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10. In the Control system details group box, under I/O type, select one of the following I/O types 
to determine the actual function of the new I/O card: 
 Fieldbus 
 Profibus DP 
 Profibus PA 

11. Under Module, type the software address that the current card is assigned to. 
 Module, Controller/ Processor, Rack, and Slot are field headers specific to panel 

manufacturers.  Selecting a different manufacturer when editing the panel displays the 
headings used by that panel manufacturer.   For details, see Customize 
Manufacturer-Specific Field Headers. 

12. From the Controller/Processor list, select an I/O card controller.  If the required controller is 

not available on the list, click  to define a new one. 
13. Click the Category Properties tab. 
14. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 A category property is a wiring equipment category property that you can define 

yourself.  For details, see Add User-Defined Wiring Equipment Category Properties (on 
page 63). 

15. Click the Associated Symbols tab to associate a symbol with this item .  The software will 
use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

16. Click OK to accept your settings and close the dialog box. 

See Also 
Fieldbus Bricks (on page 194) 
Profibus Design Common Tasks (on page 213) 
 

Effect Fieldbus I/O Assignment 
1. In the Domain Explorer, select the DCS and PLC cabinets for which you want to effect I/O 

assignment. 
2. Right-click the panel that you selected and then on the shortcut menu, click Actions > I/O 

Assignment. 
3. On the I/O Assignment Type dialog box, click Segment I/O Assignment. 
4. In the Segment I/O Assignment window, under Assignment details, do the following for 

each I/O card that requires I/O assignment. 
5. Under I/O termination, select the desired I/O card. 
6. For each segment for which you want to effect I/O assignment, drag it from the Segments 

data window to the appropriate channel in the data window of the I/O card details pane. 
7. To cancel fieldbus I/O assignment for a given segment, drag it from the data window of the I/O 

card details pane back to the Segments data window. 

 
 To rename a selected control system tag, click , and on the Control System Tag 

Properties dialog box, edit the tag properties. 
 To view input/output information for the current I/O card, click . 
 To generate an I/O Tag Assignment report, click . 



 Foundation Fieldbus and Profibus 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 207 
 

 

Fieldbus Validation 
SmartPlant Instrumentation validates that you design fieldbus segments according to basic 
connection rules and according to parameters that you set for a given segment: 
On-the-Fly Connection Validations 
Upon attempting to connect, the software verifies that: 
 An instrument to be connected is not associated with another segment. 
 A home-run cable to be connected is not already connected to another segment. 
 You are not associating or wiring a non-intrinsically-safe instrument to an intrinsically safe 

segment.  In this case, SmartPlant Instrumentation will warn, but allow. 
Segment-Report Validations 
You perform other validations by running a report from the Fieldbus Segment 
Manager.  SmartPlant Instrumentation notifies you in the report of a failed validation in the 
following cases: 
 There are fieldbus tags that are associated with a segment but not wired. 
 There are fieldbus tags that have wiring, but are not yet connected to a segment. 
 There is a connection discontinuity between the field and a DCS or an I/O terminal strip. 
 The number of instruments in a segment exceeds the maximum specified for that segment. 
 The number of devices on a given spur exceeds the segment-wide parameter profile. 
 A spur length is exceeds the maximum set for that spur. 
 Total cable length exceeds the maximum you defined for the segment profile. 
 There are less than two terminators in a segment. 
 Actual voltage at instrument terminals is below the minimum operating voltage. 
 Total segment current consumption exceeds the maximum specified value. 
 Total capacitance exceeds segment maximum specified capacitance. 

 
 To define a cable type that supports fieldbus validation, make sure that in the Cable Type 

Properties dialog box, you enter the required values for capacitance, capacitance UOM (unit 
of measure), cable resistance, cable resistance UOM, length UOM, and maximum fieldbus 
length (for details, see Create a Cable (on page 28)). 

 To define an instrument tag that supports fieldbus validation, make sure that on the Tag 
Number dialog box you enter valid information under Fieldbus Tag Number Properties 
Create Foundation Fieldbus and Profibus Instruments (on page 176)). 

 SmartPlant Instrumentation validation supports basic fieldbus networks consisting of a single 
segment with no parallel branches and no repeaters. 

 
 
  



Foundation Fieldbus and Profibus 
 

 
208 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

 



 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 209 
 

S E C T I O N  2 9  

Fieldbus Validation Common Tasks 
The following tasks are used frequently when you generate validation reports for your Foundation 
Fieldbus and Profibus systems. 

Generate a Validation Report for One Segment 
This procedure shows you how to generate a validation report for one fieldbus segment.  Such a 
report allows you to verify that you created this segment according to general connection rules 
and the specific segment-wide parameter profile associated with each section.  Note that 
SmartPlant Instrumentation will formulate this type of report in the unit of measure set on the 
Cable Lengths tab of the Segment- Wide Parameter Profile Properties dialog box.  For more 
information, see Generate a Validation Report for One Segment (on page 209). 

Generate a Validation Report for Multiple Segments 
This procedure shows you how to generate a validation report for one of more fieldbus 
segments.  Such a report allows you to verify that you created fieldbus segments according to 
general connection rules and the specific segment-wide parameter profile associated with each 
segment.  For more information, see Generate a Validation Report for Multiple Segments (on 
page 210). 

Generate a Segment Wiring Report 
Use this procedure to generate an enhanced report for a fieldbus segment.  Note that you must 
install the Enhanced Report Utility on your local machine to be able to generate the 
communication line report.  For more information, see Generate a Segment Wiring Report (on 
page 210). 
 
 

Generate a Validation Report for One Segment 
1. In the Domain Explorer, expand the Fieldbus Segments folder. 
2. Select a segment and then on the shortcut menu, click Reports > Validation Report. 

 SmartPlant Instrumentation formulates this type of report in the unit of measure set on the 
Cable Lengths tab of the Segment-Wide Parameter Profile Properties dialog box. 
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Generate a Validation Report for Multiple Segments 
1. In the Domain Explorer, click the Fieldbus Segments folder. 
2. In the Items pane of the Domain Explorer, select the segments that you require. 
3. Right-click the selected segments and then on the shortcut menu, click Reports > Validation 

Report. 
 You can also generate a validation report from the Fieldbus Segment Manager. 

 

Generate a Validation Report for Multiple Segments from the 
Fieldbus Tag Numbers Browser 

1. On the Wiring module menu bar, click Actions > Fieldbus Segment Manager. 
2. Do one of the following: 

 Click Actions > Batch Validation. 

 Click . 
3. On the Validation Reports dialog box, under Segment list, select the segments that you 

require or click Select all to include all segments in the validation report. 
4. Under Unit of measure for the report, select Feet or Meters. 
5. Click Print. 

 You can also generate a validation report from the Fieldbus Segments folder. 
 

Generate a Segment Wiring Report 
1. In the Domain Explorer, expand the Fieldbus Segments folder. 
2. Right-click a segment, and then on the shortcut menu, click Reports > Enhanced Segment 

Wiring. 
3. At the print preview prompt, do one of the following: 

 Click Yes to open the print preview of the generated report.  Choose this option if you 
want to modify or annotate the report. 

 Click No to start printing the report without displaying its print preview. 

 
 You must install the Enhanced Report Utility on your local machine to be able to generate the 

communication line report.  For details, see Enhanced Report Utility Installation Guide. 
 In the General tab folder of the Preferences dialog box, you can set SmartPlant 

Instrumentation to display a print preview always, never or with your approval. 
 If you select not to preview a report, and you are using Acrobat Distiller as your default printer, 

make sure that Distiller is configured to enable report generation without prompting for the 
output file location.  To do this, open the Distiller Preferences dialog box and under Output 
Options, clear the check boxes Ask for PDF file destination and Ask to replace existing 
PDF file. 
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Profibus Design 
SmartPlant Instrumentation supports Profibus technology which is based on a two-level bus 
hierarchy, DP and PA Profibus segments.  Each DP bus can connect multiple addressable link 
hardware devices that link various types of input and output devices.  Every link device has a 
unique node number.  The DP link devices that you can connect to a DP bus can belong to one of 
the following types: 
 Motor drive (connecting a VFD to a DP bus). 
 PLC or DCS panel that connects a conventional I/O system of analog and discrete field 

devices to a DP bus. 
 DP/PA type that connects a lower PA (Process Automation) bus along with its PA field devices 

to the DP bus (similar to Foundation Fieldbus segments). 
Profibus PA 
Profibus PA segments and Profibus instruments have the same characteristics as Foundation 
Fieldbus segments and Foundation Fieldbus instruments. 
 
 

Flow of Activities for Profibus Design 
The following is a suggested flow of activities for Profibus design in SmartPlant 
Instrumentation.  Note that you can carry out some of the procedures in a different order, 
depending on your preferences or requirements. 
1. Set the basic definitions as follows: 

a. Define Profibus instrument type profiles - Prior to creating new Profibus tag numbers, you 
need to customize wiring reference items and then define appropriate instrument type 
profiles in the Instrument Index module so that new tag numbers acquire Profibus 
properties.  This results in automatic assignment of the required properties to the new tag 
numbers.  For details, see Define Foundation Fieldbus and Profibus Instrument Type 
Profiles (on page 176). 

b. Add a new browser view - In the Browser module, create a browser view with the required 
fields for the Fieldbus Segment Manager.  This facilitates the assignment of tag 
numbers to segments.  You can create multiple Browser views with different Style, Sort, 
and Filter functions.  For example, by using the filter function you may create independent 
views for each segment, so that only tags of that segment will be displayed in its 
corresponding view.  For more information, see Add a New View. 

2. Create the required DP segments.  For details, see Create a Profibus DP Segment (on 
page 214). 

3. Create your PLC and/or DCS panels that are compatible with Profibus.  For details, see 
Create a DP-Compatible PLC or DCS Panel (on page 215). 

4. Associate the PLC and DCS panels with the DP segments.  For details, see Associate a PLC 
or DCS Panel with a Profibus DP Segment (on page 215). 

5. Create the required Profibus DP multi-input instruments.  Create these multi-input 
instruments with their connected I/O's.  For example, create a motor drive and insert it in an 
MCC cabinet.  For details, see Create a Multi-Input Instrument with Terminal Connections for 
a Fieldbus Segment (on page 225) and Create a Multi-Input Instrument with Plug-and-Socket 
Connections for a Fieldbus Segment (on page 223). 

6. Associate the DP motor drives with the DP segments. 
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 For more information, see Associate Profibus DP Instruments with a DP Segment (on 
page 214). 

 Effect the DP Segment I/O Assignment 
 Create the required PA segments.  For more information, see Create a Profibus PA 

Segment (on page 214). 
7. Create the Profibus PA instruments.  You create these tags based on the instrument types 

that you defined, and edit the tag number properties as required.  For more information, see 
Create Foundation Fieldbus and Profibus Instruments (on page 176). 

8. Associate the PA instruments with the PA segments.  For details, see Associate Profibus PA 
Instruments with a PA Segment (on page 214). 

9. Generate a Profibus layout report.  For details, see Generate an Enhanced Profibus Layout 
Report (on page 216). 
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Profibus Design Common Tasks 
The following is a suggested flow of activities for Profibus design in SmartPlant 
Instrumentation.  Note that you can carry out some of the procedures in a different order, 
depending on your preferences or requirements. 

Create a Profibus DP Segment 
You need to create a DP bus prior to creating PA segments or any instruments that are associated 
with Profibus.  This procedure explains how to create a DP bus..  For more information, see 
Create a Profibus DP Segment (on page 214). 

Create a Profibus PA Segment 
This procedure explains how to create a Profibus PA segment.  Note that you can create a 
Profibus PA segment only if you already have an existing DP bus.  For more information, see 
Create a Profibus PA Segment (on page 214). 

Associate Profibus PA Instruments with a PA Segment 
This procedure outlines the steps required to associate PA instruments with a PA segment.  Note 
that an instrument can be associated with one segment only.  For more information, see 
Associate Profibus PA Instruments with a PA Segment (on page 214). 

Associate Profibus DP Instruments with a DP Segment 
Use this procedure to associate a Profibus DP device or an instrument (for example, a motor 
drive) with a DP segment.  For more information, see Associate Profibus DP Instruments with a 
DP Segment (on page 214). 

Create a DP-Compatible PLC or DCS Panel 
You need DP-compatible panels for your Profibus system.  For more information, see Create a 
DP-Compatible PLC or DCS Panel (on page 215). 

Associate a PLC or DCS Panel with a Profibus DP Segment 
This procedure explains how to associate a PLC or a DCS panel with a DP segment.  For more 
information, see Associate a PLC or DCS Panel with a Profibus DP Segment (on page 215). 

Generate an Enhanced Profibus Layout Report 
This report allows you to view a schematic drawing of a Profibus segment.  The report includes 
one page per segment and shows all the associated devices and their node numbers.  For more 
information, see Generate an Enhanced Profibus Layout Report (on page 216). 
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Create a Profibus DP Segment 
1. In the Domain Explorer, right-click the Fieldbus Segments folder. 
2. On the shortcut menu, click New > Profibus DP Segment. 
3. In the Profibus DP Segment Properties dialog box, under Segment, type a unique name for 

the new segment. 
4. Click OK to create the new segment. 
  
 

Create a Profibus PA Segment 
1. In the Domain Explorer, expand the Fieldbus Segments folder. 
2. Right-click a DP segment and then on the shortcut menu, click New > Profibus PA Segment. 
3. In the Profibus PA Segment Properties dialog box, type the segment name. 

4. Select a segment-wide parameter profile if needed.  You can click  to define a new 
segment-wide parameter profile if you need one.  For details, see Define Segment-Wide 
Parameters. 

5. Select the Intrinsically safe check box if you want to define the new segment as intrinsically 
safe. 

6. Click OK to create the new segment. 
 
 

Associate Profibus PA Instruments with a PA Segment 
1. On the Wiring module menu bar, click Actions > Fieldbus Segment Manager. 
2. In the Fieldbus Segment Manager, select one or more PA instruments. 
3. Drag the instruments you selected to a PA segment in the Fieldbus Segments folder of the 

Domain Explorer. 
 To dissociate a PLC or DCS panel from a DP segment, in the Domain Explorer, right-click 

a panel in the Fieldbus Segment folder, then on the shortcut menu, click Actions > Dissociate 
Item from Segment. 
 
 

Associate Profibus DP Instruments with a DP Segment 
1. On the Wiring module menu bar, click Actions > Fieldbus Segment Manager. 
2. Select the desired instruments in the browser. 
3. Do one of the following: 

 On the browser toolbar, click   and then select an unassociated instrument in the DP 
Instruments pop-up window and drag it to a DP segment in the Domain Explorer. 

 In the Fieldbus Segment Manager, select an unassociated instrument and drag it to a 
DP segment in the Domain Explorer. 

 To dissociate an instrument from a DP segment, in the Domain Explorer, right-click an 
instrument in the Fieldbus Segments folder, and then on the shortcut menu, click Actions > 
Dissociate Item from Segment. 
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Create a DP-Compatible PLC or DCS Panel 
You can connect several different types of devices to a DP segment.  As DP segments are 
Ethernet busses, you can connect PLC or DCS panels to a DP segment via a special I/O card. 
You create a PLC or DCS panel compatible with a DP segment exactly the same way you create 
any other PLC or DCS panel.  While creating such a panel, make sure that you select the Enable 
DP Profibus check box so that you can associate this panel with a DP Profibus segment. 
For details, see the following: 
 Create a Distributed Control System (DCS) Panel (see "Create a DCS (Distributed Control 

System) Panel" on page 42) 
 Create a Programmable Logic Controller (PLC) Panel (see "Create a PLC (Programmable 

Logic Controller) Panel" on page 43) 
 
 

Associate a PLC or DCS Panel with a Profibus DP Segment 
1. Start the Wiring module. 
2. Do one of the following to open the Fieldbus Segment Manager. 

 Click Actions > Fieldbus Segment Manager. 

 On the module toolbar, click . 
3. In the Fieldbus Segment Manager, do one of the following to open the Panels pop-up 

window: 
 On the main menu, click View > Panels. 

 On the Fieldbus Segment Manager toolbar, click . 
 The Panels pop-up window displays all the PLC panels that have been enabled for use 

with DP Profibus and that have not been associated with a DP segment. If the pop-up window 
is empty, create a new PLC cabinet and make sure that you select the Enable DP segment 
check box on its properties dialog box. 

4. In the Domain Explorer, expand the Fieldbus Segments hierarchy to display the available 
DP segments. 

 To create a new DP segment, right-click the Fieldbus Segments folder in the Domain 
Explorer and then click New. 

5. In the Panels pop-up window, select an appropriate PLC panel and drag it to the required DP 
segment in the Fieldbus Segments folder of the Domain Explorer. 

 To dissociate a PLC or DCS panel from a DP segment, in the Domain Explorer, right-click 
a panel in the Fieldbus Segment folder, then on the shortcut menu, click Actions > Dissociate 
Item from Segment. 
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Generate an Enhanced Profibus Layout Report 
1. In the Domain Explorer, expand the Fieldbus Segments folder. 
2. Right-click a Profibus segment. 
3. On the shortcut menu, click Reports > Enhanced Profibus Layout. 
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HART (Highway Addressable Remote Transducer) technology is one of the first fieldbus digital 
communication techniques that were implemented in instrumentation.  HART is a widely 
acceptable and recognized standard for digitally enhanced 4-20 milliamp smart instrumentation 
communication.  This technology extends the 4-20 mA standard analog transmission with a 
superimposed digital signal that contains process and instrument data. 
The advantage of HART instruments is that they can be connected to standard 4-20 milliamperes 
systems and, at the same time; make use of digital communication to collect additional data. 
 
 

Flow of Activities for HART Instrumentation 
The following is a suggested flow of activities for HART instrumentation in SmartPlant 
Instrumentation.  Note that you can carry out some of the procedures in a different order, 
depending on your preferences or requirements. 
1. Define the appropriate instrument types for HART instruments.  When defining the profile for 

HART instrument types you must select HART AI or HART AO as the I/O type.  For more 
information, see Define Instrument Type Profiles for HART Instruments (on page 218). 

2. Create your HART instruments.  HART instruments can be HART transmitters, HART IP 
converters, and so on.  For details, see Create a HART Instrument (on page 218). 

3. Create a virtual digital tag.  Each HART instrument has a different set of digital signals.  The 
digital signals depend on the I/O type (AI or AO) and on the instrument manufacturer who 
supplies the HART instruments with a specified variety of possible digital signals.  For more 
information, see Create a Virtual Digital Tag (on page 220). 

4. Create I/O cards compatible with HART instruments.  For details, see Create an I/O Card 
Compatible with HART Instruments (on page 220). 

5. Connect the HART instruments to the appropriate HART I/O cards.  You make this 
connection by right-clicking an I/O card in the Domain Explorer and then clicking Actions 
>Connection. 

6. Effect I/O assignment for HART instruments.  For details, see Effect I/O Assignment for 
HART Instruments (on page 220). 
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Define Instrument Type Profiles for HART Instruments 
1. On the Instrument Index module, click Tables > Instrument Types. 
2. In the Instrument Types dialog box, from the Process function list, select an appropriate 

process function. 
3. Do one of the following: 

 Click New to create a new instrument type.  For details, see Define an Instrument Type. 
 In the data window, select an existing instrument type. 

4. Click Profile. 
5. In the Instrument Type Profile dialog box, on the General tab, under Specification, select 

an appropriate fieldbus specification. 
6. Select Include I/O type, and then from the list, select one of the following: 

 HART AI 
 HART AO 

7. On the Wiring and Control System tab, select the appropriate reference device panel and 
reference cable.  For details, see Define a Wiring and Controls System Instrument Type 
Profile. 

8. Click OK in the Instrument Type Profile dialog box. 
  
 

Create a HART Instrument 
Press F7 to open in the Domain Explorer. 
1. Expand the plant hierarchy to display the Instruments and Loops folders. 
2. Do one of the following: 

 To create an instrument  not associated with a loop number, right-click the Instruments 
folder, and then click New > Instrument. 

 To create an instrument that is associated with a specific loop number, expand the Loops 
folder, right-click a loop, and then click New > Instrument. 

3. On the New Tag Number dialog box, do the following: 
a. From the Tag class list, select HART. 
b. Type the name of the new tag number. 
c. Click OK. 

4. On the Select Instrument Type dialog box, select the instrument type you want to associate 
with the current hart instrument, and then, click OK. 

5. Click OK. 

 
 Remember that you need to define appropriate instrument type profiles for your HART 

instruments prior to creating them.  These instrument type profiles must include an I/O 
type which is either HART AI or HART AO.  For details, see Define Instrument Type 
Profiles for HART Instruments (on page 218). 

 If the tag number does not correspond to an existing loop name, SmartPlant 
Instrumentation prompts you to enter a loop name based on the tag number you have 
entered.  If the loop identifier already matches an existing loop, the software will 
automatically associate the new tag number with the loop. 
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 If the loop convention includes the loop function parameter, the prompt will always 
appear.  In this case, you have to complete the loop number. 
If a profile exists for the selected instrument type, any new tags for that instrument type 
will be created with the selected reference items. 

 For DeltaV compatibility, you must select an instrument type that you associated with a 
DeltaV device type during the downloading process.  To display the Associate 
Foundation Fieldbus Device Types with Instrument Type supporting table of 
associations that you built among DeltaV device types, instrument manufacturers, and 
SmartPlant Instrumentation instrument types, see Associate Device Types for DCS 
Vendors. 

6. On the Loop Name dialog box, do one of the following: 
 Type the loop number that the new tag is associated with. 
 Accept the displayed loop number. 
 Click Cancel to create the tag number without a loop association.  Note that if a loop with 

the same name exists, the tag number is automatically associated with it, without creating 
a new loop. 

7. Click OK to create the loop number. 
8. On the Loop Number Properties dialog box, accept the loop number properties or modify 

them as you require and then click OK. 
9. On the Tag Number Properties dialog box, on the General tab, enter the tag number 

attributes that you require. 
 For DeltaV compatibility, make sure that the value that you select from the Manufacturer 

list is among the acceptable values for the instrument type that you selected for the current 
tag.  For details, see Crucial Fields for the DeltaV Interface. 

10. To enter power supply properties, see Enter Power Supply Data for Panels and Instrument 
Tags (on page 45). 

11. Click the HART tab to define the instrument parameters and create virtual digital tags. 
12. Select a signal type and linearity type values if needed. 
13. From the Analog signal parameter list, select a parameter that is appropriate for the analog 

signal of the current HART instrument. 
 This selection is available only if the I/O type of the current instrument is HART AI. 

14. Enter the required DC consumption, capacitance, minimum transmit level, and operating 
voltage. 

15. Create the required virtual digital tags.  For details, see Create a Virtual Digital Tag (on 
page 220). 
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Create a Virtual Digital Tag 
1. In the Tag Number Properties dialog box, click the HART tab. 
2. From the Analog signal parameter list, select an appropriate signal parameter. 
3. In the Virtual tags group box, click New. 
4. Click Yes in the prompt to save the changes to the tag properties. 
5. In the New Virtual HART Tag Number dialog box, select a signal parameter, enter the tag 

number name. 
6. Click OK. 

 The signal parameter depends on whether the I/O type of the current HART instrument is 
HART AI or HART AO. 
 
 

Create an I/O Card Compatible with HART Instruments 
To make an I/O card compatible with a HART instrument, you must select one of the following I/O 
types when defining the control system properties of a new I/O card: 
 HART AI 
 HART AO 
 AI 
 AO 
 MIXED 

For details on how to create an I/O card, see Create an I/O Card (on page 68). 
 
 

Effect I/O Assignment for HART Instruments 
You effect I/O assignment for your HART instruments like with any other instruments that require 
I/O assignment.  In the Domain Explorer, right-click the required I/O card and then click Actions 
> I/O Assignment.  For details, see I/O Assignment (on page 105). 

Instruments Cards    

 AI AO HART AI HART AO 

AI Yes No Yes (see note 1) No 

AO No Yes No Yes (see note 1)

HART AI Yes (see note 2) No Yes No 

HART AO No Yes (see note 2) No Yes 

Mixed Yes Yes Yes (see note 3) Yes (see note 3)

 
 When assigning "non-HART" analog instruments to HART-compatible I/O cards, the software 

assigns only the analog signals.  (DI or DO are not allowed anyway). 
 You can assign HART instruments to conventional I/O cards (AI to HART AI, AO to HART 

AO), but the software assigns only the analog signals and not the virtual digital tags. 
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 You can assign HART instruments to I/O cards with MIXED I/O type, but the software assigns 
only the analog signals and not the virtual digital tags. 

 
 

Many modern fieldbus or conventional digital instruments support more than one input, for 
example, temperature transmitters and Bentley Nevada vibration monitors.  SmartPlant 
Instrumentation supports various configurations for instrument tags with multi-input device 
panels.  Multi-input devices can recognize input signals from distant device panels. 
 

Managing Multi-Input Devices 
The following tasks are used frequently when you create and manage the fieldbus and 
conventional multi-input devices in your plant.  
You can create new multi-input devices either in the Domain Explorer or the Reference 
Explorer.  If you are creating a multi-input device that is going to have a frequently used 
configuration, we recommend that you create it in the Reference Explorer.  Reference 
multi-input devices facilitate fast creation of plant multi-input devices that are based on the 
configuration of an item in the Reference Explorer.  However, if you want to create a multi-input 
device that does not have a configuration that you intend to use frequently, we recommend that 
you create this multi-input device in the Domain Explorer and in the <unit> where it is to be 
physically located.  This is helpful when filtering the panels in the current <unit>. 

Create a Multi-Input Device Panel with Terminal Connections 
This procedure explains how to create a multi-input device panel that has terminal 
connections.  For more information, see Create a Multi-Input Device Panel with Terminal 
Connections (on page 223). 

Create a Plug-and-Socket Multi-Input Device Panel 
This procedure shows you how to create a plug-and-socket multi-input device panel.   For more 
information, see Create a Plug-and-Socket Multi-Input Device Panel (on page 222). 

Create a Multi-Input Instrument with Plug- and-Socket Connections for a Fieldbus Segment 
You use this procedure to create a multi-input instrument with plug-and-socket connections for a 
fieldbus segment and then assign the signals to fieldbus I/O card channels.  For more 
information, see Create a Multi-Input Instrument with Plug- and-Socket Connections for a Fieldbus 
Segment (see "Create a Multi-Input Instrument with Plug-and-Socket Connections for a Fieldbus 
Segment" on page 223). 

Create a Multi-Input Instrument with Terminal Connections for a Fieldbus Segment 
This procedure explains how to create a multi-input instrument with terminal connections for a 
fieldbus segment.  Also, you can assign the signals to fieldbus I/O card channels.  For more 
information, see Create a Multi-Input Instrument with Terminal Connections for a Fieldbus 
Segment (on page 225). 

Conventional and Fieldbus Multi-Input 
Devices 
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Create a Multi-Input Instrument with Plug- and-Socket Connections for a Serial Loop 
Interface 
This procedure explains how to create a multi-input instrument with plug-and-socket connections 
for a serial interface loop.  Also, you can assign the signals to fieldbus I/O card channels and 
generate an enhanced report for the wiring loop.  For more information, see Create a Multi-Input 
Instrument with Plug-and-Socket Connections for a Serial Loop Interface (on page 226). 

Create a Multi-Input Instrument with Terminal Connections for a Serial Loop Interface 
This procedure explains how to create a multi-input instrument with terminal connections for a 
serial interface loop.  Also, you can assign the signals to fieldbus I/O card channels and generate 
an enhanced report for the wiring loop.  For more information, see Create a Multi-Input Instrument 
with Terminal Connections for a Serial Loop Interface (on page 227). 
 

Create a Plug-and-Socket Multi-Input Device Panel 
1. In the Domain Explorer or Reference Explorer, do one of the following: 

 In the Domain Explorer, expand the Panels by Category folder. 
 In the Reference Explorer, expand the Panels folder. 

2. Right-click the Device Panels folder and then on the shortcut menu, click New > Multi-Input 
(Plug-and-Socket). 

3. In the Plug-and-Socket Box Wizard - Multi-Input Device, read the instructions carefully and 
then click Next to open the Define the New Panel page. 

4. Under Panel name, type a unique device panel name. 
5. Define the new panel by entering the panel type, manufacturer, model, area class, location, 

mounting, dimensions, and backplane as needed. 
6. To define the device panel as intrinsically safe, select Intrinsic safety. 
7. Click Next, and on the Define the Plug-and-Socket Layout page, enter the number of ports 

that you need on the left and on the right sides of the panel. 
8. Click Next, and on the Define the Ports page, for each port that you created, type the name 

and select In or Out. 
 You must define one and only one out port. 

9. Click Next, and on the Define the Plug-and-Socket Box Connectors page, for each 
connector, do the following: 

a. From the Connector type list, select the required connector, or click  to open the 
Connectors dialog box. 

b. From the Male/female list, define the connector as Male or Female. 
c. If these settings are constant for all of the connectors in the panel, select Apply to all after 

you set the above. 
10. Click Next and then click Finish. 

 You can delete the terminals that were created after completing the wizard only when you 
delete the multi-input device panel. 
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Create a Multi-Input Device Panel with Terminal 
Connections 

1. In the Domain Explorer or Reference Explorer, do one of the following: 
 In the Domain Explorer, expand the Panels by Category folder. 
 In the Reference Explorer, expand the Panels folder. 

2. Right-click the Device Panels folder and then on the shortcut menu, click New > Multi-Input 
(Conventional). 

3. In the Conventional Box Wizard - Multi-Input Device, read the instructions carefully and 
then click Next to open the Define the New Panel page. 

4. Under Panel name, type a unique device panel name. 
5. Define the new panel by entering the panel type, manufacturer, model, area class, location, 

mounting, dimensions, and backplane as needed. 
6. To define the device panel as intrinsically safe, select Intrinsic safety. 
7. Click Next, and on the Define the Multi Input Layout page, enter the number of inputs and 

outputs that you need on the left and on the right sides of the panel. 
8. Click Next, and on the Define the Multi Input page, for each multi input that you created, type 

the name and select In or Out. 
 Only one of the input/outputs can be defined as an output. 

9. Click Next, and on the Define the Input / Output Configuration page, for each connector, 
do the following: 
a. From the Input/Output list, select the required input or output. 
b. From the Configuration list, select an appropriate configuration. 
c. Under First terminal, enter the first terminal as you require. 
d. If these settings are constant for all of the inputs and outputs in the panel, select Apply to 

all after you set the above. 
10. Click Next and then click Finish. 

 You can delete the terminals that were created after completing the wizard only when you 
delete the multi-input device panel. 
 
 

Create a Multi-Input Instrument with Plug-and-Socket 
Connections for a Fieldbus Segment 

1. In the Reference Explorer, create reference panels that feed into the multi-input device 
panel. 

2. In the Reference Explorer, create a reference multi-input device panel with plug- and-socket 
connections. 

3. In the Reference Explorer, create reference spur cables. 

 
 Use the same connector type required for the device panels. 
 Set the male/female property for coupling with the device panels. 
 On the Cable Properties dialog box, under Cable class, select Conventional. 
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4. In the Instrument Index module, create instrument type profiles for multi-input plug-and-socket 
socket fieldbus instruments and instruments that feed into the multi- input instrument. 

 
 For each instrument type, on the Wiring and Control System tab, select the reference 

device panel and reference cable that you created for each type. 
 For the instrument type upon which you base the multi-input device panel, make sure that 

you select the Fieldbus I/O type on the Instrument Type Profile dialog box and that you 
associate enough function blocks for the inputs.  For details, see Define Foundation 
Fieldbus and Profibus Instrument Type Profiles (on page 176). 

5. In the Instrument Index module, create the following, based on the instrument types that you 
defined: 
 Create the instrument tags that feed into the multi-input instrument tag. 
 Create the multi-input instrument tag.  Make sure that on the New Tag Number dialog 

box, you select Fieldbus from the Tag class list. 
6. In the Domain Explorer, right click the multi-input device panel that was created, and on the 

shortcut menu, click Actions > Connection. 
7. In the Plug-and-Socket Connection window, do the following to connect the input device 

cables to the multi-input device panel. 
a. In the Domain Explorer, expand the device cables that feed into the multi- input device 

panel. 
b. Drag the appropriate cable connectors to the in-ports of the multi-input device. 

8. Do the following to route the multiplexed signal through a plug-and-socket junction box: 
a. In the Domain Explorer, right click the junction box, and on the shortcut menu, click 

Actions > Connection. 
b. In the Domain Explorer, expand the multi-input device cable. 
c. Drag the appropriate cable connector to the desired in-port of the junction box in the 

Plug-and-Socket Connection window. 
9. Do the following to associate the multi-input tag signal with the available function blocks in the 

target fieldbus segment: 
a. In the Wiring Module window, click Actions > Fieldbus Segment Manager. 
b. Drag the multi-input device tag from the Instruments pane to the target segment in the 

Fieldbus Segments folder of the Domain Explorer. 
c. In the Fieldbus Segments pane, right click the multi-input device tag, and on the shortcut 

menu, click Associate Multi-Input Device Tag. 
d. Drag each tag from the Connected tags available for association pane to the Function 

Block - Tag Association pane. 
e. Click Close. 

10. Do the following to assign the demultiplex signals to the segment I/O card: 
a. In the Domain Explorer, right-click the desired DCS, then on the shortcut menu click 

Actions > I/O Assignment. 
b. If the I/O Assignment dialog box opens, select Segment I/O assignment, and click OK. 
c. Select the desired segment in the Segment list pane of the Segment I/O Assignment 

window. 
d. In the I/O card details pane, select the channel to which you want to assign the 

demultiplex signals. 
e. Click Actions > Assign to a Channel. 
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Create a Multi-Input Instrument with Terminal 
Connections for a Fieldbus Segment 

1. In the Reference Explorer, create reference panels that feed into the multi-input device 
panel. 

2. In the Reference Explorer, create a reference multi-input device panel with terminal 
connections. 

3. In the Reference Explorer, create reference spur cables. 
 In the Cable Properties dialog box, under Cable class, select Conventional. 

4. In the Instrument Index module, create instrument type profiles for multi-input plug-and-socket 
socket fieldbus instruments and instruments that feed into the multi-input instrument. 

 
 For each instrument type, on the Wiring and Control System tab, select the reference 

device panel and reference cable that you created for each type. 
 For the instrument type upon which you base the multi-input device panel, make sure that 

you select the Fieldbus I/O type in the Instrument Type Profile dialog box and that you 
associate enough function blocks for the inputs.  For details, see Define Foundation 
Fieldbus and Profibus Instrument Type Profiles (on page 176). 

5. In the Instrument Index module, create the following, based on the instrument types that you 
defined: 
 Create the instrument tags that feed into the multi-input instrument tag. 
 Create the multi-input instrument tag.  Make sure that in the New Tag Number dialog 

box, you select Fieldbus from the Tag class list. 
6. In the Domain Explorer, right click the multi-input device panel that was created, and on the 

shortcut menu, click Actions > Connection. 
7. In the Plug-and-Socket Connection window, connect the input device cables to the 

multi-input device panel. 
8. Do the following to route the multiplexed signal through a junction box: 

a. In the Domain Explorer, right click the junction box, and on the shortcut menu, click 
Actions > Connection. 

b. In the Connection window, connect the multi-input device cable to the junction box. 
9. Do the following to associate the multi-input tag signal with the available function blocks in the 

target fieldbus segment: 
a. In the Wiring Module window, click Actions > Fieldbus Tag Numbers Browser. 
b. Drag the multi-input device tag from the Instruments pane to the target segment in the 

Fieldbus Segments folder of the Domain Explorer. 
c. In the Fieldbus Segments pane, right click the multi-input device tag, and on the shortcut 

menu, click Associate Multi-Input Device Tag. 
d. Drag each tag from the Connected tags available for association pane to the Function 

Block - Tag Association pane. 
e. Click Close. 

10. Do the following to assign the demultiplex signals to the segment I/O card: 
a. In the Domain Explorer, right-click the desired DCS, then on the shortcut menu click 

Actions > I/O Assignment. 
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b. If the I/O Assignment dialog box opens, select Segment I/O assignment, and click OK. 
c. In the Segment I/O Assignment window, in the Segment list pane, select the desired 

segment. 
d. In the I/O card details pane, select the channel to which you want to assign the 

demultiplex signals. 
e. Click Actions > Assign to a Channel. 

 
 

Create a Multi-Input Instrument with Plug-and-Socket 
Connections for a Serial Loop Interface 

1. In the Reference Explorer, create reference panels that feed into the multi-input device 
panel. 

2. In the Reference Explorer, create a reference multi-input device panel with plug- and-socket 
connections. 

3. In the Reference Explorer, create reference spur cables. 

 
 For both types, in the Cable Properties dialog box, under Cable class, select 

Conventional. 
 Use the same connector type required for the device panels. 
 Set the male/female property for coupling with the device panels. 
 For the instrument type that you will use with the multi-input device panel, create one 

connector only (for the device panel end).  Leave the second end without a connector, for 
terminal connection to the DCS I/O card. 

4. In the Instrument Index module, create instrument type profiles for instruments with 
plug-and-socket multi-input serial interface and instruments that feed into the multi- input 
instrument. 

 
 For each instrument type, on the Wiring and Control System tab, select the reference 

device panel and reference cable that you created for each type. 
 For the instrument type upon which you base the multi-input device panel, make sure that 

you select the Serial Interface I/O type in the Instrument Type Profile dialog box. 
5. In the Instrument Index module, create the following, based on the instrument types that you 

defined: 
 Create the instrument tags that feed into the multi-input instrument tag. 
 Create the multi-input instrument tag.  Make sure that in the New Tag Number dialog 

box, you select Fieldbus from the Tag class list. 
6. In the Domain Explorer, right click the multi-input device panel that was created, and on the 

shortcut menu, click Actions > Connection. 
7. In the Plug-and-Socket Connection window, do the following to connect the input device 

cables to the multi-input device panel. 
8. In the Domain Explorer, expand the device cables that feed into the multi- input device panel. 
9. Drag the appropriate cable connectors to the in-ports of the multi-input device. 
10. In the Domain Explorer, right- click the DCS panel to which you connect the output of the 

multi-input device panel, then on the shortcut menu, click Actions > Connection. 
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 Make sure that the I/O type of the I/O card to which you connect the multi-input device is 
SI. 

11. In the Connection window, connect the output cable of the multi-input device panel to the 
DCS. 

12. To view the I/O assignment of the signals, click Actions > I/O Assignment. 
 
 

Create a Multi-Input Instrument with Terminal 
Connections for a Serial Loop Interface 

1. In the Reference Explorer, create reference panels that feed into the multi-input device 
panel. 

2. In the Reference Explorer, create a reference multi-input device panel with terminal 
connections. 

3. In the Reference Explorer, create reference spur cables. 

 
 For both types, in the Cable Properties dialog box, under Cable class, select 

Conventional. 
 Do not create connectors for this reference cable. 

4. In the Instrument Index module, create instrument type profiles for multi-input instruments 
with terminal connections for a serial interface and instruments that feed into the multi-input 
instrument. 

 
 For each instrument type, on the Wiring and Control System tab, select the reference 

device panel and reference cable that you created for each type. 
 For the instrument type upon which you base the multi-input device panel, make sure that 

you select the Serial Interface I/O type in the Instrument Type Profile dialog box. 
5. In the Instrument Index module, create the following, based on the instrument types that you 

defined: 
 Create the instrument tags that feed into the multi-input instrument. 
 Create the multi-input instrument tag.  Make sure that in the New Tag Number dialog 

box, you select Fieldbus from the Tag class list. 
6. In the Domain Explorer, right click the multi-input device panel that was created, and on the 

shortcut menu, click Actions > Connection. 
7. In the Plug-and-Socket Connection window, do the following to connect the input device 

cables to the multi-input device panel. 
8. In the Domain Explorer, expand the device cables that feed into the multi-input device panel. 
9. Drag the appropriate cable connectors to the in-ports of the multi-input device. 
10. In the Domain Explorer, right-click the DCS panel to which you connect the output of the 

multi-input device panel, then on the shortcut menu, click Actions > Connection. 
 Make sure that the I/O type of the I/O card to which you connect the multi-input device is 

SI. 
11. In the Connection window, connect the output cable of the multi-input device panel to the 

DCS. 
12. To view the I/O assignment of the signals, click Actions > I/O Assignment. 
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S E C T I O N  3 2  

SmartPlant Instrumentation provides the ability to efficiently define and manage most commonly 
used telecommunication equipment. 
Here are a few examples of telecom equipment that you can create and manage: 
 Field equipment (speakers, intercoms, telephones, and so forth) 
 Public announcement (PA) equipment and amplifiers 
 Switchboards 
 Network equipment (hubs, switches, routers, and so forth) 
 Miscellaneous equipment (video and entertainment equipment) 

The software provides the means to define all the connections and the internal equipment 
configuration.  Furthermore, you can define and create the logical structures (for example, 
channels, port, and so forth) as well the physical structures, such as racks and cards. 
You can generate appropriate reports, such as telecommunication field lists, communication line 
diagrams (telecom point-to-point diagrams), network class diagrams (network area maps), and so 
forth. 

 
 
 
 

Flow of Activities for Telecom Design 
The following is a suggested flow of activities that will help you design the telecommunication 
system in your <plant>. 
The first step in your telecom design is to create the reference telecommunication equipment. 
Then, in the Instrument Index module, you define telecommunication device types (similar to 
instrument types for non-telecommunication devices).  You can also define telecom line numbers, 
field equipment (that is, equipment classification), and signal levels.  Now you can create your 
telecom tag numbers based on the telecom device type that you defined.  At this stage, you can 
generate various Instrument Index reports as needed. 
Once all the supporting table data is entered and all the telecom tags are created, you start 
creating your telecom panels and telecom equipment based on the reference equipment and 
reference panels you created previously.  Make the required connections among the your 
telecom equipment.  You can then generate telecom wiring reports as needed. 
We recommend the following flow of activities: 
1. In the Reference Explorer, create the following reference equipment: 

a. Telecom cables with appropriate configurations 
b. Telecom device panels 
c. Telecom equipment panels with or without their internal equipment 
d. Telecom equipment items such as amplifiers, switchboards, hubs, and so forth that serve 

as the internal equipment of telecom panels 
2. Start the Instrument Index module and define the following: 

Telecom Design 
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a. A telecom device panel type and device type profile defaults for telecom tags 
b. Communication line numbers 
c. Field equipment classification 
d. Signal levels 
e. Generate Instrument Index telecom reports if needed (telecom devices and various 

telecom table reports). 
3. In the Domain Explorer, do the following: 

a. Create the telecom tag numbers that you require. 
b. Create plant equipment panels with the necessary hardware shelves or racks. 
c. Create the telecom equipment items that you require by copying the reference items. 
d. Define network classes. 
e. Make all necessary connections. 
f. Generate the Telecom reports in the Wiring module. 

See Also 
Working with Old Equipment (on page 232) 
 

Arrangement of Telecom Items in the Domain Explorer 
You use the Domain Explorer to access telecom panels and equipment.  Typical telecom 
equipment, that is, telecom reference equipment, is organized in the Reference Explorer. 
Telecom equipment is organized in several different folders in the Domain Explorer: 

 
 Telecom Panels — contains telecom panels arranged according to their types: 
 Field Devices — holds plug-and-socket boxes and conventional field device panels. 
 Junction Boxes 
 Splice Panels 
 Patch Panels 
 Distribution Frames 
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 Equipment Cabinets — holds PA cabinets, PABX cabinets, hub cabinets, intercom cabinets, 
and miscellaneous cabinets for video and entertainment systems) 

 Old Equipment — contains telecom panels created prior to Version 7.  Note that you cannot 
create additional panels in this folder, but you can add new child items, modify the properties 
of the existing items, and delete the old equipment items, as you require. 

 Panels by Manufacturer — arranges telecom panels according to their manufacturers. 
 Telecom Equipment — lists telecom panels and equipment classified according to their 

types.  Note that the items in this folder are for viewing only. 
In the Reference Explorer, reference telecom items reside under Wiring Equipment. 
 

Supporting Tables for Telecom 
The following table lists all the available Telecom supporting tables and the description of their 

functions.  You can access these supporting tables by clicking  next to a list arrow or by 
clicking Tables > Telecom and then an appropriate command in the Instrument Index and Wiring 
modules. 

Supporting Table Description 

Telecom Device Types Allows you to create and manage telecom device types.  You define the 
required telecom device type profile for your telecom tag numbers so that 
new tags that you create can acquire the necessary 
properties.  SmartPlant Instrumentation provides a number of 
predefined telecom device types, such as AL (alarm), CAM (camera), 
and so forth.  You can add new telecom device types and modify the 
shipped ones as desired.  You can also delete a telecom device type 
that is not in use, but the software does not let you delete a telecom 
device type that you already used to create a tag number. 

Telecom Line Numbers Allows you to maintain the contents of the Telecom line list when 
creating a telecom field device in the Plug-and-Socket Box wizard and 
the Line number list on the Tag Number Properties dialog box. 

Telecom Field 
Equipment 

Allows you to maintain the contents of the Field equipment select list on 
the Tag Number Properties dialog box. 

Telecom Signal Levels Allows you to maintain the contents of the Signal level select list on the 
Tag Number Properties dialog box. 

Panel Sub-Systems Allows you to maintain the contents of the Sub-system select list on the 
Equipment Panel Properties dialog box. 

Telephone Numbers Allows you to define new telephone numbers that you can associate with 
existing switch channels in PABX cabinets. 

Telephone Number 
Statuses 

Allows you to manage the contents of the Telephone number status 
select list on the Telephone Number Properties dialog box. 

Telephone Number 
Usages 

Allows you to manage the contents of the Telephone number usages 
select list on the Telephone Number Properties dialog box. 

Intercom Numbers Allows you to define new intercom numbers that you can later associate 
with amplifiers. 
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Supporting Table Description 

PA Zones Allows you to manage the PA zone definitions which are available for 
selection on the Category Properties tab of the Wiring Equipment 
Properties (Amplifier) dialog box. 

Alarm Zones Allows you to manage the alarm zone definitions which are available for 
selection on the Category Properties tab of the Wiring Equipment 
Properties (Amplifier) dialog box. 

PABX Categories Allows you to manage the contents of the PABX categories select list on 
the PABX Cabinet Properties dialog box. 

 For the various actions that you can perform with supporting tables, see Supporting Tables. 
 

Working with Old Equipment 
SmartPlant Instrumentation partially supports telecom panels created prior to Version 7.  These 
panels and their child items are organized in the Old Equipment folder. 
Note that you cannot create additional panels in this folder, but you can add new child items, 
modify the properties of the existing items, and delete the old equipment items, as you require. 

See Also 
Arrangement of Telecom Items in the Domain Explorer (on page 230) 
Flow of Activities for Telecom Design (on page 229) 
 



 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 233 
 

S E C T I O N  3 3  

Telecom Devices and Cables 
This section describes the creation and management of telecom devices and cables. 

In This Section 
Set Telecom Device Type Profile Defaults .................................... 233 
Create a Telecom Field Tag .......................................................... 234 
Duplicate a Telecom Field Tag ...................................................... 234 
Create a Telecom Conventional Field Device ............................... 235 
Create a Telecom Plug-and-Socket Field Device ......................... 236 
Create a Telecom Cable ................................................................ 236 
 
 

Set Telecom Device Type Profile Defaults 
You define a telecom device type profile for your telecom devices so that new telecom tag 
numbers that you create acquire the necessary properties.  SmartPlant Instrumentation provides 
a number of predefined telecom device types, such as AL (alarm), CAM (camera), and so 
forth.  You can add new telecom device types and modify the shipped ones as required.  You can 
delete a telecom device type that is not in use.  However, SmartPlant Instrumentation does not let 
you delete a telecom device type that you already used to create a tag number. 
SmartPlant Instrumentation uses standard function identifier acronyms to identify telecom device 
types.  If some acronyms are not unique and are used for more than one device type, the Select 
Telecom Type dialog box opens where you select the appropriate device type. 
After defining a device type, you set device type profile defaults for new telecom tag numbers.  As 
result, SmartPlant Instrumentation will create your new tag numbers with certain predefined 
properties based on the telecom device type you select for the new tag number.  You set profiles 
for every telecom device type that you use. 
1. On the Instrument Index Module window menu bar, click Tables > Telecom > Telecom 

Device Types. 
2. On the Telecom Device Types dialog box, do one of the following: 

 Select an existing device type and click Profile. 
 Click New and define a device type that you need and then click Profile. 

3. On the Telecom Device Type Profile dialog box, define the general default settings for new 
telecom devices. 

4. Click the Wiring tab if you need to define wiring default settings. 
5. On the Wiring and Control System tab, select the Include wiring check box. 
6. To define new device tags as control-system-enabled, select the Control system check 

box.  This enables the corresponding tag numbers for tag assignment. 
7. To enable automated creation of coupled control system tags, select Automatic CS tags. 
8. From the Reference device panel list, select an appropriate reference panel for this 

instrument type.  These are device panels that were created in Reference Explorer. 
9. If your reference device panel settings enable the Conventional connections group box, do 

one of the following for each connection that you need for the current instrument type: 
 Click New, to add a connection. 
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 Click Properties, to edit the properties of an existing convention, and on the 
Conventional Connection Properties dialog box, define the settings that you require, 
and click OK. 

10. If your reference device panel settings enable the Plug-and-socket connections group box, 
do one of the following for each connection that you need for the current instrument type: 
 Click New, to add a connection. 
 Click Properties, to edit the properties of an existing convention, and on the 

Plug-and-Socket Connection Properties dialog box, define the settings that you 
require, and click OK. 

 

Create a Telecom Field Tag 
This procedure explains how to create new telecom tag numbers.  Note that the new tag numbers 
will be based on the telecom profile default that you defined. 
1. Do one of the following: 

 In the Domain Explorer, right-click the Instruments folder and then click New. 
 On the Instrument Index Module window menu bar, click Edit > Tag Numbers > New 

Tag Number. 

 On the module toolbar, click New Tag . 
2. On the New Tag Number dialog box, from the Tag class list, select Telecom. 
3. Under Tag number, type the name of the new tag number.  For details on how to name new 

tag numbers, see Instrument Tag Naming Convention. 
 If more than one function identifier exists for the current telecom type acronym, select an 

appropriate telecom device type on the Select Telecom Type dialog box and then click OK. 
4. On the New Tag Number dialog box, click OK. 
5. On the Select Instrument Type dialog box, select the instrument type you want to associate 

with the current telecom instrument, and then, click OK. 
6. On the Tag Number Properties dialog box, enter appropriate values on the General tab. 
7. Click the Telecom tab and enter your values as needed. 
8. If the current field tag requires power supply definitions, click the Power Supply tab and enter 

your values as needed.  Make sure that you have selected the Requires power supply 
check box on the General tab. 

9. Click OK to accept all the values that you have entered and to create the field tag. 
 

Duplicate a Telecom Field Tag 
This procedure explains how to create a telecom field tag by duplicating the properties of an 
existing one.  You can then edit the new telecom field tag properties as required.  You can create 
the new duplicated telecom field tag in any <unit> of the current domain. 
1. In the Domain Explorer, double-click the Instruments folder to display the existing 

instruments. 
2. Right-click a telecom field tag and then click Duplicate. 
3. On the Duplicated Tag Number dialog box, under Tag number, type the name of the new 

tag number.  For details on how to name new tag numbers, see Instrument Tag Naming 
Convention. 

4. To create the new field tag in the another <unit> of the current domain, select the Create in 
another unit check box and do the following: 
a. On the Open dialog box, select the target <unit> for the new field tag. 
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b. Click OK. 
5. Click OK to duplicate the field tag and close the Duplicated Tag Number dialog box. 

 In SmartPlant Instrumentation, a device field segment of a telecom field tag, for example, 
HO, is associated with an existing device type acronym and description, for example, HO 
HOODS, ACOUSTIC.  If you have changed the telecom device field segment in the telecom 
tag number and the system cannot recognize its association with the existing device field, you 
must select a telecom device field from the Select Telecom Device dialog box, and then click 
OK. 

6. On the Tag Number Properties dialog box, modify the values as you require and click OK. 
 

Create a Telecom Conventional Field Device 
This procedure explains how to create a conventional telecom field device.  Conventional field 
devices are not plug- and- socket boxes.  Conventional field devices are connected to regular 
terminals. 
You can create a new telecom field device panel in the Domain Explorer or the Reference 
Explorer.  If you are creating a panel that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference panels facilitate fast 
creation of plant panels by copying an existing panel configuration from the Reference Explorer 
to the Domain Explorer.  However, if you want to create a panel that does not have a 
configuration that you intend to use frequently, we recommend that you create this panel in the 
Domain Explorer and in the <unit> where it is to be physically located.  This is helpful when 
filtering the panels in the current <unit>. 
1. In the Domain Explorer, double-click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Field Devices folder and then on the shortcut menu click New > Field Device 

(Conventional). 
3. On the Device Panel Properties dialog box, on the General tab, under Panel, type a name 

of the new panel. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Mounting, type a value if needed. 
6. Select the Set as intrinsically safe check box if this field device panel has intrinsic safety 

certification. 
7. Click Revisions to manage the revisions of the new panel if needed. 
8. Click OK to accept your definitions for the new field device panel and close this dialog box. 
 



Telecom Design 
 

 
236 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

Create a Telecom Plug-and-Socket Field Device 
You use plug-and-socket boxes to connect telecom objects that have connectors.  The 
Plug-and-Socket Box Wizard enables you to create plug-and-socket boxes or reconfigure the 
existing ones. 
You can create a new telecom plug-and-socket box field device in the Domain Explorer or the 
Reference Explorer.  If you are creating a plug-and-socket box that is going to have a frequently 
used configuration, we recommend that you create it in the Reference Explorer.  Reference 
plug-and- socket boxes facilitate fast creation of plant plug-and-socket boxes by copying required 
configurations from the Reference Explorer to the Domain Explorer.  However, if you want to 
create a plug-and-socket box that does not have a configuration that you intend to use frequently, 
we recommend that you create it in the Domain Explorer and in the <unit> where it is to be 
physically located.  This is helpful when filtering the panels in the current <unit>. 
1. In the Domain Explorer, double- click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Field Devices folder and then on the shortcut menu click New > Field Device 

(Plug-and-Socket). 
3. In the Plug-and-Socket Box wizard, follow all the instructions carefully and click Next until 

you complete the wizard. 
 

 You can click  next to a list arrow to access the appropriate supporting table.  This allows 
you to add, edit, or delete select list items. 

 When defining plug-and-socket box connectors, under Connector type definition display, 
SmartPlant Instrumentation displays the connector sequence, the appropriate pin number, 
and the pin polarities according to the configuration of the connector than you selected. 

 

Create a Telecom Cable 
This procedure explains how to create a telecom cable.  When creating a cable, you select an 
existing cable configuration that includes a particular arrangement of cable sets (pairs, triads, and 
so forth within a cable) and wires to be built with the cable.  You can then add additional cable 
sets and wires to that cable if required. 
If you are creating a cable that is going to have a frequently used configuration, we recommend 
that you create it in the Reference Explorer.  Reference cables facilitate fast creation of plant 
cables by copying an existing cable configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a cable that does not have a configuration that you 
intend to use frequently, we recommend that you create this cable in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the cables in the 
current <unit>. 
1. In the Domain Explorer, right-click the Cables folder. 
2. On the shortcut menu click New > Cable. 
3. On the Cable Configuration dialog box, select an existing telecom cable configuration or 

create a new one.  For details, see Define a Cable Configuration (on page 26). 
4. Click Create. 
5. On the Cable Properties dialog box, under Cable, type a unique cable name. 
6. Under Cable class, select Telecom. 
7. Enter the rest of the cable properties as you require and click OK. 
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Telecom Panels 
This section deals with the creation and management of telecom panels. 

In This Section 
Create a Telecom Junction Box .................................................... 237 
Create a Splice Panel .................................................................... 238 
Create a Distribution Frame........................................................... 238 
Create a Patch Panel ..................................................................... 239 
 
 

Create a Telecom Junction Box 
This procedure explains how to create a telecom junction box. 
You can create a telecom panel in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the panels in the 
current <unit>. 
1. In the Domain Explorer, double-click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Junction Boxes folder and then on the shortcut menu click New > Telecom 

Junction Box. 
3. On the Telecom Junction Box Properties dialog box, on the General tab, under Panel, type 

the name of the new junction box. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the junction box dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this junction box. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this junction box has intrinsic safety 

certification. 
10. Click the Associate Symbols tab to associate a symbol with the current junction box.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new panel if needed. 
12. Click OK to accept your definitions for the new panel and close this dialog box. 
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Create a Splice Panel 
This procedure explains how to create a splice panel. 
You can create a telecom panel in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the panels in the 
current <unit>. 
1. In the Domain Explorer, double- click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Splice Panels folder and then on the shortcut menu click New > Splice. 
3. On the Splice Panel Properties dialog box, on the General tab, under Panel, type the name 

of the new panel. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the splice panel dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this splice. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this splice panel has intrinsic safety 

certification. 
10. Click the Associate Symbols tab to associate a symbol with the current splice.  The software 

will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new splice panel if needed. 
12. Click OK to accept your definitions for the new splice panel and close this dialog box. 
 

Create a Distribution Frame 
This procedure explains how to create a distribution frame. 
You can create a telecom panel in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the panels in the 
current <unit>. 
1. In the Domain Explorer, double- click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Distribution Frames folder and then on the shortcut menu click New > 

Distribution Frame. 
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3. On the Patch Panel Properties dialog box, on the General tab, under Panel, type the name 
of the new panel. 

4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the distribution frame dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this distribution frame. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this distribution frame has intrinsic safety 

certification. 
10. Click the Associate Symbols tab to associate a symbol with the current distribution 

frame.  The software will use this symbol when generating a report in the Enhanced Report 
Utility.  For details, see Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new panel if needed. 
12. Click OK to accept your definitions for the new distribution frame and close this dialog box. 
 

Create a Patch Panel 
This procedure explains how to create a patch panel. 
You can create a telecom panel in the Domain Explorer or the Reference Explorer.  If you are 
creating a panel that is going to have a frequently used configuration, we recommend that you 
create it in the Reference Explorer.  Reference panels facilitate fast creation of plant panels by 
copying an existing panel configuration from the Reference Explorer to the Domain 
Explorer.  However, if you want to create a panel that does not have a configuration that you 
intend to use frequently, we recommend that you create this panel in the Domain Explorer and in 
the <unit> where it is to be physically located.  This is helpful when filtering the panels in the 
current <unit>. 
1. In the Domain Explorer, double-click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Patch Panels folder and then on the shortcut menu click New > Patch Panel. 
3. On the Patch Panel Properties dialog box, on the General tab, under Panel, type the name 

of the new panel. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the patch panel dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this panel. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this panel has intrinsic safety certification. 
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10. Click the Associate Symbols tab to associate a symbol with the current panel.  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new panel if needed. 
12. Click OK to accept your definitions for the new panel and close this dialog box. 
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Equipment Cabinets and Equipment Items 
This section deals with the creation and management of equipment cabinets and equipment 
items. 

In This Section 
Create a PA Cabinet ...................................................................... 241 
Create an Amplifier ........................................................................ 242 
Add a Connector to an Amplifier .................................................... 243 
Add an Amplifier Channel to an Amplifier ...................................... 243 
Create a PABX Cabinet ................................................................. 244 
Create a PABX Rack ..................................................................... 245 
Create a Switch ............................................................................. 245 
Add a Connector to a Switch ......................................................... 246 
Add a Switch Port .......................................................................... 246 
Create a Switch Channel ............................................................... 247 
Create and Associate a Telephone Number ................................. 247 
Create an Unassociated Telephone Number ................................ 248 
Associate a Telephone Number with a Channel ........................... 248 
Create a Miscellaneous Cabinet .................................................... 248 
Create a Hub Cabinet .................................................................... 249 
Create Hub Equipment .................................................................. 250 
Create a Hub Connector ................................................................ 250 
Add a Port to a Hub ....................................................................... 251 
Create an Intercom Cabinet........................................................... 251 
Add Intercom Equipment ............................................................... 252 
Add an Intercom Connector ........................................................... 252 
 
 

Create a PA Cabinet 
This procedure explains how to create a PA cabinet. 
SmartPlant Instrumentation allows you to create a number of equipment cabinets that you can use 
for various purposes.  Once you have created the cabinets you require, you can create the 
appropriate equipment for each cabinet. 
You can create an equipment cabinet in the Domain Explorer or the Reference Explorer.  If you 
are creating an equipment cabinet that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference equipment cabinets 
facilitate fast creation of plant equipment cabinets by copying an existing cabinet configuration 
from the Reference Explorer to the Domain Explorer.  However, if you want to create an 
equipment cabinet that does not have a configuration that you intend to use frequently, we 
recommend that you create it in the Domain Explorer and in the <unit> where it is to be physically 
located.  This is helpful when filtering the panels in the current <unit>. 
1. In the Domain Explorer, double- click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Equipment Cabinets folder and then on the shortcut menu click New > PA 

Cabinet. 
3. On the PA Cabinet Properties dialog box, on the General tab, under Panel, type the name of 

the new cabinet. 
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4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the cabinet dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this cabinet. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this cabinet has intrinsic safety certification. 
10. Click the Associate Symbols tab to associate a symbol with the current cabinet.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new cabinet if needed. 
12. Click OK to accept your definitions for the new cabinet and close this dialog box. 
 

Create an Amplifier 
The software allows you to add amplifiers to an existing PA cabinet.  Once you have created an 
amplifier, you can create strips and connectors under this amplifier. 
SmartPlant Instrumentation allows you to create a number of equipment cabinets that you can use 
for various purposes.  Once you have created the cabinets you require, you can create the 
appropriate equipment for each cabinet. 
You can create an equipment cabinet in the Domain Explorer or the Reference Explorer.  If you 
are creating an equipment cabinet that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference equipment cabinets 
facilitate fast creation of plant equipment cabinets by copying an existing cabinet configuration 
from the Reference Explorer to the Domain Explorer.  However, if you want to create an 
equipment cabinet that does not have a configuration that you intend to use frequently, we 
recommend that you create it in the Domain Explorer and in the <unit> where it is to be physically 
located.  This is helpful when filtering the panels in the current <unit>. 
1. In the Domain Explorer, double-click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Expand the Equipment Cabinets folder and then right-click a PA cabinet to which you want 

to add an amplifier. 
3. On the shortcut menu click New > Amplifier. 
4. On the New Wiring Equipment dialog box, type a name for the new amplifier and click OK. 
5. On the Wiring Equipment Properties – Amplifier dialog box, on the General tab, under 

Name, accept or type a name of the new amplifier. 
6. Select the Double width check box if the amplifier occupies a double width slot or position. 
7. In the Details group box do the following as you require: 

a. Type a description. 
b. Select an amplifier type, model, and manufacturer.  If the required value is not available 

on the list, click  to define a new one. 
c. Enter a sequence if you need to define the amplifier sequence. 

8. Click the Category Properties tab. 
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9. Revise and modify category property values as you require.  Click the value for each property 
and modify it as needed. 

 Wiring equipment categories that are shipped with SmartPlant Instrumentation have 
predefined properties.  You cannot delete or rename any of these categories or their 
properties.  You can only edit their values.  However, you can add user-defined properties to 
any category which you can rename or delete as you wish.  For details, see Customize and 
Use Wiring Equipment Categories (on page 62). 

10. Click OK to accept your settings and close the dialog box. 
 

Add a Connector to an Amplifier 
This procedure explains how to add a connector to an amplifier.  In the SmartPlant 
Instrumentation Explorer, connectors are child items of amplifiers and switches. 
1. In the Domain Explorer, right-click an amplifier to which you want to add a connector. 

 You can create an amplifier only under a PA cabinet.  For more details, see Create an 
Amplifier (on page 242). 

2. On the shortcut menu click New > Connector. 
3. On the Connector Properties dialog box, type a connector name. 

4. Select a connector type.  Click  to add new connector types to this list. 
5. Define the connector as male or female. 
6. Select a panel side for the connector. 
7. Click OK. 
 

Add an Amplifier Channel to an Amplifier 
This procedure explains how to add an amplifier channel to an amplifier.  In the SmartPlant 
Instrumentation Explorer, amplifier channels are child items of amplifiers.  You can add as 
many amplifier channels to an amplifier as you need. 
1. In the Domain Explorer, right-click an amplifier to which you want to add an amplifier 

channel. 
 You can create an amplifier only under a PA cabinet.  For more details, see Create an 

Amplifier (on page 242). 
2. On the shortcut menu click New > Amplifier Channel. 
3. On the New Wiring Equipment dialog box, under Name, type an amplifier channel name and 

click OK. 
4. On the Wiring Equipment Properties dialog box, define the properties that you require. 
5. Click OK. 
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Create a PABX Cabinet 
This procedure explains how to create a PABX (private automatic branch exchange) 
cabinet.  Then, you can add PABX racks and terminal strips to the new PABX cabinet. 
SmartPlant Instrumentation allows you to create a number of equipment cabinets that you can use 
for various purposes.  Once you have created the cabinets you require, you can create the 
appropriate equipment for each cabinet. 
You can create an equipment cabinet in the Domain Explorer or the Reference Explorer.  If you 
are creating an equipment cabinet that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference equipment cabinets 
facilitate fast creation of plant equipment cabinets by copying an existing cabinet configuration 
from the Reference Explorer to the Domain Explorer.  However, if you want to create an 
equipment cabinet that does not have a configuration that you intend to use frequently, we 
recommend that you create it in the Domain Explorer and in the <unit> where it is to be physically 
located.  This is helpful when filtering the panels in the current <unit>. 
1. In the Domain Explorer, double- click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Equipment Cabinets folder and then on the shortcut menu click New > PABX 

Cabinet. 
3. On the PABX Cabinet Properties dialog box, on the General tab, under Panel, type the 

name of the new cabinet. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the cabinet dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this cabinet. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this cabinet has intrinsic safety certification. 
10. Click the Associate Symbols tab to associate a symbol with the current cabinet.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new cabinet if needed. 
12. Click OK to accept your definitions for the new cabinet and close this dialog box. 
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Create a PABX Rack 
This procedure explains how to create a rack in a PABX (private automatic branch exchange) 
cabinet. 
1. In the Domain Explorer, expand the Telecom Panels folder, which is located within the 

Panels by Category folder. 
2. Expand the Equipment Cabinets folder and then right-click a PABX cabinet where you want 

on create a rack. 
3. On the shortcut menu click New > PABX Rack. 
4. On the Rack Properties dialog box, on the General tab, under Rack, type the name of the 

new rack 
5. Type a brief description as you require. 
6. Enter the rack sequence in its parent cabinet. 
7. Click Slots to add slots to the current rack. 
8. On the Batch Slot Creation dialog box, type the number of new slots that you want to add in 

the new rack. 
9. Do the following to define the slot numbering: 

a. Type a prefix for the slot name. 
b. Enter a value in the Start from number and Increment by fields. 
c. Click OK to add the new slots and to return to the Rack Properties dialog box. 

 On the Rack Properties dialog box, the software now displays the number of slots that 
you added. 

10. Click the Associate Symbols tab to associate a symbol with the current rack.  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

11. Click OK to accept your definitions for the new rack and close this dialog box. 
 

Create a Switch 
The software allows you to create switches after adding a rack to a PABX cabinet.  Once you 
have created a switch, you can add a switch port and a connector. 
1. In the Domain Explorer, expand the Telecom Panels folder, which is located within the 

Panels by Category folder. 
2. Expand the Equipment Cabinets folder to display the existing PABX cabinets. 
3. Double-click a PABX cabinet to display the existing PABX racks. 
4. Right-click a PABX rack to which you want to add a new switch and then on the shortcut 

menu, click New > Switch. 
5. On the New Wiring Equipment dialog box, type a name for the new switch and click OK. 
6. On the Wiring Equipment Properties – Switch dialog box, on the General tab, under 

Name, accept or type a name of the new switch. 
7. Select the Double width check box if the amplifier occupies a double width slot or position. 
8. In the Details group box do the following as you require: 

a. Type a description. 
b. Select an amplifier type, model, and manufacturer.  If the required value is not available 

on the list, click  to define a new one. 
c. Enter a sequence if you need to define the switch sequence. 
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9. Click the Category Properties tab. 
10. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 Wiring equipment categories that are shipped with SmartPlant Instrumentation have 

predefined properties.  You cannot delete or rename any of these categories or their 
properties.  You can only edit their values.  However, you can add user-defined properties to 
any category which you can rename or delete as you wish.  For details, see Customize and 
Use Wiring Equipment Categories (on page 62). 

11. Click OK to accept your settings and close the dialog box. 
 

Add a Connector to a Switch 
This procedure explains how to add a connector to a switch.  In the SmartPlant Instrumentation 
Explorer, connectors are child items of switches and amplifiers. 
1. In the Domain Explorer, expand the Telecom Panels folder, which is located within the 

Panels by Category folder. 
2. Expand the Equipment Cabinets folder to display the existing PABX cabinets. 
3. Double-click a PABX cabinet and then a PABX rack to display the existing switches. 
4. Right-click a switch to which you want to add a new connector and then on the shortcut menu, 

click New > Connector. 
5. On the Connector Properties dialog box, type a connector name. 

6. Select a connector type.  Click  to add new connector types to this list. 
7. Define the connector as male or female. 
8. Select a panel side for the connector. 
9. Click OK. 
 

Add a Switch Port 
This procedure explains how to add a port to an existing switch. 
1. In the Domain Explorer, expand the Telecom Panels folder, which is located within the 

Panels by Category folder. 
2. Expand the Equipment Cabinets folder to display the existing PABX cabinets. 
3. Double-click a PABX cabinet and then a PABX rack to display the existing switches. 
4. Right-click a switch to which you want to add a new port and then on the shortcut menu, click 

New > Switch Port. 
5. On the General tab of the Switch Port Properties dialog box, type a name for the new switch 

port. 
6. Click the Associate Symbols tab to associate a symbol with the current switch port.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

7. Click OK. 
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Create a Switch Channel 
After creating a switch port, you can add a channel to this port. 
1. In the Domain Explorer, expand the Telecom Panels folder, which is located within the 

Panels by Category folder. 
2. Expand the Equipment Cabinets folder to display the existing PABX cabinets. 
3. Expand the hierarchy of a PABX cabinet and then double-click a PABX rack, switch, and then 

a switch port. 
4. Right-click a switch port to which you want to add a new channel and then on the shortcut 

menu, click New > Switch Channel. 
5. On the General tab of the Channel Properties dialog box, type a name for the new channel. 
6. Type a brief description if required. 
7. Enter an appropriate sequence of the current channel in its parent switch port. 
8. Click the Associate Symbols tab to associate a symbol with the current channel.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

9. Click OK to accept your settings and close this dialog box. 
 

Create and Associate a Telephone Number 
This option allows you to create a telephone number in a PABX cabinet and automatically 
associate it with a switch channel. 
1. In the Domain Explorer, expand the Telecom Panels folder, which is located within the 

Panels by Category folder. 
2. Expand the Equipment Cabinets folder to display the existing PABX cabinets. 
3. Expand the hierarchy of a PABX cabinet and then double-click a PABX rack, switch, and then 

a switch channel. 
4. Right-click a switch channel and create a terminal if there is there is no terminal under the 

current switch channel. 
5. Right-click the Telephone folder and then on the shortcut menu, click New > Telephone. 
6. On the Telephone Properties dialog box, type a telephone number and description as you 

require. 
7. Select an appropriate telephone state and usage.  If the values that you need do not exist on 

the Telephone state and Telephone usage lists, you can add them in the Telecom 
supporting tables in the Wiring module.  To do this, in the Wiring module, click Tables > 
Telecom > Telephone State or Telephone Usage. 

8. Click OK. 
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Create an Unassociated Telephone Number 
1. In the Wiring module, click Tables > Telecom Telephone Numbers. 
2. On the Telephone Numbers dialog box, click New. 
3. Type an appropriate number, description, telephone state, and telephone usage as you 

require. 
4. Click OK. 
 

Associate a Telephone Number with a Channel 
The software allows you to associate a telephone number with a switch channel.  Note that a 
switch channel can be associated with many telephone numbers. 
1. In the Domain Explorer, expand the hierarchy of a PABX panel to display the existing racks, 

switches, switch ports, and terminals. 
2. Right-click a channel, then on the shortcut menu, click Actions > Associate Telephone 

Numbers. 
3. On the Associate Telephone Numbers dialog box, select an available telephone number 

and click Associate. 
4. Click Close when done. 
 

Create a Miscellaneous Cabinet 
Miscellaneous cabinets are intended for video equipment, entertainment systems, and so 
forth.  After creating a miscellaneous cabinet, you can add a rack and a terminal strip. 
SmartPlant Instrumentation allows you to create a number of equipment cabinets that you can use 
for various purposes.  Once you have created the cabinets you require, you can create the 
appropriate equipment for each cabinet. 
You can create an equipment cabinet in the Domain Explorer or the Reference Explorer.  If you 
are creating an equipment cabinet that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference equipment cabinets 
facilitate fast creation of plant equipment cabinets by copying an existing cabinet configuration 
from the Reference Explorer to the Domain Explorer.  However, if you want to create an 
equipment cabinet that does not have a configuration that you intend to use frequently, we 
recommend that you create it in the Domain Explorer and in the <unit> where it is to be physically 
located.  This is helpful when filtering the panels in the current <unit>. 
1. In the Domain Explorer, double- click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Equipment Cabinets folder and then on the shortcut menu click New > 

Miscellaneous Cabinet. 
3. On the Miscellaneous Cabinet Properties dialog box, on the General tab, under Panel, 

type the name of the new cabinet. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the cabinet dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this cabinet. 
 Type zero if you want to have an unlimited number of racks. 
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7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this cabinet has intrinsic safety certification. 
10. Click the Associate Symbols tab to associate a symbol with the current cabinet.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new cabinet if needed. 
12. Click OK to accept your definitions for the new cabinet and close this dialog box. 
 

Create a Hub Cabinet 
This procedure explains how to create a hub cabinet.  After creating a hub cabinet, you can add 
hub equipment. 
SmartPlant Instrumentation allows you to create a number of equipment cabinets that you can use 
for various purposes.  Once you have created the cabinets you require, you can create the 
appropriate equipment for each cabinet. 
You can create an equipment cabinet in the Domain Explorer or the Reference Explorer.  If you 
are creating an equipment cabinet that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference equipment cabinets 
facilitate fast creation of plant equipment cabinets by copying an existing cabinet configuration 
from the Reference Explorer to the Domain Explorer.  However, if you want to create an 
equipment cabinet that does not have a configuration that you intend to use frequently, we 
recommend that you create it in the Domain Explorer and in the <unit> where it is to be physically 
located.  This is helpful when filtering the panels in the current <unit>. 
1. In the Domain Explorer, double- click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Equipment Cabinets folder and then on the shortcut menu click New > Hub 

Cabinet. 
3. On the Hub Cabinet Properties dialog box, on the General tab, under Panel, type the name 

of the new cabinet. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the cabinet dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this cabinet. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this cabinet has intrinsic safety certification. 
10. Click the Associate Symbols tab to associate a symbol with the current cabinet.  The 

software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new cabinet if needed. 
12. Click OK to accept your definitions for the new cabinet and close this dialog box. 
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Create Hub Equipment 
You can add hub equipment to a hub cabinet.  Hub equipment is a type of wiring 
equipment.  After creating hub equipment, you can add a port and a hub connector. 
1. In the Reference Explorer or Domain Explorer, expand the Telecom Panels folder. 
2. Expand the Equipment Cabinets folder to display the existing hub cabinets. 
3. Right-click a hub cabinet and then on the shortcut menu, click New > Hub Equipment. 
4. On the New Wiring Equipment dialog box, type a name for the new hub equipment and then 

click OK. 
5. On the General tab of the Wiring Equipment Properties – Hub dialog box, type the name of 

the new hub. 
6. Select the Double width check box if the hub occupies a double width slot or position. 
7. In the Details group box do the following as you require: 

a. Type a description. 
b. Select a hub type, model, and manufacturer.  If the required value is not available on the 

list, click  to define a new one. 
c. Enter a sequence if you need to define the hub sequence. 

8. Click the Category Properties tab. 
9. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 Wiring equipment categories that are shipped with SmartPlant Instrumentation have 

predefined properties.  You cannot delete or rename any of these categories or their 
properties.  You can only edit their values.  However, you can add user-defined properties to 
any category which you can rename or delete as you wish.  For details, see Customize and 
Use Wiring Equipment Categories (on page 62). 

10. Click OK to accept your settings and close the dialog box. 
 

Create a Hub Connector 
This procedure explains how to add a hub connector to a hub. 
1. In the Domain Explorer or Reference Explorer, expand a hub cabinet hierarchy to display 

the existing hub equipment and hub ports. 
2. Do one of the following: 

 Right-click a port to which you want to add a hub connector. 
 Right-click the Hub Connectors folder. 

3. On the shortcut menu, click New > Hub Connector. 
4. On the Connector Properties dialog box, type a connector name. 

5. Select a connector type.  Click  to add new connector types to this list. 
6. Set whether the connector is male or female. 
7. Select a panel side for the connector. 
8. Click OK. 
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Add a Port to a Hub 
This procedure explains how to add a port to a hub. 
1. In the Domain Explorer or Reference Explorer, navigate to a hub cabinet. 
2. Double-click a hub cabinet to display the existing hub equipment. 
3. Right-click a hub equipment item and then on the shortcut menu, click New > Port. 
4. On the General tab of the Port Properties dialog box, type a name for the new port. 
5. Type a brief description if necessary. 
6. Enter the port sequence in the hub if needed. 
7. Click the Associate Symbols tab to associate a symbol with the current port.  The software 

will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item (on page 23). 

8. Click OK. 
 

Create an Intercom Cabinet 
This procedure explains how to create an intercom cabinet.  After creating an intercom cabinet, 
you can add intercom equipment and a terminal strip. 
SmartPlant Instrumentation allows you to create a number of equipment cabinets that you can use 
for various purposes.  Once you have created the cabinets you require, you can create the 
appropriate equipment for each cabinet. 
You can create an equipment cabinet in the Domain Explorer or the Reference Explorer.  If you 
are creating an equipment cabinet that is going to have a frequently used configuration, we 
recommend that you create it in the Reference Explorer.  Reference equipment cabinets 
facilitate fast creation of plant equipment cabinets by copying an existing cabinet configuration 
from the Reference Explorer to the Domain Explorer.  However, if you want to create an 
equipment cabinet that does not have a configuration that you intend to use frequently, we 
recommend that you create it in the Domain Explorer and in the <unit> where it is to be physically 
located.  This is helpful when filtering the panels in the current <unit>. 
1. In the Domain Explorer, double-click the Panels by Category folder and expand the 

Telecom Panels folder. 
2. Right-click the Equipment Cabinets folder and then on the shortcut menu click New > 

Intercom Cabinet. 
3. On the Intercom Cabinet Properties dialog box, on the General tab, under Panel, type the 

name of the new cabinet. 
4. Select the required values from the Type, Manufacturer, Model, Area classification, and 

Location lists.  If the required value is not available, click  next to the relevant list arrow 
to open the appropriate supporting table. 

5. Under Dimensions, type a value for the cabinet dimensions if needed. 
6. Under Maximum number of racks, type a value to set the maximum number of racks that will 

be possible to create in this cabinet. 
 Type zero if you want to have an unlimited number of racks. 

7. Under Mounting, type a value if needed. 
8. Under Backplane, type a value if needed. 
9. Select the Set as intrinsically safe check box if this cabinet has intrinsic safety certification. 
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10. Click the Associate Symbols tab to associate a symbol with the current cabinet.  The 
software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item (on page 23). 

11. Click Revisions to manage the revisions of the new cabinet if needed. 
12. Click OK to accept your definitions for the new cabinet and close this dialog box. 
 

Add Intercom Equipment 
This procedure explains how to add intercom to an intercom cabinet. 
1. In the Reference Explorer or Domain Explorer, expand the Telecom Panels folder. 
2. Expand the Equipment Cabinets folder to display the existing intercom cabinets. 
3. Right-click an intercom cabinet and then on the shortcut menu, click New > Intercom 

Equipment. 
4. On the New Wiring Equipment dialog box, type a name for the new intercom equipment and 

then click OK. 
5. On the General tab of the Wiring Equipment Properties – Intercom dialog box, type the 

name of the new intercom. 
6. Select the Double width check box if the hub occupies a double width slot or position. 
7. In the Details group box do the following as you require: 

a. Type a description. 
b. Select a intercom type, model, and manufacturer.  If the required value is not available on 

the list, click  to define a new one. 
c. Enter a sequence if you need to define the intercom sequence in the cabinet. 

8. Click the Category Properties tab. 
9. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 Wiring equipment categories that are shipped with SmartPlant Instrumentation have 

predefined properties.  You cannot delete or rename any of these categories or their 
properties.  You can only edit their values.  However, you can add user-defined properties to 
any category which you can rename or delete as you wish.  For details, see Customize and 
Use Wiring Equipment Categories (on page 62). 

10. Click OK to accept your settings and close the dialog box. 
 

Add an Intercom Connector 
This procedure explains how to a connector to an intercom. 
1. In the Domain Explorer or Reference Explorer, expand a hub cabinet hierarchy to display 

the existing intercom equipment. 
2. Do one of the following: 
3. Right-click an intercom to which you want to add a connector. 
4. On the shortcut menu, click New > Connector. 
5. On the Connector Properties dialog box, type a connector name. 

6. Select a connector type.  Click  to add new connector types to this list. 
7. Set whether the connector is male or female. 
8. Select a panel side for the connector. 
9. Click OK. 
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You use the Loop Drawings module to retrieve predefined instrumentation data and generate 
appropriate loop drawings.  Each component in the loop drawing is assigned the necessary 
drawing blocks that represent its functionality and wiring routing.  The drawings display 
information about the loops and their instruments, wiring routing, line data, DCS data, document 
references, approvals, revisions, and general information. 
The Loop Drawings module generates loop drawings by means of a fast build process.  By 
configuring typical drawing blocks for key instrument types, the loop components can be 
automatically initialized with their corresponding graphical elements.  The Loop Drawings module 
enables you to create loop drawings that include data retrieved from the database and if required, 
from an external file. 
You can generate loop drawings in one of the following ways: 
 Using the Enhanced Report Utility. 
 Using an external CAD application (SmartPlant Instrumentation supports Intergraph 

SmartSketch, Autodesk AutoCAD, or Bentley Systems MicroStation for Windows). 
  SmartPlant Instrumentation and the CAD drawing programs required to work with 

SmartPlant Instrumentation, must be installed on the same machine. 
 
 

CAD Drawing Blocks in SmartPlant Instrumentation 
In SmartPlant Instrumentation, a block is considered as a template CAD drawing file (with or 
without macros) that is assigned to a loop or instrument.  The software uses blocks in CAD loop 
drawing generation.  You can use similar blocks to represent identical components in different 
drawing positions by defining several blocks that use the same drawing file. 
A block is a term that is used in SmartPlant Instrumentation.  Depending on the CAD application 
that you use, the following equivalent terms apply. 

SmartPlant 
Instrumentation Term 

SmartSketch AutoCAD MicroStation 

Block Symbol Drawing Cell 

Macro Text element Attribute element Tag 

There must be a correlation between the file formats supported by your CAD application and the 
file format in which you save a new drawing block.  Standard drawing blocks exist for each of the 
following CAD applications (shown with the appropriate file extension): 
 Intergraph SmartSketch — .sym 
 AutoCAD — .dwg 
 MicroStation — .cel 

Loop Drawings Module 
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SmartPlant Instrumentation is shipped with several examples of blocks that are used in the 
demonstration database (IN_DEMO.DB).  The wiring methodology behind these blocks includes 
the use of an overall shield with single cables and multiple pair cables.  After the installation, 
these blocks can be found in the path <SmartPlant Instrumentation home 
folder>\CAD\Blocks.  For details, see Shipped Block Files (on page 257). 

Block Organization and Management 
SmartPlant Instrumentation requires that each drawing block belongs to a particular block 
type.  Therefore, after you define block files in your CAD application, you need to assign these 
blocks to the appropriate block types in SmartPlant Instrumentation. 
You define and manage blocks in the Drawing Block Types folder of the Domain 
Explorer.  After you define blocks and organize them according to their block types, you can 
perform block association procedures, which depend on the block type of the source 
block.  Blocks that are already associated with specific loops or instruments appear in the Loops 
folder of the Domain Explorer.  For details of the available block types, see Block Types (on 
page 254). 

Block Assignment Methods 
After defining the blocks and their macros, it is necessary to assign your instrument tag numbers 
to the drawing blocks that represent the instruments graphically.  The following is the description 
of the available assignment methods: 
 Automatic block assignment method — In the Loops folder of the Domain Explorer, these 

blocks are shown under instruments as . 
Also, you must use this method if you want to assign user-defined general blocks to your loop 
drawings.  After assigning such a block to an instrument type, the software displays this block 
in every loop drawing whose source loop contains an instrument with the same instrument 
type.  The assigned user-defined general blocks do not appear in the Domain Explorer. 

 Manual block assignment method — In the Loops folder of the Domain Explorer, these 
blocks are shown under instruments as . In the Domain Explorer, it is possible to change 
the block assignment method from automatic to manual. 

 

Block Types 
SmartPlant Instrumentation requires each drawing block to belong to a specific block type.  This 
is because blocks in SmartPlant Instrumentation function according to the block type they are 
assigned to.  For example, if a block belongs to the Loop Block type, you can only assign this 
block to a loop; if a block belongs to an Instrument Block type, you can only assign this block to a 
specific instrument of the loop but not to the loop itself. 
You organize blocks according to block types in the Drawing Block Types folder of the Domain 
Explorer.  At this level, the software displays all the block types that exist in the current domain 
and allows you to add general and instrument block types and manage block type properties.  All 
block types that appear in the current <plant> also appear in all <plants> that exist in the domain. 
The following drawing block types are available in the Drawing Block Types folder of the 
Domain Explorer: 
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 Loop Block ( ) — A shipped block type that allows you to define, edit or duplicate a block 
that you can associate with a loop number.  The Loop Block folder is the only folder of the 
Domain Explorer where you can define and manage loop blocks.  Loop blocks are shown as 

.  After defining a loop block, you can assign it directly to a loop number in the Loops folder 
of the Domain Explorer.  When generating a CAD loop drawing using a loop block, the 
generation is based on a single template block file that can include references to all tags in the 
loop.  For more details, see Loop Blocks (on page 256). 

 Instrument Block ( ) — A user-defined block type that allows you to define, edit, or 
duplicate a block that you can associate with an instrument.  Instrument blocks are shown as 

. Blocks that you assign to instruments appear at the instrument level in the Loops folder of 
the Domain Explorer.  When generating a CAD loop drawing using instrument blocks, the 
generation is based on template CAD blocks that contain macros specific to each instrument 
tag of the loop.  This requires assignment of individual drawing block files to instruments 
whose data you want to display in the loop drawing (one block file per instrument).  In the 
generated drawing, the software displays the instrument blocks according to their insertion 
points that you defined.  The macros the blocks contain retrieve data from SmartPlant 
Instrumentation for all the associated instruments.  You can create as many instrument block 
types as you require.  After defining instrument blocks, you can choose a block assignment 
method to associate your blocks with specific instruments; therefore, you must define at least 
one instrument block type before you can add a new block (apart from the default general 
block types and the Loop Block type).  

 Border ( ) — A shipped block type that allows you to define a border block for use in all loop 
drawings or hook-up drawings.  You can also modify properties of an existing loop or hook-up 
drawing border block.  Border blocks are shown as .  After defining border blocks, you can 
assign one border block to all loop drawings or hook-up drawings using the Default General 
Blocks dialog box. 

 Logo ( ) — A shipped block type that allows you to define a logo block for use in all loop 
drawings or hook-up drawings.  You can also modify properties of an existing loop or hook-up 
drawing logo block.  Logo blocks are shown as .  After defining logo blocks, you can 
assign one logo block to all loop drawings or hook-up drawings using the Default General 
Blocks dialog box. 

 User-Defined General Block ( ) — A user-defined block type that allows you to define, 
edit, or duplicate a block that you want to use in all loop drawings in addition to the border and 
logo blocks.  This block does not contain any macros.  User- defined general blocks are 
shown as .  You can assign any number of user-defined general blocks to loop instruments 
using the Automatic block assignment method.  The software automatically displays all the 
assigned user-defined general blocks in every CAD loop drawing that you generate, 
regardless of the CAD application you use.  User-defined general blocks cannot be assigned 
to hook-up drawings. 

 
 The software always places in the drawing one block belonging to the Logo type and one 

block belonging to the Border type regardless of whether you add user-defined general blocks 
in the drawing.  For a complete list of the shipped logo and border blocks, see Shipped Block 
Files (on page 257). 

 You can specify the coordinates of user-defined general blocks to prevent overlapping with 
other drawing elements, such as the border or the logo. 

 In hook-up drawings, you can only use the blocks created in the default Border and Logo 
general block types. 
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Loop Blocks 
A loop block is a CAD drawing block with macros that retrieve data from all instrument tags of a 
specific loop.  Since a loop block is a single template block file, you do not need to specify 
insertion points for this block.  You need to create loop blocks in your CAD application and modify 
the macros as appropriate.  Then, in SmartPlant Instrumentation, in the Drawing Block Types > 
Loop Block folder of the Domain Explorer, you define loop blocks you want to make available for 
association with loop numbers.  After that, you can associate the loop blocks with loop numbers 
displayed in the Loops folder of the Domain Explorer. 
You define loop blocks and manage their properties in the same way as you do with instrument 
blocks.  You can only assign one loop block to a particular loop.  However, in contrast to 
instrument blocks, you cannot assign the same loop block to more than one loop.  Therefore, 
when duplicating a loop that already has a loop block assigned, the software ignores the loop 
block for the duplicated loop. 
In loop drawing generation, the loop block has the highest generation priority.  The software 
ignores the instrument blocks when generating a loop drawing if the source loop has a loop block 
and also blocks assigned to the loop instruments via the instrument type using the automatic block 
assignment method. 
The loop block macro structure is MACRO.<macro function>.<instrument type>.<tag suffix>, 
where each segment of the macro structure is described as follows: 
 MACRO — This segment denotes an existing macro used by SmartPlant Instrumentation in 

CAD loop drawing generation.  A loop block macro definition can be either MACRO, 
MACRO.X, or MACRO.X.Y if the macro requires additional parameters. 

 Macro function — This is an optional segment displaying the macro function name, for 
example, TRIM. 

 Instrument type — This is a required segment that denotes the instrument type abbreviation 
of a loop tag, for example, FT, FE, and so forth. 

 Tag suffix — This segment denotes the suffix identification defined in the instrument naming 
convention.  This segment is only required if a loop includes more than one instrument with 
the same instrument type. 

The following are examples of loop block macros: 
 TAG_MOD_DESC.FE — The instrument model description for the flow element in the loop. 
 TERM_NUM.1.3.FT.B — The terminal name of the first termination of the wire level 3 for the 

second (Suffix B) flow transmitter in the loop. 
 TAG_NUM.s54.LSHH — Four characters of the level switch name starting from the fifth 

character, as defined in the s54 macro function.  For example, if the tag number is 
101-LSHH   -100, the macro retrieves LSHH. 
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Shipped Block Files 
Border and Logo Block Files 
The files in the list are the predefined drawing blocks that you can use to represent the border / title 
(one of which should be defined as the default border) and the logo (one of which should be 
defined as the default logo). 

File Name Description Available Formats 

BORD_DEF Border and title. .dwg, .sym 

BORD_DEM Border and title. .dwg 

BORDER Border and title. .cel 

BRDDEM Border and title. .cel 

TITLE Border and title. .cel 

INGR Intergraph logo. .cel 

LOGO_DEF Intergraph logo. .dwg, .sym 

LOGO_DEM Intergraph logo. .dwg, .sym 

LOGO_IN Intergraph logo. .dwg 

LOGOIG Intergraph logo. .cel 
DCS and Control Block Files 

File Name Description Available 
Formats 

CTRL1 Analog input control. .dwg 

CTRL2 Analog input and analog output 
control.  

.dwg 

Field Device Block Files 

File Name Description Available 
Formats 

CV2 Control valve. .dwg, .sym 

ORIF_1 Orifice on a steam traced line. .dwg 

ORIF_2 Orifice. .dwg 

PLOC_IND.DWG Parallel connection of an 
indicator. 

.dwg 

PT_1 Pressure element. .dwg 

SLOC_IND.DWG Series connection of an 
indicator. 

.dwg 

TC_1 Skin temperature controller 
(welded). 

.dwg 

TC_2 Temperature element. .dwg 
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File Name Description Available 
Formats 

TE Temperature element wired to 
a temperature transmitter. 

.dwg 

Wiring Routing Block Files 

File Name Description Available 
Formats 

AIT_ROUT Typical analog input routing; field 
device, junction box, marshaling 
rack, and an analog input I/O card.

.dwg 

AOT_ROUT Typical analog output routing; I/P 
transducer, junction box, 
marshaling rack, and an analog 
output I/O card. 

.dwg 

PAIT1 Use for parallel indicator and 
transmitter. 

.dwg 

SAIT Use for serial indicator and 
transmitter. 

.dwg 

 
 

Managing CAD Drawing Blocks Common Tasks 
The following tasks are used when you create and manage CAD drawing blocks. 

Add a Block Type 
Use this procedure to add a new instrument block type or a user-defined general block type in the 
Drawing Block Types folder of the Domain Explorer. 
For more information, see Add a Block Type (on page 259). 

Add a Block to a Block Type 
Use this procedure to add a block to a block type. 
For more information, see Add a Block to a Block Type (on page 259). 

View a Drawing Block in a CAD Application 
Use this procedure to display a block it in your CAD application — SmartSketch, MicroStation or 
AutoCAD — depending on the settings you made on the Preferences dialog box. 
For more information, see View a Drawing Block in a CAD Application (on page 260). 

Define Insertion Points for Blocks 
In SmartSketch, AutoCAD or MicroStation, you can define the insertion point for individual blocks 
relative to the drawing origin (lower left corner).  This enables you to use the same block in 
different positions in different loop drawings. 
For more information, see Define Insertion Points for Blocks (on page 260). 
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Copy Blocks to Another <Plant> 
Use this procedure to copy one or more blocks that you select in the Drawing Block Types folder 
of the Domain Explorer to another <plant> that exists in the current domain. 
For more information, see Copy Blocks to Another <Plant> (on page 261). 
 
 

Add a Block Type 
1. In the Domain Explorer, right- click the Drawing Block Types folder and, on the shortcut 

menu, click New. 
2. Do one of the following: 

 Click General Block Type to create a user-define general block type. 
 Click Instrument Block Type to create a block type whose blocks you can then assign to 

instrument tags in the Loops folder of the Domain Explorer. 
3. In the BlockType Properties dialog box, type the new block name and description in the 

appropriate boxes. 

 
 Block types are defined at the domain level; therefore, a block type that you add in the current 

<plant> automatically appears in all the <plants> that exist in the current domain. 
 You cannot add a new block type for loop blocks. 

 
 

Add a Block to a Block Type 
1. In the Domain Explorer, double-click the Drawing Block Types folder to expand its 

hierarchy. 
2. Right-click a block type and on the shortcut menu click New > Block. 
3. On the Block Properties dialog box, enter information as follows: 

a. In the Block field, enter the name to be used for the block by SmartPlant Instrumentation. 
b. In the Description field, type in a description for the block. 
c. Under Block type, select a block type from the list. 

4. Under Drawing block file, navigate to the block source file by clicking Browse. 
5. Specify the file path. 
6. Under Origin, enter the required X and Y parameters to position the new block on the 

drawing. 

 
 You can enter decimal numbers as well as whole numbers. 
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 Blocks that you add under the Border, Logo, or a user-defined general block type appear on 
the Default General Blocks dialog box, which you open from the Actions menu of the Loop 
Drawings Module window menu bar.  In the Domain Explorer, general blocks only appear 
in the Drawing Block Types folder and are shown as . 

 Loop blocks that you add become available for association with loops in the Loops folder of 
the Domain Explorer.  These blocks are shown as . 

 Instrument blocks that you add become available for association with instrument tag numbers 
in the Loops folder of the Domain Explorer.  In the Drawing Block Types folder, instrument 
blocks are shown as .  In the Loops folder, blocks assigned to instruments using the 
automatic block assignment method are shown as  and blocks assigned to instruments 
using the manual block assignment method are shown as . 

  
 

View a Drawing Block in a CAD Application 
 The difference between viewing and generating is that viewing only shows the code fields 

of blocks and macros while generating actually retrieves the data and displays it on the drawing 
layer. 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the tree view pane, expand the loop hierarchy to the tag level and select a tag. 
3. In the Items pane, right-click a block. 
4. On the shortcut menu, click Reports > View Block in CAD Application. 
 
 

Define Insertion Points for Blocks 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. Expand the loop-tag-block hierarchy and then do one of the following: 

 In the tree view pane, right-click a desired block. 
 In the Items pane, select and right-click several blocks. 

 You can only define insertion points for blocks shown as .  These blocks are 
assigned to instruments using the manual block assignment method.  If your block selection 
in the Items pane includes automatically assigned blocks, (shown as ), you need to 
redefine your selection. 

3. On the shortcut menu, click Actions > Define Block Origin. 
4. On the Define Block Origin dialog box, select a block. 

 If there is a large number of blocks in the data window, under Find, select a column 
heading and then type a value.  For example, if you select Tag Number as a column heading 
and type a specific tag number, in the data window, the software finds the block assigned to 
this tag number. 

5. Under Tag assignments, enter the required values (in the CAD application units) for the 
block new insertion point X- and Y-coordinates. 

 The block origin can consist of numbers that include decimal values, for example, 9.85. 
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Copy Blocks to Another <Plant> 
1. In the Domain Explorer, double-click the Drawing Block Types folder to expand its 

hierarchy. 
2. Double-click a block type whose blocks you want to copy. 
3. Do one of the following: 

 In the tree view pane, right-click a specific block. 
 In the Items pane, select and right-click blocks you want to copy. 

4. On the shortcut menu, click Actions > Copy Blocks to Another <Plant>. 
5. In the Items pane, select and right-click the blocks that you want to copy to other tag numbers. 
6. On the shortcut menu, click Actions > Copy Blocks to Tag Numbers. 
7. On the dialog box that opens, select a target plant and click OK. 

 
 The blocks that you copy appear in the appropriate block type of the target plant.  The block 

types you define in the source plant automatically appear in all the plants in the current domain 
because block types are defined at the domain level. 

 When copying blocks, the software does not copy any associations you made for the blocks in 
the source plant. 

  
 

CAD Drawing Block Assignment Common Tasks 
The following tasks are used when you assign blocks to instrument loops or tags. 

Associate a Loop Block 
Use this procedure to associate a loop block with one or more loop numbers.  You can only 
assign a loop block if the loop that you selected does not have any instrument blocks assigned 
using the manual block assignment method.  Such blocks are shown under the loop tags as 
.  The software, however, does not prevent you from assigning a loop block to the loop is the loop 
tags have instrument blocks assigned using the automatic block assignment method.  Such 
blocks are shown under the loop tags as .  After associating a block with a loop, when 
generating a loop drawing, the software always uses the loop block and ignores instrument blocks 
this loop might contain.  For more information, see Associate a Loop Block (on page 263). 

Associate Instrument Blocks Automatically (via Instrument Type) 
In an instrumentation design setup with a very large number of control loops, similar tag numbers 
are represented repeatedly using the same drawing block, the only difference being the data that 
is retrieved by the macros in the drawing.  Therefore, instead of having to associate each block 
with an instrument manually, you can use this procedure to associate typical blocks with a specific 
instrument type.  For more information, see Associate Instrument Blocks Automatically (via 
Instrument Type) (on page 263). 
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Change the Block Assignment Method from Automatic to Manual 
This procedure enables you to change the assignment method of instrument blocks from 
automatic to manual.  Blocks assigned to tag numbers using the manuals block assignment 
method become available for selection in the Generate Loop Drawings dialog box, where you 
can set the software to generate loop drawings only for those loops that use a specific manually 
assigned instrument block.  For more information, see Change the Block Assignment Method 
from Automatic to Manual (on page 264). 

Associate Instrument Blocks Manually 
You can manually associate one or more blocks with tag numbers belonging to the same loop 
number.  In this case, that the software draws blocks after you select a loop number in the 
Domain Explorer.  For more information, see Associate Instrument Blocks Manually (on 
page 265). 

Update Block Assignments 
This procedure enables you to update block assignments that might have been changed during 
your <plant> life cycle.  You can update block assignments in batch mode, for one or more 
instrument tags belonging to the same loop or to a group of loops.  For more information, see 
Update Block Assignments (on page 265). 

Copy Associated Blocks to Other Instrument Tags 
Use this procedure to copy one or more blocks that are associated with a particular instrument to 
other instrument tags displayed in the Domain Explorer.  For more information, see Copy 
Associated Blocks to Other Instrument Tags (on page 266). 

Copy Automatically Assigned Blocks to Tags of Other Loops 
Use this procedure to copy blocks from all instrument tags of a specific loop to all instruments of 
one or more target loops.  The software only copies those blocks that are assigned to the source 
loop instruments using the automatic block assignment method.  In the Domain Explorer, these 
blocks are indicated with the  icon.  The software validates the instrument tag assignments 
and the drawing type of the target loops before copying the blocks.  For more information, see 
Copy Automatically Assigned Blocks to Tags of Other Loops (on page 266). 

Assign an Instrument Block to a Drawing Page 
Use this procedure to assign a CAD drawing block to a specific page in the generated loop 
drawing when the loop drawing multi-page drawing or multi-drawing.  You must perform this 
procedure if the drawing block is assigned to the loop instrument using the automatic block 
assignment method.  Such blocks are shown under the loop tags as .  For more information, 
see Assign an Instrument Block to a Drawing Page (on page 267). 

Dissociate Blocks from Instruments 
Use this procedure to dissociate blocks from instruments belonging to the same or different 
loops.  For more information, see Dissociate Blocks from Instruments (on page 267). 
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Specify Border and Logo Blocks for Loop Drawings 
This procedure allows you to set SmartPlant Instrumentation to use a specific border block and 
logo block every time you generate a CAD loop drawing.  Blocks that you set as default general 
blocks must belong to the shipped general block types, that is, Border and Logo.  You define and 
manage blocks in the Drawing Block Types folder of the Domain Explorer.  For more 
information, see Specify Border and Logo Blocks for Loop Drawings (on page 268). 

Assign General Blocks to All Loop Drawings via Instrument Type 
Use this procedure to assign user-defined general blocks to a specific instrument type.  This 
procedure allows you to display general blocks in all loop drawings automatically if the source 
loops have tags belonging to the instrument type to which you assigned the blocks.  The software 
displays such blocks in addition to the default border and logo blocks that you specify on the 
Default General Blocks dialog box.  For more information, see Assign General Blocks to All 
Loop Drawings via Instrument Type (on page 268). 
 

Associate a Loop Block 
 You must first define loop blocks in the Drawing Block Types folder of the Domain 

Explorer.  In the Domain Explorer, loop blocks are shown as .  For details, see Add a Block 
to a Block Type (on page 259). 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the tag level in the 

Loops folder. 
2. Do one of the following: 

 In the tree view pane, right-click a specific loop number. 
 In the Items pane, select and right-click several loop numbers. 

3. On the shortcut menu, click Actions > Associate Loop Block. 

 
 If there is a large number of blocks in the data window, under Find block, select a column 

heading and then type a value.  For example, if you select Block as a column heading 
and type block name Control, in the data window, the software selects the block whose 
name starts with Control. 

 If you want to display only specific blocks in the data window, click Filter and specify a 
filter parameter. 

4. In the data window, select the loop block and then click OK. 

 
 You can only assign one loop block per loop. 
 To dissociate loop block, right-click it and then, on the shortcut menu, click Actions > 

Dissociate Loop Block. 
  
 

Associate Instrument Blocks Automatically (via Instrument 
Type) 

1. In the Loop Drawings Module window, do one of the following: 

 On the toolbar, click . 
 Click Actions > Block - Instrument Type Assignment. 
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2. On the Block - Instrument Type Assignment dialog box, in the Type data window column, 
select an instrument type. 

 If there is a large number of instrument types in the data window, under Find instrument 
type, select a column heading and then type a value.  For example, if you select Description 
as a column heading and type Control, in the data window, the software locates the 
instrument types whose description starts with Control. 

3. Click Assign. 
4. If you defined several instrument block types in the Drawing Block Types folder of the 

Domain Explorer, from the Block type list, select the appropriate instrument block type. 
5. Select blocks that you want to assign to the instrument type. 

 
 If you select Show blocks of all types, the software displays all blocks belonging to all 

the instrument block types that you defined n the Drawing Block Types folder of the 
Domain Explorer.  In addition to instrument blocks, the software displays all 
user-defined general blocks.  If you assign a user-defined blocks to the instrument type, 
the software displays this block in all loop drawings that include an instrument belonging 
to the current instrument type. 

 Click View to open a block in your CAD application. 
6. Click OK and then check the block assignment in the Loops folder of the Domain Explorer. 

 In the Loops folder of the Domain Explorer, the instrument blocks that you assigned appear 
under the tag numbers belonging to the instrument type that you selected.  These blocks are 
indicated with the icon . 
  
 

Change the Block Assignment Method from Automatic to 
Manual 

 You cannot use this procedure if the source loop contains a loop block (shown as  
under the loop number). 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the instrument level 

in the Loops folder. 
2. Do one of the following: 

 In the Items pane, select and right-click one or more loops. 
 In the tree view pane, select a specific loop and then in the Items pane, select and 

right-click instruments whose blocks are assigned using the automatic block assignment 
method. 
 In the Loops folder, blocks associated with tags using the manual method are marked 

with the icon .  Blocks associated with tags using the automatic block assignment method 
are marked with the icon . 

3. On the shortcut menu, click Actions > Change Block Assignment Method. 
4. Click Yes when prompted. 

 
 In the Domain Explorer, the block icons change accordingly. 
 After changing the block assignment method from automatic to manual, these blocks are no 

longer associated with an instrument type, and therefore are not affected by any changes you 
or other users can make to the block - instrument type association. 
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 Manually associated blocks become available for selection in the Generate Loop Drawings 
dialog box, where you can generate a CAD loop drawing per block. 

  
 

Associate Instrument Blocks Manually 
 If you have a large number of loops with tag numbers that have identical properties, you 

can assign block using the automatic block assignment method.  For details, see Associate 
Instrument Blocks Automatically (via Instrument Type) (on page 263). 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the tag level in the 

Loops folder. 
2. In the Items pane, select and right-click tag numbers to which you want assign blocks. 
3. On the shortcut menu, click Actions > Associate Instrument Blocks. 

 
 If there is a large number of blocks in the data window, under Find block, select a column 

heading and then type a value.  For example, if you select Block as a column heading 
and type block name Control, in the data window, the software locates the block whose 
name starts with Control. 

 If you want to display only specific blocks in the data window, click Filter and specify a 
filter parameter. 

4. In the data window, select the blocks that you want to associate and then click OK. 
5. In the Specify Drawing Pages for Blocks Assignment dialog box, under Page, use 

spinners to specify pages on which you want the selected blocks to appear after loop drawing 
generation. 

 
 The Specify Drawing Pages for Blocks Assignment dialog box opens when the source 

loop number is assigned to a multi- page drawing or multi-drawing. 
 In the Loops folder of the Domain Explorer, the instrument blocks that you assigned appear 

under the tag numbers that you selected.  These blocks are indicated with the icon . 
 
 

Update Block Assignments 
1. In the Domain Explorer, expand the Loops folder hierarchy. 
2. Do one of the following: 

 In the Items pane, select and right-click one or more loops. 
 In the tree view pane, select a specific loop and then in the Items pane, select and 

right-click tag numbers. 
3. On the shortcut menu, click Actions > Update Block Assignments. 
4. On the Update Block Assignments dialog box, select an update option as you require. 

 When selecting the Overwrite option, any existing blocks associated manually 
with the current tag number are dissociated.  For the update option descriptions and possible 
scenarios, see Update Block Assignments Dialog Box. 

5. Do one of the following: 
 To update block assignments for the displayed tag number only, click Apply and then 

click Next to display another tag number. 
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 To update block assignments for the all the tag numbers you selected in the Domain 
Explorer, click Apply to All. 

  
 

Copy Associated Blocks to Other Instrument Tags 
 

 You can only copy blocks to those tags that belong to loops you assigned to the CAD 
generation method.  In the Domain Explorer, the icons of such loops appear with the C 
indicator. 

 This procedure only allows you to copy blocks assigned to a specific instrument.  If you want 
to copy all instrument blocks that all of the loop instrument contain, you need to perform a 
different procedure.  For details, see Copy Automatically Assigned Blocks to Tags of Other 
Loops (on page 266). 

1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 
Loops folder. 

2. In the tree view pane, expand the loop hierarchy to the tag level and select a source tag. 
3. In the Items pane, select and right-click the blocks that you want to copy to other tag numbers. 
4. On the shortcut menu, click Actions > Copy Blocks to Tag Numbers. 
5. In the dialog box that opens, do one of the following to find tags belonging to the loops whose 

generation method is CAD: 
 Click Find to find all the tag numbers. 
 Set search parameters and then click Find to display tag numbers that match the search 

parameters. 
6. Under Search results, select tag numbers to which you want to copy the blocks. 
7. Click OK. 

 If any of the source blocks is associated with an instrument type, when copying the blocks, 
the software changes the block assignment method from automatic to manual.  In the Loops 
folder of the Domain Explorer, under the target instrument tags, the block icons change from  
too . 
 

Copy Automatically Assigned Blocks to Tags of Other Loops 
 

 You can only copy blocks to those tags that belong to loops you assigned to the CAD 
generation method.  In the Domain Explorer, the icons of such loops appear with the C 
indicator. 

 Using this procedure, you copy blocks at the <plant> level, that is, your target loops belong to 
different <units> of the current plant.  If you only want to copy blocks that belong to a specific 
instrument or copy blocks at the <unit> level, you need to perform a different procedure.  For 
details, see Copy Associated Blocks to Other Instrument Tags (on page 266). 

1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 
Loops folder. 

2. In the tree view pane, right-click a loop. 
3. On the shortcut menu, click Actions > Copy Blocks to Tags of Other Loops. 
4. On the dialog box that opens, under Target loop number, select one or more loops. 

 You can select all the target loops or find a specific loop.  The software finds and selects 
the loop number as you type its name in the Find target loop box. 
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5. Click OK to validate the target blocks and create the copy_block.txt log file in the temporary 
folder path of SmartPlant Instrumentation. 

6. When prompted to copy the blocks, do one of the following:: 
 Click Yes to start copying the blocks and skip problematic loops automatically. 
 Click No if you only want to view the target loop validation problems in the log file. 

7. In the temporary folder path of SmartPlant Instrumentation, view the copy_block.txt log file. 
  
 

Assign an Instrument Block to a Drawing Page 
1. In the Domain Explorer, expand the Loops folder hierarchy. 
2. In the tree view pane, expand the hierarchy to the instrument level and then select an 

instrument tag. 
3. In the Items pane, right-click a block. 

 
 You can only select one block at a time. 

 For a block shown as , you might have already specified the drawing page when 
assigning the block to the instrument using the following procedure: Associate Instrument 
Blocks Manually (on page 265).  It is possible to specify a different page for such a block. 

4. On the shortcut menu, click Actions > Select Drawing Page. 
5. On the Select Drawing Page dialog box, select a page number. 
6. Double-click the selected number or click OK and then repeat this procedure to assign 

another block to a drawing page. 
 
 

Dissociate Blocks from Instruments 
Use this procedure to dissociate blocks from instruments belonging to the same or different loops. 
1. On the Loop Drawings Module window, click Actions > Dissociate Blocks from 

Instruments. 
2. In the Dissociate Blocks from Instruments dialog box, under Select blocks, select one or 

more blocks and also select the specific instruments form which you want to dissociate the 
blocks. 

3. Click OK to dissociate the blocks. 

 
 When dissociating blocks assigned to instruments using the automatic block assignment 

method, the software does not dissociate these blocks from the instrument type.  You can 
reassign these blocks automatically whenever you require.  In the Domain Explorer, these 
blocks are shown as .  For details, see Update Block Assignments (on page 265). 

 You can also dissociate instrument blocks from the Loops folder of the Domain 
Explorer.  However, it is only possible to dissociate blocks belonging to one specific 
instrument.  After you select an instrument in the Loops folder, the software displays the 
associated blocks in the Items pane.  You can right-click one or more blocks and then, on the 
shortcut menu, click Actions > Dissociate Instrument Blocks. 
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Specify Border and Logo Blocks for Loop Drawings 
 

 You can only perform this procedure after you have assigned blocks to the Border and Logo 
general block types in the Drawing Block Types folder of the Domain Explorer.  

 In addition to the shipped general block types, you might have created user-defined general 
block types. All blocks belonging to the block types appear automatically in every CAD loop 
drawing that you generate.  

1. In the Loop Drawings Module window, click Actions > Default General Blocks.  
2. In the Default General Blocks dialog box, select the border and logo blocks to be used in all 

the loop drawings.  
  
 

Assign General Blocks to All Loop Drawings via Instrument 
Type 

1. In the Domain Explorer, right-click the Drawing Block Types folder. 
2. On the shortcut menu, click New > General Block Type and define a block type. 
3. Right-click the block type you created and then, on the shortcut menu, click New > Block. 
4. Define one or more blocks as you require. 
5. In the Loop Drawings Module window, do one of the following: 

 On the toolbar, click . 
 Click Actions > Block - Instrument Type Assignment. 

6. On the Block - Instrument Type Assignment dialog box, in the Type data window column, 
select an instrument type. 

 If there is a large number of instrument types in the data window, under Find instrument 
type, select a column heading and then type a value.  For example, if you select Description 
as a column heading and type Control, in the data window, the software locates the 
instrument types whose description starts with Control. 

7. Click Assign. 
8. From the Block type list, select the user-defined general block type that you created in the 

Drawing Block Types folder. 
9. Select one or more blocks that you want to assign to the instrument type. 
10. Click OK and then generate the appropriate loop drawing to display the assigned blocks. 

 User-defined general blocks are only shown in the Drawing Block Types folder of the 
Domain Explorer. 
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Loop Drawing Types and Drawing Properties 
In the Loop Drawings module, you can specify a drawing type for every loop drawing that you want 
to generate. 
The following drawing types are available: 
 Single-page — A loop drawing type used to display all the drawing blocks and the title block 

on a single drawing page.  Property updates for this drawing type take effect in both CAD loop 
drawings and drawings you generate by the Enhanced Report Utility. 

 Multi-page — A loop drawing type used to display drawing blocks on more than one page, 
where all the pages share the same document number, description, and title block.  Property 
updates for this drawing type only take effect in CAD loop drawings. 

 Multi-drawing — A loop drawing type used to display blocks on more than one page, where 
each page has an individual document number, description, and title block.  Property updates 
for this drawing type only take effect in CAD loop drawings. 

By default, all drawings belong to the single page drawing type. 
Loop drawing properties appear in the title block fields.  These fields contain identifying 
information about the document number, page number, and file name, and also information about 
revisions, approvals, and references to other documents. 
Properly completed identifying information ensures that each drawing is uniquely 
identifiable.  You can maintain your loop drawing properties by keeping the revision, document 
reference and client / vendor approval information up to date. 
 
 

Loop Drawing Types and Drawing Properties Common Tasks 
The following tasks are used when defining the properties of loop drawing types and drawings. 

Set the Date Format in CAD Loop Drawings 
Use this procedure to set a date format in your CAD loop drawings.  You set the date format when 
customizing your CAD loop drawing preferences on the Preferences dialog box. 
For more information, see Set the Date Format in CAD Loop Drawings (on page 271). 

Define a Drawing as a Multi-Drawing 
Use this procedure to define a CAD drawing as a multi- drawing. 
For more information, see Define a Drawing as a Multi- Drawing (see "Define a Drawing as a 
Multi-Drawing" on page 271). 

Define a Drawing as a Multi-Page Drawing 
Use this procedure to define a CAD drawing as a multi-page drawing. 
For more information, see Define a Drawing as a Multi-Page Drawing (on page 272). 

Modify Properties of a Single-Page Drawing 
Use this procedure to modify properties of a CAD drawing to be generated as a single-page 
drawing. 
For more information, see Modify Properties of a Single- Page Drawing (see "Modify Properties of 
a Single-Page Drawing" on page 272). 
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Maintain CAD Loop Drawing Revisions 
Use this procedure to maintain CAD loop drawing revisions.  Revisions enable you to keep track 
of the changes made to the CAD loop drawing during its lifetime.  It is important and useful to 
have a chronological description of the changes, dates of change, and a list of persons who 
approved them.  Use the following procedure to add, edit, or delete revisions. 
For more information, see Maintain CAD Loop Drawing Revisions (on page 273). 

Maintain Document References 
Use this procedure to maintain document references that you include in title blocks of CAD loop 
drawings.  You can manually add a new document reference, or you can edit or delete an existing 
document reference. 
Title blocks can display the following document references: 
Automatic references to P&ID drawings 
 Manual references to loop drawings 
 Automatic references to reports generated in the Wiring module 

For more information, see Maintain Document References (on page 274). 

Make CAD Drawing Approvals 
Use this procedure to make client and vendor approvals for CAD loop drawings. 
For more information, see Make CAD Drawing Approvals (on page 274). 

Modify Loop Drawing Identifying Information 
Use this procedure to set or modify loop drawing identifying information. 
For more information, see Modify Loop Drawing Identifying Information (on page 274). 

Update Paths for CAD Drawings and Block Files 
Use this procedure to update in the SmartPlant Instrumentation database paths for existing 
drawings and block files.  You can update paths globally for block files associated with 
instruments and loops, for general block files,  and for generated CAD drawings. 
For more information, see Update Paths for CAD Drawings and Block Files (on page 275). 

Associating an External CAD Drawing 
This option enables you to associate an external CAD drawing with one or more loops you have 
selected in the Domain Explorer.  An external CAD drawing is a drawing you have created 
outside the SmartPlant Instrumentation environment, using SmartSketch, AutoCAD, or 
MicroStation.  After associating an external CAD drawing, you can open it in a compatible CAD 
application using the View External CAD Drawing option of the Domain Explorer.  External 
CAD drawings are only used for viewing from within SmartPlant Instrumentation.  They are nether 
included in loop drawing generation, nor referenced in any item properties or settings. 
For more information, see Associating an External CAD Drawing (on page 275). 

View an External CAD Drawing 
This option allows you to view an external CAD drawing that has been associated with one or 
more loops the Domain Explorer.  An external CAD drawing is a drawing you have created 
outside the SmartPlant Instrumentation environment, using SmartSketch, AutoCAD, or 
MicroStation. 
For more information, see View an External CAD Drawing (on page 276). 
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Set the Date Format in CAD Loop Drawings 
1. On the File menu, click Preferences. 
2. In the tree view, click Loop Drawings > General. 
3. In the Date format box, enter the date format using the syntax in the following table: 

Date Format Example  

mm-dd- yy 01-30- 09 

mm-dd- yyyy 01-30- 2009 

dd-mm- yy 30-30- 09 

dd-mm- yyyy 30-30- 2009 

d-mmm- yy 30-Jan- 09 

mmm-yy Jan-09 

 
 SmartPlant Instrumentation only support date formats that are listed in this table. 
 You can use one of the following characters as separators: dash (-), slash (/), space, comma, 

semicolon, colon, or dot. 
 
 

Define a Drawing as a Multi-Drawing 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the tree view pane, right-click a loop. 
3. On the shortcut menu, click Actions > Loop Drawing List. 
4. On the Loop Drawing List dialog box, select the loop, and then click Properties. 
5. On the Loop Drawing Properties dialog box, under Drawing type, click Multi-drawing. 
6. Click New and then enter the values as you require. 

 
 You cannot change the loop number value. 
 In the Page column, you can type any alphanumeric character that designates a specific loop 

drawing page. 
 You can specify an individual source path for any drawing page by clicking  to the right of 

the selected drawing file.  A source path is a path which software uses to locate the source file 
when generating a CAD drawing that belongs to the multi-drawing type.  The path that you 
specify does not overwrite the path setting specified in the Preferences dialog box.  The 
software saves all generated loop drawings in a designated folder that you define on the 
Preferences dialog box. 
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Define a Drawing as a Multi-Page Drawing 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the tree view pane, right-click a loop. 
3. On the shortcut menu, click Actions > Loop Drawing List. 
4. On the Loop Drawing List dialog box, select the loop, and then click Properties. 
5. On the Loop Drawing Properties dialog box, under Drawing type, click Multi-page. 
6. Click New and then enter the values as you require.  Repeat this action as many times as you 

need. 

 
 You cannot change the loop number value. 
 In the Page column, you can type any alphanumeric character that designates a specific loop 

drawing page. 
 You can specify an individual source path for any drawing page by clicking  to the right of 

the selected drawing file.  A source path is a path which software uses to locate the source file 
when generating a CAD drawing that belongs to the multi-page type.  The path that you 
specify does not overwrite the path setting specified on the Preferences dialog box.  The 
software saves all generated loop drawings in a designated folder that you define on the 
Preferences dialog box. 

 
 

Modify Properties of a Single-Page Drawing 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the tree view pane, right-click a loop. 
3. On the shortcut menu, click Actions > Loop Drawing List. 
4. On the Loop Drawing List dialog box, select the loop number, and then click Properties. 

 If the drawing belongs to the single page type, the Single page button under Drawing 
type is selected automatically.  You can change the type of the drawing to multi-page or 
multi-drawing.  For more information, see Define a Drawing as a Multi-Page Drawing (on 
page 272) or Define a Drawing as a Multi-Drawing (on page 271). 

5. Modify the values as you require. 
 
 



 Loop Drawings Module 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 273 
 

Maintain CAD Loop Drawing Revisions 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click one or more loops. 
3. On the shortcut menu, click Actions > Loop Drawing List. 
4. On the Loop Drawing List dialog box, click Revisions. 
5. On the Revisions dialog box, select one of the revision numbering methods (use P0, P1, 

P2...  for preliminary revisions or 0, 1, 2 / A, B, C and so forth for normal serial revisions). 

 
 When you first select a revision numbering method, several options are available to you, 

including preliminary revisions (designated by P0, P1, P2…).  Once you select one of the 
other revision methods, you can no longer return to the preliminary revision method and 
this option becomes disabled. 

 When working with revisions in an integrated environment, the revision numbering 
methods are not available for selection. 

6. Click New to add new revision data or update the existing data as desired. 

 
 SmartPlant Instrumentation automatically adds a new line with the next logical character 

and date each time you click New after you select the initial method. 
 If you are working in an integrated environment in a module that supports publishing and 

retrieving of documents, clicking New opens the Revise dialog box for the integrated 
environment instead of the SmartPlant Instrumentation Revisions dialog box. 

7. Add or edit the revision data in the appropriate data fields. 

 
 The By column contains the current user initials by default, if previously defined by the System 

Administrator.  You can edit this value as you require. 
 You can delete obsolete revisions by clicking Delete. 
 You can also maintain revisions in batch mode. 
 Each revision is represented by a numbered macro and the revisions are displayed in the 

order of the macro numbering, beginning with the first revision (ascending order) or the last 
revision (descending order).  If the total number of revisions is greater than the number of 
lines available for display in the drawing and you want to see the latest revisions, you should 
set your preferences to display the revisions in descending order so that the latest revision is 
displayed first. 
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Maintain Document References 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click one or more loops. 
3. On the shortcut menu, click Actions > Loop Drawing List. 
4. On the Loop Drawing List dialog box, click References. 
5. On the Document References dialog box, do one of the following: 

 Select a row in the data window and click Properties to update the existing document 
reference name and description of a manually inserted reference. 

 Click New to define properties of a new document reference. 

 
 You can view document references to reports generated in the Wiring module only if you have 

selected the Display references to wiring reports automatically check box in the Loop 
Drawings > General page of the Preferences dialog box.  You cannot edit properties of 
these document references. 

 The time of reference creation determines the order of the references in the title block.  In the 
title block, the software displays the references in descending order, according to the time of 
creation.  This means that the reference you create first appears in the title block at the top of 
the reference list. 

 If an instrument in the selected loop has a reference in a P&ID drawing, this reference 
automatically appears on the Document References dialog box.  It is possible, you can edit 
a P&ID drawing reference in the Instrument Index module. 

 
 

Make CAD Drawing Approvals 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click one or more loops. 
3. On the shortcut menu, click Actions > Loop Drawing List. 
4. On the Loop Drawing List dialog box, click Approvals. 
5. On the Approvals dialog box, set data for client and vendor approvals as you require. 
 
 

Modify Loop Drawing Identifying Information 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click loops. 
3. On the shortcut menu, click Actions > Loop Drawing List. 
4. On the Loop Drawing List dialog box, click Properties. 
5. Modify the data as you require. 

 
 Properties that you can edit are determined by the specified drawing type. 
 The document number does not have to be unique. 
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 Properties that only apply to CAD drawings are indicated as such.  Other properties, such as 
document number and loop drawing description, are used in both CAD loop drawings and in 
loop drawings generated by the Enhanced Report Utility. 

 
 

Update Paths for CAD Drawings and Block Files 
 The paths that you specify do not overwrite the preferences settings specified for new block 

files and output drawings.  For more information about the CAD path preferences, see Loop 
Drawings > CAD File Locations (Preferences). 

Update Paths for Existing CAD Drawings And Block Files 
1. In the Loop Drawings Module, click Actions > Update Paths for Existing Drawings and 

Blocks. 
2. Under Path for associated block, do one of the following: 

 Click Apply to drawings in the domain/project to apply the new path to all the plants in 
the current domain, or to the current project in an owner operator domain. 

 Click Apply to drawings in the current <plant> only to apply the new path to the 
current plant only. 

3. Type the full path to the folder where you keep your drawing blocks files or click Browse to 
navigate to the desired folder. 

4. Under Path for generated drawings, do one of the following: 
 Click Apply to blocks in the domain/project to apply the new path to all the plants in the 

current domain, or to the current project in an owner operator domain. 
 Click Apply to blocks in the current <plant> only to apply the new path to the current 

plant only. 
5. Type the full path to the folder where you keep your generated drawings or click Browse to 

navigate to the desired folder. 
  
 

Associating an External CAD Drawing 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click one or more loops. 
3. On the on the shortcut menu, click Actions > Associate External CAD Drawing. 
4. On the Select File dialog box, select the desired SmartSketch, AutoCAD or MicroStation file. 

 You can associate the following file types: .dwg, .dxf, .dgn, .cgm. 
5. Click Open to associate the selected drawing. 

 
 If there is already an external CAD drawing associated with the current loop or loops, the new 

CAD drawing overwrites the existing one. 
 To dissociate the external CAD drawing, the on the shortcut menu, click Actions > Dissociate 

External CAD Drawing. 
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View an External CAD Drawing 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click one or more loops. 
3. On the on the shortcut menu, click Reports > View External CAD Drawing to open the CAD 

drawing associated with the selected loop or loops. 
  
 

CAD Loop Drawing Generation 
SmartPlant Instrumentation allows you to generate loop drawings using external CAD 
applications.  The same generation principles are valid for any of the listed CAD 
applications.  The following CAD applications are supported: 
 Intergraph SmartSketch 
 AutoCAD 
 MicroStation 

In the generation process, SmartSketch (.sym), AutoCAD (.dwg), or MicroStation (.dgn) type 
drawings are created from the selected loops. 

Prerequisites 
 Before generating loop drawings, make sure that CAD application paths are set up correctly 

on the Preferences dialog box.  For details, see CAD Settings for SmartPlant Instrumentation 
(on page 278). 

  SmartPlant Instrumentation and the CAD drawing programs required to work with 
SmartPlant Instrumentation, must be installed on the same machine. 

 If you use SmartSketch, prior to starting the generation process, in the Preferences dialog 
box, you must select the check box Use macro symbol (&) to retrieve data because in 
SmartSketch all macros have the '&' prefix.  If you clear the check box, the software displays 
only macro attributes in the drawings. 

 If you use AutoCAD, to ensure that the software displays macro captions, on the Custom tab 
of the Preferences dialog box, in the Parameter box, type TagAsMacroName and in the 
Value field, type Y. 
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Basic Principles of CAD Loop Drawing Generation 
The following diagram illustrates a (schematic) flow control loop.  The loop drawing includes five 
drawing blocks for the following components: monitoring system, control valve, each set of wiring 
connections to the DCS, and the DCS itself.  The wiring routing and control systems are 
conceptually the same for both tags (but with different data), so in this example, the blocks for 
these items are identical. 

 
Tag A is a monitoring system consisting of a flow transmitter and flow element. 
Tag B consists of a control valve with an I/P transducer. 
 

Loop Drawing Generation Methods 
SmartPlant Instrumentation allows you to assign a loop number to one of the following generation 
methods: CAD, Enhanced Reports, and manual.  Methods are marked by designated symbols 
attached to loop numbers in the Loops folder of the Domain Explorer.  By default, loop numbers 
are not assigned to any generation method. 
Loop drawing generation is traditionally done using a CAD application such as SmartSketch, 
AutoCAD, or MicroStation.  You must specify the CAD application paths and other CAD file 
locations on the Loop Drawings > CAD File Locations page of the Preferences dialog box. 
In addition to using a CAD method, you can also use the Enhanced Report Utility, which is 
supplied with SmartPlant Instrumentation.  This utility enables you to generate, view, modify, and 
annotate loop drawings as needed.  The Enhanced Report Utility has an advantage over CAD as 
a loop drawing generation method in that it requires no extra work in creating CAD drawing 
blocks.  The report comes directly from the database and does not necessarily require additional 
modifications 
You can either assign each loop number to a specific method or apply the same method to all loop 
numbers when generating loop drawings in batch mode.  In the Domain Explorer, for the 
intended method of generation, the software assigns an appropriate generation indicator to the 
loop number icons. 
The available indicators are: 
 C — Loop drawing to be generated by a CAD application (SmartSketch, AutoCAD, or 

MicroStation). 
 M — Loop drawing to be generated manually, without using SmartPlant Instrumentation 

options.  When generating loop drawings, the software always skips loops assigned to the 
Manual method. 

 For loop drawings where the selected generation method is Enhanced Report, the following 
symbols are available: 
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 E — By Loop 
 ES — By Signal 
 CL — Custom by Loop 
 CS — Custom by Signal 

 

Steps in Loop Drawing Generation Using a CAD Application 
SmartPlant Instrumentation enables you to generate drawings for loop numbers in your domain 
using an external CAD application.  The main steps required to generate these loop drawings are 
as follows: 
 Drawing Preparations 

 CAD Loop Drawing Generation (on page 276) 
 Insert Macros in an AutoCAD Drawing Block (on page 296) 

 Defining Blocks in SmartPlant Instrumentation 
 Add a Block Type (on page 259) 
 Blocks in SmartPlant Instrumentation (see "CAD Drawing Blocks in SmartPlant 

Instrumentation" on page 253) 
 Loop Blocks (on page 256) 

 Setting CAD Application Parameters 
For details on preliminary Intergraph SmartSketch, AutoCAD or MicroStation settings, see: 

 CAD Settings for SmartPlant Instrumentation (on page 278) 
 MicroStation and SmartPlant Instrumentation  (on page 307) 

 Customizing SmartPlant Instrumentation Macro Definitions (if required) 
 Customizing Macro Definitions (on page 297) 
 Working with User-Defined Macro Functions (on page 299) 
 Using External Macro Data Sources (on page 303) 

 Making Block Associations 
 Associate Instrument Blocks Automatically (via Instrument Type) (on page 263) 
 Apply Associated Blocks to all Tag Numbers Belonging to a Specific Instrument Type (see 

"Associate a Loop Block" on page 263) 
 Associate Instrument Blocks Manually (on page 265) 

 Performing the Generation Process 
 Generate CAD Loop Drawings (on page 283) 

 

CAD Settings for SmartPlant Instrumentation 
The table below contains the CAD interface parameters together with the appropriate values for 
SmartSketch, MicroStation, and AutoCAD.  You can modify these parameters on the Loop 
Drawings > CAD File Locations page of the Preferences dialog box.  The Preference column 
of the table below shows the label that appears on the Preference dialog box. 

Preference for 
SmartSketch 

Default Value  Description 

CAD folder  C:\Program\ The path to the draft.exe for 
SmartSketch.  
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Preference for 
SmartSketch 

Default Value  Description 

CAD configuration folder C:\Program\  There is no configuration file for 
SmartSketch.  However, the default 
value for the path does exist.  

Temporary folder path  C:\Program 
Files\SmartPlant\Instrumentation
\TEMP\ 

The path to the SmartPlant 
Instrumentation temporary folder 
where the software stores temporary 
logo and custom style files.  

Drawing file folder C:\Program 
Files\SmartPlant\Instrumentation
\CAD\DWG\  

The path to the location of the loop 
drawing that was last generated. 

Drawing block folder  C:\Program 
Files\SmartPlant\Instrumentation
\CAD\Blocks\ 

The default path for new drawing 
block files.  

 

Preference for AutoCAD Default Value  Description 

CAD folder  C:\Acadwin\ The path to the acad.exe file for 
AutoCAD.  

CAD configuration folder C:\Acadwin\  The path to the AutoCAD 
configuration file ACAD.CFG. 

CAD function folder  C:\Program 
Files\SmartPlant\Instrumentation
\CAD\CADfunc\ 

The path to the AutoCAD function 
files (.lsp file format).  

Temporary folder path C:\Program 
Files\SmartPlant\Instrumentation
\TEMP\  

The path to the SmartPlant 
Instrumentation temporary folder 
where the software stores temporary 
logo and custom style files. 

Drawing file folder  C:\Program 
Files\SmartPlant\Instrumentation
\CAD\DWG\ 

The path to the location of the loop 
drawing that was last generated.  

Drawing block folder C:\Program 
Files\SmartPlant\Instrumentation
\CAD\Blocks\  

The default path for new drawing 
block files. 

 

Preference for 
MicroStation  

Default Value Description  

CAD folder C:\Win32appl\Ustation  The path to the ustation.exe file for 
MicroStation SE. 

CAD configuration folder  C:\Win32appl\Ustation\Config\ The path to the MicroStation SE 
configuration file MSCONFIG.CFG.  
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Preference for 
MicroStation  

Default Value Description  

CAD function folder C:\Program 
Files\SmartPlant\Instrumentation
\CAD\CADfunc\  

The path to the MicroStation SE 
function files (.ma file format). 

Temporary folder path  C:\Program 
Files\SmartPlant\Instrumentation
\TEMP\ 

The path to the SmartPlant 
Instrumentation temporary folder 
where the software stores temporary 
logo and custom style files.  

Drawing file folder C:\Program 
Files\SmartPlant\Instrumentation
\CAD\DWG\  

The path to the location of the loop 
drawing that was last generated. 

Drawing block folder  C:\Program 
Files\SmartPlant\Instrumentation
\CAD\Blocks\ 

The default path for new drawing 
block files.  

 
 SmartPlant Instrumentation uses the shipped LISP function plot.lsp for plotting generated 

drawings.  If this function is not suitable for the specific current AutoCAD plotter, you can 
select the Current Systems Plotter option from the AutoCAD Plotter Configuration menu 
of AutoCAD, or modify the plate.lsp file.  If you do the latter, you should be aware that the last 
Enter for the AutoCAD plot command is supplied automatically; you do not need to press 
Enter manually. 

 When defining a new CAD drawing block for MicroStation, the files you select represent cell 
libraries.  To specify a particular cell in the library, you must type its name manually in the 
appropriate field. 

 Make sure the temporary folder path string does not exceed fifty two characters.  A longer 
path prevents MicroStation from generating or displaying drawings or cells from SmartPlant 
Instrumentation. 

 SmartPlant Instrumentation and the CAD drawing programs required to work with SmartPlant 
Instrumentation, must be installed on the same machine. 

See Also 
Loop Drawing Generation Methods (on page 277) 
CAD Loop Drawing Generation (on page 276) 
CAD Loop Drawing Generation Common Tasks (on page 282) 
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Sample Loop Drawing (After Generation) 
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CAD Loop Drawing Generation Common Tasks 
The following tasks are used when you generate CAD loop drawings. 

Apply Loop Drawing Generation Method 
You can specify the desired method for one or more selected loops in the Domain Explorer.  You 
can also specify in the Preferences dialog box which generation method to use by default and 
whether to display each signal on a separate drawing sheet when you select By Signal or 
Custom by Signal as the generation method. 
For more information, see Apply Loop Drawing Generation Method (on page 283). 

Generate CAD Loop Drawings 
You use this procedure to generate CAD loop drawings. 
For more information, see Generate CAD Loop Drawings (on page 283). 

Show the Latest Generated CAD Drawing 
This option enables you to display the latest loop drawing that was generated in SmartPlant 
Instrumentation using an external CAD application.  The drawing opens in the CAD application 
you set as default on the Preferences dialog box. 
For more information, see Show the Latest Generated CAD Drawing (on page 285). 

Display CAD Loop Drawing Generation History 
You can keep track of all the macro data changes in your CAD drawings.  You choose this option 
when generating a loop using an external CAD engine.  You can access the loop generation 
history from the print preview of loop drawings and the relevant reports. 
The loop generation history feature compares the retrieval values of macros from different 
generations.  Therefore, the history data is available when you have already generated at least 
one loop drawing for a selected loop. 
For more information, see Display CAD Loop Drawing Generation History (on page 285). 

Delete CAD Loop Drawing Generation History 
You use this procedure to improve performance when comparing generated data values in CAD 
loop drawings, by deleting the history of obsolete CAD loop drawing generations.  Before deleting 
the values of previous CAD loop drawing generations, you select the required loops, and then set 
the period within which you want to delete the selected history records. 
For more information, see Delete CAD Loop Drawing Generation History (on page 286). 

Clear Previous Macro Result Records 
Use this procedure to clear macro result records of generated loop drawings.  The software saves 
the macro results in the database for the next time you want to generate a loop drawing for the 
same loop.  The saved data accumulates and at a certain stage might affect the generation 
performance. 
For more information, see Clear Previous Macro Result Records (on page 286). 
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Apply Loop Drawing Generation Method 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. Do one of the following: 

 In the tree view pane, right-click a target loop. 
 In the Items pane, select and right-click several loops. 

3. On the shortcut menu, click Apply Generation Method and then select a generation method. 

 
 In the Domain Explorer, the icons of the loop numbers to which you applied a generation 

method appear with method indicators.  For method indicator descriptions, see Loop Drawing 
Generation Methods (on page 277). 

 To clear the current loop generation method for one or more loops, on the shortcut menu, click 
Clear Generation Method. 

 

Generate CAD Loop Drawings 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click one or more loop numbers. 

 If among the loops that you selected there are loops assigned to the Manual method 
(symbol M in the Explorer), the software skips these loops when generating drawings in 
batch mode. 

3. On the shortcut menu, click Reports > Generate Loop Drawings. 
4. On the Generate Loop Drawings dialog box, from the Generation method list, select CAD. 
5. Under Automatic save options, select Save drawing automatically and do one of the 

following: 
 In the Output drawing path data field, type the exact folder path to which you want to 

save the generated drawing. 
 Click Browse to navigate to the desired path for saving the file. 

6. Click CAD Options, and then, from Save file in format list, specify the CAD file format in 
which to save the generated drawings (if your CAD application supports more than one file 
format). 

7. Select the following check boxes: 
 Send to plotter or printer — Sends the generated drawing to the current CAD plotter. 
 Use macro functions — Applies macro functions associated with the macros. 
 Save output data to database — Enables you to compare drawing data of the current 

generation to data of a subsequent generation made for the same loop. 
8. Under Generation criteria, do one of the following: 

 Click Per loop to generate drawings for all the loops you selected. 
 Click Per page and then type the desired page number to generate only a specific 

drawing page for the drawings you selected. 
 Click Per block to select a block from the list and generate drawings only for the loops 

that to which you assigned this block. 
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 The Per block option is useful when you select several loops in the Items pane of the 
Domain Explorer.  If your selection includes loops that do not contain the block that you 
selected, the software does not generate loop drawings for those loops.  For the loops that do 
contain the selected block, the software includes all of the blocks when generating loop 
drawings.  For example, if you selected five loops and each of them has the block that you 
selected and also has three other different blocks, the software includes all of these blocks in 
the generated loop drawings.  The blocks displayed in the lists are blocks associated with 
instruments using the manual block assignment method.  In the Loops folder of the Domain 
Explorer, these blocks are shown as are shown with the  icon. 

9. Under Create report about, select which reports you want to generate: 
 Null data — Displays macro strings in the drawing for which SmartPlant Instrumentation 

data is unavailable. 
 Invalid macros — Displays macro strings in the drawing which are not defined in 

SmartPlant Instrumentation. 
 You can select to generate both reports if needed. 

10. Under Mark drawing using, select the options for which you want to display a text string, 
specified in the adjacent text box: 
 String for null data — Allows you to type a string that indicates in the drawing those 

macros for which SmartPlant Instrumentation data is unavailable. 
 String for invalid macros — Allows you to type a string that indicates in the drawing 

those macros which are not defined in SmartPlant Instrumentation. 
11. If you need to use macros from an external source during the current loop drawing generation, 

under External data, select the Use external macro source check box, and then click 
Define. 

12. Click OK to start the loop drawing generation process in your CAD application. 
 

 If your CAD application is SmartSketch, by default, all drawings that you generate have 
the A3 Wide print sheet size.  This print sheet size is defined in the template file pid.igr, 
which comes shipped with SmartPlant Instrumentation.  This file appears in the 
CADFunc folder, for which you specified the path setting on the Preferences dialog box, 
Loop Drawings > CAD File Locations page.  If you want to generate loop drawings 
using a different print sheet size, you must open the pid.igr file in SmartSketch and modify 
the sheet settings as you require.  Note, however, that changes that you make in the 
pid.igr file affect both loop drawings and hook-up drawings you generate in 
SmartSketch.  If you want the print sheet size of loop drawings not to affect the print sheet 
size of hook-up drawings, duplicate the CADFunc folder with all its content and define a 
different path setting preference for hook-up drawings on the Hook-Ups > CAD File 
Locations page. 

 SmartPlant Instrumentation and the CAD drawing programs required to work with 
SmartPlant Instrumentation, must be installed on the same machine. 
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Show the Latest Generated CAD Drawing 
This option enables you to display the latest loop drawing that was generated in SmartPlant 
Instrumentation using an external CAD application.  The drawing opens in the CAD application 
you set as default on the Preferences dialog box. 
 In the Loop Drawings module, click Actions > Show Latest Generated Drawing. 

 You must have checked the Save drawings automatically check box and entered the 
path for the Output drawing folder, under Preferences > Loop Drawings > CAD File 
Locations, for this procedure to work. 
 

Display CAD Loop Drawing Generation History 
1. On the GenerateLoop Drawings dialog box, in the CAD Options tab, select the Save 

output data to database check box. 
2. On the CAD History tab, select the Compare outputs check box if this is not the first 

generation to make the additional options available. 
3. Do one of the following: 

 Click Set date range and then, in the From and To boxes, specify the history date range 
you need for the comparison. 

 Click Select specific generation, and then, from the data window, select a specific 
generation to which you want to compare the current generation. 

4. Under History data, select one of the following check boxes or both check boxes: 
 Select Display in the drawing to display history data in the generated drawing. 
 Select Display in the report to display the Data Changes Report before proceeding 

with the loop generation.  The report includes the tag number, block name, macro name 
and description, old value and the new value. 

5. Do one of the following: 
 Click Show data from previous generation to display the old history value from the 

previous generation. 
 Click Mark with user- define value and type a new value in the box below.  This marks 

the drawing or the report with the new value instead of the old history value from the 
previous generation. 

 
 In the generated drawing or report, the software displays the old value in parentheses. 
 If you selected Display in the report, the software displays the Data Changes Report 

before proceeding with the loop generation.  After printing or viewing the report, click OK 
to return to the Generate Loop Drawings dialog box. 

6. Click OK to start the generation process. 

 
 When comparing a loop drawing that you have just generated with an older one, you have to 

set the comparison date range to include both generations.  If that date includes more than 
one loop drawing, select the exact loop drawing to which you want to compare the currently 
generated one. 

 The results show a comparison of the current data in the loop drawing with the data stored in 
the history for the specified date range or generation. 
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Delete CAD Loop Drawing Generation History 
1. In the Domain Explorer, right- click loops that you select, and then, on the shortcut menu, 

click Actions > Delete Generation History Records. 
2. In the From and To boxes, specify the date range of the generation history records that you 

want to delete. 
3. Click Show Records. 
4. Under Select records for deletion, select history records that you want to delete. 

 Select the Select all check box to be able to delete all the displayed records at once. 
5. Click Delete. 

See Also 
CAD Loop Drawing Generation Common Tasks (on page 282) 
 

Clear Previous Macro Result Records 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the Items pane, select and right-click loops whose temporary generation data table you 

want to clear. 
3. On the shortcut menu, click Actions > Clear Temporary Data. 
 
 

Loop Drawing Reports 
The following reports are associated with loop drawings that you can generate in SmartPlant 
Instrumentation: 
 CAD Loop Drawing Generation Errors — Available on the shortcut menu in the Domain 

Explorer.  This report lists a summary of errors that occurred during the last loop drawing 
generation using your CAD application.  Data that appears in this report depends on specific 
loop numbers that you select.  For details, see Generate a Report of CAD Loop Drawing 
Generation Errors (on page 287). 

 Macros — Available in the Loop Drawings module, on the Reports menu of the main 
window.  Lists all the SmartPlant Instrumentation macros.  This report provides you with 
information about every macro name, description, database name, and function description (if 
it exists).  This report displays macros for all loop numbers existing in your database.  For 
details, see Generate a Macro Report (on page 295). 

 User-Defined Macro Functions — Available in the Loop Drawings module, on the Reports 
menu of the main window.  Lists all the macro functions you created on the basis of 
SmartPlant Instrumentation standard macro functions.  The macro function affects the value 
which the macro returns after generation.  For example, you can specify a user- defined 
function that removes all the spaces in the retrieved values and displays the remaining 
characters as upper case.  This report displays user-defined macro functions for all loop 
numbers in your database. 
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Generate a Report of CAD Loop Drawing Generation Errors 
Use this procedure to create a CAD loop drawing generation error report for loop numbers for 
which you generated CAD loop drawings. 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. In the tree view pane, right-click a loop for which you want to generate the CAD loop 

generation error report. 
3. On the shortcut menu, click Reports > CAD Loop Drawing Generation Errors. 
 

Working with Macros in SmartPlant Instrumentation 
A macro is a text string that is recognized by SmartPlant Instrumentation and is used to extract 
data from a given item such as a loop, instrument, panel, strip, and so forth.  Each macro 
corresponds to specific information available in SmartPlant Instrumentation database, for 
example, the color of a wire.  SmartPlant Instrumentation provides you with easy ways to search 
for the macros that need to be placed on a drawing block or a symbol.  The software also comes 
with a standard set of macros that you can customize according to your needs 
The type of data that the software can retrieve depends on whether you are working with loop 
drawings or hook-up drawings.  For loop drawings, you can retrieve data for the following item 
types: 
 Domain definitions 
 Plant hierarchy items 
 Documents 
 Revision information 
 Loop data and instrument tag numbers 
 Wiring data (including connection information) 
 Process data 
 Specifications data 
 Loop drawing data 
 Hook-up drawing data 

For hook-up drawings, you can retrieve data for the following item types: 
 Domain definitions 
 Plant hierarchy items 
 Documents 
 Revision information 
 Instrument tag numbers 
 Process data 
 Hook-up drawing data 

All of the standard SmartPlant Instrumentation macros are displayed on the Macro Definitions 
dialog box. 
You can use SmartPlant Instrumentation macros in: 
 Enhanced reports — You can add macros to the various symbols used to represent items that 

appear in enhanced reports using the Symbol Editor, or you can add macros directly in an 
enhanced report after generation.  For further details, see Using Macros: An Overview in the 
Enhanced Report Utility User's Guide. 
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 CAD drawings — To display data in CAD drawings, you must add them to the blocks that are 
used in generating the drawings.  For further details, see Using Macros in CAD Blocks (on 
page 295). 

 Macros in a CAD application, that you want to solve with a general signal in SmartPlant 
Instrumentation, must have the general signal name (as defined in the SmartPlant 
Instrumentation Local Signal dialog box) added as a prefix to the CAD application macro.  For 
example, for the CAD macro PNL_NAME.1.4, to be recognized by SmartPlant Instrumentation 
and solved with the general signal called GENERALSIG1, you add the general signal name to the 
CAD macro as a prefix in the CAD application: GENERALSIG1.PNL_NAME.1.4. 

See Also 
Working with User-Defined Macro Functions (on page 299) 
Standard Functions (on page 300) 
Customizing Macro Definitions (on page 297) 
 

SmartPlant Instrumentation Macro Structure 
You select the SmartPlant Instrumentation macros that you want the software to recognize in 
hook-up drawings or in loop drawings by defining custom macro names on the Macro Definitions 
dialog box for the appropriate drawing type.  To see the entire list of SmartPlant Instrumentation 
macros, you can generate a macro report in the Loop Drawings module.  For details, see 
Generate a Macro Report (on page 295). 
Certain SmartPlant Instrumentation macros that include a group level have the following structure: 

[Macro_name.x] 
The letter 'x' designates the group level.  The group level depends on the number of macros in a 
group.  The software creates a group when several macros of the same macro type are 
associated with a tag number.  For example, when associating several tag categories with a tag 
number, the system combines all the TAG_CAT macros into a TAG_CAT.x group so that you set 
a separate level for each macro: TAG_CAT.1, TAG_CAT.2, TAG_CAT.3, and so forth. 
For CAD drawings only, if desired, you can associate each macro with a macro function, which 
determines how the software performs string manipulation on the target data.  For example, a 
macro function can retrieve the entire target data string or just part of the data string and display it 
on the generated drawing.  Associating a macro function with a macro is optional.  For details, 
see Working with User-Defined Macro Functions (on page 299). 
The structure of a macro including a user-defined macro function is as follows: 

[Macro_name.F1] 
where F1 is the macro function abbreviation.  If you set a macro function as a default, the software 
automatically adds the abbreviation of the function to the macro in the actual CAD drawings 
(SmartSketch, AutoCAD and MicroStation).  If you do not set a macro function as default, you 
need to add the macro function abbreviation manually on the drawing. 

 
 The separator in a macro string is a period (.), therefore within a macro name segment, 

periods are not allowed. 
 Some of the wiring macros have a different structure.  For details, see Wiring Module Macros 

Conventions (see "Wiring Module Macros - Conventions" on page 293). 
 



 Loop Drawings Module 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 289 
 

Loop Block Macro Syntax 
There are nine different permutations for the syntax used to construct macros for use with CAD 
loop drawings in SmartPlant Instrumentation, four macros for  use with loops, loop blocks, and so 
forth, and five for use with wiring. The different segments that make up the macros are: 

 Macro_Name — the macro name, for example Tag_Num or Cbl_Num 
 IT — instrument type, for example FY 
 F1 — user defined function name, set in the User Defined Macro Function Properties 

dialog box, for example Trim 
 X — the group level (wiring macros), for example 2 
 Y — the group sequence (wiring macros), for example 3 
 Suffix — The tag suffix as used in the tag naming convention. 

 Each segment must be separated by a period (.) from the next segment 
The four syntax permutations for loop block macros are: 

 Macro_Name.IT 
 Macro_Name.F1.IT 
 Macro_Name.IT.Suffix 
 Macro_Name.F1.IT.Suffix 

The five syntax permutations for wiring macros are: 
 Macro_Name.F1.X.Y 
 Macro_Name.X.Y.IT 
 Macro_Name.F1.X.Y.IT 
 Macro_Name.X.Y.IT 
 Macro_Name.F1.X.Y.IT.Suffix 

 

Title Block Macro List 
You specify macros in your title block by adding SmartText and defining the appropriate macro in 
the user properties.  The following list summarizes the macros available for use in enhanced 
report title blocks (where a macro name appears in parentheses, the main name is the macro alias 
while the name in parentheses is the actual database name). 

General 

Name Description 

plant_name or plnt_name Plant name 

area_name Area name 

sub_area_name Sub-area name 

unit_name Unit name 

unit_num Unit number 

unit_note Note added for unit 

city City where plant is located 

location Location of plant 
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Name Description 

owner (owner_name) Owner name 

domain_name (proj_name) Domain name 

domain_desc (proj_desc) Domain description 

eng_proj_name or proj_name 
(engineer_name) 

Project name 

eng_proj_desc or proj_desc 
(engineer_desc) 

Project description 

date Date of drawing generation 

time Time of drawing generation 

Loop 

Name Value Description 

loop_name  Loop name 

loop_serv  Loop service 

loop_note  Loop note 

ref_name 1..5 Loop drawing reference name (for 
revisions 1 to 5) 

ref_desc 1..5 Loop drawing reference description (for 
revisions 1 to 5) 

Strip & Panel 

Name Description 

panel_name Panel name 

panel_note Panel note 

strip_name Strip name 

Segment & Profibus 

Name Description 

group_name Segment name 

wire_group_note Segment note 

Telecom Line 

Name Description 

line_name (tc_line_number_name) Telecom line name 
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Telecom Class 

Name Description 

class_name (tc_net_cls_name) Telecom class name 

Telecom Speaker 

Name Description 

cmpnt_name Telecom speaker name 

cmpnt_note Telecom speaker note 

Cable 

Name Description 

cable_name (cable_num) Cable name 

cable_note Cable note 

Cable Harness 

Name Description 

harness_name (cable_harness_name) Cable harness name 

Location 

Name Description 

location_name (panel_loc_name) Panel location 

Rack 

Name Description 

rack_name (cabinet_rack_name) Cabinet rack name 

Hook-Up 

Name Description 

hu_name Hook-Up name 

gen_output_file Hook-Up output file name 

hu_udf_co1 Hook-Up user defined fields 

hu_type_desc Hook-Up description 
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Drawing 

Name Value Description 

dwg_name  Drawing name 

dwg_desc  Drawing description 

dwg_num  Drawing number 

cl_ck_by or cl_chk_by  Client checked by 

cl_ck_date or cl_chk_date  Client checked date 

cl_engr_by  Client engineered by 

cl_engr_date  Client engineered date 

cl_appr_by  Client approved by 

cl_appr_date  Client approved date 

ven_appr_by  Vendor approved by 

ven_appr_date  Vendor approved date 

ven_chk_by or ven_ck_by  Vendor checked by 

ven_ck_date or ven_chk_date  Vendor checked date 

ven_drwn_by  Vendor drawn by 

ven_drwn_date  Vendor drawn date 

ven_dsgn_by  Vendor design by 

ven_dsgn_date  Vendor design date 

ven_prop_by  Vendor proposed by 

ven_prop_date  Vendor proposed date 

loop_func (loop_func_name)  Loop function 

dwg_udf_c01... - 
...dwg_udf_c102 

 Drawing user- defined 
character fields 

loop_udf_c01... - 
...loop_udf_c50 

 Loop user-defined 
character fields 

curr_rev_name (current 
revision number) 

1 Current revision name 

pid_name  P&ID drawing name 

Sheetno  Current sheet number 

Sheettotal  Total number of sheets 

Sheetcount  <sheetno> of 
<sheettotal> 
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Revisions 
These macros have the structure [Macro_name.x.f1] where x is the revision number (max.value 
=5), and f1 is the abbreviation for a user-defined function (optional). 

Name Value Description 

dwg_rev_num or rev_no 1..5 Drawing revision number (for 
revisions 1 to 5) 

dwg_rev_desc or 
rev_desc 

1..5 Drawing revision description 
(for revisions 1 to 5) 

dwg_rev_date or 
rev_date 

1..5 Drawing revision date (for 
revisions 1 to 5) 

curr_rev_num  Last active revision 

rev_create_by or 
rev_drawn_by 

1..5 Revision created by (for 
revisions 1 to 5) 

rev_sign 1..5 Revision signed by (for 
revisions 1 to 5) 

rev_chk_by 1..5 Revision checked by (for 
revisions 1 to 5) 

rev_appr_by 1..5 Revision approved by (for 
revisions 1 to 5) 

rev_udf_c01... - 
...rev_udf_c20 

 Revision user-defined 
character fields 

 
 
 

Wiring Module Macros - Conventions 
To retrieve wiring information, SmartPlant Instrumentation uses macros that are identified by their 
macro name, together with appropriate parameters needed to retrieve specific tag data. 
When you create a tag number and a matching device panel, the software creates a group that 
includes all the wires associated with that specific tag.  Each wire can belong to one group 
only.  Once you connect a cable with the device panel, the software sorts the wires into different 
group levels.  Every connection of a wire to a terminal is assigned a group sequence that maps 
and numbers the connections starting with the value '1' that is usually on the device panel side. 
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The following diagram is an example that explains the meaning of wire groups. 

 
Before you can start to build typical wiring drawing blocks, you need to know: 
 How to identify typical wiring routing. 
 The number of routing levels, usually determined by the number of wires connected to the 

device-panel, but this may be different if, for example, a power supply is involved. 
 The group sequence that each wire and terminal connection has in the current typical routing. 

Syntax 
The syntax used for wiring macros is as follows: 
[Macro_name.x.y] 

where the letter 'x' designates the group level and the letter 'y' designates the group 
sequence. 

Examples 
The following examples show how the wiring macro syntax is used to retrieve specific data for a 
terminal and for a wire: 
 To retrieve the number of the terminal at Group Level 1 and Group Sequence 3, the required 

macro is TERM_NUM.1.3. 
 To retrieve the color of the wire at Group Level 2 and Group Sequence 2, the required macro 

is W_CLR.2.2. 

 
 When retrieving data for a wire, you may use the group sequence corresponding to either of 

the wire ends, so for example, to extract the wire name for the wire at Group Level 2 whose 
ends have sequence numbers 3 and 4, you may use either macro W_TAG.2.3 or W_TAG.2.4. 

 Control system macros do not require the 'y' (group sequence) parameter. 
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 If you generate a loop drawing with tag numbers that have incomplete wiring, the macros will 
not be able to retrieve all the needed wiring information since propagation is bi-directional: 
from the field device and from the Control System. 

 The software does not order wire sequence numbers sequentially until the propagation 
process finds signal continuity between the field device and the Control System. 

 Special macros exist to extract data related to an overall shield.  The macro for a wire that is 
used as an overall shield has the format [OSHW_TAG.x.y.] and the macro for a terminal to 
which an overall shield is connected has the format [OSHT_NUM.x.y.].  For these macros to 
function properly, the following conditions must be met: 

 The polarity of the wire must be designated as Shield. 
 The level and sequence of at least one of the wires in the cable must be defined. 
 For CAD drawings only, if desired, you can associate each macro with a macro function, which 

determines how the software performs string manipulation on the target data.  For example, a 
macro function can retrieve the entire target data string or just part of the data string and 
display it on the generated drawing.  Associating a macro function with a macro is optional. 

 The general format of a wiring macro that includes a user-defined macro function is 
[Macro_name.F1.x.y]. 
 

See Also 
Working with User-Defined Macro Functions (on page 299) 
 

Generate a Macro Report 
1. Start the Hook-Ups or Loop Drawings module. 
2. Click Reports > Macros. 
3. On the Macro Report Print Request dialog box, do one of the following: 

 Click No grouping if you want to generate a report in which all the macros are displayed 
in alphabetical order. 

 Click Group by item type if you want to generate a report in which the macros are 
grouped alphabetically by item type. 
 When you group the macros by item type, the software organizes the report pages 

according to the module titles. 
4. Click OK to generate the report. 
 

Using Macros in CAD Blocks 
A macro enables you to perform a number of automated actions in a predefined order.  When 
using a CAD application, macros are used to retrieve data from the database to a predefined 
location on the drawing layer.  The macros are assigned per block and the text that they retrieve is 
eventually displayed as part of the block. 
You can assign one or more macros to each block.  Some macros are used for retrieving data for 
instruments with the same function.  For example, flow transmitters, flow elements, and I/P 
transducers have a common function.  Therefore the same macros are used to retrieve the data 
for each of these instruments.  The macros required for each of these instruments are the tag 
prefix (TAG_PRFX), instrument type (FUNC_ID), tag number (TAG_NUMC), and tag suffix 
TAG_SUFF). 
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The diagrams below display a loop drawing that was generated along with its related 
macros.  This example illustrates how the same macros can be used to extract the same or 
different data for different tag numbers – the Tag Prefix and Tag Number are identical for each of 
the three instruments.  However, the instrument type is different, although represented by the 
same macro. 

 For the instruments in this example, the tag suffix was not used. 

Loop Drawing with Macros  Generated Loop Drawing 

 

 
If you have used the standard drawing blocks supplied with SmartPlant Instrumentation, or if you 
created your own drawing blocks with the predefined macros, SmartPlant Instrumentation 
recognizes these macros when generating the loop drawings, and you do not need to make any 
modifications to them.  However, you may want to modify macros in the following circumstances: 
 If your drawings include macro names other than the predefined ones, you can customize the 

default macro definitions as required.  For details, see Customizing Macro Definitions (on 
page 297). 

 If you want to modify certain display formatting of the macros, you can specify user- defined 
macro functions.  For details, see Working with User-Defined Macro Functions (on page 299). 

 If you want to use an external data source other than the SmartPlant Instrumentation database 
for displaying information defined by a macro, you can connect to the appropriate database 
and use the macros defined in that database.  For details, see Using External Macro Data 
Sources (on page 303). 

 Macros in a CAD application, that you want to solve with a general signal in SmartPlant 
Instrumentation, must have the general signal name (as defined in the SmartPlant 
Instrumentation Local Signal dialog box) added as a prefix to the CAD application macro.  For 
example, for the CAD macro PNL_NAME.1.4, to be recognized by SmartPlant Instrumentation 
and solved with the general signal called GENERALSIG1, you add the general signal name to the 
CAD macro as a prefix in the CAD application: GENERALSIG1.PNL_NAME.1.4. 

See Also 
Steps in Loop Drawing Generation Using a CAD Application (on page 278) 
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Command line prompt Action  

ATTDEF Press Enter 

Attribute modes Press Enter 

Attribute Tag: Type in [macro name] and press Enter 

Attribute prompt: Press Enter. 

Default attribute value Type in [macro name] and press Enter 

Justify/Style/<Start point>: Position cursor and click once to define the bottom left position of 
the string. 

Height: Position cursor and click once to determine the height of the 
macro text.  (The height of the macro text is also dependent on 
the current font size.) 

Rotation angle <0>: Type in a number to represent the angle of rotation of the macro 
text from the horizontal (the default is 0). 

 You can have AutoCAD automatically enter most of the above parameters by using the ATT 
AutoLISP application.  This application is automatically installed if you select AutoCAD as your 
default CAD interface.  By using the ATT application you only need to enter the macro name 
once, and enter the start point, height and rotation parameters. 
 

Customizing Macro Definitions 
The database contains a number of default macros predefined for convenience of use and 
uniformity.  If needed, for any default macro, you can assign one or more custom macro names or 
change the macro description on the Macro Definitions dialog box.  You can also associate a 
macro function with a particular macro name. 

 
 Other users working in the same domain or in the same project (when the domain type is 

Owner operator) can use your customized macro definitions. 
 A macro name can contain a maximum of 30 characters. 
 If you want to assign a macro function to a macro directly on a drawing, you can add a function 

abbreviation of up to 4 characters to the macro.  The total number of allowed characters, 
including separators (periods) is 50. 

 To see the entire list of SmartPlant Instrumentation macros, you can generate a macro report 
for the type of drawings you are working with (hook-ups or loop drawings).  For more details, 
see Generate a Macro Report (on page 295). 

 Plug and Socket macros, for example PIN_NAME, are not supported in CAD generation. 

See Also 
Create a New Macro Definition (see "Create a New Hook-Up Macro Definition" on page 298) 
Delete a Macro Definition (see "Delete a Hook-Up Macro Definition" on page 298) 
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Create a New Hook-Up Macro Definition 
1. From the Hook-Ups or Loop Drawings module, do one of the following: 

 Click Tables > Macro Definitions. 

 Click . 
2. Select the desired macro by choosing the item type and property, and where applicable, the 

relation between a specified item type and its parent.  To do this, make a selection from each 
of the lists at the top of the dialog box. 

3. In the Macro definition details data window, select the desired macro definition. 
 If there are a large number of macro definitions in the Macro definition details data 

window, under Find macro definition, select a column heading and then type a value.  For 
example, if you select Function as a column heading and type a macro function value, in the 
data window, the software locates the macro definition to which that macro function belongs. 

4. To create a customized macro definition, do one or more of the following: 
a. Under User-Defined Macro Name, type the desired user name for your macro. 

 The User-Defined Macro Name field must contain a name, it cannot be left 
empty.  If a name is missing, the macro will not function and data could be lost. 

b. Click in the Description field and change the description as desired. 
c. Under Macro Function, select a macro function to modify the appearance of the retrieved 

data. 
d. To add another customized macro definition, click New and repeat the previous step. 
e. Click Apply to accept your customized macro definitions. 

See Also 
Using Macros in CAD Blocks (on page 295) 
 

Delete a Hook-Up Macro Definition 
1. From the Hook-Ups or Loop Drawings module, do one of the following: 

 Click Tables > Macro Definitions. 

 Click . 
2. Select the desired macro by choosing the item type and property, and where applicable, the 

relation between a specified item type and its parent.  To do this, make a selection from each 
of the lists at the top of the dialog box. 

3. In the Macro definition details data window, select the row containing the macro definition 
that you want to delete. 

 If there are a large number of macro definitions in the Macro definition details data 
window, under Find macro definition, select a column heading and then type a value.  For 
example, if you select Function as a column heading and type a macro function value, in the 
data window, the software locates the macro definition to which that macro function belongs. 

4. Click Delete. 

See Also 
Using Macros in CAD Blocks (on page 295) 
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Working with User-Defined Macro Functions 
You can perform string manipulation on retrieved data by assigning user-defined functions to the 
macro that retrieved the data.  You create user-defined macro functions on the basis of 
SmartPlant Instrumentation standard macro functions. 
The macro function affects the display formatting of the data which the macro returns after 
generation.  For example, you can specify a user-defined function that removes all the spaces in 
the retrieved values and displays the remaining characters as upper case. 
You can apply functions to macros directly on the CAD drawing or in the database. 

Priority for Macro Functions 
The order of priority for macro functions is as follows: 
1. CAD drawing level — A macro function that you specify at the CAD drawing level has the 

highest priority for execution.  In this case, you type the macro function abbreviation directly 
in the generated drawing in your CAD application.  At this level, you can define one function 
per macro. 

2. Database level — The next highest level of priority for execution is when you define a function 
with a specific macro. 

3. Database level — The lowest priority for execution is given when you define a default 
function.  To learn how to set a macro function as default, see Create a User-Defined Macro 
Function (on page 302). 

Macro Function Syntax 
If you want to apply the highest macro function priority do the data retrieval, you can associate a 
function with a macro directly on the CAD drawing block using the function abbreviation.  The 
function abbreviation is a string with maximum of 4 characters, the first of which must be a 
letter.  The general structure of a macro with a function is: 

[Macro_name.F1] 
where F1 is the macro function abbreviation. 
The general format of a wiring macro that includes a user- defined macro function is: 

[Macro_name.F1.x.y] 

Example 
The following is an example of a macro with a function: 

W_CLR.1.1.RS 
In this example, the macro name is W_CLR.1.1 and the macro function is RS (remove spaces). 

 
 Use a period (.) as the separator to separate the individual macro segments. 
 The software uses the macro function parameters. 
 When using a macro function at the database level, you should not define that macro function 

on the drawing block or in the generated drawing.  For the software to recognize macro 
functions defined at the database level, on the Preferences dialog box, under Loop 
Drawings > General, select the Use macro functions check box.  If you set a macro 
function as default, the software automatically adds the abbreviation of the function to the 
macro in the actual CAD drawings, and you do not need to add it with every block and 
macro.  If you do not set a macro function as default, you need to add the macro function 
abbreviation manually on the drawing. 
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 Macros in a CAD application, that you want to solve with a general signal in SmartPlant 
Instrumentation, must have the general signal name (as defined in the SmartPlant 
Instrumentation Local Signal dialog box) added as a prefix to the CAD application macro.  
For example, for the CAD macro PNL_NAME.1.4, to be recognized by SmartPlant 
Instrumentation and solved with the general signal called GENERALSIG1, you add the 
general signal name to the CAD macro as a prefix in the CAD application: 
GENERALSIG1.PNL_NAME.1.4. 

See Also 
Customizing Macro Definitions (on page 297) 
 

Standard Functions 
A standard macro function is a function that is supplied with the software and contains a set of 
predefined commands.  You can associate a standard function with SmartPlant Instrumentation 
macros or specify a combination of standard functions to create a user-defined macro function. 
SmartPlant Instrumentation has seven standard macro functions.  The following table shows how 
each of the standard functions modifies the macro string. 

Function Description Resulting String Comments 

None Original string FT – 100 
a[space][space] 

  

Trim Trims trailing spaces FT    –  100 a Does not affect internal spaces 

Upper Changes characters 
to upper case 

FT  – 100 
A[space][space] 

  

Lower Changes characters 
to lower case 

ft  – 100 
a[space][space] 

  

Substr (3,5) Returns a substring of 
the original string 

- 10 In this example, the substring 
starts from 3rd character and 
extends to 5 characters including 
the starting character 

RemSpace 
(1) 

Clears internal 
spaces when 
exceeding the 
maximum number of 
allowed spaces. 

FT - 100 
a[space][space] 

In this example, where internal 
spaces exist, a maximum of 1 
space is allowed.  Does not 
affect trailing spaces. 

RemSpace 
(0) 

  FT- 100a[space][space] No internal spaces allowed 

Integer Converts real 
numbers to integers 

    

Left Displays from the left 
of the string, a specific 
number of characters 
according to user 
defined parameters 

FT 1 In this example, 4 characters 
from the left of the string are 
displayed 
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Function Description Resulting String Comments 

Right Displays from the 
right of the string, a 
specific number of 
characters according 
to user defined 
parameters 

100 a[space][space] In this example, 7 characters 
from the right of the string are 
displayed 

Left Trim Removes spaces to 
the left of the first 
character  

FT - 100 
a[space][space] 

In this example any spaces to the 
left of the character F are 
removed from the string 

Right Trim Removes spaces to 
the right of the last 
character  

FT - 100 a In this example any spaces to the 
right of the character a are 
removed from the string 

 

Standard Function Parameters 
Some standard functions require additional parameters in their definitions: 

Function Parameters Explanation 

Substr Start position   
 Length The position of the first character of the sub- string 

from the start of the string to be displayed, and the 
number of characters to be displayed in the sub- string

RemSpace Max. contiguous spaces Maximum number of internal spaces allowed in the 
string 

Left Length The number of characters to be displayed starting 
from the left of the string 

Right Length The number of characters to be displayed starting 
from the right of the string 

 
 You cannot change the code of standard macro functions. 
 When calculating the number of characters to be trimmed, remember that a space is counted 

as one character. 

See also: 
Working with User-Defined Macro Functions (on page 299) 
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Create a User-Defined Macro Function 
Each user-defined macro function includes a set of selected standard functions.  Use the 
following procedure to create user-defined macro functions at the database level. 
1. Depending which module you have open, do one of the following: 

 In the Loop Drawings module, click Tables > User Defined Macro Functions. 
 In the Hook-Ups module click Tools > User Defined Macros Functions. 

2. On the User-Defined Macro Functions dialog box, click New to open the User- Defined 
Macro Function Properties dialog box. 

3. Type a name and macro function abbreviation for the new macro function, and, if needed, a 
description. 

 If you want to use macro function abbreviations in loop block macros, make sure 
the macro function abbreviation is different from an instrument type abbreviation, which is a 
required segment in the loop macro function string.  For details about loop blocks and loop 
block macro structure, see Loop Blocks (on page 256). 

4. To superpose a standard function, do the following: 
a. Click Insert to open the Standard Macro Functions dialog box. 
b. Select a standard function and click OK. 
c. If you selected a standard function that can accept parameters, specify appropriate values 

in the fields.  For details, see Standard Functions (on page 300). 
 The user-defined macro function operates in the macro string according to the order of 

the standard functions superposition.  Use Move Up and Move Down to change the order of 
the standard functions. 

5. Click OK to confirm your changes and close the User-Defined Macro Function Properties 
dialog box. 

6. Do one of the following: 
 Select Set macro function as default to apply the specified macro function to all existing 

macros. 
 Clear Set macro function as default to be able to associate the specified macro function 

with a specific macro. 
 
 

Modify a User-Defined Macro Function 
1. Depending which module you have open, do one of the following: 

 In the Loop Drawings module, click Tables > User Defined Macro Functions. 
 In the Hook-Ups module click Tools > User Defined Macros Functions. 

2.  
3. On the User-Defined Macro Functions dialog box, select the row with the macro function 

you want to modify, and click Properties to open the User-Defined Macro Function 
Properties dialog box. 

4. Modify the macro function properties as desired. 
5. To superpose or change a standard function, do the following: 

a. Click Insert to open the Standard Macro Functions dialog box. 
b. Select a standard function and click OK. 
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c. If you selected a standard function that can accept parameters, specify appropriate values 
in the fields.  For details, see Standard Functions (on page 300). 
 The user-defined macro function operates in the macro string according to the order of 

the standard functions superposition.  Use Move Up and Move Down to change the order of 
the standard functions. 

6. Click OK to confirm your changes and close the User-Defined Macro Function Properties 
dialog box. 

7. Do one of the following: 
 Select Set macro function as default to apply the specified macro function to all existing 

macros. 
 Clear Set macro function as default to be able to associate the specified macro function 

with a specific macro. 
 
 

Delete a User-Defined Macro Function 
1. In the Loop Drawings or Hook-Ups module, click Tables > User Defined Macro Functions. 
2. On the User-Defined Macro Functions dialog box, select the row with the macro function 

you want to delete. 
3. Click Delete. 

See Also 
Modify a User-Defined Macro Function (on page 302) 
 

Using External Macro Data Sources 
You can use macros from an external source with the macros in your domain.  This means that 
macro sources that are both external and internal in relation to SmartPlant Instrumentation are 
used when you generate a loop drawing. 
Working with external macro sources includes the following steps: 
1. Establishing a connection to an external data source from which SmartPlant Instrumentation 

can retrieve macro data. 
2. In the Domain Explorer, assigning the connected external data source to the loop numbers 

for which you want to generate loop drawings. 
 Before you start working with external macro data sources, make sure that the 

external source data naming and structure conventions comply with the SmartPlant 
Instrumentation macro conventions.  For details, see External Macro Structure Conventions (on 
page 304) and External Macro Naming Conventions (on page 304). 

 Macros in a CAD application, that you want to solve with a general signal in SmartPlant 
Instrumentation, must have the general signal name (as defined in the SmartPlant 
Instrumentation Local Signal dialog box) added as a prefix to the CAD application macro.  For 
example, for the CAD macro PNL_NAME.1.4, to be recognized by SmartPlant Instrumentation 
and solved with the general signal called GENERALSIG1, you add the general signal name to the 
CAD macro as a prefix in the CAD application: GENERALSIG1.PNL_NAME.1.4. 
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External Macro Naming Conventions 
The macro names for external macros in a drawing must be identical to the names in the external 
database file or table. 

 
 To be able to use an external macro source, you need to establish a connection to the macro 

source in the Define External Macro Source dialog box. 
 In your target drawing blocks or symbols, you need to add the E_ prefix to the name of the 

macro that you want to use to retrieve data from the external macro source. 
For example, if a drawing contains an external macro named PROCESS which is used to retrieve 
the string Flow, the macro label must be written as E_PROCESS.  This means that after 
generation, every occurrence of the label E_PROCESS in the drawing will be replaced with the 
value Flow. 
 
 

External Macro Structure Conventions 
SmartPlant Instrumentation has set a few basic requirements regarding the structure of external 
data sources from which you add macros to your loop drawings.  Therefore, before you use an 
external macro make sure that its structure complies with SmartPlant Instrumentation 
conventions.  The structure has to include the tag number (cmpnt_name) as the first (leftmost) 
column, and occupying the rest of the columns, the desired macros and their retrieval values. 
The following table is an example of an external source structure (the table headers below 
exemplify column names): 

cmpnt_name macro1 macro2 macro3 

108-PI -2212 Pressure Bar Indicator 

108-FE -2225 Flow Ft3/s Element 
In the above example, using the macro macro1 in a loop drawing generated for instrument tag 
108-PI-2212, will display the retrieved value Pressure instead of the macro1 string.  You can 
create the above structure by using any text editing application (for Text format files), dBase 
(*.dbf) editing tools, or any other appropriate database editing utility.  For further details, see the 
user's guide for your database platform. 

 The name of the first (leftmost) column name must always be cmpnt_name 
(representing the tag number). 
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Connecting to an External Data Source 
The first stage is connecting to the appropriate source data form whose macro data you want to 
use.  After connecting to the database or the database file you can generate CAD drawings using 
the retrieved macros as required. 
You can connect to any of the following database platforms and files: 
 Oracle (only if you selected Oracle as your current database platform during Setup or you 

installed an Oracle client manually) 
 Microsoft SQL Server (only if you selected SQL Server as your current database platform 

during Setup or you installed a SQL Server client manually) 
 Sybase Adaptive Server Anywhere (only if you selected Sybase Adaptive Server Anywhere as 

your current database platform during Setup or you installed a Sybase Adaptive Server 
Anywhere client manually) 

 Microsoft Access 
 *.dbf 
 ASCII delimited files 
 Excel worksheets 
 Text files 

 The external database file with source macros must not reside in the SmartPlant 
instrumentation home folder. 

 You can connect to database platforms (Oracle, SQL Server or Sybase Adaptive Server 
Anywhere) other than your current database platform but you have to comply with the external 
database platform requirements.  For example, if your current database platform is Sybase 
Adaptive Server Anywhere and you want to import data from Oracle, you must have an Oracle 
client installed and running on your computer.  See Internal Setup Utility to learn how to configure 
your environment to connect to database platforms other than your current database platform. 

See Also 
Connecting to Database Platforms Other Than ODBC (on page 306) 
Connecting to an ODBC Profile (on page 306) 
 

Prerequisites for Connecting to a dBase ODBC Profile 
You can generate loop drawings in SmartPlant Instrumentation using your dBase (.dbf) external 
macro source.  Prior to connecting to dBase (.dbf) external macro source, you need to create a 
dBase ODBC profile in accordance with the driver requirements of your Windows system. 
The following prerequisites apply: 
 In your ODBC Data Source Administrator, select the Microsoft dBase Driver. For details, see 

Configure ODBC Data Source for DBF Files. 
 Create an ODBC profile using your Windows ODBC Data source Administrator.  For further 

details, see the user's guide for your database platform. 
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Connecting to an ODBC Profile 
This procedure describes the steps required to connect to a database file (for example, .dbf, 
ASCII, and so forth) using the ODBC profile.  This way you can generate your CAD drawings 
using macros from an external macro source. 
The following file types are available: 
 dBase (.dbf) 
 Excel worksheets 
 ASCII delimited files 
 Text files 

 If you want to connect to dBase (.dbf file), you must create an ODBC profile in accordance 
with your Windows system.  For more details, see Prerequisites for Connecting to a dBase ODBC 
Profile (on page 305) and Configure ODBC Data Source for DBF Files. 

Connect to an ODBC Profile 
1. Click Actions > Define External Macro Source. 
2. On The Define External Macro Source dialog box, from the Database type list, select 

ODBC. 
3. From the Data source list, select the source database file profile, for example, .dbf, ASCII 

files, and so forth. 
4. Click Browse and select macro source file. 

See Also 
Connecting to an External Data Source (on page 305) 
 

Connecting to Database Platforms Other Than ODBC 
This procedure describes the steps required to connect to a database platform such as Oracle or 
SQL Server.  To connect to an external database platform, you must have access rights to the 
database server as well as the appropriate database drivers.  You must also have the appropriate 
settings in the configuration files (for example, .ini files) and in the Windows registry. 

Connect to Database Platforms Other Than ODBC 
1. Click Actions > Define External Macro Source. 
2. In The Define External Macro Source dialog box, from the Database type list, select the 

source database platform: Oracle or SQL Server. 
3. In the Server box, type the name of the server that you use to connect to the database server: 

 <alias name> — if you connect to Oracle 
 <server name> — if you connect to SQL Server 

4. In the Database schema logon name box, type the logon name required to connect to the 
source domain in the database server. 

5. In the Database schema logon password box, type the logon password required to connect 
to the source domain in the database server. 
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Assigning an External Macro Data Source 
This procedure enables you to assign an external macro data source to one or more loop 
numbers. 

 
 To be able to use an external macro source, you need to establish a connection to the macro 

source in the Define External Macro Source dialog box. 
 In your target drawing blocks or symbols, you need to add the E_ prefix to the macros which 

you want to use to retrieve data from an external macro source. 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the loop level in the 

Loops folder. 
2. Do one of the following: 

 In the tree view pane, right-click a desired loop. 
 Items pane, select and right-click several loops. 

3. On the shortcut menu, click Actions > Assign External Macro Source. 
4. Under the Macro Source column, do one of the following: 

 If your macro source is an ODBC profile, type the exact path and the file name of the 
source database file. 

 If your macro source is a specific table on Oracle or SQL Server, you need to type the 
exact table name. 

 If you want to assign the same macro source to all the loop numbers displayed in the Assign 
External Macro Source dialog box, select a row with the desired macro source and then select 
Apply same source to all displayed loop numbers. 

See Also 
Using External Macro Data Sources (on page 303) 
Connecting to an External Data Source (on page 305) 
 

MicroStation is a three-dimensional CAD software package which includes features to allow the 
interchange of design data with SmartPlant Instrumentation.  SmartPlant Instrumentation 
supplies the design data, and generates a schematic drawing associated with a specific loop, 
component or block by means of MicroStation. 

 
 SmartPlant Instrumentation use of the term block corresponds to the term cell in 

MicroStation. 
 This section explains how MicroStation works with SmartPlant Instrumentation.  All the topics 

in this section require a basic level of familiarity with MicroStation.  Refer to the MicroStation 
user manual for detailed explanations of MicroStation functionality. 

MicroStation and SmartPlant 
Instrumentation 
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System Requirements 
The following minimum hardware and software requirements must be met before installing 
MicroStation on your computer: 
 16 MB RAM in addition to SmartPlant Instrumentation installation requirements. 
 75 MB of free hard disk space. 

Refer to the Getting Started section of your MicroStation user manual for more detailed 
requirements of the MicroStation software package. 
 

Set MicroStation for SmartPlant Instrumentation 
Once MicroStation has been successfully installed, a number of modifications still have to be 
made to ensure compatibility with SmartPlant Instrumentation. 

Define MicroStation Settings in SmartPlant Instrumentation 
To generate CAD loop drawings using MicroStation, the temporary folder path setting on the 
General page of the SmartPlant Instrumentation Preferences dialog box must not exceed fifty 
two characters.  This means that you cannot use the default path C:\Program 
Files\SmartPlant\Instrumentation\TEMP.  The same restriction applies to the CADFunc folder 
path you define on the CAD File Locations page for loop drawings or hook-up drawings on the 
Preferences dialog box.  A longer path prevents MicroStation from generating or displaying 
drawings or cells from SmartPlant Instrumentation.  If your CAD function folder path is longer than 
allowed, you need to copy the CADFunc folder and its content to another location, for example, 
C:\CAD\CADFunc. 

Define MicroStation Settings in MicroStation 
The following modifications need to be done using the options on the menu bar of the main 
MicroStation window. 
1. Click Workspace > Preferences. 
2. On the Preferences dialog box, under Category, select Memory Usage and ascertain that 

your settings are as follows: 

Setting MicroStation SE MicroStation J 

Max. Element Cache 8000 10240 

Resource Cache 24 1024 

Undo Buffer 256 2048 

Font Cache 30 256 

Conserve Memory Cleared Cleared 

Disable OLE Automation Cleared Cleared 
 When working with MicroStation, clear Conserve Memory check box. 
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3. Under Category, select Operation and ascertain that your settings are as follows: 

Setting Value 

Locate Tolerance 10 

Pointer Size Normal 

Pointer Type Orthogonal 

Display Levels Names 

Immediately Save Design Changes Selected 

Save Settings on Exit Cleared 

Compress Design on Exit Cleared 

Enter into Untitled Design Selected 

Reset Aborts Fence Operations Selected 

Level Lock Applies for Fence Operations Selected 

Use Semaphore File for Locking Cleared 
 When working with MicroStation, the Immediately Save Design Changes check box 

must be selected to enable viewing or generation of loop drawings if MicroStation was not 
previously launched. 

4. Under Category, select Tags and ascertain that your settings are as follows: 

Setting Value 

Prompt on Duplicate Tag Sets Cleared 

Use Design File Tag Sets by Default Cleared 

Place Tags in Same Graphic Group Cleared 
5. When finished, click OK to return to the main MicroStation window. 
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S E C T I O N  3 6  

Working with MicroStation 
This section contains topics that relate to procedures within Microstation. 

In This Section 
Create Tag Sets (MicroStation) ..................................................... 311 
Export Tag Sets (MicroStation) ..................................................... 312 
Import a Tag Set (MicroStation)..................................................... 312 
Link a Tag to a Drawing Element (MicroStation) ........................... 312 
Create a Cell Library (MicroStation) .............................................. 313 
Fence Elements for a Cell (MicroStation) ...................................... 313 
Define the Cell Origin (MicroStation) ............................................. 314 
Define the Coordinates of the Cell Origin (MicroStation) .............. 314 
Add a Cell to the Cell Library (MicroStation) ................................. 314 
Preview a Cell (MicroStation) ........................................................ 314 
Display a Cell on the Desktop (MicroStation) ................................ 315 
Generating a Report Using MicroStation ....................................... 315 
 
 

Create Tag Sets (MicroStation) 
In MicroStation you group tags into tag sets.  Use this procedure when you need to create a new 
tag set from scratch.  To save time it is recommended that you duplicate and rename tag sets 
instead of creating new ones.  You can save tag sets to a tag set library file and then copy them to 
other files as desired. 
1. In the main MicroStation window, click Element > Tags > Define. 
2. In the Tag Sets window, under Sets, click Add. 
3. On the Tag Set Name dialog box, type the desired name, for example instrument. 
4. Click OK to accept the value and reopen the Tag Sets window. 
5. Repeat the above steps to add another tag set named loop. 
6. In the Tag Sets window, under Sets, select instrument. 
7. Under Tags, click Add. 
8. On the Define Tag dialog box, type tag_loc.  This value represents the tag location. 
9. Repeat the above steps to add another property named tag_num. 

 The text in the Default Tag Value pane must be typed in upper case. 
10. In the Tag Sets window, under Sets, select loop. 
11. Under Tags, add the following properties: 

 loop_func (Loop Function) 
 loop_type (Loop Type) 
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Export Tag Sets (MicroStation) 
Exporting Tag Sets allows you to save new tag sets in a library file.  This makes it more 
convenient to import the exported tag set. 
1. In the Tag Sets window, select the Set (for example, instrument) to export. 
2. Click File > Export > Create. 
3. On the Export Tag Library dialog box, click OK to return to the Tag Sets window. 
4. Repeat the previous steps to create a tag library for the loop set. 

 The next time you open a MicroStation session, select Import to display the latest tag 
set definition. 

 

Import a Tag Set (MicroStation) 
This procedure explains how to retrieve a previously created tag set from a tag library file. 
1. In the Tag Sets window, click File > Import. 
2. On the Open Tag Library dialog box, select the desired library and click OK to open the 

Import Sets dialog box. 
3. Click OK to reopen the Tag Sets window with the set and its associated tags displayed. 
4. To add another set, to the Tag Sets window, repeat steps 1 and 2, but this time select 

instrmnt.tlb on the Open Tag Library dialog box. 
 

Link a Tag to a Drawing Element (MicroStation) 
This procedure explains how to create a drawing element and associate it with the tag definitions 
that you defined in the Define Tag window. 
1. In the main MicroStation window, click Tools > Main > Tags. 
2. In the Tags window, select, for example, the Place Block tool from the Main tool palette to 

draw a rectangle on the MicroStation desktop. 
3. Select Attach tags to an element to open the Attach Tags dialog box. 
4. On the Attach Tags dialog box, place the cursor on the rectangle that you drew in step two: 

 
5. Double click the cursor to open the Attach Tags dialog box. 

 If you want to display another tag set, such as the loop tag set, open the Attach Tags 
dialog box and repeat steps 3 - 5. 

6. Click OK to display the tags on the desktop. 
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7. Move the tags, without clicking, to the desired location.  Below is a typical example. 

 
8. Click the left mouse button when the tag position is appropriate. 

The tag is now associated with the design element (the rectangle in this case). 
 

Create a Cell Library (MicroStation) 
This procedure explains how to create a cell library to which you can add cells. 
1. In the main MicroStation window, click Element > Cells to open an unnamed Cell Library 

window. 
2. Click File > New to open the Create Cell Library dialog box. 
3. Click OK to reopen the Cell Library window. 
4. Drag the Cell Library window as far off the desktop as possible and store it for future 

use.  The window will be recalled later when you add a cell to it. 
 

Fence Elements for a Cell (MicroStation) 
You can fence elements to globally perform actions on them in batch mode.  This allows you to 
identify the cell in a cell library to be recalled as many times as needed.  This enables you for 
example to edit the cell, or combine it with other cells to create a larger design. 
1. Set all the elements on the desktop, and select the fence icon on the main tool palette. 

 
2. Fence the desired elements. 

 
 Fencing an area automatically opens the Cell Library window.  Prior to saving a cell in the 

cell library you need to define the cell origin. 
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Define the Cell Origin (MicroStation) 
You define a cell origin to set the position of a graphic object in a design.  This will subsequently 
and automatically entail the Create action in the Cell Library window. 
1. Select the Define Cell Origin icon from the Main tool palette. 
2. Click the cursor on the lower left corner of the desktop. 

 Now that the cell origin is defined, you have to accurately set the cell origin coordinates (for 
details, see Define the Coordinates of the Cell Origin (see "Define the Coordinates of the Cell 
Origin (MicroStation)" on page 314)). 
 

Define the Coordinates of the Cell Origin (MicroStation) 
This procedure explains how to generate the cell origin coordinates for a graphic element placed 
on the desktop. 

1. With the cell origin defined (typically, on the lower left corner of the desktop), click  to 
open the AccuDraw window. 

2. Set the X and Y coordinates to 0.0000. 
3. Select all the check boxes. 
 

Add a Cell to the Cell Library (MicroStation) 
1. Open the Cell Library window. 
2. Click Create to open the Create New Cell dialog box. 

 Both Name and Description must be defined otherwise the software does not perform 
the create action. 

3. Click Create to display the new cell name and description in the data window of the Cell 
Library window. 

 

Preview a Cell (MicroStation) 
When several cells are listed in the cell library, it is recommended that you preview a cell to make 
sure that you have selected the correct one.  This procedure explains how to generate a 
thumbnail view of the cell. 
1. Open the appropriate cell library. 
2. Click the cell that you want to preview. 

A thumbnail view of the cell appears in the Print Preview pane. 
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Display a Cell on the Desktop (MicroStation) 
This procedure explains how to take a previewed cell and place it on the desktop.  This may also 
be useful when you want to relocate a cell to achieve a different design than the current one. 
1. Open the Cell Library window, click a cell to preview it, and then click Placement. 
2. On the Main tool palette, click the Place Active Cell icon. 

 A tool from the View Control bar may be needed to display your Cell. 
3. Move the mouse to the desired location on the desktop. 
4. Click to pin the cell to a selected location. 
5. If you need another copy of the same cell, repeat steps 3 and 4. 
6. When done, right click. 

 You can also add cells from other libraries, print/plot your design, and so forth.  Refer to the 
MicroStation user manual to learn more about the available MicroStation options. 
 

Generating a Report Using MicroStation 
You can generate SmartPlant Instrumentation reports using MicroStation from either SmartPlant 
Instrumentation or MicroStation.  When you generate the report from the MicroStation 
environment you need to manually open the desired report file using the Open dialog box in 
MicroStation.  However, the recommended method is to generate the reports from the SmartPlant 
Instrumentation Loop Drawings module (for details, see CAD Loop Drawing Generation: An 
Overview (see "CAD Loop Drawing Generation" on page 276)). 
 

In SmartPlant Instrumentation, you can create, view and edit installation details for all prepared 
instrument drawings (hook-ups) within a domain.  A hook-up is a graphical representation of an 
assembly drawing — a drawing prototype. 
You can perform various actions in the Reference Explorer, the Domain Explorer, and the 
Hook-Ups module. 
In the Hook-Up Item Libraries folder of the Reference Explorer, you define your item libraries, 
create and manage hook-up items.  You need to set a specific library as the active item library, 
which becomes your <plant> default library.  The completeness of this library is up to the user. 
In the Hook-Ups folder of the Domain Explorer, which depicts the hierarchy of hook-up data, you 
can organize hook-ups in hook-up types and associate hook-ups with instrument tags and 
hook-up items.  You can determine the name of each hook-up and hook-up type based on your 
specific requirements.  After that, you can generate hook-up drawings using the Enhanced 
Report Utility or your CAD application. 
Using the Hook-Ups module options, you generate various hook-up reports and a Bill of Material, 
define hook-up item manufacturers, make hook-up macro definitions, and so forth. 
 

Hook-Ups in SmartPlant Instrumentation
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Hook-Ups Module Window 
This window allows you to use general hook-up options, which do not depend on specific item 
selection in the Domain Explorer.  In this window, the following menu commands are available: 

Menu Command Description 

Associations > Default 
General Blocks 

Allows you to select default border and logo blocks to appear 
in all hook-up drawings that you generate.  For details, see 
Default General Blocks Dialog Box. 

Associations > Update Paths 
for Existing Drawings and 
Blocks 

Allows you to update paths globally for block files associated 
with tag numbers and for generated hook-up drawings.  The 
paths that you specify do not overwrite the default paths 
specified for new block files and output drawings on File 
Locations page of the Preferences dialog box.  For details, 
see Update Paths for Existing Drawings and Blocks Dialog 
Box. 

Reports Allows you to generate all reports that are available in the 
Hook-Ups module, for example, a Bill of Material, the 
Library Items report, and so forth.  For details, see Hook-Up 
Reports (on page 345). 

Tables > Macro Definitions Allows you to create or modify user-defined macros for use 
with hook- up drawings only.  For details, see Macro 
Definitions Dialog Box. 

Tables > Item Manufacturers Allows you to manage hook-up item manufacturer definitions 
and their descriptions.  For details, see Item Manufacturers 
Dialog Box. 

Tools > User-Defined Macro 
Functions 

Allows you to define or modify macro functions that can then 
be used with user- defined macros for hook-up or loop 
drawings.  For details, see User-Defined Macro Functions 
Dialog Box. 

 
 

Hook-Up Items and Libraries 
A hook-up drawing is made up of individually marked parts called items.  These items have to be 
purchased.   The service that a Bill of Material provides you with depends upon how completely 
you fill in the hook-up item library.  The minimum amount of data required to provide is the item 
number.  Entering more data is left to your discretion. 
SmartPlant Instrumentation allows you to define a large number of hook-up items and group them 
in item libraries and sub-libraries.  You create and manage item libraries in the Reference 
Explorer.  A new item library that you create automatically contains a default sub-library, which 
you can use for assigning hook-up items if you do not work with pipe specs.  For more information 
on implementation of pipe specs in SmartPlant Instrumentation, see Pipe Specs.  When defining 
a new item in SmartPlant Instrumentation, you can enter a number of hook-up item properties, 
such as item size, model, material, storage number, unit of measure, and so forth.  Also, it is 
possible to define hook-up item manufacturers in the Item Manufacturers the supporting table and 
then assign the appropriate manufacture to the item. 



 Hook-Ups in SmartPlant Instrumentation 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 317 
 

You must set one item library as the active item library for your <plant>.  After you create hook-up 
items in this library, you can use the Domain Explorer options to associate the appropriate 
sub-library with hook-ups, and then, associate specific items with these hook-ups.  After making 
the associations, you can generate Hook-Up Item List reports and a Bill of Material.  In the Bill Of 
Material, you can sort the items by the item order.  After associating hook-up items with a 
hook-up, the software generates new sequence numbers automatically and allows you to sort the 
items by their order of their assignment to a hook-up. 
In the Reference Explorer, hook-up items are displayed in the Hook-Up Item Libraries folder, 
under sub-libraries.  In the Domain Explorer hook-up items are displayed in the Hook-Ups 
folder, under hook-ups.  Hook-up items are indicated with the  icon. 
 

Hook-Up Item Libraries and Sub-Libraries 
An item sub-library is a term which refers to a part of an item library and contains a specific set of 
hook-up item data and associations.  You create and manage item libraries in the Reference 
Explorer, where item libraries are indicated with the  icon.  An item library can contain any 
number of user-defined sub-libraries that you can use when working with pipe specs.  A new item 
library that you create automatically contains a default sub-library, which you can use for 
assigning hook-up items if you do not work with pipe specs.  For more information on 
implementation of pipe specs in SmartPlant Instrumentation, see Pipe Specs.  Sub-libraries are 
indicated with the  icon. 
You must set one item library as the active item library for your <plant>.  After you create hook-up 
items in this library, you can associate the appropriate sub-library with hook-ups, and then, 
associate specific items with these hook-ups.  In the Reference Explorer, the active item library 
is indicated with the  icon. 
 
 

Workflow for Creating Hook-Up Items in the Reference 
Explorer 

This workflow describes the steps needed to create a hook-up item in the reference explorer.  
1. In the Reference Explorer, Hook-Up Item Libraries folder, under Default Sub-Library, 

create a hook-up item. For more information, see Create a Hook-Up Item (on page 321). 
2. In the Reference Explorer, Hook-Ups Library, create a user-defined sub-library. For more 

information, see Create User-Defined Sub-Libraries (on page 320). 
3. If pipe specs are to be associated with the hook-up item, then you must first define or modify 

the required pipe spec. For more information, see Define or Modify Pipe Specifications. see 
the SmartPlant Instrumentation Basic Engineering User's Guide > Instrument Index Module > 
Managing Lines > Define or Modify Pipe Specifications. 

4. After defining the pipe specs, you must associate them with the user-defined sub-library 
created previously. For more information, see Associate Pipe Specs with Sub- Libraries. see 
the SmartPlant Instrumentation Basic Engineering User's Guide > Specifications > Pipe 
Specs > Associate Pipe Specs with Sub-Libraries. 

5. Assign the hook-up item to the user-defined sub-library. For more information, see Associate 
Items with User-Defined Sub-Libraries (on page 322). 

6. Add any macros that are required. For more information, see Create a New Hook-Up Macro 
Definition (on page 298). 

7. Generate your hook-up drawing. For more information, see the following topics: 
 Generate CAD Hook-Up Drawings (on page 339) 
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 Generate Enhanced Hook-Up Drawings (on page 340) 
 Generate Hook-Up Drawings in Mixed Mode (on page 341) 

See also 
Hook-Ups in SmartPlant Instrumentation (on page 315) 
Hook-Up Items (see "Hook-Up Items and Libraries" on page 316) 
Hook-Up Drawing Generation (on page 331) 
 

Managing Hook-Up Items and Libraries Common Tasks 
These tasks deal with creating and managing hook-up item libraries, sub-libraries, and hook-up 
items in the Reference Explorer. 

Create an Item Library 
This procedure describes how to create a new item library.  An item library contains fittings and 
associations created on a domain level.  Therefore, when you enter a domain, you can have any 
number of relevant libraries.  The number of libraries, names, and completeness are all up to your 
requirements.  An item library can also contain any number of user-defined sub-libraries that you 
can use when working with pipe specs.  A new item library that you create automatically contains 
a default sub-library, which you can use for assigning hook-up items if you do not work with pipe 
specs.  For more information, see Create an Item Library (on page 319). 

Set an Item Library As the Active Item Library 
Use this procedure to set a specific item library as the active item library for the current 
<plant>.  You must set a specific library as the active item library to be able to create hook-ups in 
the current <plant> and assign the library items to hook-ups.  The information is filled in to pick out 
parts of a specific hook-up.  You can also enter description, material, rating, and so forth, to 
provide as much information as possible for the Bill of Material that the software creates based on 
this data.  For more information, see Set an Item Library As the Active Item Library (on page 320). 

Assign the Same Active Item Library to More Than One Plant 
Use this procedure if you need to assign an existing active item library to more than one <plant> in 
your domain.  For more information, see Assign the Same Active Item Library to More Than One 
Plant (on page 320). 

Create User-Defined Sub-Libraries 
Use this procedure to create user-defined sub-libraries in the library set as the active item 
library.  You can also assign pipe specs to user-defined sub-libraries.  For more information, see 
Create User-Defined Sub-Libraries (on page 320). 

Create a Hook-Up Item 
Use this procedure to create a hook-up item under the default or user-defined sub-library.  For 
more information, see Create a Hook-Up Item (on page 321). 

Create Hook-Up Items in Batch Mode 
Use this procedure to create several hook-up items in the default sub-library of a specific hook-up 
library.  For more information, see Create Hook-Up Items in Batch Mode (on page 321). 
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Sort Hook-Up Items in a Sub-Library 
Use this procedure to sort the hook-up items defined in a specific sub-library.  For more 
information, see Sort Hook-Up Items in a Sub-Library (on page 322). 

Associate Items with User-Defined Sub- Libraries 
Use this procedure to assign items that exist in the default sub-library to a user-defined 
sub-library.  For more information, see Associate Items with User-Defined Sub- Libraries (see 
"Associate Items with User-Defined Sub-Libraries" on page 322). 

Remove Items from a User-Defined Sub- Library 
Use this procedure to remove one or more items from a user- defined sub-library.  When 
removing the items, the software only dissociates them from that sub-library but does not delete 
them from the parent hook-up item library.  For more information, see Remove Items from a 
User-Defined Sub- Library (see "Remove Items from a User-Defined Sub-Library" on page 323). 

Delete Hook-Up Items 
Use this procedure to delete one or more hook-up items from a specific hook-up item library.  For 
more information, see Delete Hook-Up Items (on page 323). 

Delete Hook-Up Sub-Libraries 
Use this procedure to delete an empty user-defined sub- library from the parent hook-up item 
library.  For more information, see Delete Hook-Up Sub-Libraries (on page 324). 
  
 

Create an Item Library 
1. Press F8 to open the Reference Explorer, and right-click the Hook-Up Item Libraries folder. 
2. On the shortcut menu, click New > Item Library. 
3. Type a unique name for the item library and an optional description. 
4. Click OK. 

 
 On creating the item library, the software automatically creates the default sub- library under 

the library. 
 You can create a hook-up library by duplicating an existing library.  When duplicating the 

library, the software also duplicates all the sub-libraries and the items that are associated with 
the sub-libraries.  If a library contains a large number of sub-libraries and hook- up items, the 
duplication process might take time. 
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Set an Item Library As the Active Item Library 
1. In the Reference Explorer, expand the Hook-Up Item Libraries folder. 
2. Right-click a library that you require. 
3. On the shortcut menu, click Actions > Set As Active item Library. 

 
 You can only set one library as the active item library for a <plant>.  If another item library has 

been set as the active item library for the current <plant>, the software dissociates the 
hook-ups from the previous active library and assigns the default sub-library of the new active 
library to all the hook-ups in your <plant>. 

 In the Reference Explorer, the library icon changes from  too . 
 

Assign the Same Active Item Library to More Than One Plant 
1. Open a <unit> in the target plant. 
2. In the Reference Explorer, expand the Hook-Up Item Libraries folder. 
3. Right-click the library that has been set as the active item library in another <plant>. 

 Since you can only set one library as the active item library for a specific <plant>, the 
Hook-Up Item Libraries folder does not indicate any active item libraries specified for other 
<plants>. 

4. On the shortcut menu, click Actions > Set As Active item Library and change the library 
icon from  too . 

5. Repeat this procedure for every plant to which you want to assign the same active item library. 
 
 

Create User-Defined Sub-Libraries 
1. Press F8 to open the Reference Explorer, and expand the hierarchy to the item library level 

in the Hook-Up Item Libraries folder. 
2. Right-click the item library. 
3. On the shortcut menu, click New > Item Sub-Library. 
4. Type a unique name for the item sub-library and an optional description. 

 You can click Pipe Specs and assign pipe specs to the sub-library you are creating.  If 
you have not defined pipe specs yet, you can create the sub-library first and assign pipe specs 
at a later stage. 

5. Click OK to create the sub- library. 
 It is possible to create more than one sub-library by duplicating several existing user-defined 

sub-libraries that you can select in the Items pane.  To display the sub-libraries in the Items pane, 
in the tree view pane, select the parent item library.  When duplicating a user-defined sub- library, 
the software also duplicates all of the hook- up items that exist in that sub-library.  You cannot 
duplicate the default sub-library. 
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Create a Hook-Up Item 
1. Press F8 to open the Reference Explorer, and expand the hierarchy to the item library level 

in the Hook-Up Item Libraries folder. 
2. Double-click the item library to display the item sub-libraries. 

 The default sub-library exists in every library that you create.  In addition, you can create 
user-defined sub-libraries if you want to associate pipe specs to hook-ups. 

3. Right click the default or user-defined sub-library. 
4. On the shortcut menu, click New > Hook-Up Item. 
5. Type a unique name for the hook- up item and define other properties as needed. 
6. Click OK to create the hook-up item. 

 If you created a new item in a user-defined sub-library, this item automatically appears in the 
default sub-library too. 
  
 

Create Hook-Up Items in Batch Mode 
1. Press F8 to open the Reference Explorer, and expand the hierarchy to the item library level 

in the Hook-Up Item Libraries folder. 
2. Double-click the item library to display the item sub-libraries. 

 The default sub-library exists in every library that you create.  In addition, you can create 
user-defined sub-libraries if you want to associate pipe specs to hook-ups. 

3. Right-click the default sub-library. 
4. On the shortcut menu, click Actions > Batch Item Creation. 
5. Under Number of items to create, use the spinner to enter the number of the hook- up items 

you want to create under the default sub- library. 
6. In the Prefix box, type an optional prefix you want to assign to the batch of the items you are 

about to create. 
7. In the Start from number box, type the starting number you want to append to the name of 

the first item in the batch. 
 If you leave the Start from number box empty, after you click OK, the software 

automatically appends 0 (zero) to the name of the first item in the batch. 
8. In the Increment by box, use the spinner to change the incrementing value as needed. 

 The default value in the Incremented by box is 1.  When using the default value, to 
ensure item name uniqueness within the current default sub-library, the software increments 
every subsequent item number in the batch of items by one digit.  you can change this value 
as needed.  For example, if your want to create three items with prefix MyItem, the Start 
from number value 5, and the Increment by value 2, the software creates the following 
items: MyItem5, MyItem7, and MyItem9. 

9. Click OK to open the Hook-Up Item Properties dialog box, where you can define properties 
for each item and complete the item creation. 
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Sort Hook-Up Items in a Sub-Library 
1. In the tree view of the Reference Explorer, select and right-click a sub-library. 
2. On the shortcut menu, click Sort. 
3. From the Item type list, select Hook-Up Item. 
4. Under Available Property, select a property you want to use for sorting hook-up items, for 

example Item Number. 
5. Drag this property to the Sort Property pane, select the check box and click OK. 

 The software sorts the items that start with a numeric character first.  For example, if you sort 
by item number items whose numbers are 5, 1, A, 4, AA, BB, A, AB, 2, 3, these items appear in 
descending order as follows: 1, 2, 3, 4, 5, A, AA, AB, B. 
 
 

Associate Items with User-Defined Sub-Libraries 
1. In the Hook-Up Item Libraries folder of the Reference Explorer, do one of the following: 

 In the tree view pane, expand the hierarchy of an item library and right-click a 
user-defined sub-library. 

 In the tree view pane, select an item library and then, in the Items pane, select one or 
more user-defined sub-libraries. 

2. On the shortcut menu, click Actions > Associate Items with Sub-Libraries. 

 
 On the dialog box that opens, the software displays all the items available in the default 

sub-library of the library you selected.  You can set a filter to display only those items that 
you require for association.  In the filter that you require in not available in the Filter 

available items list, you can click  and define a new filter. 
 In the dialog box panes, you can double-click a column header in the to sort the items in 

ascending order.  Double-click again to sort the items in descending order. 
 In the dialog box panes, there is a vertical bar that you can drag to the right and view your 

data in a split display.  To find the vertical bar, place the cursor to the left of the left scroll 
box arrow so that the cursor changes its shape as shown: 

. 
3. Under Available items, select one or more hook-up items and do one of the following: 

 Click Associate. 
 Drag the selected items to the Associated items pane. 

4. If you selected more than one user-defined sub-library in the Reference Explorer, click Next 
to display another sub-library and associate hook-up items as you require. 
 You can associate the same items with more than one user-defined sub- library. 
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Remove Items from a User-Defined Sub-Library 
1. In the Hook-Up Item Libraries folder of the Reference Explorer, do one of the following: 

 In the tree view pane, expand the hierarchy of an item library and right-click a 
user-defined sub-library. 

 In the tree view pane, select an item library and then, in the Items pane, select one or 
more user-defined sub-libraries. 

2. On the shortcut menu, click Actions > Associate Items with Sub-Libraries. 

 
 On the dialog box that opens, the software displays all the items available in the default 

sub-library of the library you selected.  You can set a filter to display only those items that 
you require for association.  In the filter that you require in not available in the Filter 

available items list, you can click  and define a new filter. 
 In the dialog box panes, you can double-click a column header in the to sort the items in 

ascending order.  Double-click again to sort the items in descending order. 
 In the dialog box panes, there is a vertical bar that you can drag to the right and view your 

data in a split display.  To find the vertical bar, place the cursor to the left of the left scroll 
box arrow so that the cursor changes its shape as shown: 

. 
3. Under Associated items, select one or more hook-up items and do one of the following: 

 Click Dissociate. 
 Drag the selected items to the Available items pane. 

4. If you selected more than one user-defined sub-library in the Reference Explorer, click Next 
to display another sub-library and dissociate hook-up items as you require. 

 
 

Delete Hook-Up Items 
1. Press F8 to open the Reference Explorer, and expand the hierarchy to the item sub-library 

level in the Hook-Up Item Libraries folder. 
2. In the tree view pane, do one of the following: 

 Double-click the default sub-library from which you want to delete a specific item, and 
then select and right-click a specific item you want to delete. 

 Select the default sub-library from which you want to delete one or more items, and then, 
in the Items pane, select and right-click items you want to delete. 

3. On the shortcut menu, click Delete. 

 
 The software only allows you to delete those items that are not associated with hook-ups. 
 If you created user-defined sub-libraries, the software automatically deletes the items from all 

the sub-libraries that exist in the library.  You can also perform item deletion from a 
user-defined sub-library. 
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Delete Hook-Up Sub-Libraries 
1. Press F8 to open the Reference Explorer, and double-click the Hook-Up Item Libraries 

folder. 
2. Select an item library to display its sub-libraries in the Items pane. 
3. In the Items pane, select and right-click one or more user-defined sub-libraries. 
4. On the shortcut menu, click Delete. 

 You can only delete empty user-defined sub-libraries that exist in the library. 
 
 

Managing Hook-Ups Common Tasks 
These tasks deal with creating and managing hook-ups and hook-up types in the Domain 
Explorer.  Also, these tasks describe various association procedures you need to perform, for 
example, association of instrument tags to hook-ups, association of items to hook-ups, and so 
forth. 

Create a Hook-Up Type 
Use this procedure to create a hook-up type at the domain level.  A hook-up type is a common 
name of group of hook-ups that share distinguishing characteristics common to one kind of 
instrument.  These characteristics set one hook-up type apart from another type, for example 
Flow, Temperature, Level, and so forth.  You can only create one hook-up type at a time.  For 
more information, see Create a Hook-Up Type (on page 326). 

Create Hook-Ups 
Use this procedure to add one or more hook-ups to existing hook-up types.  Hook-ups that you 
create under hook-up types only appear in the current <plant>.  A hook-up is a graphical 
representation of an assembly drawing — a drawing prototype.  Adding a hook-up to a hook-up 
type is a prerequisite for assigning instruments tags to hook-ups.  For more information, see 
Create Hook-Ups (on page 326). 

Associate Hook-Up Types with Instrument Types 
Use this procedure to assign one or more hook-up types an instrument type.  Your database can 
contain a seemingly endless number of tag numbers.  To make the task of attaching multiple 
instruments to a specific hook-up type manageable, use a filter that allows you to assign any 
instrument type in the current domain to your hook-up type..  For more information, see Associate 
Hook-Up Types with Instrument Types (on page 327). 

Associate Instrument Tag Numbers with Hook-Ups 
Use this procedure to assign one or more tag numbers to one or more hook-ups.  The hook-ups 
can belong to the same or different hook-up types.  For more information, see Associate 
Instrument Tag Numbers with Hook-Ups (on page 327). 

Move Hook-Ups to Another Hook-Up Type 
This procedure enables you to move all hook-ups from one or more hook-up types to another 
existing hook-up type.  For more information, see Move Hook-Ups to Another Hook-Up Type (on 
page 328). 
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Change a Hook-Ups Sub-Library Association 
Use this procedure to associate a hook-up with a user- defined sub-library or to change the 
existing hook-up sub- library assignment. 
You can associate a hook-up with a sub-library when performing the following activities: 
 Adding a new hook-up to a hook-up type — You can assign any new hook-up to any sub- 

library. 
 Editing properties of an existing hook- up 
 Duplicating a hook-up 

When editing or duplicating hook-up properties, you can change the existing association of a 
hook- up sub-library under the following conditions: 
 If the hook-up has associated instrument tags with pipe spec data, the target user- defined 

sub-library must also have pipe specs suitable for association of these tags. 
 The target user-defined sub- library must contain all hook-up items that are associated with 

the hook-ups. 
For more information, see Change a Hook-Ups Sub-Library Association (on page 328). 

Associate Items with Hook-Ups 
This procedure enables you to associate one or more items with hook-ups.  You can only 
associate those items that exist in the sub-library assigned to the hook-ups that you select in the 
Domain Explorer.  In hook-up drawings that you generate, the associated items are displayed as 
the identifying.  For more information, see Associate Items with Hook-Ups (on page 329). 

Dissociate Items from Hook-Ups 
Use this procedure to dissociate one or more items from a hook-up.  You must dissociate an item 
from a hook-up prior to deleting this item from the active item library.  For more information, see 
Dissociate Items from Hook-Ups (on page 330). 

Dissociate Tag Numbers from Hook-Ups 
Use this procedure to dissociate one or more instrument tags from a hook-up.  You must 
dissociate all instruments from a hook-up prior to deleting this hook-up.  For more information, 
see Dissociate Tag Numbers from Hook-Ups (on page 330). 

Delete Hook-Ups 
This option enables you to delete a hook-up which is not associated with any tag numbers.  If an 
association exists, first dissociate the tag numbers from this hook-up and then delete the 
hook-up.  For more information, see Delete Hook-Ups (on page 331). 

Delete Hook-Up Types 
This option enables you to delete one or more hook-up types which are not associated with any 
hook-ups.  To delete a hook-up type that contains hook-ups, first delete the hook-ups or move 
them to another hook-up type.  For more information, see Delete Hook-Up Types (on page 331). 
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Create a Hook-Up Type 
1. Press F7 to open the Domain Explorer, expand the hierarchy of any <plant> and right-click 

the Hook-Ups folder. 
 Since hook-up types are defined at the domain level, any hook-up type that you create 

appears in the Hook-Ups folder of every <plant> that exists in the current domain. 
2. On the shortcut menu, click New > Hook-Up Type. 
3. In the Hook-Up Type Properties dialog box, type a unique hook-up type name and an 

optional description. 
4. Click OK. 
  
 

Create Hook-Ups 

Prerequisite 
 Set a specific hook-up item library as the active item library for the current <plant>.  For 

details, see Set an Item Library As the Active Item Library (on page 320). 
1. Press F7 to open the Domain Explorer. 
2. Expand the item hierarchy of the current <plant> and do one of the following: 

 Right-click the Hook-Ups folder. 
 Double-click the Hook-Ups folder and then, in the Items pane, select and right-click the 

hook-up type to which you want to add a new hook-up. 
3. On the shortcut menu, click New > Hook-Up. 
4. If you right-clicked the Hook-Ups folder, from the Hook-up type list, select the target hook-up 

type. 
5. In the appropriate boxes, enter a name for the new hook-up and a description. 

 If the same name is used for more than one hook-up then the description must be 
unique. 

6. Type a unique name for the item sub-library and an optional description. 
7. From the Item sub-library list, select a sub-library to which you want to assign the hook-up. 

 If you do not work with user- defined sub-libraries, the software assigns the hook- up to 
the default sub-library automatically.  If you work with user-defined sub-libraries, we 
recommend that you read the topic Change a Hook-Ups Sub- Library Association (see 
"Change a Hook-Ups Sub-Library Association" on page 328). 

8. Beside Drawing block file name and path, click Browse to navigate to the drawing block file 
name and path. 

 
 Click View to open the selected drawing in the CAD application installed on your 

computer. 
 The path setting that appears in the Generation output path box is the path that you 

specified in the Generate Hook-Up Drawings dialog box.  The software only displays 
the path if you already generated a hook-up drawing for the source hook-up. 

9. Click OK to create the hook-up. 
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 It is possible to create more than one hook-up by duplicating several existing hook-ups that 
you can select in the Items pane.  To display the hook-ups in the Items pane, in the tree view 
pane, select the parent hook-up type or the Hook-Ups folder.  When duplicating a hook-up, the 
software also duplicates all of the hook-up items that are associated with the source hook-ups. 
  
 

Associate Hook-Up Types with Instrument Types 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. In the tree view pane, do one of the following: 

 Select and right-click a specific hook-up type. 
 Select the Hook-Ups folder and then, in the in the Items pane, select and right-click one 

or more hook-up types. 
3. On the shortcut menu, click Actions > Associate with Instrument Types. 

 
 On the dialog box that opens, the software displays all the instrument types defined in the 

current domain.  You can associate the same instrument type with more than one hook- 
up type. 

 In the dialog box panes, you can double-click a column header in the to sort the items in 
ascending order.  Double-click again to sort the items in descending order. 

4. Under Available instrument types, select one or more instrument types and do one of the 
following: 
 Click Associate. 
 Drag the selected items to the Associated instrument types pane. 

5. If you selected more than one hook-up type in the Domain Explorer, click Next to display 
another hook-up type and associate instrument types as you require. 

 

Associate Instrument Tag Numbers with Hook-Ups 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up and then, In the Items pane, select and right-click 
one or more hook-ups. 

 In the tree view pane, select the hook- up hierarchy root node to display all the existing 
hook-up types in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types. 
 When selecting a hook-up type or several hook-up types, you can associate tags with 

multiple hook-ups that belong to different hook-up types.  If you select a specific hook-up, you 
can only assign tag numbers to the selected hook-up. 

3. On the shortcut menu, click Actions > Associate Tag Numbers with Hook-Ups. 
4. Under Instrument type assigned to hook-up type, select an instrument type by which you 

want to filter tag numbers in the Available tag numbers pane. 

 
 In the dialog box panes, you can double-click a column header to sort the items in 

ascending order.  Double-click again to sort the items in descending order. 
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 In the dialog box panes, there is a vertical bar that you can drag to the right and view your 
data in a split display.  To find the vertical bar, place the cursor to the left of the left scroll 
box arrow so that the cursor changes its shape as shown: 

. 
 Under Available tag numbers, tags displayed in italics indicate tags that are already 

assigned to another hook-up.  You can still associates these tags with the current 
hook-up.  Click the Hook-Ups button above the Available tag numbers pane to display 
tag numbers available for association with hook-ups and also display existing hook-up 
associations. 

 If the specified hook-up is assigned to a user-defined sub-library with pipe specs, the 
software filters the tag numbers so that only tag numbers with the appropriate pipe spec 
data are displayed.  The software only displays tag numbers whose pipe spec data fits 
the pipe specs assigned to the sub-library to which the hook-up belongs. 

 You can display the available tag numbers either on the highest or lowest level of your 
plant hierarchy defined by the Domain Administrator.  The default highest level is 
Plant.  The default lowest level is Unit. 

5. Under Available tag numbers, select one or more tags and do one of the following: 
 Click Associate. 
 Drag the selected tags to the Associated tag numbers pane. 

6. If you selected more than one hook-up or hook-up type in the Domain Explorer, click Next and 
make associations for another hook-up. 
 In the Associated tag numbers pane you can select to include specific tags in a Bill of 

Material (BOM), or not to display the tag the next time you open the dialog box, or when you 
generate a CAD or Enhanced Utility Report Hook-Up drawing. 
 

Move Hook-Ups to Another Hook-Up Type 
1. Press F7 to open the Domain Explorer, and double-click the Hook-Ups folder to display all 

the existing hook-ups types and hook-ups in the Items pane. 
2. In the Items pane, select and right-click hook-ups that you want to move to another hook-up 

type. 
3. On the shortcut menu, click Actions > Move Hook-Ups. 
4. On the dialog box that opens, select the target hook-up type and click OK. 
 

Change a Hook-Ups Sub-Library Association 
1. Press F7 to open the Domain Explorer, and double-click the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, right-click a specific hook-up. 
 In the Items pane, select and right-click one or more hook-ups. 

3. On the shortcut menu, click Properties. 
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4. On the Hook-Up Properties dialog box, from the Item sub-library list, select a desired 
sub-library. 

 
 The Item sub-library contains all sub-libraries you defined in the active item library in the 

Reference Explorer, where the active library is indicated with the  icon.  If you set 
another library as the active item library, the software automatically assigns the default 
sub-library of the new active item library to all the existing hook-ups. 

 If you assigned the hook-up to one of the user-defined sub-libraries, you can click Pipe Specs 
to display the pipe specs you associated with the selected user-defined sub- library in the 
Reference Explorer. 

 

Associate Items with Hook-Ups 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up type and then, in the Items pane, select and 
right-click one or more hook-ups. 

 In the tree view pane, select the Hook-Ups folder to display all the existing hook- up types 
and hook-ups in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types or hook-ups. 

3. On the shortcut menu, click Actions > Associate Items with hook-Ups. 

 
 On the dialog box that opens, the software displays all the items available in the library 

you set in the Reference Explorer as the active item library. 
 In the dialog box panes, you can double-click a column header in the to sort the items in 

ascending order.  Double-click again to sort the items in descending order. 
 In the dialog box panes, there is a vertical bar that you can drag to the right and view your 

data in a split display.  To find the vertical bar, place the cursor to the left of the left scroll 
box arrow so that the cursor changes its shape as shown: 

 
4. Under Items available for association, select one or more hook-up items and do one of the 

following: 
 Click Associate. 
 Drag the selected items to the Associated items pane. 

5. In the Quantity column, type a value for the quantity of items for a Bill of Material.  For 
example, if you associated a male connector and the current hook-up requires twenty male 
connectors, type 20. 

6. In the Spares Percentage column, type or modify the percentage of total units of measure 
specified for the current hook-up item on the Hook-Up Item Properties dialog box. 

 
 The software uses the values that you add in the Quantity and Spares Percentage columns 

when calculating the total quantity of items for a Bill of Material.  For details, see Calculating 
the Total of Hook-Up Items for a Bill of Material (on page 346). 
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 After associating hook-up items with a hook-up, the software generates new sequence 
numbers automatically and displays the numbers in the Order column, where you can sort the 
items by their order of their assignment to a hook-up.  You can type a new sequence number 
if needed.  You can open a Bill Of Material and sort the items by the item order.  For more 
information, see Sort Data in a Bill of Material (on page 348). 

 

Dissociate Items from Hook-Ups 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up type and then, in the Items pane, select and 
right-click one or more hook-ups. 

 In the tree view pane, select the Hook-Ups folder to display all the existing hook- up types 
and hook-ups in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types or hook-ups. 

3. On the shortcut menu, click Actions > Associate Items with hook-Ups. 

 
 On the dialog box that opens, under Associated items, you can double- click a column 

header in the to sort the items in ascending order.  Double-click again to sort the items in 
descending order. 

 In the Associated items pane, there is a vertical bar that you can drag to the right and 
view your data in a split display.  To find the vertical bar, place the cursor to the left of the 
left scroll box arrow so that the cursor changes its shape as shown: 

. 
4. Under Associated items, select one or more hook-up items and do one of the following: 

 Click Dissociate. 
 Drag the selected items from the Associated items pane to the Items available for 

association pane. 
  
 

Dissociate Tag Numbers from Hook-Ups 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up and then, In the Items pane, select and right-click 
one or more hook-ups. 

 In the tree view pane, select the hook-up hierarchy root node to display all the existing 
hook-up types in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types. 

3. On the shortcut menu, click Actions > Associate Tag Numbers with Hook-Ups. 

 
 In the dialog box panes, you can double-click a column header in the to sort the items in 

ascending order.  Double-click again to sort the items in descending order. 
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 In the dialog box panes, there is a vertical bar that you can drag to the right and view your 
data in a split display.  To find the vertical bar, place the cursor to the left of the left scroll 
box arrow so that the cursor changes its shape as shown: 

. 
4. Under Associated tag numbers, select one or more tags and do one of the following: 

 Click Associate. 
 Drag the selected tags to the Available tag numbers pane. 

5. If you selected more than one hook-up or hook-up type in the Domain Explorer, click Next 
and dissociate tag numbers from another hook- up. 

  
 

Delete Hook-Ups 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a specific hook-up you want to delete. 
 In the tree view pane, select a hook-up type, and then, in the Items pane, select and 

right-click one or more hook-ups. 
3. On the shortcut menu, click Delete. 

 When deleting hook-ups, the software automatically dissociates all the hook- up items and 
instrument tags. 
 

Delete Hook-Up Types 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, right-click a hook-up type that does not have hook-ups. 
 In the Items pane, select and right-click several hook-up types that do not have hook-ups. 

3. On the shortcut menu, click Delete. 
 

Hook-Up Drawing Generation 
You can generate a hook-up drawing using either the Enhanced Report Utility or an external CAD 
application such as SmartSketch, AutoCAD, or MicroStation.  Generated drawings contain the 
hook-up block drawing, the list of assigned tag numbers, and hook-up items associated with the 
current hook-up. 
CAD Hook-Up Drawing Generation Scenario 
1. On the Preferences dialog box, on the Hook-Ups > File Locations page, define the CAD 

paths for hook-up drawings. 
2. If you require a global border and logo, in your CAD application, prepare a drawing border and 

logo, and then, enable the use of it in SmartPlant Instrumentation.  For details, see Assign 
Border and Logo Blocks to Hook-Up Drawings (on page 337). 
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3. In your CAD application, create a general drawing (optional).  You only need to create such a 
drawing if you intend to use the General drawing option of SmartPlant Instrumentation when 
generating a hook-up drawing that contains more than one page.  Then, on the SmartPlant 
Instrumentation Preferences dialog box , on the Hook-Ups > General page, specify the 
general drawing that you want to appear on the second and all other subsequent pages of the 
hook-up drawing you will generate. 

 A generated hook-up drawing, using the General drawings options, contains more than 
one page.  Your general drawing will appear on the second page and all other subsequent 
pages of the hook-up drawing generated from SmartPlant Instrumentation. All the tags that 
appear on the first page are duplicated on the second page along with those tags that do not 
fit on the first page. 

4. On the Preferences dialog box, on the Hook-Ups > General page, set the revision display 
order. 

You can display a number of revisions in the title block of a hook-up drawing.  Each 
revision is represented by a numbered macro and the revisions are displayed in the order of 
the macro numbering, beginning with the first revision (ascending order) or the last revision 
(descending order).  If the total number of revisions is greater than the number of lines 
available for display in the drawing and you want to see the latest revisions, you should select 
to display the revisions in descending order so that the latest revision is displayed first. 

5. In your CAD application, create a hook-up drawing template using your CAD application so 
that this template includes the tag number and hook-up item macros as well as the title block. 

 Make sure the macro names you enter in the drawing template match the macro 
names you defined on the Macro Definitions dialog box in the Hook-Ups module. 

6. If you want to edit the hook-up drawing identifying fields, associate the document and revision 
numbers, in the Domain Explorer, open the Hook-Up Drawing List dialog box and define 
data accordingly. 

7. In the Domain Explorer, open the Generate Hook-Up Drawings dialog box and set the 
generation options as you require. 

8. Generate a hook-up drawing from the Generate Hook-Up Drawings dialog box. 
Enhanced Hook-Up Drawing Generation Scenario 
1. On the Preferences dialog box, on the Enhanced Reports > Hook-Up > View page, select 

the options you want to see in your drawing. 
2. On the Enhanced Reports > Hook-Up > File Locations page, set the file paths for the 

various options. 
3. If required, change the text appearance by changing the settings on the Fonts page. 
4. On the Enhanced Reports > Hook-Up > Title Block page, select the title block you require 

for your drawing. 
5. On the Enhanced Reports > Hook-Up > Page and Revisions page, set the revision display 

order. 
 You can display a number of revisions in the title block of a hook-up drawing.  Each 

revision is represented by a numbered macro and the revisions are displayed in the order of 
the macro numbering, beginning with the first revision (ascending order) or the last revision 
(descending order).  If the total number of revisions is greater than the number of lines 
available for display in the drawing and you want to see the latest revisions, you should select 
to display the revisions in descending order so that the latest revision is displayed first. 

6. If you want to edit the hook-up drawing identifying fields, associate the document and revision 
numbers, in the Domain Explorer, open the Hook-Up Drawing List dialog box and define 
data accordingly. 
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7. Assign the required hook-up symbol file to the hook-up.  For more information, see Assign an 
Enhanced Symbol to a Hook-Up (on page 338). 

8. In the Domain Explorer, open the Generate Hook-Up Drawings dialog box and set the 
generation options as you require. 

9. Generate a hook-up drawing from the Generate Hook-Up Drawings dialog box. 
 

Shipped Enhanced Hook-Ups Symbols 
SmartPlant Instrumentation supplies two symbols for use with enhanced hook-ups; 
 HookUp_CV.sym 
 HookUp_DPtransmit.sym 

They are located in the SmartPlant Instrumentation home folder\RAD\Symbols\Custom. 
These shipped files can be used, as is, to produce enhanced hook-ups drawings for control 
valves, or data process transmitters.  They can also be customized to produce enhanced hook-up 
drawings for other hook-up items.  For more information on editing and customizing symbols, see 
the Symbol Editor or Catalog Manager User Guides. 

See Also 
Assign an Enhanced Symbol to a Hook-Up (on page 338) 
 

Managing Hook-Up Drawings Common Tasks 
These tasks deal with generating hook-up drawings using a CAD application or the Enhanced 
Report Utility, maintaining revisions, editing hook-up drawing identifying fields that appear in the 
title block, and so forth.  For a complete list of hook-up reports, see Hook-Up Reports (on 
page 345). 

Apply a Drawing Generation Method to Hook-Ups 
Use this procedure to apply a drawing generation method to one or more hook-ups 
manually.  This feature is useful if you intend to generate hook-up drawings in a mixed mode, that 
is, generate several CAD hook-up drawings and several enhanced hook-up drawings in one 
generation session.  You generate CAD hook-up drawings using your CAD application 
(SmartSketch, AutoCAD, or MicroStation), whose paths you specified on the Preferences dialog 
box.  You generate enhanced hook-up drawings using the Enhanced Report Utility, which comes 
with the SmartPlant Instrumentation software package.  For more information, see Apply a 
Drawing Generation Method to Hook-Ups (on page 335). 

Set Default Generation Method for Hook- Up Drawings 
Use this procedure to set the default generation method that the software can use automatically 
when your hook-up selection contains hook-ups that do not have a generation method applied 
manually.  For more information, see Set Default Generation Method for Hook-Up Drawings (on 
page 335). 

Edit Hook-Up Drawing Identifying Fields 
Hook-up drawing properties appear in the title block fields.  These fields contain identifying 
information about the drawing name, page number, and file name, and also information about 
revisions, approvals, and references to other documents.  You can modify the property 
information using the options in the Hook-Up Drawing List dialog box. 
For each hook-up drawing, SmartPlant Instrumentation displays the hook-up name and hook- up 
description.  You can use this procedure to edit the hook-up name, description, and the output file 
name.  For more information, see Edit Hook-Up Drawing Identifying Fields (on page 335). 
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Make Approvals for Hook-Up Drawings 
This procedure enables you to make client and vendor approvals for hook-up drawings.  For more 
information, see Make Approvals for Hook-Up Drawings (on page 336). 

Maintain Hook-Up Drawing Revisions 
The revision feature is used to keep track of the changes made to the hook-up drawing during its 
lifetime.  It is important and useful to have a chronological description of the changes, dates of 
change, and a list of persons who approved them.  Using this procedure, you can add, edit, and 
delete revisions. 
The revision feature is used to keep track of the changes made to the hook-up drawing during its 
lifetime.  It is important and useful to have a chronological description of the changes, dates of 
change, and a list of persons who approved them.  Using this procedure, you can add, edit, and 
delete revisions.  For more information, see Maintain Hook- Up Drawing Revisions (see "Maintain 
Hook-Up Drawing Revisions" on page 336). 

Add Document References in Hook-Up Drawings 
This procedure enables you to make a reference to a drawing and add this reference to the title 
block of the hook- up drawing.  For more information, see Add Document References in Hook-Up 
Drawings (on page 337). 

Assign Border and Logo Blocks to Hook- Up Drawings 
This procedure allows you to set SmartPlant Instrumentation to use a specific border block and 
logo block every time you generate a CAD hook-up drawing.  Blocks that you set as default 
general blocks must belong to the shipped general block types, that is, Border and Logo block 
types available in the Drawing Block Types folder of the Domain Explorer.  For more 
information, see Assign Border and Logo Blocks to Hook-Up Drawings (on page 337). 

Assign a Hook-Up Symbol to a Hook-Up 
Use his procedure to assign a hook-up symbol to your hook- up when generating an enhanced 
hook-up drawing using the Enhanced Report Utility.  The hook-up symbol is of the file type 
.sym.  For more information, see Assign an Enhanced Symbol to a Hook-Up (on page 338). 

Update Paths for Hook-Up Drawings and Block Files 
Use this procedure to update in the database paths for existing hook-up drawings and block 
files.  You can update paths globally for block files associated with hook-ups, for logo and border 
blocks, and for hook-up drawings that you generated.  For more information, see Update Paths 
for Hook-Up Drawings and Block Files (on page 338). 

Generate CAD Hook-Up Drawings 
Use this procedure to generate one or more hook-up drawings using you CAD application.  For 
more information, see Generate CAD Hook-Up Drawings (on page 339). 

Generate Enhanced Hook-Up Drawings 
Use this procedure to generate one or more hook-up drawings using the Enhanced Report 
Utility.  For more information, see Generate Enhanced Hook-Up Drawings (on page 340). 
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Generate Hook-Up Drawings in Mixed Mode 
Use this procedure to generate several hook-up drawings according to the generation method 
applied to the source hook-ups.  For more information, see Generate Hook-Up Drawings in Mixed 
Mode (on page 341). 
 
 

Apply a Drawing Generation Method to Hook-Ups 
1. Press F7 to open the Domain Explorer and then double-click the Hook-Ups folder. 
2. In the Items pane, select and right-click one or more hook-ups. 
3. On the shortcut menu, click Apply Generation Method. 
4. Select one of the following: 

 CAD — Allows you to and assigns the indicator to the selected hook-ups. 
 Enhanced Report — Allows you to and assigns the indicator to the selected hook-ups. 

 
 To view an existing generation method assignment, you can right-click the appropriate 

hook-up and click Properties to open the Hook-Up Properties dialog box. 
 To clear the current generation method for one or more hook-ups, select and right-click the 

required hook-ups, and then, on the shortcut menu, click Actions > Clear Generation 
Method. 

 
 

Set Default Generation Method for Hook-Up Drawings 
1. Click File > Preferences > Hook-Ups > General. 
2. From the Default generation method list, one of the following methods: 

 CAD — Generates hook-up drawings using your CAD application and allows you to use 
the CAD Options tab. 

 Enhanced Report — Generates hook-up drawings using the Enhanced Report Utility. 
 The default generation method that you set appears on the General Tab (Generate Hook-Up 

Drawings Dialog Box). 
  
 

Edit Hook-Up Drawing Identifying Fields 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up type and then, in the Items pane, select and 
right-click one or more hook-ups. 

 In the tree view pane, select the Hook-Ups folder to display all the existing hook-up types 
and hook-ups in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types or hook-ups. 

3. On the shortcut menu, click Actions > Hook-Up Drawing List. 
4. On the Hook-Up Drawing List dialog box, select a row and click Edit. 
5. In the Document field, type a name for the drawing document. 
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 If you type an existing document name, the software prompts you to confirm the multiple 
use of the name. 

6. In the Document Description field, type a description. 
7. To change the default output file name, in the Output File Name field, type a different file 

name over the default name. 
 The default output file name is the same as the hook-up name.  If there are any spaces 

in the hook-up name, the software replaces the space with an underscore ( _ ).  The file name 
ends with an underscore ( _ ) and a two-digit sequence number representing the page number 
of a multi-page drawing.  For example, flow_transmitter_03.dwg.  When the drawing consists 
of a single page, the file name ends with _01. 

8. Repeat the appropriate steps of this procedure for any other hook-up drawing. 
  
 

Make Approvals for Hook-Up Drawings 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up type and then, In the Items pane, select and 
right-click one or more hook-ups. 

 In the tree view pane, select the Hook-Ups folder to display all the existing hook-up types 
and hook-ups in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types or hook-ups. 

3. On the shortcut menu, click Actions > Hook-Up Drawing List. 
4. On the Hook-Up Drawing List dialog box, click Approvals and then enter the client and 

vendor data as needed. 
  
 

Maintain Hook-Up Drawing Revisions 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up type and then, In the Items pane, select and 
right-click one or more hook-ups. 

 In the tree view pane, select the Hook-Ups folder to display all the existing hook-up types 
and hook-ups in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types or hook-ups. 

3. On the shortcut menu, click Actions > Hook-Up Drawing List. 
4. On the Hook-Up Drawing List dialog box, select a desired row and click Revisions. 
5. On the Revisions dialog box, select one of the revision numbering methods (use P0, P1, 

P2... for preliminary revisions or 0, 1, 2 / A, B, C, and so forth, for normal serial revisions). 
 When you first select a revision numbering method, several options are available to you, 

including preliminary revisions (designated by P0, P1, P2).  Once you select one of the other 
revision methods, you will not be able to return to the preliminary revision method and this 
option will be disabled. 

6. Do one of the following: 
 Click a field of an existing row to update the existing revision data. 
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 Click New to add new revision data, and then type new revision data values. 
 As a time saver and a forget-me-not precaution, take advantage of using a default 

revision method.  The software automatically adds a new line with the next logical character 
and date each time you click New after you select the initial method. 

7. If necessary, click Delete to delete any previous revisions that are no longer needed. 
 You can also maintain revisions in batch mode using global revisions.  For more information, 

see Global Revisions. 
 

Add Document References in Hook-Up Drawings 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a hook-up type and then, In the Items pane, select and 
right-click one or more hook-ups. 

 In the tree view pane, select the Hook-Ups folder to display all the existing hook-up types 
and hook-ups in the Items pane, and then, in the Items pane, right-click one or more 
hook-up types or hook-ups. 

3. On the shortcut menu, click Actions > Hook-Up Drawing List. 
4. On the Hook-Up Drawing List dialog box, click References to open the Document 

References dialog box. 
5. To insert a new document reference, do the following: 
6. Click New to open the Drawing Reference Properties dialog box. 
7. Select a value from the References list. 
8. Type the name and description in the appropriate boxes. 
9. Click OK to return to the Document References dialog box. 
10. To edit a manually inserted drawing reference, do the following: 
11. Select a desired row and click Properties to open the Drawing Reference Properties dialog 

box. 
12. Edit the name and description. 
13. Click OK to return to the Document References dialog box. 

 To delete a reference, select a row, and click Delete. 
  
 

Assign Border and Logo Blocks to Hook-Up Drawings 
1. In the Domain Explorer, expand the hierarchy of the Drawing Block Types folder. 
2. Right-click the Border block type, and then, on the shortcut menu, click New > Block. 
3. Define the new border block as you require. 
4. Right-click the Logo block type, and then, on the shortcut menu, click New > Block. 
5. Define the new logo block as you require. 

 In hook-up drawings, you can only use the blocks created in default Border and Logo 
general block types.  Blocks belonging to user-defined general block types, which you create 
for loop drawings, do not appear in hook-up drawings. 

6. Click File > Preferences > Hook-Ups > General. 
7. Select Use global border/logo. 
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8. In the Hook-Ups module menu bar, click Associations > Default General Blocks. 
9. On the DefaultGeneral Blocks dialog box, select the border and logo blocks from the lists. 
  
 

Assign an Enhanced Symbol to a Hook-Up 
1. In the Domain Explorer, open the Hook-Up folder 
2. Right-click the required hook-up, and from the shortcut menu click Properties. 
3. On the Hook-Up Properties dialog box, locate the Drawing block file name and path list, 

and click Browse. 
4. On the Select File dialog box, navigate to, and select the .sym file you want to associate with 

the hook-up. 
 If you want to view the symbol before assigning it to the hook-up, on the Hook-Up 

Properties dialog box, click View to display the symbol in your default symbol editor. 
5. Click OK. 
 
 

Update Paths for Hook-Up Drawings and Block Files 
 The paths that you specify do not overwrite the settings specified for new block files and 

output drawings on the Hook-Ups > File Locations page of the Preferences dialog box. 
Open the Hook-Ups module. 
1. Click Actions > Update Paths for Existing Drawings and Blocks. 
2. Under Path for associated block files, do one of the following: 

 Click Apply to drawings in the domain or project to apply the new path to all the 
<plants> in the current domain, or to the current project in an owner operator domain. 

 Click Apply to drawings in the current <plant> only to apply the new path to the 
current <plant> only. 

3. Type the full path to the folder where you keep your drawing blocks files or click Browse to 
navigate to the desired folder. 

4. Under, Path for generated hook-up drawings do one of the following: 
 Click Apply to blocks in the domain or project to apply the new path to all the <plants> 

in the current domain, or to the current project in an owner operator domain. 
 Click Apply to blocks in the current <plant> only to apply the new path to the current 

<plant> only. 
5. Type the full path to the folder where you keep your generated hook-up drawings or click 

Browse to navigate to the desired folder. 
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Generate CAD Hook-Up Drawings 
 A complete hook-up drawing generation scenario is described in the Help topic Hook-Up 

Drawing Generation (on page 331). 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the hook-up type 

level in the Hook-Ups folder. 
2. In the tree view pane, select a hook-up type. 
3. In the Items pane, select and right-click one or more hook-ups. 

 In the Domain Explorer, you can also select hook-up types instead of hook-ups.  In this 
case, you can generate hook-up drawings that belong to all the hook-ups that are assigned to 
the selected hook-up types. 

4. On the shortcut menu, click Reports > Generate Hook-Up Drawings to display the General 
tab of the Generate Hook-Up Drawings dialog box. 

5. From the Generation method list, select CAD. 
6. Click the CAD Options tab. 
7. If you want to save the generated hook-up drawing as external CAD files, select the Save file 

in format check box, and then beside the Target folder path box click Browse to specify the 
folder.  To select a folder, you have to select any file that exists in that folder. 

 
 In the Target folder path box, the software displays the default folder you specified on 

the Preferences dialog box, in the Hook-Ups > CAD File Locations page, in the Output 
drawing folder box. 

 The file format that the software uses when saving a hook-up drawing depends on your 
CAD application.  If you use AutoCAD, the software saves the drawing file in .dwg 
format.  If you select MicroStation, the software saves the drawing file in .dgn format. 

 When using SmartSketch, you can save the drawings in any format available in the 
list.  From the box below Save file in format, select a desired format.  If you select 
SmartSketch, the software saves the drawing file in .sym format. 

 The output filename is the same as the hook-up name.  If there are any spaces in the 
hook-up name, the software replaces the space with an underscore ( _ ).  The filename 
ends with an underscore ( _ ) and a two-digit sequence number representing the page 
number of a multi- page drawing.  For example, flow_transmitter_03.dwg. 

8. If needed, select Send to plotter or printer to send the generated drawings to the current 
CAD plotter or printer. 

9. If you want to apply the macro functions associated with macros, select Use macro 
functions. 

10. For a multi-page hook-up drawing generation, under Drawing for subsequent pages, select 
one of the following: 
 Same as first — Allows you to display the generated hook-up drawing on the first page 

as well as on all the subsequent pages as well. 
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 General drawing — Allows you to display the generated hook-up drawing on the first 
page and the general drawing on all the subsequent pages.  The general drawing is a 
predefined drawing that you specified on the Preferences dialog box. 

 
 The software generates a multi-page drawing automatically. If the number of tag numbers 

associated with the selected hook-up is greater than the number of macros that can be 
accommodated on the first hook-up drawing page, then all the tag numbers appear on the 
second page (including those that already appeared on the first page).  For a multi-page 
drawing, you can enter the page number of the first generated page of the hook-up drawing in 
the Generate from page box.  For example, if you enter the value 2 and then generate a 
hook-up drawing, the first page of the hook-up drawing displays the value 2.  A multi-page 
drawing is a drawing in which the number of tags associated with the current hook-up is larger 
than the number of macros that can be accommodated in the generated hook-up drawing. 

 If your CAD application is SmartSketch, by default, all drawings that you generate have the A3 
Wide print sheet size.  This print sheet size is defined in the template file pid.igr, which comes 
shipped with SmartPlant Instrumentation.  This file appears in the CADFunc folder, for which 
you specified the path setting on the Preferences dialog box, Hook-Ups > CAD File 
Locations page.  If you want to generate hook-up drawings using a different print sheet size, 
you must open the pid.igr file in SmartSketch and modify the sheet settings as you 
require.  Note, however, that changes that you make in the pid.igr file affect both hook-up 
drawings and loop drawings you generate in SmartSketch.  If you want the print sheet size of 
hook-up drawings not to affect the print sheet size of loop drawings, duplicate the CADFunc 
folder with all its content and define a different path setting preference for loop drawings on the 
Loop Drawings > CAD File Locations page. 

 SmartPlant Instrumentation and the CAD drawing programs required to work with SmartPlant 
Instrumentation, must be installed on the same machine. 

 

Generate Enhanced Hook-Up Drawings 
 A complete hook-up drawing generation scenario is described in the Help topic Hook-Up 

Drawing Generation (on page 331). 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the hook-up type 

level in the Hook-Ups folder. 
2. In the tree view pane, select a hook-up type. 
3. In the Items pane, select and right-click one or more hook-ups. 

 In the Domain Explorer, you can also select hook-up types instead of hook-ups.  In this 
case, you can generate hook-up drawings that belong to all the hook-ups that are assigned to 
the selected hook-up types. 

4. Assign the required hook-up symbol file to the hook-up.  For details, see Assign an Enhanced 
Symbol to a Hook-Up (on page 338). 

5. On the shortcut menu, click Reports > Generate Hook-Up Drawings to display the General 
tab of the Generate Hook-Up Drawings dialog box. 

6. From the Generation method list, select Enhanced Report. 
 Under Automatic save options for enhanced hook-up drawings, you can select 

Save drawings automatically to overwrite the default folder specified on the Preferences 
dialog box, Enhanced Report > Hook-Ups > File Locations page.  You can click Browse 
and specify a different folder for saving the hook-up drawings automatically as files at the time 
of generation. 

7. Click OK to generate the drawings for the selected hook-ups. 
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 Generating an enhanced hook- up drawing with a Tag List and /or an Associated Item 
List, results in the lists being randomly positioned on your drawing.  You can drag the lists and 
position them on the drawing as required.  Each time you regenerate the drawing, the lists are 
randomly repositioned. To save the positions of the lists, drawing items, and so forth, in a 
Hook-Up drawing, use the File > Save Custom Changes > Save position at > Drawing level or 
Layout level command in the Enhanced Report Utility. For more information, see the Using 
Enhanced Report Layouts and the Saving Custom Changes to Enhanced Reports sections 
in the Enhanced Report Utility online help. 
 

Generate Hook-Up Drawings in Mixed Mode 
 

 When generating hook-up drawings in mixed mode, you use the As previously applied 
option of the Generate Hook-Up Drawings dialog box.  Mixed mode enables you to generate 
CAD hook-ups drawings and enhanced hook-up drawings altogether: CAD hook-up drawings 
for hook-ups whose generation method in the Domain Explorer is indicated as C and 
enhanced hook-up drawings for hook-ups whose generation method in the Domain Explorer 
is indicated as E.  You must first assign your hook-ups to the appropriate generation 
methods.  For details, see Apply a Drawing Generation Method to Hook-Ups (on page 335). 

 A complete hook-up drawing generation scenario is described in the Help topic Hook-Up 
Drawing Generation (on page 331). 

1. Press F7 to open the Domain Explorer and then expand the hierarchy to the hook-up type 
level in the Hook-Ups folder. 

2. In the tree view pane, select a hook-up type. 
3. In the Items pane, select and right-click one or more hook-ups. 

 
 In the Domain Explorer, you can also select hook-up types instead of hook-ups.  In this 

case, you can generate hook-up drawings that belong to all the hook-ups that are 
assigned to the selected hook-up types. 

 For hook-up drawing generation in mixed mode, you selection can include hook-ups 
assigned to the CAD generation method, hook-ups assigned to the Enhanced Reports 
method, and also hook-ups that are not assigned to any generation method. 

4. On the shortcut menu, click Reports > Generate Hook-Up Drawings to display the General 
tab of the Generate Hook-Up Drawings dialog box. 

5. Click the CAD Options tab and define options for CAD hook-up drawings as you require. 
 You must first set generation options for CAD hook-up drawings because after you select 

As previously applied on the General tab, the CAD Options tab becomes disabled.  For 
example, on the CAD Options tab, you can select the Send to plotter or printer check box if 
you want to print out the generated CAD hook- up drawings at the time of generation.  This 
check box is cleared by default. 

6. Click the General tab. 
7. From the Generation method list, select As previously applied. 

 
 After you select As previously applied, the CAD Options tab and the Automatic save 

options for enhanced hook-up drawings become disabled.  When generating the 
drawings, the software saves the output files to the default folders whose paths you 
specified on the Preferences dialog box individually for CAD drawings and enhanced 
hook-up drawings, which are generated by the Enhanced Report Utility. 
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 If you hook-up selection in the Domain Explorer includes hook-ups that are not assigned 
to any method, the software applies the method displayed in the Default generation 
method box.  You define the default generation method on the Hook-Ups > General 
page of the Preferences dialog box. 

8. Click OK to generate the hook-up drawings for the selected hook-ups. 
  
 

Displaying CAD Hook-Up Drawings with the Enhanced Report 
Utility Common Tasks 
These tasks deal with using the Enhanced Report Utility to display hook-up drawings originating in 
AutoCAD, MicroStation and SmartSketch.  Hook-up drawings comprise of a drawing, a title block, 
a block, and macros within the block.  The Enhanced Report utility handles each CAD format 
differently. 

 The Enhanced Report utility recognizes only tag and hook-up item macros within a 
given CAD block. 

Display SmartSketch Hook-Up Drawings with the Enhanced Report Utility 
Use this procedure to display a SmartSketch hook-up drawing in .sym format in the Enhanced 
Report Utility.  You can display the drawing, block, and macros leaving the title block.  For details, 
see Display SmartSketch Hook-Up Drawings with the Enhanced Report Utility (on page 342). 

Display AutoCAD Hook-Up Drawings with the Enhanced Report Utility 
Use this procedure to display an AutoCAD hook-up drawing in .dwg or .dxf format in the Enhanced 
Report Utility.  You can display the block, drawing and the macros inside the block.  However, 
you cannot associate an AutoCAD title block with the drawing.  For details, see Display AutoCAD 
Hook-Up Drawings with the Enhanced Report Utility (on page 343). 

Display MicroStation Hook-Up Drawings with the Enhanced Report Utility 
Use this procedure to display a MicroStation drawing in .dgn format in the Enhanced Report 
Utility.  You can display the drawing and the block leaving the block macros, and the title 
block.  For details, see Display MicroStation Hook-Up Drawings with the Enhanced Report Utility 
(on page 343). 
 

Display SmartSketch Hook-Up Drawings with the Enhanced Report Utility 
1. Set the preferences to view the tag and item lists in the generated hook-up drawing.  For 

details, see Enhanced Reports > Hook-Ups > View (Preferences). 
2. In SmartPlant Instrumentation, from the Domain Explorer, create a new hook-up item. 
3. From the right click shortcut menu of the hook-up item, select Properties. 
4. On the Properties dialog box, in the Drawing block file name and path data field, type the 

name and path of the desired SmartSketch block and click Ok. 
5. Set the drawing generation method for this hook-up item to Enhanced Report.  For details, 

see Apply a Drawing Generation Method to Hook-Ups (on page 335). 
6. Generate the hook-up drawing.  For details, see Generate Enhanced Hook-Up Drawings (on 

page 340). 
 The Enhanced Report utility recognizes only tag and hook-up item macros within a 

SmartSketch block. 
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Display AutoCAD Hook-Up Drawings with the Enhanced Report Utility 

 You must have AutoCAD open to be able to use this utility. 
1. In the SmartPlant Instrumentation > RAD folder, double-click TranslateCADMacro.exe to start 

the utility that allows you to adjust the macros in an AutoCAD block to the Enhanced Report 
utility macro convention. 

2. In the TranslateCADMacro utility, do the following: 
a. In the AutoCad blocks folder pane, browse to and select the desired AutoCAD block 

folder. 
b. In the Target folder pane, select the folder in which you want to place the adjusted 

blocks. 
c. Click OK. 

3. In SmartPlant Instrumentation, set the preferences to view the tag and item lists in the 
generated hook-up drawing.  For details, see Enhanced Reports > Hook-Ups > View 
(Preferences). 

4. From the Domain Explorer, create a new hook-up item. 
5. Right click the Hook-up item, and on the shortcut menu, select Properties. 
6. On the Properties dialog box, in the Drawing block file name and path data field, type the 

name and path of the desired AutoCAD block and click OK. 
7. Set the drawing generation method for this hook-up item to Enhanced Report.  For details, 

see Apply a Drawing Generation Method to Hook-Ups (on page 335). 
8. Generate the hook-up drawing.  For details, see Generate Enhanced Hook-Up Drawings (on 

page 340). 
 The Enhanced Report utility recognizes only tag and hook-up item macros within an 

AutoCAD block. 
 

Display MicroStation Hook-Up Drawings with the Enhanced Report Utility 
1. Set the preferences to view the tag and item lists in the generated hook-up drawing.  For 

details, see Enhanced Reports > Hook-Ups > View (Preferences). 
2. In SmartPlant Instrumentation, from the Domain Explorer, create a new hook-up item. 
3. From the right click shortcut menu of the hook-up item, select Properties. 
4. On the Properties dialog box, in the Drawing block file name and path data field, type the 

name and path of the desired MicroStation block and click OK. 
5. Set the drawing generation method for this hook-up item to Enhanced Report.  For details, 

see Apply a Drawing Generation Method to Hook-Ups (on page 335). 
6. Generate the hook-up drawing.  For details, see Generate Enhanced Hook-Up Drawings (on 

page 340). 
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Create a New Hook-Up Macro Definition 
1. From the Hook-Ups or Loop Drawings module, do one of the following: 

 Click Tables > Macro Definitions. 

 Click . 
2. Select the desired macro by choosing the item type and property, and where applicable, the 

relation between a specified item type and its parent.  To do this, make a selection from each 
of the lists at the top of the dialog box. 

3. In the Macro definition details data window, select the desired macro definition. 
 If there are a large number of macro definitions in the Macro definition details data 

window, under Find macro definition, select a column heading and then type a value.  For 
example, if you select Function as a column heading and type a macro function value, in the 
data window, the software locates the macro definition to which that macro function belongs. 

4. To create a customized macro definition, do one or more of the following: 
a. Under User-Defined Macro Name, type the desired user name for your macro. 

 The User-Defined Macro Name field must contain a name, it cannot be left 
empty.  If a name is missing, the macro will not function and data could be lost. 

b. Click in the Description field and change the description as desired. 
c. Under Macro Function, select a macro function to modify the appearance of the retrieved 

data. 
d. To add another customized macro definition, click New and repeat the previous step. 
e. Click Apply to accept your customized macro definitions. 

See Also 
Using Macros in CAD Blocks (on page 295) 
 

Delete a Hook-Up Macro Definition 
1. From the Hook-Ups or Loop Drawings module, do one of the following: 

 Click Tables > Macro Definitions. 

 Click . 
2. Select the desired macro by choosing the item type and property, and where applicable, the 

relation between a specified item type and its parent.  To do this, make a selection from each 
of the lists at the top of the dialog box. 

3. In the Macro definition details data window, select the row containing the macro definition 
that you want to delete. 

 If there are a large number of macro definitions in the Macro definition details data 
window, under Find macro definition, select a column heading and then type a value.  For 
example, if you select Function as a column heading and type a macro function value, in the 
data window, the software locates the macro definition to which that macro function belongs. 

4. Click Delete. 

See Also 
Using Macros in CAD Blocks (on page 295) 
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Hook-Up Reports 
The following hook-ups reports are available in SmartPlant Instrumentation: 
 Bill of Material — Displays data used in a Bill of Material. 
 Hook-Up Tag List — Displays instrument tag numbers assigned to hook-ups. 
 Hook-Up Item List — Displays hook-up items assigned to hook-ups. 
 Library Items — Displays items defined in the item libraries.  If an item library contains 

user-defined sub-libraries, the items are displayed in the report per sub-library. 
 Hook-Up Macros — Displays all SmartPlant Instrumentation macros used in hook-up 

drawings.  The report displays the macro name, description, name used in SmartPlant 
Instrumentation and, if applicable, the macro function. 

According to the report type, you can generate reports either using the Reports menu of either 
Domain Explorer, the Reference Explorer, or the Hook-Ups window.  The following table lists 
the report-specific options: 

Access to 
Report 

Bill of Material Hook- Up Tag 
List 

Hook- Up Item 
List 

Library 
Items 

Hook- Up 
Macros 

Domain 
Explorer 

Allows you to 
select all or 
selected hook-up 
types, or hook-ups 
in the Hook-Ups 
folder. 

Allows you to 
select all or 
selected 
hook-up types, 
or hook-ups in 
the Hook-Ups 
folder. 

Allows you to 
select all or 
selected 
hook-up types, 
or hook-ups in 
the Hook-Ups 
folder. 

N/A N/A 

Reference 
Explorer 

N/A N/A N/A Allows you 
to select all 
or specific 
libraries or 
sub- 
libraries in 
the 
Hook-Up 
Item 
Libraries 
folder 

N/A 
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Access to 
Report 

Bill of Material Hook- Up Tag 
List 

Hook- Up Item 
List 

Library 
Items 

Hook- Up 
Macros 

Hook-Ups 
Module 
window 

Allows you to open 
previously 
generated Bills of 
Materials Bill of 
Material by 
selecting the 
document number 
of the existing Bills 
of Materials. 

Allows you to 
open previously 
generated 
Hook- Up Tag 
List reports by 
selecting the 
document 
number of the 
existing reports.

Allows you to 
open previously 
generated 
Hook- Up Item 
List reports by 
selecting the 
document 
number of the 
existing reports.

Allows you 
to click 
Reports > 
Library 
Items to 
generate a 
report of all 
existing 
hook-up 
items. 

Allows you to 
click Reports > 
Hook-Up Macros 
and group the 
macros by 
module to 
organize the 
report pages 
according to the 
module titles.  If 
you do not group 
the macros, the 
report displays all 
the macros in 
alphabetical 
order. 

  
 

Calculating the Total of Hook-Up Items for a Bill of Material 
When you generate a Bill of Material, SmartPlant Instrumentation calculates the total quantity of 
hook-up items according to the following formula: (number of associated instrument tags + 
number of additional tags for the Bill of Material) × quantity of items of the same type × (item 
spares percentage + 100) / 100.  For example, if the total number of control valves associated 
with the hook-ups in the Bill of Material is 5, the number of additional instruments is 2, the quantity 
of male connector items is 2, and spares percentage is 20%, the total quantity is calculated as (5 
+ 2) × 2 × (20 +100) / 100 and the Total Qty column in the Bill of Material displays 12. 

 
 If the unit of measure of the hook-up item is either Item or Piece, the software rounds up the 

calculated total quantity value so that no fraction remains. 
 You define the number of the additional tags on the Associate Tag Numbers with Hook-Ups 

dialog box. 
 You define the item quantity and spares percentage on the Associate Items with Hook-Ups 

dialog box.  It is also possible to define item spares percentage on the Hook-Up Item 
Properties dialog box. 
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Hook-Up Reports Common Tasks 
These tasks deal with generating and opening a print preview of a Bill of Material and reports that 
show hook-up data, the associated instruments, and hook-up items.  For a complete list of 
hook-up reports, see Hook-Up Reports (on page 345). 

Generate a Bill of Material 
This procedure describes how to generate a Bill of Material (BOM), which is the main purpose of 
the Hook-Ups module.  Prior to generating a Bill of Material, you need to define hook- up types 
and hook-ups in the Domain Explorer, and then, associate hook-up items and instruments to the 
hook-ups.  For more information, see Generate a Bill of Material (on page 348). 

Sort Data in a Bill of Material 
Use this procedure to sort data in a Bill of Material print preview.  For more information, see Sort 
Data in a Bill of Material (on page 348). 

Generate a Hook-Up Item List Report 
Use this procedure to generate a report that displays hook-up items associated with the hook-ups 
you select in the Domain Explorer.  For more information, see Generate a Hook-Up Item List 
Report (on page 349). 

Generate a Hook-Up Tag List Report 
Use this procedure to generate a report that displays instrument tag numbers associated with the 
hook-ups you select in the Domain Explorer.  For more information, see Generate a Hook-Up 
Tag List Report (on page 349). 

Open Reports by Selecting Document Numbers 
Use this procedure to open reports by selecting document numbers you created for the current 
report type.  To use this procedure, you must first generate reports and define a document 
number for each report you want to make available for selection.  For example, you can generate 
five Hook-Up Item List reports for hook-ups belonging to the FLOW hook- up type and define the 
Flow Hook-Up document number for each report.  Furthermore, you can generate four Hook-Up 
Item List reports for hook-ups belonging to the LEVEL hook- up type and define the Level 
Hook-Up document number for each report.  You can then use this procedure to select all or 
some of the defined document numbers and open the report print preview.  For example, you can 
select five Flow Hook- Up document numbers and open the print preview of five Hook-Up Item 
List reports.  For more information, see Open Reports by Selecting Document Numbers (on 
page 350). 
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Generate a Bill of Material 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the hook-up type 

level in the Hook-Ups folder. 
2. In the tree view pane, select a hook-up type. 
3. In the Items pane, select and right-click one or more hook-ups. 

 In the Domain Explorer, you can also select hook-up types instead of hook-ups.  In this 
case, you can generate a Bill of Material for all hook-ups that belong to the selected hook-up 
types.  If you select all the hook-up types, you generate a Bill of Material for all the existing 
hook-ups. 

4. On the shortcut menu, click Reports > Bill of Material. 
5. Click Yes to open the print preview of the new Bill of Material or click No to send it to your 

default printer. 

 
 In the Bill of Material header area, some of the headers are not displayed if you generated a 

Bill of Material for more than one hook- up or hook-up type.  For details, see Bill of Material 
Print Preview Window. 

 In the Print Preview window, you can sort the Bill of Material data as you need and group the 
Bill of Material data by hook-up item manufacturer. 

 If you select the Edit mode check box, you can enter values in the For Order field, which 
appears under the Total Qty field.  The For Order values are not saved in the database and 
only appear in the current printout.  For details about the calculation formula, see Calculating 
the Total of Hook-Up Items for a Bill of Material (on page 346). 

 You can select Print BOM together with the tag list to print out the instrument tags 
associated with the hook-ups when printing the Bill of Material.  The Print Preview window 
does not show the instrument tags. 

 On the Print Preview window toolbar, clicking the revision icon  enables you to create the 
Bill of Material revision and define the document number.  After you define the document 
number, you can then open the same report using the Reports > Reports by Document 
Numbers option of the main Hook-Ups Module window. 

 Clicking  on the Print Preview window toolbar, allows you to save the Bill of Material to an 
external file and see the changes in the Bill of Material the next time you generate it. 

  
 

Sort Data in a Bill of Material 
1. In the Bill of Material print preview, from the Sort by list, select an option to arrange the fields 

as you require. 
 Each option in the Sort by list corresponds to a column header in the print preview. 

2. Select the Ascending order check box to display the fields in ascending order or clear the 
Ascending order check box to display the fields in descending order. 
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Generate a Hook-Up Item List Report 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the hook-up type 

level in the Hook-Ups folder. 
2. In the tree view pane, select a hook-up type. 
3. In the Items pane, select and right-click one or more hook-ups. 

 In the Domain Explorer, you can also select hook-up types instead of hook-ups.  In this 
case, you can generate a report for all hook-ups that belong to the selected hook-up types.  If 
you select all the hook-up types, you generate a report of all the hook-up items associated 
with for the existing hook-ups. 

4. On the shortcut menu, click Reports > Hook-Up Item List. 
5. Click Yes to open the report print preview or click No to send it to your default printer. 

 On the Print Preview window toolbar, clicking the revision icon  enables you to create 
the report revision and define the document number.  After you define the document number, you 
can then open the same report using the Reports > Reports by Document Numbers option of 
the main Hook-Ups Module window. 
  
 

Generate a Hook-Up Tag List Report 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the hook-up type 

level in the Hook-Ups folder. 
2. In the tree view pane, select a hook-up type. 
3. In the Items pane, select and right-click one or more hook-ups. 

 In the Domain Explorer, you can also select hook-up types instead of hook-ups.  In this 
case, you can generate a report for all hook-ups that belong to the selected hook-up types.  If 
you select all the hook-up types, you generate a report of all the tags associated with for the 
existing hook-ups. 

4. On the shortcut menu, click Reports > Hook-Up Tag List. 
5. Click Yes to open the report print preview or click No to send it to your default printer. 

 On the Print Preview window toolbar, clicking the revision icon  enables you to create 
the report revision and define the document number.  After you define the document number, you 
can then open the same report using the Reports > Reports by Document Numbers option of 
the main Hook-Ups Module window. 
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Open Reports by Selecting Document Numbers 
 To use this procedure, you must first generate the appropriate hook-up report in the 

Domain Explorer. 
1. On the Hook-Ups module menu bar, click Reports > Reports by Document Numbers, and 

then, select the appropriate report. 
2. On the dialog box that opens, select one or more document numbers and click OK to open the 

print preview of the reports. 
 
 

The Maintenance module provides you with all the tools required to plan, carry out, and document 
the breakdown and preventive maintenance associated with the instruments in your plant. 

Breakdown Maintenance 
Breakdown maintenance features deal with the malfunction of equipment.  You can deal with 
problems on two levels: 
 Work Requests 

A work request can be initiated by most of the technical staff.  A work request describes a 
possible malfunction or repair that may be required in the future.  The work requests are then 
examined by the maintenance supervisor or foreman who can approve them and then create 
an actual work order (repair). 

 Repair Forms 
A repair form is the actual repair or work that has been approved by the maintenance 
supervisor or foreman.  It indicates the repair date and describes the nature of the problem as 
well as the work group that is assigned to carry out the job.  The repair form also includes, in 
a different section, the information that is filled in by the person who performed the work, 
malfunction cause and action taken, as well as the down and repair time. 

Preventive Maintenance 
Preventive maintenance features enable you to maintain and schedule periodic maintenance 
activities that contain tasks and procedures. 

 
 The Maintenance module is available only if it is included in the software license that you 

purchased from Intergraph. 
 You can issue new work requests, repairs, or preventive maintenance work orders only from 

the Instrument Index module.  Once you have added maintenance records, you need to 
access the Maintenance Activities Summary window for further handling of these activities. 
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Access Rights in the Maintenance Module 
The access rights in the Administration module that control the data input for the Maintenance 
module are summarized in the following table. 

Level Item Description 

<Plant> Supporting tables Ability to access, edit and delete items from the supporting 
tables of the module which controls the forms. 

<Unit> Module Access Ability to allow or deny access to this module. 

<Unit> Work Request - 
Technician 

Ability to add new work request Forms from the Index 
module.  This option should be enabled to all technical staff.

<Unit> Repair - Technician Ability to convert and schedule the work request into an 
actual work order. 

<Unit> Repair - Supervisor Technician's option includes filling in the repair data. 

<Unit> Preventive 
Maintenance - 
Supervisor 

Preventive Maintenance supervisor's option to schedule PM 
activities, assign a work group and schedule dates. 

<Unit> Preventive 
Maintenance - 
Technician 

Preventive Maintenance technician options include filling out 
test results. 

 
 

Start the Maintenance Module 
 The Maintenance module is available only if it is included in the software license that you 

purchased from Intergraph.  Before starting this module, check with the Domain Administrator to 
ensure that you have been granted appropriate access rights for the tasks you will carry out. 

Starting the Maintenance Module From Any SmartPlant 
Instrumentation Module 

 Do one of the following: 
 Click Modules > Maintenance. 

 On the main toolbar, click . 
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Starting the Maintenance Module From an Instrument Index 
Browser View 

1. Open an Instrument Index Standard Browser view. 
2. In the browser view, select and then right-click the tag numbers that require maintenance. 
3. On the shortcut menu, point to Maintenance and then click one of the following options: 

 Schedule Preventive Maintenance Activities 
 Work Request Form 
 Repair Form 

See Also 
Performing Breakdown Maintenance (see "Performing Preventive Maintenance" on page 355) 
Performing Preventive Maintenance (see "Performing Breakdown Maintenance" on page 359) 
 

Filter Maintenance Activities 
Use this procedure to filter the maintenance records of the current domain displayed in the 
Maintenance Activities Summary window.  These include the following types of records: 

 Preventive maintenance 
 Repair forms 
 Work requests 

1. Open the Maintenance Activities Summary window. 
2. Under Process function, do one of the following: 

 To display records for tags of all process functions, select the blank row. 
 To limit the records to tags of one process function, select the process function of interest. 

3. To limit the display of preventive maintenance records to a given preventive maintenance 
code, select the code under Preventive maintenance code. 

4. To limit the display of maintenance records to a given date range, do the following: 
a. Under From, enter the starting date. 
b. Under To, enter the ending date. 

5. Do one of the following under Data level: 
 To limit the records displayed, select Plant, Area, or Unit. 
 To not limit the records displayed, accept the default setting of Domain. 

6. To limit the display of maintenance records by tag category, select a value from the Category 
list. 

7. In the Maintenance records pane, do one of the following: 
 To display records for all of the tags that have maintenance data, select All Activities. 
 To display records for selected tags, click  to open the tree, and then, select the tag for 

which you want to display maintenance records 
 To clear all filter settings, click Reset. 
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Generate a Maintenance Report 
This option enables you to select and generate a maintenance report.  You can generate the 
following reports: 
 Scheduled Preventive Maintenance Report 
 Summary of Failure Reason Report 
 Summary of Repair Action Report 
 Summary of Outcome Report 
 Repair Details Report 

1. Start the Maintenance module. 
2. In the Maintenance Activities Summary window, on the Reports menu, click the report that 

you want to generate. 
3. On the Report Properties dialog box, in the Date range group box, do one of the following to 

set the date range for the report: 
 Select the User defined option and set a specific period by typing or selecting the 

required dates from the From and To lists. 
 Select the Predefined option to generate a report for the last, current or next week, 

month, or year. 
4. To filter the data level of the report, select Plant, Area, or Unit. 
 

Preventive Maintenance Preliminary Activities 
You have to define certain preliminary settings before you can start scheduling preventive 
maintenance activities or issuing work requests and repair forms.  These preliminary settings 
include the following three definitions: 
 Define a Preventive Maintenance Attachment (on page 353) 
 Define a Preventive Maintenance Task (on page 354) 
 Define a Preventive Maintenance Activity (on page 354) 

These definitions then serve as references for the actual maintenance procedures carried out by 
the field maintenance personnel. 
 

Define a Preventive Maintenance Attachment 
An attachment is an external document that is provided to the maintenance crew.  This procedure 
describes how to define an attachment and associate it with an external file, which can be a text 
document, a .doc file, a drawing, a sketch, and so forth. 
1. Start the Maintenance module. 
2. In the Maintenance Activities Summary window, do one of the following: 

 Click Tables > Attachments. 

 Click . 
3. On the Attachments dialog box, click New to define a new attachment. 
4. Click in the Name field and type the attachment name or code that will then serve as a 

reference for the task. 
5. In the Description field, type an appropriate description. 
6. Click Browse to associate the current attachment with an external file which can be a 

drawing, a text file, or a vendor's document, and so forth. 
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7. Click View to view the external file to make sure it is the correct one. 
8. Click Save and then Close to return to the Maintenance Activities Summary window. 
 
 

Define a Preventive Maintenance Task 
After defining the preventive maintenance attachments, you have to define the appropriate 
maintenance tasks that will be carried out.  The tasks are associated with the attachments you 
have defined and then they will be included in the appropriate maintenance activities. 
1. Start the Maintenance module. 
2. In the Maintenance Activities Summary window, do one of the following: 

 Click Tables > Preventive Maintenance Tasks. 

 Click . 
3. On the Preventive Maintenance Tasks dialog box, click New to define a new task. 
4. Click in the Task field and type the new task name. 
5. Click in the Attachment field and select the appropriate attachment with which new task is to 

be associated. 
6. Click in the Note field and type any note you deem fit for the current task. 
7. Click Save and then Close to return to the Maintenance Activities Summary window. 
 
 

Define a Preventive Maintenance Activity 
You define the preventive maintenance activities after defining the preventive maintenance tasks 
and attachments.  Each activity can hold a number of tasks which are in turn associated with the 
defined attachments.  You select the defined tasks in the sequence they are to be 
performed.  The defined activity also contains other default scheduling information, such as the 
down/repair time, the interval and frequency for the current PM activity, the required calibration 
values, and so forth. 
1. Start the Maintenance module. 
2. In the Maintenance Activities Summary window, do one of the following: 

 Click Tables > Preventive Maintenance Activities. 

 On the module toolbar, click . 
3. On the Preventive Maintenance Activities dialog box, click New to define a new activity. 
4. Click in the PM code field and type a new preventive maintenance code for the current 

activity. 
5. Click in the Typical Instrument field and select the appropriate typical instrument from the 

list.  If the required option is not available, click Typical Instrument. 
6. Click in the Description field and type an appropriate description for the current activity. 
7. Click in the Note field and type any appropriate note if necessary.  Use the horizontal scroll 

bar to make the Note field visible. 
8. In the Associated preventive maintenance tasks section, click Add to include a task with 

the activity. 
9. Click in the Task field and select the appropriate task from the list.  You can assign more than 

one task to the same activity.  Click Add to add more tasks as required.  Note that each task 
must be unique.  If the required task is not available, click Tasks. 



 Instrument Maintenance 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 355 
 

The software assigns the new task a sequence number.  The appropriate attachment is 
selected and it appears in the Attachment field. 

10. Enter the default scheduling data as needed by selecting the appropriate scheduling settings 
from the Default scheduling and Estimated maintenance time sections. 

 Selecting the Calibration Required check box enables you to enter calibration values 
when filling out the Preventive Maintenance details.  This option becomes available in the 
Preventive Maintenance Activity Details dialog box if you have defined the required 
calibration settings for the current tag before you started the Maintenance module. 

11. Click Save and then Close to return to the Maintenance Activities Summary window. 
  
 

Performing Preventive Maintenance 
Scheduling new preventive maintenance work orders is done only from the Instrument Index 
module (unless you are extending an already assigned PM job).  Once a PM work order has been 
scheduled, you open the Maintenance Activities Summary window for further handling of these 
activities where you fill in the maintenance details or reports. 
To define the raw PM activities, tasks and attachments, you need to access the Maintenance 
module and start to define the tasks from the lowest level – the 'attachment'.  An 'attachment' 
describes a set of instructions to the technical staff.  An attachment can be associated with any 
external document (a Microsoft Word file, a scanned image, or manufacturer maintenance 
document).   Typical attachments define safety precaution instructions, technical instructions for 
bypassing a process, the actual set of instructions required to carry out the activity itself, restoring 
the process back to its operational status, and so forth. 
A task is a set of instructions associated with an attachment.  You can associate a single 
attachment with multiple PM activities.  A task can include the attachment and a description. 
Once you define the attachments and tasks, you can introduce a new PM activity.  Each PM 
activity can hold several tasks in the sequence they were added.  At this stage, it is also advisable 
to associate a PM code with a particular typical instrument (for example, transmitter, transducer, 
control valve, switch, and so forth.) This is very useful for report generation and other 
statistics.  Moreover, a PM activity contains additional default information, such as the required 
calibration values, the down/repair time that an average maintenance job will take, the interval and 
frequency for each PM job. 
Once all the required attachments, tasks, and activities have been defined, the preventive 
maintenance supervisor can schedule these activities to the selected tags from an Instrument 
Index Standard Browser view.  At this stage, the PM activities are ready to be further processed 
and be filled in by the maintenance crew in due time. 
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Perform Preventive Maintenance 
The following is the recommended flow of activities for preventive maintenance: 
1. Start the Maintenance module and define the raw PM activities, tasks, and attachments. 
2. Start the Instrument Index module and open an Instrument Index Standard Browser view. 
3. Select the required tag numbers for which you want to schedule a PM job and start the 

Calibration module. 
4. If the instrument requires calibration, enter the appropriate calibration settings for the selected 

tags. 
 Failure to define the calibration settings prior to starting the Maintenance module 

result in the inability to enter the calibration values when entering preventive maintenance 
details.  The Calibration As Found/As Left dialog box will not be accessible.  Therefore, it 
is essential that you enter the calibration settings for the selected tags before you schedule a 
PM job from the browser view. 

5. Go back to the Instrument Index Standard Browser view and right-click the selected tags. 
6. Associate the tag category and criticality as needed.  For details, see Associate Tag 

Category and Criticality. 
7. On the shortcut menu, click Maintenance > Schedule Preventive Maintenance Activities. 
8. Create the new schedule for the PM activity. 
9. Start the Maintenance module and fill out the PM activity details as desired. 

At this stage, you can also issue work requests and open repair forms for the instruments as 
needed. 

 When saving PM activity details, SmartPlant Instrumentation prompts you to create a work 
request if the status of the PM activity is Failed.  Clicking Yes creates the Preventive 
Maintenance record and opens the Work Request dialog box where you can create a repair form. 
 
 

Schedule Maintenance 
1. With the Maintenance Activities Summary window open, click  on the Main toolbar to 

start the Instrument Index module. 

2. Click Actions > Browse Index or click  on the Instrument Index module toolbar. 
3. In the Instrument Index Standard Browser view, select the instrument for which you want to 

schedule maintenance.  You can select multiple tag numbers if needed. 
4. Right-click the selected tags to open a shortcut menu, point to Maintenance and select 

Schedule Preventive Maintenance Activities. 
5. From the PM code list, select the appropriate preventive maintenance code to associate the 

selected instruments with the required PM code, or click . 
6. From the Assigned workgroup list, select the work group to which the preventive 

maintenance activity will be assigned.  If the required work group is not available in the list, 

click . 
7. From the Priority list, select the required job priority. 
8. Set the starting date, frequency, and the PM interval.  By default, these values are taken from 

PM definition. 
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9. In the Limit by section, select either the Date or the Number of PM Activities option button 
to choose whether you want to set the number of times this PM activity to be carried out or be 
limited by a time period. 

10. In the Scheduling Options section, select how you want to fine-tune the scheduling: 
 No changes — the scheduling will remain as you defined it in the Start date, Frequency, 

Interval, and Limit by options. 
 Schedule jobs for — fine- tune the scheduling by selecting a specific day of the week, for 

example every Tuesday of the month. 
 Schedule jobs for each — fine-tune the scheduling by selecting a specific day of the 

month, for example every 15th of the month. 
11. Click Preview to display the scheduling in the Preview data window. 

 You can also fine-tune the scheduling by editing the PM dates in the Preview data 
window.  Click the required PM date and modify the date as needed.  All the changes will be 
implemented after you click Generate. 

12. Click Generate and then click Close. 
13. Go back to the Maintenance Activities Summary window by selecting it from the Window 

menu. 

14. In the Maintenance Activities Summary window, click  to display the new PM records 
that you have just scheduled for selected instruments. 

 
 

Extend Existing Scheduling 
1. Start the Maintenance module. 
2. In the Maintenance Activities Summary window, filter the records as needed. 
3. Highlight the required row in the Preventive Maintenance data window and do one of the 

following: 
 Click Actions > Extend. 

 Click . 
4. On the Extend Scheduling dialog box, do the following: 

a. On the Take scheduling data from group box, select one of the following: 
 Last preventive maintenance activity — fetch the scheduling data from the last PM 

activity. 
 Preventive maintenance code defaults — fetch the scheduling data from the PM 

codes. 
b. On the Limit scheduling by group box, select one of the following: 

 Date — Sets the scheduling limited by date.  Use the spinner to set the required date. 
 Number of activities — Sets the scheduling limited by the number of 

activities.  Enter the number of activities in the field provided. 
5. Click Generate. 
6. Click Close after the record generation is complete. 
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Enter Preventive Maintenance Details 
1. Start the Maintenance module. 
2. In the Maintenance Activities Summary window, filter the records that you want to display. 
3. In the Preventive maintenance pane, select the desired record and do one of the following: 

 Click Actions > Open. 

 Click . 
4. In the Work Activity Details window, from the Work Status list, select the required work 

status if you need change the displayed one. 

 
 You can add your own values to the lists in the Work Activity Details window using the 

supporting tables, which you access from the Tables menu. 
 The following parameters in this window are not accessible to the repair technician and 

can be modified only by the maintenance supervisor: 
 PM code 
 Priority 
 Created by 
 Creation Date 
 Last preventive maintenance 
 Interval 
 Frequency 

5. Assign the required work group by selecting the required option from the Maintenance staff 
(scheduled) list. 

6. Modify the automatically generated work order number if required. 
7. Modify the scheduled date if needed. 
8. Enter the start and completion dates, service, and down time. 
9. From the Maintenance staff (actual) list, select the repair technician. 
10. Select the required PM result from the Results list. 
11. If the maintenance result is Failed, select the failure reason and repair action. 

 The Failure reason and Repair action lists are available only if the maintenance result is 
Failed. 

12. Type any additional notes you might require in the Note data window. 

13. Select the Calibration Required check box and click  to open the Calibration Data Entry 
window where you enter the required calibration values.   Note that the Calibration Data 
Entry window is accessible only if you have entered appropriate calibration settings for the 
selected instrument before entering PM activity details. 

14. To change the work status, select the required option from the Work status list. 

15. Click  and create a work request if needed. 
16. Click Yes when prompted for SmartPlant Instrumentation to create a work request 

automatically. 
 SmartPlant Instrumentation prompts you to create a work request when a maintenance 

activity fails.  This happens when you select Failed from the Results list in the Work Activity 
Details window. 
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17. Click Close in the Work Activity Details window to return to the Maintenance Activities 
Summary window. 

 
 

Performing Breakdown Maintenance 
You create new work requests or repair forms from the Instrument Index module.  These 
procedures depend on the level of access rights granted to you.  For details, see Access Rights in 
the Maintenance Module (on page 351).  Once a new work request or a repair form has been 
created, it can only be accessed from the Maintenance module Maintenance Activities 
Summary window.  The maintenance supervisor can review the work requests and use them to 
create repair forms.  The repair form indicates the work request number that was used to create 
it.  The repair form also includes the problem description.  At this stage, it is also possible to 
indicate that calibration is required.  The supervisor then schedules this work for a certain date 
and assigns the work group that will deal with it.  The status of the job at that point is Scheduled. 
After the maintenance work is carried out, the technician responsible for it can fill in the rest of the 
repair information, and change its status to Done or close it.  You can customize additional 
statuses such as Hold, Turnaround, and so forth to cope with situations and that comply with the 
conventions at your plant. 

 It is recommended to set the required quality system and criticality prior to starting the 
Maintenance module. 
 

Perform Breakdown Maintenance 
The following is the recommended flow of activities for breakdown maintenance: 
1. Start the Instrument Index module and open an Instrument Index Standard Browser view. 
2. Select the desired instruments (tag numbers) for which you want to enter work requests and 

start the Calibration module. 
3. If the instruments require calibration, enter the required calibration settings for the selected 

tag numbers.  For details, see Define Tag Calibration Settings (on page 409). 
 Failure to define the calibration settings prior to starting the Maintenance module 

results in the inability to enter the calibration values when completing a Repair Form.  (The 
Calibration As Found/As Left dialog box will not be accessible.)  Therefore, it is essential 
that you enter the calibration settings for the selected tags before you open Work Requests 
from the Instrument Index Standard Browser view. 

4. Go back to the Instrument Index Standard Browser view and right-click the selected tags. 
5. Associate the tag category and criticality as needed.  For details, see Associate Tag 

Category and Criticality. 
6. In the browser view, right-click the selected tags and click Maintenance > Repair Form or 

Maintenance > Work Request Form. 
7. Enter the desired repair or work request values. 
8. Start the Maintenance module to complete the entry of the required repair or work request 

values. 
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Issue a New Work Request 
 You can issue new work requests only from the Instrument Index Standard Browser view or 

from the Work Activity Details window if the activity result status was Failed. 
1. Open an Instrument Index Standard Browser view. 
2. Select the required tag number for which you want to issue a work request. 

 Do not select multiple tag numbers in the browser view.  This option is available for 
single instruments only. 

3. Right-click the selected tag and from the shortcut menu,  click Maintenance > Create Work 
Request. 

4. In the Create Work Request dialog box, modify the work request number if needed - the 
software fills in the values automatically. 

5. Select the Typical Instrument and the Work Request Reason from the lists.  
6. Type the required work request title. 
7. Type the appropriate problem description if needed. 
8. Click Save and then Close to return to the browser view. 

 You cannot generate a repair form in this case. 
  
 

Opening a Work Request 
You can open work requests from an Instrument Index Standard Browser view or from the 
Maintenance Activities Summary window.  However, you can issue new work requests only 
from the Instrument Index Standard Browser view or from the Work Activity Details window if the 
activity result was Failed.  It is recommended that you create a new work request from the 
browser view and then open this new work request record in the Maintenance Activities 
Summary window.  Due to the access rights restrictions, some of the work request features are 
disabled if accessed from the browser view. 
If you have been granted full access rights and you are the maintenance supervisor, you can first 
issue a new work request in the Instrument Index Standard Browser view and then open it in the 
Maintenance Activities Summary window.  This enables you to create a repair form.  Repair 
form creation is not available when issuing a new work request, which is only possible from the 
Maintenance Activities Summary window.  It is not possible to create a repair form from the 
work request because all work requests have to be reviewed by the supervisor. 
When you issue or open a work request, SmartPlant Instrumentation automatically assigns this 
record a work request number that you can modify if needed. 
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Open an Existing Work Request 
1. In the Maintenance Activities Summary window, filter the records as needed. 

2. In the Work requests pane, select the required records and click . 
 All work requests have the WR notation preceding the work request number. 

3. In the Work Request window, modify the work request number and title if needed these are 
filled in automatically by SmartPlant Instrumentation.  If you leave the Word request title 
field blank, the software fills it after you select a typical instrument and a work request reason. 

4. Modify or select the typical instrument and the work request reason from the lists.   If the 
required option is not on the list, click Tables > Typical Instruments or Tables > Work 
Request Reasons as needed. 

5. Type the appropriate problem description if needed. 
6. To generate a repair form, click Actions > Repair Form. 

 
 This option is not available if you opened the Work Request dialog box from an 

Instrument Index Standard Browser view. 
 This option is accessible only if you have been granted the appropriate access rights.  

For details, see Access Rights in the Maintenance Module (on page 351). 
7. Click Save and then Close to return to the Maintenance Activities Summary window. 
 
 

Create a New Repair Form 
1. Open an Instrument Index Standard Browser view. 
2. Select the required tag number for which you want to issue a work request. 
3. Right-click the selected tag, and from the shortcut menu click Maintenance > Repair Form. 

 It is also possible to create a new repair form from the Work Request window when 
opening a work request from the Maintenance Activities Summary window.  You can then 
open the newly created repair form from the Maintenance Activities Summary window. A 
repair form that you create from a work request retains its WR identification number. 

4. In the Repair (scheduled) group box of the Repair Form window, modify the scheduled date 
and the work order number if necessary. 

 The Repair (actual) options are not available at this stage.  The Repair options contain 
the actual work order information. 

5. Select a work request reason from the list.  If the required option is not available in the list, 
click the required option on the Tables menu. 

6. Type the work request title and the problem description. 
7. Set the repair priority by selecting the required option from the Priority list. 
8. From the Maintenance staff (scheduled) list, select the appropriate work group from the list 

or accept the displayed one.  If the required option is not available, click the required option 
on the Tables menu. 

9. Click Save and then Close to return to the Maintenance Activities Summary window. 
In due time, a repair technician can open this repair form from the Maintenance Activities 
Summary window and fill out the information under Repair (actual). 
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Fill Out a Repair Form 
 You can add your own values to the lists in the repair form using the supporting tables, 

which you access from the Tables menu. 
1. In the Maintenance Activities Summary window, filter the records as needed. 

2. In the Repairs pane, select the desired records and click . 
3. In the Repair (scheduled) group box of the Repair Form window, do the following: 

a. Update the work status from the Work Status list. 
b. Modify other values as needed. 

4. In the Repair (actual) group box, set the start and completion dates. 
5. Set the down and repair time. 
6. To perform a calibration, do the following: 

a. Select the Calibration required check box. 
b. Click Actions > Calibration. 
c. Follow the calibration flow of activities.  For details, see Flow of Activities for Entering Tag 

Calibration Data (see "Calibration Data Entry Activities" on page 411). 
7. From the Maintenance staff (actual) list, select the person who is assigned to carry out the 

repair. 
8. From the Failure reason list, select the failure reason of the instrument. 
9. From the Outcome list, select the required item that describes the effect of the current failure, 

for example partial or complete unit shutdown, and so forth. 
10. From the Repair Action list, select the value that describes what action has been taken to 

repair the failure. 
11. In the Comments data window, type a brief comment if needed. 
12. When done, click Save and then Close to return to the Maintenance Activities Summary 

window. 
 
 

Maintenance Event Records 
For an instrument existing in As-Built or in an engineering company domain it is possible to create 
records of repairs, tests, inspections, calibrations, and so forth.  These records are called 
maintenance event records.  It is possible to associate several maintenance event records with a 
particular instrument, provided that this instrument belongs to one of the following tag classes: 
Conventional, Fieldbus, HART, or Profibus.  A user with full Calib. & Maint. Events access rights 
can create maintenance event records.  After a record is created, it is considered active until a 
supervisor user with full Calib. & Maint. Event Supervisor rights marks the record as 
complete.  Completed records are automatically saved to the database.  Only a supervisor can 
delete completed maintenance event records. 
Maintenance event record creation and management is performed in the Domain Explorer.  In 
the Domain Explorer, all maintenance event records appear under instruments, in the 
Maintenance Events folder.  Active records are indicated by .  Completed records are 
indicated by . 
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When creating a record, the software specifies a name for the record automatically, according to 
the preferences that you set on the Preferences dialog box.  For details of the preferences 
options, see Calibration and Maintenance > General (Preferences).  The maximum length of the 
record name can be sixty characters.  Before a record is complete, a user with full Calib. & Maint. 
Events access rights can update the record name by changing the event date. 
When creating a maintenance event record, you must select a maintenance even form whose 
process function is the same as the process function of the source instrument.  If you assign a 
maintenance event form to an instrument type profile in the Instrument Index module, this form is 
selected automatically when you open the Maintenance Event Properties dialog box to create a 
new record.  You need to familiarize yourself with various options of the Specifications module to 
be able to define and manage forms compatible with maintenance event records.  For more 
details about forms, see Spec Forms.   There is one shipped form designed for displaying 
maintenance event records for level instruments: Displacer Level Switch (form number 93).  You 
need to restore this form first.  This form page contains non- editable fields from the 
COMPONENT table.  When regenerating a page for such a form, you can add editable fields from 
the WORK_ACTIVITY table, and also add non- editable fields from the CALIBRATION_SETTING, 
COMPONENT, PD_GENERAL, and SPEC_SHEET_DATA tables.  If you want to create 
maintenance event records for instruments whose process function is other than Level, you need 
to use the Change Process Function options of the Page Editor.  For details, see Select a 
Different Process Function for a Page. 
A page on which you base maintenance event records does not have a title block and, therefore, 
does not contain any revision data or document number.  You cannot use comparison options 
with maintenance event records.  You can create, open and complete one record at a time.  It is 
possible to open and print out several completed records at a time. 
 
 

Defining and Managing Maintenance Event Records 
The following is the recommended flow of activities for defining and managing maintenance event 
records in SmartPlant Instrumentation. 

1. Grant Access Rights for Opening and Completing Maintenance Event Records 
The Domain Administrator needs to define access rights for users working with maintenance 
event records in As-Built or in an engineering company domain.  These access rights allow a 
regular user to create maintenance event records and update the record names.  Such a user 
must have full Calib. & Maint. Events access rights.  After a record is created, it is considered 
active until a supervisor user marks this record as complete.  A supervisor user can delete the 
record if it becomes obsolete.  Such a user must have full Calib. & Maint. Event Supervisor 
access rights.  Before granting access rights, the Domain Administrator needs to assign these 
users to different user groups because access rights in SmartPlant Instrumentation are granted 
per group.  For details about access rights, see the Administration Module User's Guide, Domain 
and Project Administration, Access Rights. 

2. Set a Date Format for Maintenance Event Record Names 
Use this procedure to set a date format that the software applies to names of maintenance event 
records when you create such records in the Domain Explorer.  This procedure can be only be 
performed by a user that have rights to set or modify preference settings of SmartPlant 
Instrumentation.  For details, see Set a Date Format for Maintenance Event Record Names (on 
page 364). 
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3. Create a Maintenance Event Record 
Use this procedure to create a maintenance event record.  This procedure can only be performed 
by a user with full Calib. & Maint. Event Supervisor access rights.  For details, see Create a 
Maintenance Event Record (on page 364). 

4. Complete a Maintenance Event Record 
Use this procedure to mark a maintenance event record as completed.  This procedure can only 
be performed by a user with full Calib. & Maint. Events access rights.  For details, see Complete a 
Maintenance Event Record (on page 365). 
 
 

Set a Date Format for Maintenance Event Record Names 
1. Click File > Preferences. 
2. In the tree view, click Calibration and Maintenance > General. 
3. In the Maintenance event date format box, enter a valid date format using one of the 

following examples: 

Date Format Example  

mm-dd- yy 01-30- 09 

mm-dd- yyyy 01-30- 2009 

dd-mm- yy 30-30- 09 

dd-mm- yyyy 30-30- 2009 

d-mmm- yy 30-Jan- 09 

mmm-yy Jan-09 

 
 SmartPlant Instrumentation only support date formats that are listed in this table. 
 You can use one of the following characters as separators: dash (-), slash (/), space, comma, 

semicolon, colon, or dot. 
 
 

Create a Maintenance Event Record 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the instrument level 

in the Instruments folder. 
2. Click an instrument for which you want to create a maintenance event record.  The 

instrument that you select must belong to one of the following classes: Conventional, 
Fieldbus, HART, or Profibus. 

3. Right-click the Maintenance Events folder and on the shortcut menu click New > 
Maintenance Event Record. 

 You can create one maintenance event record at a time. 
4. Under Maintenance event date, define the date of the event. 

When you define the date, the software automatically displays the record name in the Record 
name box, according to the preferences you set.  For details, see Calibration and 
Maintenance > General (Preferences). 

5. In the Maintenance event description box, type and optional description. 
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The description does not appear automatically on the record sheet.  To display the 
description on the record sheet, you need to regenerate the form page on which the record is 
based and add the wa_prob_desc field in the page. 

6. Under Form number, select a form whose process function is the same as the process 
function of the source instrument. 

7. Click OK to create the record and display it in the Maintenance Events folder.  It is indicated 
as an active record by . 

 
 

Complete a Maintenance Event Record 
1. Press F7 to open the Domain Explorer and then expand the hierarchy to the instrument level 

in the Instruments folder. 

2. Click an instrument containing active maintenance event records, which are indicated by . 
3. Click the Maintenance Events folder to display the existing records. 
4. Right-click a specific record and then, on the shortcut menu, click Actions > Open 

Document. 
5. On the Maintenance Event Record window menu bar, click Actions > Mark as Complete. 

 
 In the Domain Explorer, completed records are indicated by . 
 After a record is marked as completed, you cannot update any settings for the record, only 

open a record print preview or delete the record. 
 To delete obsolete records, right-click one or more records in the Domain Explorer and then, 

on the shortcut menu, click Delete. Alternatively, click Properties and then delete the selected 
records one by one from the Maintenance Event Properties dialog box.  All records in your 
selection must be either active or completed. 

 
 

The Dimensional Data for Piping (DDP) module enables you to store and manage three levels of 
dimensional data: default, working, and vendor.  This structure represents the natural flow of 
information and activities related to dimensional data processing. 
You can store and maintain default instrument dimensional data by classifying it per group, 
manufacturer, or process connection. 
The DDP module also enables you to store and maintain dimensional data received from a 
vendor.  This data can also be classified per group, manufacturer, or process connection. 
Most significantly, the DDP module provides the means to transfer, store, and maintain certified 
vendor dimensional data for your instruments.  This certified vendor data will then be transferred 
to your Working data which you use for the actual instruments in your database. 
You can use the DDP module to transfer external dimensional data to your SmartPlant 
Instrumentation database and export of dimensional data from your database to an external 3-D 
piping design application. 

Dimensional Data and Piping 



Dimensional Data and Piping 
 

 
366 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

In addition, the DDP module enables you to generate and print out various dimensional data 
reports that facilitate your dimensional data management.  These reports can help you keep track 
of suspected data, data status, default dimensional data, and vendor dimensional data, and so 
forth. 

 The Dimensional Data for Piping module is available only if it is included in the software 
license that you purchased from Intergraph. 
 
 

Principles of the DDP Module 
This section provides general guidelines and a recommended flow of activities for the DDP 
module. 
At the initial stage, you should select the appropriate instrument types and define their instrument 
profiles so that dimensional data handling is clearly specified.  Based on the existing dimensional 
library and practices of dimensional data processing, you also classify the instruments by their 
type and pre-assigned DDP group by defining this group in the instrument type profile. 
Next, define basic instrument parameters in the Instrument Index module or Specifications 
module, including the instrument manufacturer, model, and process connections. 
Group definition coupled with basic information enables the dimensional data designer to provide 
piping designers with preliminary dimensions filled from the standard dimensional data library 
based on specified basic instrument parameters. 
When requests for quotations are issued and vendor bids are evaluated, more detailed 
dimensional information supplied by vendors and manufacturers in electronic or hard copy form 
can be automatically imported or manually entered as vendor data. 
This vendor data lets the designer re-evaluate dimensional data, if desired, and issue 
vendor-certified dimensional data to the piping. 
Starting from the moment when the preliminary dimensional data was selected for the 
instruments, you are able to release this information to the piping design.  This can be done in two 
forms — electronically or by providing a hard copy.  Electronic form is an automatic transfer and 
processing of the structured data to a 3-D CAD system.  Alternatively, dimensional data report or 
dimensional data sheet can be printed out and transferred to the piping design department in 
paper form. 
The status of the dimensional data design can be tracked through the instrument status.  You can 
also view the history information for the selected instrument modifications. 
Controlling the modifications of critical definitions, such as a DDP group, instrument type, model, 
and process connections provides the means to manage and keep track of suspected data during 
the whole life cycle of the dimensional data design. 
 

Additional Settings 
You also have to make some additional settings for the dimensional data.  These settings include 
the following: 
 Equipment and equipment type 
 Instrument manufacturer 
 Instrument model 

You access the appropriate dialog boxes from the Dimensional Data for Piping Module window 
and by selecting the desired command on the Tables menu.  These definitions are actually made 
in the Instrument Index module and can be accessed from the Dimensional Data for Piping 
module too. 
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For a detailed explanation about the above-mentioned settings, see the Instrument Index module 
documentation. 

Start the DDP Module 
Use this procedure to start a DDP (Dimensional Data for Piping) module session. 

 The DDP module is available only if it is included in the software license that you purchased 
from Intergraph. 
Do one of the following: 

 Click . 
 Click Modules > Dimensional Data. 

 

Preliminary Procedures 
There are two preliminary procedures that you have to carry out before you start entering 
dimensional data.  These procedures are: 
 Defining the setting for the Dimensional Data for Piping module.  To carry out this procedure, 

you must log on to the Administration module as System Administrator and enter the desired 
data on the Dimensional Data Settings Dialog Box. 

 Associating an Instrument Type with a DDP Group (see "Associate an Instrument Type with a 
DDP Group" on page 369) 

 

Define the Process Connection Class/Rating 
This procedure enables you to define the desired process connection class / rating.  This 
represents the value of the maximum in-line pressure that the process connection can withstand. 
1. In the Dimensional Data for Piping Module window, click Tables > Process Connection 

Classes. 
2. To create a new process connection class, click New. 
Type the appropriate process connection class name and description. 

 You cannot delete a process connection class if it is associated with default, working, or 
vendor data. 

 The connection class name may not be longer than 9 characters so that the DDP Export 
Utility can include it in the output file. 
 

Define a Process Connection End Preparation 
This procedure enables you to define the desired process connection end preparation. 
1. In the Dimensional Data for Piping Module window, click Tables > Process Connection 

End Prep. 
2. To create a new process connection end preparation, click New. 
3. Type the appropriate process connection end preparation name, design code, and 

description. 
 The end preparation name may not be longer than 9 characters so that the DDP Export 

Utility can include it in the output file. 
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Define a Dimensional Group 
Defining the dimensional groups is the step in storing and managing dimensional data.  You need 
dimensional groups to store, display, and manage default, working and vendor dimensional 
data.  Moreover, instrument types are also associated with dimensional groups.  Hence, new tag 
numbers whose instrument type is associated with a particular dimensional group will contain 
dimensional data and this dimensional record will be displayed in the Working Data window. 

 The Domain Administrator first needs to import DDP library data, including default groups. 
1. In the Dimensional Data for Piping window, click Tables > Dimensional Groups. 
2. To create a new dimensional group, in the Dimensional Groups dialog box, click New. 
3. Under Dimensional Group, type the group name. 
4. Under Description, type the group description. 
5. Select the 3 Points and/or 4 Points check boxes, depending on how many connection points 

you want to define. 
6. In the CAD Code field, type the desired CAD code. 
7. To define the current group parameters, click Properties.  See Defining Dimensional Group 

Properties (see "Define Dimensional Group Properties" on page 368) for more details. 
8. To assign a picture to the selected group, do the following: 
9. Under Picture, click Assign. 
10. In the Select Group Picture dialog box, navigate to the desired file, and click Open. 
11. To assign a dimensional data sheet form to the current group, under Form, click Assign. 
  
 

Define Dimensional Group Properties 
This procedure enables you to define dimensional data parameters for a given dimensional 
group.  These parameters then appear in the Default Data window, the Working Data window, 
and the Vendor Data window, as well as in the Dimensions section of the Add Data, and Edit 
Data dialog boxes. 
Thirty parameters are available for each dimensional group.  You create an active parameter by 
typing its description, selecting it for use, and setting its allowed minimum value to be zero or 
greater than zero. 
1. In the Dimensional Data for Piping Module window, click Tables > Dimensional Groups. 

 At this point, you can modify general properties of the dimensional group.  For details, 
see Defining Dimensional Groups. 

2. Click Properties. 
3. In the Dimensional Group Properties dialog box, under Description, type the desired 

parameter description. 
4. To include this parameter in the selected dimensional group, click Select. 

 
 To select all thirty parameters, select the Select all check box. 
 You cannot clear a Select check box for a parameter for which the dimensional group is 

assigned. 
5. If you require the selected parameter to have a value greater than zero, select the Release if 

Zero check box. 
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 Clearing Release if Zero does not prevent you from placing zeros in this field, but rather 
prevents the release of dimensional data by disabling the Ready for Release option. 

6. Click OK to accept your definitions and return to the Dimensional Groups dialog box. 
 

Duplicate a Dimensional Group 
This option enables you to create a new dimensional group based on the same group parameters 
as the selected group. 
1. With the Dimensional Groups dialog box open, highlight the desired group. 
2. Click Duplicate to duplicate the selected group. 
3. Click OK to accept your definitions, save the group data, and close the dialog box. 
 

Assign Dimensional Data Forms 
Assigning a dimensional data form to a dimensional group consists of two stages: 
 Assigning a .psr file to a dimensional data form 
 Assigning the dimensional data form to a dimensional group 

Assign a PSR File to a Dimensional Data Form 
1. In the Dimensional Data for Piping Module window, on the Tables menu, click 

Dimensional Data Sheet Forms. 
2. To create a new dimensional data form, do the following: 
3. Click New. 
4. Type the form name and description in the appropriate fields. 
5. Select the dimensional data form to which you want to assign a .psr file, and click Assign. 
6. In the Select Group Form dialog box, navigate to the desired .psr file and click Open. 
7. In the Dimensional Data Forms dialog box, click OK. 

Assign a Dimensional Data Form to a Dimensional Group 
1. Click Tables > Dimensional Groups. 
2. Select the group to which you want to assign a dimensional data form, and under Form, click 

Assign. 
3. In the Assign Dimensional Data Form dialog box, select a form, and click OK. 
 
 

Associate an Instrument Type with a DDP Group 
This option enables you to set the default dimensional group for new tag numbers that are 
associated with dimensional data.  Note that this procedure is performed in the Instrument Index 
module. 
1. In the Instrument Index Module window, click the Tables > Instrument Types. 
2. From the Process function list, select the process function. 
3. In the data window, select the instrument type. 
4. Click Profile. 
5. On the General tab, under Dimensional data, do the following: 
6. Select the Include dimensional data check box to associate the selected instrument type 

with dimensional data. 
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7. From the Group Name list, select the dimensional group with which dimensional data will be 
associated by default. 

8. Click OK to close the Instrument Type Profile dialog box and then click OK to close the 
Instrument Types dialog box. 

  
 

Vendor Data 
Vendor data is used for data validation and verification purposes of dimensional data for piping 
design.  You use Vendor data to certify the Working data prior to its release to piping. 
Instead of inserting raw Vendor data manually, use the Import Utility to import a large amount of 
raw vendor information.  After importing the Vendor data, you revise the raw vendor data to 
assign it to a dimensional group, verify the instrument tags, and, if desired, manually modify the 
vendor data details. 
Sometimes multiple records for the same instrument can exist.  This can happen if you import 
vendor data from several manufacturers.  You can copy vendor data to the Working data if the 
manufacturer, model, the Dimensional Group, and the process connection values match the 
Working data values. 
You can also indicate whether the imported data has been copied to the Working data.  You can 
reset this indication every time import is performed for a specific record, thus creating a clear 
indication if the latest information has been copied to the Working data. 
Managing Vendor data involves editing it and entering new dimensional vendor data for a selected 
instrument. 
Vendor data is displayed in the Vendor Data window. 
 

Display and Access Vendor Data 
1. With the Dimensional Data for Piping Module window open, do one of the following; 

 Click . 
 Click View > Vendor Data. 

2. In the Select Dimensional Group dialog box that opens, select the desired dimensional 
group and click OK. 
The Vendor Data window opens displaying the existing vendor data records. 
You can customize the display and layout of the data in the Working Data window.  The 
following options are available: 
 Determining the fields to be displayed 
 Sorting the data 
 Filtering the data 
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Enter Vendor Data 
This feature allows you to enter vendor data manually.  It is useful when adding a few records.  If 
you want to enter numerous records, use the Import Utility. 
1. Open the Vendor Data window and do one of the following: 

 Right-click anywhere in the Vendor Data window and click New Vendor Data on the 
shortcut menu. 

 Click Actions > New Vendor Data. 
2. Beside Tag number, click Browse and then do the following: 
3. In the Enter Tag dialog box, type in the desired tag number and click OK or click Find to find 

the desired tag number. 
4. In the Find Tag dialog box, enter the desired search parameters and click Find to find the 

desired tag number. 
5. Under Search Results, highlight the desired tag number and click OK to return to the New 

Vendor Data dialog box where this tag number is displayed in the Tag name field. 
6. Select the desired instrument manufacturer from the Manufacturer list. 
7. Select the desired instrument model from the Model list. 
8. Type the desired full and dry weight values and select the weight unit of measure from the 

Weight UOM list. 
9. In the Revision field, type the revision number as needed. 
10. Enter the default INLET and OUTLET values: type in the Size values and select the 

appropriate values from the Class and End preparation lists. 
11. Enter the default #3 and #4 process connection values if needed: type in the Size values and 

select the appropriate values from the Class and End preparation lists. 
12. In the Dimensions section, type in the default dimensional properties.  Note that the 

Dimensions field names appear as you have defined them in the Dimensional Groups 
dialog box. 

13. Type the Full and Dry Weight values. 
14. Select the weight unit of measure from the Weight UOM list. 
15. Click OK to save the data and close the dialog box. 
 

Working Data 
The Working Data window displays existing Working dimensional data for tag numbers entered 
in the Instrument Index module.  Once you create a new tag number whose instrument type is 
associated with dimensional data and a dimensional group, the dimensional data for this tag will 
be displayed in the Working Data window. 
You can also add more records to the Working data by copying from Vendor data or by copying 
preliminary default data from the Default Library if the Dimensional Group, manufacturer, model, 
and the process connection values match the Working data. 
Managing Working data involves editing it, modifying the data status, entering the piping design 
area, and finally generating and printing out a Dimensional Data Sheet for a particular instrument. 
You access Working data in the Working Data window. 
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Display and Access Working Data 
This feature enables you to store and manage Working dimensional data. 
1. With the Dimensional Data for Piping Module window open, do one of the following; 

  Click .  
 Click View > Working Data. 

2. In the Select Dimensional Group dialog box, highlight the desired dimensional group and 
click OK. 
The Working Data window opens displaying the existing working data records for the 
instruments whose instrument type is associated with dimensional data and the current 
dimensional group. 
 You can customize the display and layout of the data in the Working Data window.  The 

following options are available: 
 Determining the fields to be displayed 
 Sorting the data 
 Filtering the data 

 

Edit Working Data 
You can edit the working data either in the Working Data window or in the Working Data 
Properties dialog box.  Note however, that not all the fields are accessible for editing in the 
Working Data window.  Therefore, you should edit the data in the Working Data Properties 
dialog box. 
1. With the Working Data window open, highlight the desired tags and do one of the following to 

open the Working Data Properties dialog box: 
 Right-click the selected tag numbers and click Working Data Properties on the shortcut 

menu. 
 Click Actions > Working Data Properties. 

2. Enter the default INLET and OUTLET values and from the Units of Measure list choose the 
required unit of measure. 

3. Type in the Size values and select the appropriate values from the Class and End 
preparation lists. 

4. Enter the default #3 and #4 process connection values and from the Units of Measure list 
choose the required unit of measure. 

5. Type in the Size values and select the appropriate values from the Class and End 
preparation lists. 

6. Under Dimension values, type the default dimensional properties.  Note that the 
Dimensions field names appear as you have defined them in the Dimensional Groups 
dialog box. 

7. Type the Full and Dry Weight values. 
8. Select the weight unit of measure from the Weight UOM list. 
9. Click OK to save the data and close the dialog box. 
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Piping Design Area 
This option enables the piping designers to enter 3-D CAD design model or piping design area for 
the selected instrument.  You can select multiple records from the Working Data window and 
enter or modify the piping design area as needed. 
1. In the Working Data window, highlight the desired instruments and do one of the following: 

 Right-click the selected instruments and click Piping Design on the shortcut menu. 
 Click Actions > Piping Design. 

2. Type in the desired design area name in the Design Area field and click Save. 
3. Select the Copy to all tags check box to copy the design area name you have just entered to 

all the selected instruments or click Preview or Next to open the previous or the next record. 
4. Click OK to accept the values and close the dialog box. 

 All the other fields in this dialog box are read-only. 
 

Copy Working Data to the Default Library 
This option enables you to copy working dimensional data to the Default Library.  The copied 
record includes all its definitions: the dimensional group, manufacturer, model, and the process 
connection values. 
You can select only a single instrument at a time.  This instrument will serve as a default 
example.  For each selected instrument, the software can then search a default record with 
corresponding dimensional group, manufacturer, model, and process connection values. 
1. In the Working Data window, highlight the instruments whose working data you want to copy 

to the Default Library and then do one of the following: 
 Right-click the selected tag numbers and click Copy Working to Default on the shortcut 

menu. 
 Click Actions > Copy Working to Default. 

2. Examine the information in this view-only dialog box and click Copy to copy the working data 
to the Default Library. 
 The Copy button is disabled if no matching values are found. 

 

Copy Default Data to Working Data 
This feature allows you to copy records with preliminary default dimensional data into the working 
data of the selected instrument.  Copying default data from the Default Library is only possible if 
the dimensional group, manufacturer, model, and the process connection data match the working 
data. 
You can select numerous instruments whose default data you want to copy.  For every selected 
tag number, the software can then search for values matching the working data.  Only after 
matching dimensional group, manufacturer, model, and process connection values are found, the 
software copies the default data. 
After successfully copying default data, the status of the copied records is set as Preliminary and 
its revision number as 0 (zero).  The revision number will then be incremented from the last 
preliminary status by one, for example, Preliminary 1. 
1. In the Working Data window, highlight the tag numbers whose default data you want to copy 

and then do one of the following: 
 Right-click the selected tag numbers and click Copy Default to Working on the shortcut 

menu. 
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 Click Actions > Copy Default to Working. 
The software searches for instruments with matching dimensional group, manufacturer, 
model, and process connection values.  Once matching values are found, the Copy 
Dimensional data from Default Data dialog box opens: 

2. Examine the displayed data: 
 Instruments selected — this field shows how many tag numbers you selected whose 

default dimensions you want to copy. 
 Instruments found — this field shows how many tag numbers in the working data match 

the values in the default data. 
 Instruments with incomplete data — this field shows how many tag numbers in the 

working data have incomplete data. 
A progress bar opens under the data status indication showing you the data copying 
progress.  For every instrument with matching values, default dimensional values are copied. 

3. Click Copy to start copying the data and monitor the process in the progress bar under the 
data status indication. 

 
 If the instrument contains no working data, the copied default dimensions will be marked as 

ready for release. 
 If the instrument contains working data, you will be prompted if you want the working data to 

be overwritten by the default data.  The copied dimensions will be marked as suspected. 
 

Copy from Vendor Data to Working Data 
This feature allows you to copy certified vendor data to the working data of a selected 
instrument.  Copying vendor data is only possible if the dimensional group, manufacturer, model, 
and the process connection data match the working data.  You can select numerous instruments 
for which you want to copy vendor data.  For each selected instrument, the software can then 
search for matching dimensional group, manufacturer, model, and process connection values. 
1. In the Working Data window, highlight the tag numbers for which you want to copy vendor 

data and then do one of the following: 
 Right-click the selected tag numbers and click Copy from Vendor to Working on the 

shortcut menu. 
 Click Actions > Copy from Vendor to Working. 

 The software searches for instruments with matching dimensional group, manufacturer, 
model, and process connection values.  Once matching values are found, the Copy from 
Vendor to Working dialog box opens. 

2. On the Copy Vendor to Working dialog box, examine the data displayed in the following 
boxes: 
 Instruments selected — This box shows how many tag numbers you selected for which 

you want to copy vendor dimensions. 
 Instruments found — This box shows how many tag numbers in the working data match 

the values in the vendor data. 
 Instruments with incomplete data — This box field shows how many tag numbers how 

many tag numbers have incomplete vendor data, incomplete working data, or data 
mismatch in the fields that must be identical in both vendor and working data. 

 To be able to copy vendor data to working data, make sure that the following 
vendor data properties match the corresponding working data properties: inlet, outlet, #3, and 
#4 connection points and their units of measure, instrument manufacturer and model. 
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3. In the Set Status section, select the dimensional data status of the working data as desired: 
Preliminary, Design, or Certified. 

4. Click Copy. 

 
 For every instrument with matching values, vendor dimensional values are copied including 

the vendor revision number.  This data is marked as copied to working data. 
 If the instrument contains no working data and all desired dimensional data is defined, the data 

is marked as ready for release. 
 If the instrument contains working data, you are prompted if you want the working data to be 

overwritten by the vendor data.  The copied dimensions are marked as suspected data and 
copied from vendor. 

 

Modify Working Data Status 
This option enables you to display and modify the current status of Working dimensional data for 
the selected instrument.  Three status stages are available: Preliminary, Design, and 
Certified.  Each change of status results in the revision number being set to 0.  Within each 
status, the revision number (from zero to 99) indicates the progress of the dimensional data 
handling.  An instrument status can be described as a combination of these two parameters: the 
status of the Working dimensional data and the revision number, for example PRELIMINARY 1 or 
DESIGN 5. 

 
 When you modify the data status because of any dimensional data management, you will be 

able to reset the suspected data flag and mark the data as correct and ready for release to 
piping. 

 You can select multiple instruments for status modification. 
1. In the Working Data window, highlight the instruments whose working status you want to 

modify and then do one of the following: 
 Right-click the selected instruments and click Modify Status and Revision on the 

shortcut menu. 
 Click Actions > Modify Status and Revision. 

2. On the Status tab, click Set status and select the desired status from the Status list.  The list 
displays the selected status and becomes unavailable until you click Set status again. 

3. Click Raise to next revision to raise the revision number if needed. 
4. Click in the Description text box and type a short status description. 
5. Select the Reset Suspect Flag check box to remove the suspected data status for the current 

instrument. 
6. Click Save to save your settings. 
7. Click Next or Previous to display the next or previous selected tag number. 
8. Click OK to close this dialog box or click the History tab to open the History tab folder. 
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Regenerate Dimensional Data Sheets 
This procedure can be run on a single tag or multiple tags at the same time.  You must carry out 
this procedure first to be able to use the SmartPlant menu Revise command when working with 
SmartPlant Foundation. 
1. In the Dimensional Data for Piping module open the Working Data window. 
2. Select the required tag. 

 Use the Shift or Ctrl keys and click on the required tags to select more than one tag. 
3. Right-click, and from the shortcut menu select Regenerate Dimensional Data Sheets.  
4. At the prompt, click OK. 
 

Manage Default Dimensional Data 
This feature enables you to store and manage preliminary dimensional data for your 
instrumentation design.  You can use standard (default) dimensions of known manufacturers who 
are likely to supply the instruments.  This Default data is stored in the Default Library which allows 
you browse through the data, modify it, and copy it to the Working data as needed.  Once 
sufficient Default data is available, the DDP designer can provide this data to the piping designers 
for their preliminary design.  The Default data will then be replaced or modified according to the 
actual dimensional data received from the manufacturers. 

 Note that you must first define the appropriate dimensional group, the process 
connection data, and the manufacturer before you can start entering default data.  Remember 
that only one set of default dimensional data can exist for a domain. 
 

Enter Default Data into the Default Library 
Use this procedure to add default dimensional data for a given dimensional group. 
1. With the Dimensional Data for Piping Module window open, do one of the following; 

 Click View > Default Library. 

  Click . 
2. In the Select Dimensional Group dialog box, highlight the desired group and click OK. 

 If you select All Groups, you will not be able to edit the data and no process 
connection values will be displayed. 

3. Click Actions > New Default Data. 
4. In the Default Data Properties dialog box, select the desired instrument manufacturer from 

the Manufacturer list. 
5. Select the desired instrument model from the Model list. 
6. Enter the default INLET and OUTLET values: type in the Size values and select the 

appropriate values from the Class and End preparation lists. 
7. Enter the default #3 and #4 process connection values if needed: type the Size values and 

select the appropriate values from the Class and End preparation lists. 
8. In the Dimensions section, type in the default dimensional properties.  Note that the 

Dimensions field names appear as you have defined them in the Dimensional Groups 
dialog box. 

9. Type the Full and Dry Weight values. 
10. Select the weight unit of measure from the Weight UOM list. 
11. Click OK to save the data and close the dialog box. 



 Dimensional Data and Piping 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 377 
 

 

Edit Default Dimensional Data 
Use this procedure to edit default data for a given dimensional group. 
1. Open the Default Data window for the desired dimensional group.  For details, see Entering 

Data into the Default Library (see "Enter Default Data into the Default Library" on page 376). 
2. Right-click the entries that you want to edit, and on the shortcut menu, click Default Data 

Properties. 
3. Select the desired instrument manufacturer from the Manufacturer list. 
4. Select the desired instrument model from the Model list. 
5. Enter the default INLET and OUTLET values and from the Units of Measure list choose the 

required unit of measure. 
6. Type in the Size values and select the appropriate values from the Class and End 

preparation lists. 
7. Enter the default #3 and #4 process connection values and from the Units of Measure list 

choose the required unit of measure. 
8. Type in the Size values and select the appropriate values from the Class and End 

preparation lists. 
9. In the Dimensions section, type in the default dimensional properties.  Note that the 

Dimensions field names appear as you have defined them in the Dimensional Groups 
dialog box. 

10. Type the Full and Dry weight values. 
11. Select the weight unit of measure from the Weight UOM list. 
12. Click OK to save the data and close the dialog box. 
 

Customize the Default Library Display and Layout 
You can customize the display and layout of the data in the Default Library.  The following options 
are available: 
 Sorting the data 
 Filtering the data 
 Determining the fields to be displayed 

For a detailed explanation on how to carry out these procedures, refer to the Browser module, 
Define a View Profile. 
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Services and Reports 
This section contains topics about generating dimensional sheet reports. 

Generate a Dimensional Data Sheet 
This feature enables you to produce a dimensional data sheet for a selected instrument.  The 
dimensional data sheet can complement or serve as an alternative for the automatic 3-D CAD 
piping design. 
A dimensional data sheet includes general tag information, dimensional data of the specific group, 
and the graphic schematic or detailed presentation of the instrument and its dimensions. 
1. In the Working Data window, highlight the desired instrument and do one of the following: 

 Right-click the selected instrument and click Dimensional Data Sheet on the shortcut 
menu. 

 Click Actions > Dimensional Data Sheet. 
2. In the Dimensional Data Sheet window that opens, you can do the following: 

 Enter or modify the values in the dimensional data sheet fields. Click in the appropriate 
field to type a value or select a value from a list.  Note that not all the fields are accessible 
for editing. 

 Manage and enter dimensional data sheet revisions.  Click  to open the Revisions 
dialog box where you can enter and modify revisions. 

 Save the dimensional data sheet as an external file, click . 

 Print out the dimensional data sheet, click . 
 You can also preview and print dimensional data sheets in batch mode.  For details, see 

Printing Dimensional Data Sheets (on page 380). 
 

Track the Data Status History 
This option allows you to track the working data status history. 
1. With the Modify Status dialog box open, click the History tab to open the History tab folder. 
2. Examine the information and click Edit to type in any appropriate description if necessary. 
3. Click OK to accept the values and close the dialog box. 
 

Generate DDP Reports 
You can generate and print out the following reports. 

Report Description 

Group List Contains a detailed list of all existing Dimensional Groups and 
their parameters, such as group name, description, associated 
picture file, cad group identifier, and dimensional parameter 
definitions. 

Dimensions List Displays a detailed list of all dimensional data for each 
instrument that is associated with dimensional data. 
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Report Description 

Suspected Data List Presents a list of all the instruments for which dimensional data 
must be re-evaluated due to some changes made to the 
instrument definitions.  For example, if the process connection 
or any other key parameter has been changed, the data is 
marked as suspected.  This report shows the cause of the 
suspected data flag. 

Status History Contains all the dimensional data status history per all Tags 
whose dimensional data status has been changed. 

Suspected Data 
History 

Displays a list of all Tags whose dimensional data was or still is 
marked as suspected.  The report also presents the reasons for 
the suspected data indication. 

Default Library List Contains a list of general default definitions for the elements of 
the Default Library. 

Default Dimensional 
Data 

Lists detailed definitions of the elements in the Default Library. 

Vendor Dimensional 
Data 

Contains a detailed list of vendor dimensional data. 

Data Sheets Allows you to display data sheets associated with specific tag 
numbers. 

Empty Sheet Forms Allows you to display field names and dimensional properties 
only, without displaying the values.  An empty sheet form also 
displays a dimensional group diagram. 

 
 

Generate a Group List, Dimensions List, Default Library List, 
Default Dimensional Data, Or Vendor Dimensional Data Report 
 With the Dimensional Data for Piping Module window open, on the Reports menu, click a 

report menu command. 
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Generate A Suspected Data List, Status History, Or Suspected 
Data History Report 
1. With the Dimensional Data for Piping Module window open, on the Reports menu, click the 

appropriate menu command. 
2. In the Report Parameters dialog box, in the Report Per section, select if you want the report 

to include data for all the instruments associated with dimensional data or just for the selected 
groups. 

3. In the Show data for section, select if you want the report to be generated for the current 
plant or the current unit, and click OK. 

 
 

Printing Dimensional Data Sheets 
Use this procedure to open a print preview of one more dimensional data sheets and print 
dimensional data sheets in batch mode. 
Batch preview and printing is available either from the Dimensional Data for Piping Module 
window or from the Working Data window. 
 
 

Print Dimensional Data Sheets From the Dimensional Data for 
Piping Module Window 
1. Click Reports > Data Sheets. 
2. In the Select Tags for Printing Dimensional Data Sheets dialog box, find the desired 

instruments. 
3. Under Search results, select source tag numbers. 
4. Click OK. 
 
 

Print Dimensional Data Sheets From the Working Data Window 
1. In the Working Data window, select one or more instruments. 
2. Do one of the following: 

 Click Actions > Print Dimensional Data Sheets.   
 Right-click, and from the shortcut menu click Print Dimensional Data Sheets.  

 Click . 

 Clicking  only prints the instrument list displayed in the Working Data window. 
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Print Empty Sheet Forms 
Use this procedure open a print preview and print one more empty sheet forms.  An empty sheet 
form is a form that does not contain any values.  Such a form only displays the names of the fields 
and dimensional properties, and also display the dimensional group diagram.  Each dimensional 
group is associated by default with one sheet form. 
1. Click Reports > Empty Sheet Forms 
2. In the Print Empty Sheet Forms dialog box, select one or more dimensional groups. 
3. Click OK. 
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The Construction module is used to define contracts for installation activities that are performed by 
external contractors.  This involves controlling and monitoring the contracts and installation tasks 
assigned to various external contractors, in order to enable plant start-up to take place on 
time.  An installation task can be any activity or group of activities that would be applied to an 
instrument to make it operable. 
Each item (instrument tag, wiring scheme, and so forth.) requires a specific set of activities.  The 
module matches the various activities to each contractor by listing them according to categories 
(fields of operation).  Each activity is defined as an index, which you can assign to specific items 
when required. 
You can track the status and progress of activities performed by creating index revisions, viewing 
and printing reports of each revision for a particular index. 
For example, the following activities could be involved in the installation of electronic 2-wire 
transmitters: 
Mechanical implementation: 
 Instrument stand installation 
 Physical instrument installation 
 Impulse piping connection 

Electrical implementation: 
 Wiring of instruments to junction boxes 
 Wiring of instruments to marshaling racks 
 Wiring of instruments to control system 

Instrument implementation: 
 Calibration of instruments 
 Instrument wiring continuity check 
 Configuration of control system 
 Check of instrument operation 
 Loop checks 
 Control system operation check 

Only on completion of all these activities can the instruments be fully commissioned and operated. 

See also: 
Activate the Construction Module (see "Activate the Construction Module" on page 384) 
 

Construction Module 
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Activate the Construction Module 
To work with the Construction Module you must first activate the module from the SmartPlant 
Instrumentation Preferences. 
To activate the module, 
1. Select File > Preferences. 

2. On the Preferences dialog box, click  (Module Icons). 
3. From the Available icons column do one of the following: 

 Select  and click the Add button. 

 Double-click . 

4. The  appears in the Module toolbar. 
 

Construction Flow of Activities 
A typical flow of activities for installation consists of the following stages (the procedures for each 
stage are described in more detail in the relevant sections): 
1. Populating the following supporting tables: 

 Contractors 
 Contracts: One or more contracts can be defined per contractor. 
 Installation Index Categories: SmartPlant Instrumentation provides three default 

installation index categories: Instrument, Mechanical, and Electrical.  You can edit these 
if required, and you can also add up to two more categories of your own. 

 Installation Indexes: One or more installation indexes can be associated with each 
contract.  Each installation index must belong to an installation category.  Within each 
category, there is no limit to the number of installation indexes you can define. 

2. Assigning the installation indexes to the desired items (instrument tags, panels, or cables) in 
the appropriate Construction Browser View. 

3. Issuing reports.  For each installation index, the following classes of reports can be viewed 
and printed: 
 Working report: Working (current) reports can be accessed from the Installation Index 

Manager or by selecting filtered data to display in the Browser and previewing the reports 
there. 

 Formal report: Reports related to formal issues can be accessed from the Installation 
Index Manager Archive. 

 In both classes, a complete report of the items assigned to the installation index can be 
displayed, or where relevant, you can issue a change summary report showing the 
differences between the current situation or selected revision and the previous revision. 

4. Retrieving archived reports. 
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Definitions in the Construction Module 
In order to implement the installation, the activities must be defined.  The following elements of 
the Construction module are involved in specifying the activities: 
 Installation Contractors: The companies responsible for carrying out the different installation 

tasks. 
 Installation Contracts: The documents used to specify the details and conditions for each 

task or group of tasks.  One or more contracts can be defined for each contractor. 
 Installation Categories: Each category can represent a discipline of operation (for example, 

three default categories of Installation Indexes are defined: Instrument, Electrical, and 
Mechanical). 

 Installation Indexes: An installation index is an index number within an installation category 
associated with a specific installation task.  Each task may consist of one or more activities. 

 Items: A SmartPlant Instrumentation item can be an instrument tag, a panel, or a cable to 
which an installation index can be assigned.  Within each category, only one index can be 
assigned to a particular item. 

 Formal Issue ( Revision): A formal issue is a revision that is assigned to an installation report 
when the contract data is stable and is ready to be sent to the client for approval.  The revision 
can then be used as a benchmark for monitoring any changes that may be made later. 

 Archive: After creating a formal issue for an installation index, the reports containing the 
details of that index are stored in the Installation Index Manager Archive.  From there you can 
retrieve existing installation reports showing archived information, or reports of the changes 
that were made to the installation index since the previous revision. 

 

Installation Index Category Definitions 
All new installation indexes that are defined must belong to an installation index category.  There 
are three default categories (editable) that are provided as standard: Instrument, Electrical, and 
Mechanical, and you have the option to add two further installation index categories if required. 
 

Edit an Installation Index Category 
  You may only edit installation index categories that do not have any indexes assigned to 

them. 
1. Click Tables > Category. 
2. In the Index Categories dialog box, select the desired row, and then click Edit to open that 

row for editing. 
3. Edit the code in the Prefix field (up to 5 characters) and Name fields if required (you can enter 

a name of up to 20 characters in the Name field). 
4. Do one of the following: 

 To make the new installation index category available in the Installation Index Manager 
window and in the header columns for the appropriate Browsers, select at least one of the 
check boxes: 

 Wiring Category: This makes Cable, Panel, and Wire reports available for all items 
assigned to installation indexes in this category. 

 Instrument Category: This makes an Instrument report available for all items assigned 
to installation indexes in this category. 
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 To exclude the new installation index category from the lists in the Installation Index 
Manager window and in the header columns for the appropriate Browsers, clear all the 
check boxes. 

5. Click OK. 
 

Edit an Installation Index 
There may be occasions where you will want to update or change an installation index 
definition.  Editing an installation index may involve changes to the name, description, or contract 
for the index.  After editing an index name, the new name will appear in the appropriate index field 
in the Browser Views for instrument tags where the original index was assigned. 
1. Click Tables > Installation Index. 
2. In the Installation Indexes dialog box, in the data window, select the required installation 

index, and then click Properties. 
3. Edit the data in the appropriate fields ( Number, Description, and Contract Number) as 

required. 
 Installation Index numbers must be unique. 

4. Repeat steps 2 through 4 for each installation index you want to edit. 
5. Click OK to save your changes and close the dialog box. 
 

Delete an Installation Index 
When an installation index is no longer needed, you can delete it, provided it has not already been 
assigned to an item in one of the Browser Views. 
1. Click Tables > Installation Index. 
2. In the Installation Indexes dialog box, in the data window, select the index that you want to 

delete. 
3. Click Delete. 

The installation index is deleted. 
4. Repeat steps 2 and 3 for each installation index you want to edit. 
5. Click OK to save your changes and close the dialog box. 
 
 

View and Modify Assigned Installation Indexes 
After assigning an installation index to an instrument tag, you can open a filtered browser view 
based on the currently selected index in the Installation Index Manager window.  The filtered list 
enables you to view and modify with ease those items (instrument tags, panels, cables, or wires) 
that already have a particular index assigned to them. 

 If you change the electrical index in one of the report views — tag, panel, or cable — 
SmartPlant Instrumentation updates the electrical index of all the relevant items. 
1. In the Installation Index Manager window, select the required installation index category 

from the list. 
 The list of installation indexes for the selected category is displayed in the lower data 

grid. 
2. In the Report for field, select the required report (if more than one report is available for the 

selected category). 
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 Where several reports are available for a particular installation index, the revision data 
displayed in the lower data window will depend on the report you select.  Thus for the same 
installation index, different reports may show different revisions. 

3. In the lower data window, select the required installation index from the list. 
4. Do one of the following: 

 Click . 
 Click Actions > Open Filtered Browser. 

The appropriate Browser View window opens for the report you selected, for example, the 
Panel Terminations Report.  All panels in the database that are linked to the selected 
installation index are displayed. 

5. In an Index column, modify the index selection as required. 
6. Do one of the following: 

 Close the window. 

 Click . 
 Click Actions > Refresh. 

7. At the prompt, click OK to save the changes. 
 

Construction Options 
The procedures described in this section explain how to create, maintain, and use installation 
indexes for tracking the tasks performed by contractors. 
 

Construction - Example Scenario 
Using the installation of electronic 2-wire transmitters as a basis, the following example shows the 
kind of data you would enter: 
1. In the Contractors dialog box, define contractors as follows: 
2. Contractor for mechanical tasks. 
3. Contractor for electrical tasks. 
4. Contractor for instrument- related tasks. 
5. Define one contract number for each contractor. 
6. Define installation indexes in each installation category (using the default categories) as 

follows: 
7. Instrument category 

 I1: Instrument calibration only. 
 I2: Instrument calibration and various checks. 

8. Electrical category 
 E1: Wire to JB only. 
 E2: Wire to JB and MR. 
 E3: Wire to MR only. 
 E4: Wire to MR and CS. 
 E5: Wire to CS only. 

9. Mechanical category 
 M1: Physical installation and connections. 
 M2: Connect impulse piping. 
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10. Assign the installation indexes to the required instrument tags (in the appropriate Construction 
Browser View), for example, the Instrument Installation Index View is displayed, and indexes 
I1, E2, and M1 are assigned to a number of flow transmitters. 

11. Generate a formal issue for each installation index. 
12. Change installation indexes that were wrongly assigned to one of the flow transmitters as 

follows: 
 I1 to I2. 
 E2 to E1. 

13. Create working and formal reports for installation indexes I1, I2, E1, and E2 to show the 
current statuses of the installation indexes and their statuses prior to the above changes. 

14. Generate the following new formal issues: 
 Revision for installation indexes I1 and I2. 
 Revision for installation indexes E1 and E2 (report for wires). 

 Revisions are performed per installation index and per report, and so in this example, 
you would create a revision once all the changes for the particular installation index have been 
made for the appropriate instrument tags. 

15. Change the electrical installation index for another flow transmitter from E2 to E3 and 
generate formal issues for both of these installation indexes (report for wires). 

16. Preview and print formal change summary reports from the revision archive for the last formal 
issue on installation indexes E2 and E3. 

 

View Installation Indexes in the Installation Indexes Dialog 
Box 

There are two locations from which you can view the installation indexes: 
 In the Installation Index Manager window, you can view a list of the indexes in each category 

by selecting the category from the Index category list. 
 In the Installation Indexes dialog box, you can view a list of the indexes in each category, or 

from all the categories. 
1. Click Tables > Installation Index. 
2. In the Installation Indexes dialog box, do one of the following: 

 To view the installation indexes in a particular category, from the Index category list, 
select the required category. 

 To view the installation indexes in all categories, select Show all index categories. 
3. When done, click Cancel to close the dialog box. 
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Add an Installation Index 
Adding an installation index requires the following actions: 
 Create the contractors in the supporting table. 
 Create the contracts in the supporting table. 
 Ensure that at least one installation index category is active. 
 Create the installation index itself. 

Add an Installation Index 
1. Define your contractors as follows: 
2. Click Tables > Contractor. 
3. In the Contractors dialog box, click New. 
4. In the new line, enter a name (up to 20 characters) and a definition (up to 40 characters) in the 

appropriate fields. 
5. Repeat steps b) and c) for each contractor you want to add. 
6. Click OK to save your changes and close the Contractors dialog box. 
7. Define your contracts as follows: 
8. Click Tables > Contracts. 
9. In the Contracts dialog box, click New. 

A new line appears. 
10. In the Contractor Name field, select a contractor from the list. 
11. In the Contract Number field, type a number for the contract. 
12. Repeat steps b) through d) for each contract you want to add. 
13. Click OK to save your changes and close the dialog box. 
14. Click Tables > Category. 
15. In the Index Categories dialog box, check that the category definitions meet your 

requirements, otherwise do one of the following: 
 Create a new installation index category (for details, see Adding an Installation Index 

Category (see "Add an Installation Index Category" on page 390)). 
 Edit an existing installation index category (for details, see Editing an Installation Index 

Category (see "Edit an Installation Index Category" on page 385)). 
16. Create the installation index as follows: 
17. Click Tables > Installation Index. 
18. In the Installation Indexes dialog box, from the Index category list, select a category. 

  Selection of an installation index category is a prerequisite for defining an installation 

index.  If no category is available in the list, you can create one by clicking  to open the 
Index Categories dialog box.  Select at least one of the check boxes: Wiring Category or 
Instrument Category for one or more of the installation index categories. 

19. Click New. 
  The category prefix is entered by default as the prefix for the Installation Index number. 

20. Type the installation index number and description in the appropriate fields. 
  Installation Index numbers must be unique.  If you do not modify the default, you will be 

prompted to keep it on saving. 
21. From the Contract number list, select a contract. 
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22. Repeat steps c) through e) for each installation index you want to add. 
23. Click OK to save your changes and close the dialog box. 
 

Add an Installation Index Category 
There are two user-definable installation index categories.  This section explains how to create 
and use them. 
1. Click Tables > Category. 
2. In the Index Categories dialog box, select an empty row and click Edit to open that row for 

editing. 
3. Enter a short code in the Prefix field (up to 5 characters) and type a name (up to 20 

characters) in the Name field. 
4. In order to make the new installation index category available in the Installation Index 

Manager window and in the header columns for the appropriate Browsers, select at least one 
of the check boxes: 
 Wiring Category: This makes Cable, Panel, and Wire reports available for all items 

assigned to installation indexes in this category. 
 Instrument Category: This makes an Instrument report available for all items assigned 

to installation indexes in this category. 
 Selection of both check boxes makes all four reports available. 

5. Click OK. 
 

Assign Installation Indexes to Items 
You will remember that each installation index represents a particular activity performed by a 
particular contractor.  For every item (instrument tag, panel, cable, or wire), you can assign one 
installation index in each of the active categories.  Since a contractor may perform the same 
activity on more than one item, you can assign the same installation index in a given category to 
several items of the same type, such as instrument tags.  For example, you may want to assign 
the same electrical installation index to all the instrument tags whose process function is 
measuring pressure. 
At this stage, it is assumed that you have defined all your installation indexes as described in the 
previous sections. 
1. With the Installation Index Manager window open, select the required installation index 

category from the Index category list. 
The list of installation indexes for the selected category is displayed in the data window. 

2. Beside Report for, select the required report (if more than one report is available for the 
selected category). 

3. Do one of the following: 

 Click . 
 Click Actions > Open General Browser. 

 The appropriate Browser View window opens for the report you selected.  For 
example, if you selected the Electrical Index, and you chose Panels in the Report for field, the 
Panel Terminations Report will be displayed.  In the default category definition, the Panels 
report (as part of the Wiring Category) only appears in the Electrical Index, and therefore only 
the Electrical Index column will appear in the Browser View.  In this view, all the panels in 
the database are displayed. 

4. In the Electrical Index column, select the required index from the list for each instrument tag 
as required. 
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5. Do one of the following: 
 Close the window. 

 Click . 
 Click Actions > Refresh. 

6. At the prompt, click OK to save the changes. 
 
  



Construction Module 
 

 
392 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

 



 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 393 
 

S E C T I O N  3 8  

Reports, Revisions and Archives 
This section contains topics about generating reports, revisions, and archives. 

In This Section 
Generate Reports For An Installation Index Revision Reports ...... 393 
Construction Module Revisions ..................................................... 393 
Maintaining a Revision Archive ..................................................... 394 
View an Archived Installation Index ............................................... 394 
Edit an Archived Revision .............................................................. 395 
 
 

Generate Reports For An Installation Index Revision Reports 
You can display and print a report for each installation index revision you create.  Two types of 
report are available: a general report showing details of all the items in the selected revision, and 
a change report showing only the differences between the current revision and the previous one. 
1. Follow steps 1-3 in Viewing and Editing Archives (see "View an Archived Installation Index" on 

page 394) to display the required installation index revisions. 
2. In the row with the revision for which you want to print the reports, select either or both of the 

check boxes in the following columns: 
 Report: to display the general report for the revision. 
 Change Report: to display the change report with the differences between the current 

and previous revisions. 
 You may only print reports for one revision at a time. 

3. Do one of the following: 

 Click . 
 Click Reports > Print Report. 

 

Construction Module Revisions 
The revision feature is used to keep track of the changes made to an installation index.  It is 
important and useful to have a chronological description of the changes, dates of change, and a 
list of persons who approved them.  Using this feature, you can add revisions in the Installation 
Index Manager window. 
1. With the Installation Index Manager window open, select the required installation index 

category from the list. 
The list of installation indexes for the selected category is displayed in the lower data window. 

2. In the Report for field, select the required report (if more than one report is available for the 
selected category). 

3. Do one of the following: 

 Click . 
 Click Actions > Revision. 

4. Select one of the revision numbering methods (use P0, P1, P2... for preliminary revisions or 0, 
1, 2 / A, B, C, and so forth, for normal serial revisions). 
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 When you first select a revision numbering method, several options are available to you, 
including preliminary revisions (designated by P0, P1, P2…).  Once you select one of the 
other revision methods, you will not be able to return to the preliminary revision method and 
this option will be disabled. 

5. Click New to add new revision data. 
6. Add the revision data in the appropriate data fields. 

 The By data field contains the current user's initials by default, if previously defined by 
the SmartPlant Instrumentation System Administrator. 

7. When done, click OK. 
 

Maintaining a Revision Archive 
When you create a new revision for an installation index in the Construction module, a view-only 
archive copy is made of the information contained in the installation index reports.  This 
information is stored even after the reports themselves have been deleted. 
The revision archive data can be saved in the database or in a file, depending on the setting 
selected in the Administration module. 

 
 If you select to save your previous revisions in a file, make sure that: the path to the 

appropriate file is added to your environment path parameter (see your Windows User Guide 
to learn about defining paths in your environment). 

 If the revision file is shared by a number of users via a local network connection, make sure 
that the resource on which that file is located is appropriately shared (users should have both 
read and write access rights to the revision files). 

 Identical drive mapping is used for all the appropriate workstations to indicate the location of 
the psr files. 

 

View an Archived Installation Index 
Once you generate revisions for the installation indexes, the revision information is added to the 
archive, and you can retrieve it when required.  You can filter archived indexes according to 
various criteria (contractor, contract, date ranges, etc.).  On retrieval of an archived index, you 
can edit its revision information and print reports. 
1. Do one of the following: 

 Click . 
 Click Actions > Installation Index Manager Archive. 

2. In the upper part of the window, select the required criteria to filter the retrieved installation 
indexes, from the following options: 

3. In the Index category field, select to specify a particular installation index category for filtering 
the retrieved archived indexes. 

4. In the Report for field, select the required report (if more than one report is available for the 
selected category). 

5. To specify installation indexes belonging to a particular contract, select the required contract 
in the Contract number field, or leave the field blank to retrieve archived indexes that match 
the other selection criteria for all the contracts. 

6. To specify a particular installation index, select that index in the Index number field, or leave 
the field blank to all archived indexes that match the other selection criteria. 
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7. To specify installation indexes belonging to a particular contractor, select the required 
contractor in the Contractor name field, or leave the field blank to retrieve archived indexes 
that match the other selection criteria for all the contractors. 

8. Select one of the following options: 
 Revision: to specify a particular revision number for retrieval.  If you do not specify a 

revision number, all relevant revisions will be retrieved. 
 From date / To date: to specify a range of dates for revisions.  If you do not change the 

defaults ( From date: 00/00/00, To date: <today's date>), all installation index revisions 
generated up to and including the current date will be retrieved. 

9. Do one of the following: 

 Click . 
 Click Actions > Find. 
  The installation index revisions are retrieved according to the specified selection criteria. 

 

Edit an Archived Revision 
If required, edit a revision as follows: 
1. Select a revision from the retrieved list. 
2. Do one of the following: 

 Click . 
 Click Actions > Revision. 

 When you open the Revisions dialog box from the archive, you can only edit existing 
revisions; you may not create new ones. 

3. Edit the revision data as required in the appropriate data fields. 
4. When done, click OK 

You are returned to the Installation Index Manager Archive window. 
5. To return to the current Installation Index Manager window, do one of the following: 

 Click . 
 Click Actions > Working Installation Index Manager. 

 
 
 

The Calibration module allows you to perform various types of calibrations for your instruments 
and test equipment, such as functional checks, single-point and multi-point calibrations, fiscal 
meter proving, and tank level gauging.  You can customize your own calibration forms using 
InfoMaker, and in this way specify which calibration parameters you want to include on the 
calibration form.  Furthermore, you can perform different types of calibrations on a particular 
instrument by defining separate profiles for each calibration type and associating the desired 
profiles with the instrument.  After you enter calibration data and save the record, the software 
stores a calibration event in the history repository which includes your data and a visual 
representation of the calibration form.  This way you can monitor the calibration history of each 
instrument and generate calibration certificates. 

Performing Calibrations 
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You can specify a large variety of calibration parameters such as calibration ranges, trip point 
values, and alarms.  The calibration user interface allows you to easily compare current 
measured values with the appropriate specifications. 
In order to perform calibrations, a calibration infrastructure must exist.  This infrastructure 
includes definitions of profiles, settings and data entry forms, and, if required, the creation of 
customized calibration forms.  For details, see Flow of Preliminary Activities for Calibration (see 
"Calibration Preliminary Activities" on page 403). 

 
 If you upgraded the software from a version prior to 2007.5, you must restore the standard 

forms and regenerate the form pages to be able to use existing calibration settings and 
data.  If you intend to use customized calibration forms only, you may skip this upgrade 
step.  For details, see Upgrading the Standard Calibration Forms (on page 400). 

 The Calibration module is available only if it is included in the software license that you 
purchased from Intergraph. 

 
 

Calibration Module Window 
The Calibration module window opens when you click  on the toolbar or click Module > 
Calibration. 
The window consists of the following sections: 
 Menu bar — Provides access to all the Calibration Module Commands (on page 396). 
 Application work area — The region where other Calibration module windows and dialog 

boxes open. 
 Toolbar — Provides access to the most common Calibration module commands. 
 Status bar — Shows the current status or the pertinent Microhelp message, plant hierarchy 

items, and the current date and time. 
 

Calibration Module Commands 
Use the Calibration module commands to access the user interfaces for performing the main 
calibration tasks. 

Icon Command Explanation 

 Actions > Tag 
Settings 

Opens the Tag Calibration Settings Window for the selected 
instrument tag. 

 Actions > Data Entry Opens the Calibration Data Entry Window, where you enter 
calibration data for the selected instrument tag. 

 Actions > History Opens the Calibration History Window, from which you can 
view the calibration history per tag.  The calibration history 
data includes settings and calibration results. 

 Actions > Fluke 
Interface 

Opens the Fluke Interface Wizard to allow you to exchange 
data between SmartPlant Instrumentation and the Fluke 
743B / 744 Documenting Process Calibrators. 

 Actions > Calibration 
Profile Settings 

Allows you to select a calibration profile and view or edit the 
profile settings calibration sheet. 
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Icon Command Explanation 

 Reports menu Allows you to access options for displaying various 
calibration reports. 

 Tables > Calibration 
Profiles 

Opens the Calibration Profiles dialog box, which allows you 
to define new calibration profiles or modify existing profiles. 

 
 

Enter Tag Number Dialog Box 
This dialog box opens to allow you to enter a tag number for one of the following actions: 
 Defining tag calibration settings 
 Entering calibration data 
 Viewing calibration history 

Type the entire tag number in the field, including the correct number of spaces, for example: 
101-FE   100 (3 spaces between 'FE' and '100'), or click Find to open the Find Tag dialog box. 
 

Starting the Calibration Module 
Start the Calibration Module from the SmartPlant 
Instrumentation Window 

 Do one of the following: 
 On the SmartPlant Instrumentation window menu bar, click Modules > Calibration. 

 On the SmartPlant Instrumentation window toolbar, click . 

Start the Calibration Module from the Instrument Index 
Standard Browser 

1. Open an Instrument Index Standard Browser view. 
2. Select instrument tags that require calibration. 
3. Do one of the following: 

 Click Modules > Calibration. 

 On the main toolbar, click . 
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Search for Tag Numbers in the Calibration Module 
This procedure enables you to find tag numbers in the Calibration module using search 
parameters in the Find Tag dialog box.  Entering search parameters enables you to narrow down 
your search.  You can narrow your search to the maximum by entering all the search 
parameters.  It is up to you what search parameters to specify.  You can use wildcards in the 
fields where you type values: underscore ( _ ) for single characters, and percent ( % ) for multiple 
characters. 
Leaving some of the search parameter fields empty widens the search.  If you do not specify any 
search parameters, the software finds all the existing tag numbers. 
After the search is complete, the software displays the tag numbers that match your search 
parameters in the Search results data window of the Find Tag dialog box. 
1. With the Calibration Module window open, do one of the following: 

 Click Actions > Tag Settings to find the desired tag numbers and display them in the Tag 
Calibration Settings window. 

 Click Actions > Data Entry to find the desired tag numbers and display them in the 
Calibration Data Entry window. 

 Click Actions > History to find the desired tag numbers and display them in the 
Calibration History window. 

2. On the Enter Tag Number dialog box, click Find. 
3. If needed, select Search by category to find only tag numbers that you have associated with 

tag categories in the Instrument Index module.  For details, see Associate Tag Category and 
Criticality. 

 
 Search tag numbers by category if you have created user-defined tag categories and 

associated tag numbers with these categories.  You can also type a category in the 
Category field to narrow your search to tags associated with this category only.  Use 
wildcards and not case-insensitive characters if needed. 

 When searching for tag numbers by tag category, you can narrow down your search by 
typing a specific tag category or loop name, or by selecting the required instrument type 
and process function.  Note that you cannot use certain search parameters together with 
the tag category parameter.  These fields become view-only. 

4. Define you search criteria using the required combination of the following search parameters: 

Search 
Parameter 

Explanation  Example 

Tag number Type the whole tag number you are looking 
for.  Include any prefix, suffix, and separator 
characters.  You can use wildcards if 
needed. 

101–FT 22–25/1 or use a 
wildcard: 101-FT% 

Process function Select a process function to narrow your 
search to tags belonging to this process 
function. 

Flow Pressure 

Instrument type Select an instrument type to narrow your 
search to tags belonging to this instrument 
type. 

D/P Type Flow Element (FE), 
Mass Flow Transmitter (FT) 
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Search 
Parameter 

Explanation  Example 

Status Select a tag status to narrow your search to 
tags associated with this status. 

An existing device, a new 
instrument, a relocated device 

Location Select a tag location, for example: Field, to 
narrow your search to tags for which you 
have defined this location. 

Equipment room, junction box 

I/O Type Select an I/O type to narrow your search to 
tags for which you have defined this I/O type.

AO (analog output) DI (Digital 
input) 

Prefix Type the tag number prefix to find all the tag 
numbers that contain this prefix in their 
names.  Do not include the separator 
characters.  The unit number segment in the 
tag number name is usually the tag number 
prefix.  You can also use wildcards if 
needed. 

101 

Number Type the numeric segment of a tag number 
to find all the tag numbers that contain this 
numeric segment.  You can also use 
wildcards if needed. 

2315 

Suffix Type the suffix segment of the tag number to 
find all the tags that contain this suffix.  Do 
not type the slash character before the 
suffix.  You can also use wildcards if 
needed. 

1 ( the number following the 
slash ( /) in tag number 
101–FT –2225/1) 

Equipment Select the equipment to narrow your search 
to tags for which you have defined this 
equipment. 

 

Line Select a line to narrow your search to tags 
with which you have associated this line. 

 

5. If desired, select Look in all units to look for the defined search criteria in all the units of the 
current plant. 

6. Click Find to display the tag numbers in the Search results data window. 
 Select the Show more search results check box to hide the search criteria fields and 

enlarge the Search results data window to display more tag rows.  Clearing this check box 
returns to normal view. 

7. Select the required tag numbers in the Search results data window. 
 You can also select the Select all check box to select all the displayed tag numbers. 

8. Click OK to open the appropriate window (Tag Calibration Settings, Calibration Data 
Entry, or Calibration History) and proceed with the calibration activities. 
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Calibration Forms 
Calibration forms are basis for calibration sheets, which are the means of entering data and 
viewing results in the Calibration module of SmartPlant Instrumentation.  These forms are 
completely customizable to allow users to specify various types of calibration routines.  To 
customize calibration forms, you must be familiar with InfoMaker.  For details, see Calibration 
Form Customization. 
SmartPlant Instrumentation comes shipped with two forms so that existing users can continue to 
work with legacy data and still see a calibration form layout similar to what existed 
previously.  The names of these forms are Standard Settings and Standard Data Entry.  In 
addition, there are various shipped .psr files, which you can customize as needed. 
You use the Specifications module options to create and manage calibration forms because the 
form creation mechanism is the same as for specification forms.  You can create as many 
calibration forms as you require; and the forms can differ in type of data, layout and calibration 
requirements.  In the Specifications module, there are two page item types designated for 
calibration forms: Calibration Settings and Calibration Data Entry.  You must assign one 
settings form and one data entry form to each calibration profile that you define.  There is no 
specific form for calibration history because calibration history is always based on the data entry 
form.  When opening any window in the Calibration module, you actually open a calibration form 
assigned to a calibration profile. 

 
 Any calibration form, whether shipped or user-defined, can only comprise a single data page. 
 A calibration form page may include a title block in the body of the page, as one the page 

portions.  However, in calibration form pages, you do not create revisions or revision data. 
 If you upgraded the software from a version prior to 2007.5, you must restore the standard 

forms and regenerate the form pages to be able to use existing calibration settings and 
data.  If you intend to use customized calibration forms only, you may skip this upgrade 
step.  For details, see Upgrading the Standard Calibration Forms (on page 400). 

See Also 
Flow of Preliminary Activities for Calibration (see "Calibration Preliminary Activities" on page 403) 
 

Upgrading the Standard Calibration Forms 
When upgrading the software from a version prior to 2007.5, the setup makes changes that allow 
you to continue to use existing calibration settings and data if desired.  Several of the former 
calibration types have been combined into a single multi-point calibration.  All existing tag settings 
and history event records will be updated accordingly.  In addition, some new calibration types 
have been added.  The following table shows the differences between the available calibration 
types before and after the upgrade. 

Before Upgrade After Upgrade Description 

Other, Single point, Three 
point, Five point, Five point 
calibration and hysteresis, 
Eleven point 

Multiple points Allows you to specify any number of points for 
calibration.  See Notes below for limitation on 
the number of points. 

Function check Function check Does not specify any calibration values.  This 
option is used to check whether or not the 
instrument or equipment is working. 
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Switch set point Switch set point Allows you to specify up to four calibration 
points for a temperature or pressure switch. 

Alarm/Trip/Set point Alarm/Trip/Set 
point 

Specifies a single measurement point for 
calibrating an alarm, a trip, or a set-point. 

– Fiscal flow 
meter proving 

A type of calibration for determining meter 
factor and repeatability.  Requires you to 
customize your own forms and profiles if you 
want to use this option. 

– Tank level 
gauging 

A type of calibration for tank- level 
gauging.  Requires you to customize your own 
forms and profiles if you want to use this 
option. 

 
 To ensure continued support for existing tag settings, the program creates a standard 

(shipped) profile with two associated forms: Standard Settings and Standard Data Entry. 
 The standard profile is associated with each existing instrument type. 
 Each existing tag setting is associated with the Standard Settings form. 
 Each existing calibration result record is associated with the Standard Data Entry form. 
 The Standard Settings and Standard Data Entry forms support up to 11 calibration points 

for As-Found or As-Left data.  If you want to enable more than 11 points, you must customize 
the forms using InfoMaker. 

 New properties are added to the calibration history points for the As-Found and As-Left 
expected values and calculated errors. 

 The software creates a snap-shot of all former calibration history records and points based on 
the Standard Data Entry form (this also includes results that were previously collected by a 
Fluke Calibrator). 

 Additional units of measure properties are available for trip points in the tag calibration settings 
and data entry.  Previously, a single unit of measure property was used.  The change should 
be transparent for users.  The upgrade process will populate these properties with the 
necessary unit of measure value that was used. 

 During the upgrade, test equipment items that were populated in the Test Equipment table 
are re-created as tag numbers with the tag class Test Equipment.  The test equipment 
name, description, and serial number are copied to the database (the serial number can only 
be displayed in a browser view and not on the Tag Number Properties dialog box for the test 
equipment).  Other test equipment properties (Test Date, Tested By, Accuracy, and Units 
of Measure) are not transferred as a result of the upgrade. 

 During the upgrade, many other new properties are added to the calibration tables to support 
new functionality. 

 The fields Compnt_Mfr_ID and Compnt_Mod_ID display the current manufacturer and 
model name associated with the tag.  The fields Compnt_Mfr_Name and 
Compnt_Mod_Name display the history of changes made to the manufacturer and model 
name when saving the Calibration Data Entry sheet. 
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Upgrade the Standard Calibration Forms 
You must perform this procedure once after the upgrade to prepare the new tag calibration 
settings and data entry forms so that they can use existing and new data. 
1. In the Specifications Module window, click Edit > Form Editor. 
2. Do the following to restore the Standard Settings calibration form: 

a. In the Form Editor, click Actions > Restore Form. 
b. Select the Standard Settings form and click OK to restore that form. 

3. Repeat the above steps to restore the Standard Data Entry calibration form. 
4. Close the Form Editor window. 
5. Click File > Preferences > Specifications, and on the General tab, under Calibration 

profile forms, select Reuse columns in form page. 
6. In the Specifications Module window, click Edit > Page Editor. 
7. Do the following to regenerate the Standard Settings calibration form page: 

a. In the Page Editor, click Actions > Open Page. 
b. On the Select Specification Page dialog box, select the Standard Settings form page 

and click OK. 
c. Click Actions > Regenerate Page. 
d. On the Regenerate Page dialog box, under Select tables, views and columns, select a 

check box for each table or view from which you want to display additional columns in the 
Table Column List pop-up window. 

 
 Some tables, such as Component and Flow, do not appear in the list. These tables 

contain mandatory fields and are also regenerated.  The fields will appear in the 
Table Column List window when you open Edit > Column List. 

 For the standard form pages, the tables are already selected. 
 If you have not made any changes to the page, skip this step and the two following 

steps. 
e. Under Show Columns, click Show for each required table or view. 
f. Under Select columns, do one of the following: 

 Select the Select all check box to select all the columns in the table. 
 Hold down the Ctrl key and select or clear specific columns as desired. 

g. Click OK to regenerate the page. 

h. Click Save . 
8. Repeat the above steps to regenerate the Standard Data Entry form page. 
9. If you have existing calibration records that you want to save as history events in the current 

version, do the following: 
a. Run the CalibrationResultsUpgrade.exe file, which is located in the SmartPlant 

Instrumentation home folder. 
b. On the Calibration Results Upgrade Utility dialog box, select an appropriate domain. 
c. If you do not want to keep your previous results, select the Overwrite existing results 

check box. 
 If you have updated your calibration forms, this step will ensure that the software 

re-creates previously saved history events for the updated forms. 
d. Click OK. 



 Performing Calibrations 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 403 
 

 If you have previous calibration results that originated from a Fluke Calibrator, and you 
want to save history events for these results using the Fluke forms, first save the Fluke forms 
as standard calibration forms before running the CalibrationResultsUpgrade.exe utility.  This 
results in the software saving all of your existing calibration data as history events using the 
Fluke forms.  For details of how to use the Fluke forms, see Set up a Profile for the Fluke 
Calibrator (on page 421). 

 
 

Upgrade Calibration Results 
After upgrading a database with calibration results that were obtained in a version prior to 2007.5, 
you need to run the calibration results upgrade utility so that your existing calibration results 
become compatible with the new method of displaying calibration history. 
1. Run the CalibrationResultsUpgrade.exe file, which is located in the SmartPlant 

Instrumentation home folder. 
2. On the Calibration Results Upgrade Utility dialog box, select an appropriate domain. 
3. If you do not want to keep your previous results, select the Overwrite existing results check 

box. 
4. Click OK. 

 If you are upgrading custom calibration forms to version 2009, after the upgrade, you 
need to regenerate them in the Calibration module. 
 

Calibration Preliminary Activities 
This topic describes the flow of activities for creating and customizing calibration forms, assigning 
them to calibration profiles, and associating the profiles with appropriate instrument types.  These 
activities are necessary before you can start defining calibration settings for instruments. 

 If you upgraded the software from a version prior to 2007.5, you must restore the 
standard forms and regenerate the form pages to be able to use existing calibration settings and 
data.  If you intend to use customized calibration forms only, you may skip this upgrade step.  For 
details, see Upgrading the Standard Calibration Forms (on page 400). 

1. Customize calibration form pages in InfoMaker 
SmartPlant Instrumentation comes shipped with a number of .psr files that you can customize 
according to your needs using InfoMaker.  For details, see Customizing Form Pages in InfoMaker 
Common Tasks. 

2. Add the customized forms to the database 
Using the Specifications module, you need to retrieve the customized form pages from the .psr 
files, and associate the pages with the Calibration Settings or Calibration Data Entry form 
types, and then save the forms to the database.  For details, see Add Customized Calibration 
Forms to the Database (on page 404). 

3. Create calibration profiles 
Using the Calibration module options, you must now create calibration profiles and assign the 
customized forms to the desired profiles.  You must assign one calibration settings and one 
calibration data entry form to each profile.  For details, see Create a Calibration Profile (on 
page 405). 
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4. Define calibration profile settings 
After creating your calibration profile and assigning forms to the profile, you use the Calibration 
module options to enter values in the Calibration Profile Settings window.  These values then 
appear in the Tag Calibration Settings window for the particular instrument or test equipment tag 
for which you select that profile.  For details, see Define Calibration Profile Settings (on 
page 405). 

5. Associate the calibration profiles with instrument types 
Using the Instrument Index module options, you need to associate one or more profiles with the 
appropriate instrument types.  You can associate several profiles with a specific instrument type 
and, if needed, set one profile as default.  Also, it is possible to associate the same profile with 
several instrument types.  For details, see Associate Calibration Profiles with Instrument Types 
(on page 405). 

6. Managing code tables and test equipment 
In order to perform certain calibration activities, you can specify test equipment for checking the 
accuracy of the calibration values and you can also set up various codes for classifying your 
calibration results.  For details about test equipment, see Test Equipment (see "Defining Test 
Equipment" on page 407).  For details about various codes, see Manage Code Tables (on 
page 406). 
 
 

Add Customized Calibration Forms to the Database 
1. In the Specifications Module window, click Edit > Page Editor. 
2. On the Page Editor menu bar, click Actions > Open File: 
3. On the Open File dialog box, navigate to the folder where your .psr file is located and select 

the file. 
4. Click OK to open the page in the Page Editor. 
5. Regenerate the page.  For details, see Regenerate a Specification Page. 
6. Save the page and close the Page Editor. 
7. In the Specifications Module window, click Edit > Form Editor. 
8. On the Form Editor menu bar, click Actions > New Form. 
9. On the Select Specification Page dialog box, do one of the following: 

 To create a calibration settings form, select the page whose page item type is Calibration 
Settings. 

 To create a calibration data entry form, select the page whose page item type is 
Calibration Data Entry. 
 Calibration forms are single-page forms; therefore, it is not possible to add pages to 

forms whose page item type is Calibration Settings or Calibration Data Entry. 
10. Save the form and close the Form Editor. 

 When saving your form, make sure that the name of the form is unique, to prevent you 
from overwriting previous forms. 
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Create a Calibration Profile 
1. Open the Calibration module. 
2. Click Tables > Calibration Profiles. 
3. On the Calibration Profiles dialog box, from the Calibration type list, select the desired 

calibration type for the profile you are going to create. 
4. Click New. 
5. In the Calibration Profile column, type a name for the new calibration profile. 

 All calibration profile names must be unique, regardless of the calibration type to 
which the profile belongs. 

6. Type a description and a procedure if desired. 
7. Click Assign Forms. 
8. On the Assign Forms dialog box, select the desired calibration settings and calibration data 

entry forms and click OK to return to the Calibration Profiles dialog box. 
9. Click OK to close the Calibration Profiles dialog box. 

See Also 
Calibration Forms (on page 400) 
 

Define Calibration Profile Settings 
1. Open the Calibration module. 
2. Do one of the following: 

 Click Actions > Calibration Profile Settings. 

 Click . 
3. On the Select Calibration Profile dialog box, from the Select calibration type list, select the 

calibration type to which the profile you want to edit belongs. 
4. Select the desired calibration profile. 
5. In the Calibration Profile Settings window, enter the desired values for the profile properties 

(these will usually define typical output range, number of points, and tolerances). 
6. When done, save the profile settings. 

See Also 
Define Tag Calibration Settings (on page 409) 
 

Associate Calibration Profiles with Instrument Types 
 Before associating calibration profiles, you must create them in the Calibration 

module.  For details, see Create a Calibration Profile (on page 405). 
1. In the Instrument Index module, open the Instrument Type Profile dialog box for the target 

instrument type.  For details, see Define an Instrument Type Profile. 
2. Click the Calibration tab. 
3. Click Associate. 
4. On the Associate Calibration Profile dialog box, do the following: 

a. Select a calibration type. 
b. Select a calibration profile. 
c. Click OK. 
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 It is only possible to select and associate one profile at a time. 
5. Repeat steps 3 and 4 for other profiles you want to associate with the current instrument type. 
6. If you want to set one profile as default, on the Calibration tab, in the Default column, select 

a check box beside the target profile. 
 If you set a profile as default, when opening calibration settings for a new instrument, 

you bypass the Select Calibration Profile dialog box and automatically open the Tag 
Calibration Settings window.  In the Tag Calibration Settings window, the software loads 
the Calibration Settings form assigned to the default profile, including data values you 
defined in the Calibration Profile Settings window.  You do not have to set a profile as 
default.  If more than one profile is available for the instrument type, and none of them are 
marked as default, the Select Calibration Profile dialog box opens, where you select the 
profile you need, and then open the calibration settings. 

7. On the Instrument Type Profile dialog box, click Apply or OK. 
 
 

Dissociate Profiles from Instrument Types 
1. In the Instrument Index module, open the Instrument Type Profile dialog box for the target 

instrument type.  For details, see Define an Instrument Type Profile. 
2. Click the Calibration tab. 
3. Select a profile and click Dissociate. 

 
 You can dissociate only one profile at a time. 
 You can dissociate any profile, including profiles you already used for creation of 

calibration settings.  Once calibration settings are created for a given instrument, they are 
saved in the database for that instrument. 

 If more than one profile is available for the instrument type, and you dissociate the default 
profile without defining a new one, when opening calibration settings for a new instrument, 
you can no longer open the Tag Calibration Settings window automatically.  If no profile 
is set as default, the software first opens the Select Calibration Profile dialog box, where 
you select the profile you need, and then you can open the Tag Calibration Settings 
window. 

4. On the Instrument Type Profile dialog box, click Apply or OK. 
 
 

Manage Code Tables 
There are four code tables that you can use to specify your own set of values that you can use for 
classifying your calibration results: Action Codes, Damage Codes, Diagnostic Codes, and 
Result Codes.  After you define your own codes in each of these tables, the values become 
available for selection on the Standard Data Entry calibration form or on any customized 
calibration form where you choose to display the codes. 

 There are three predefined result codes: Passed, Failed, and None that you cannot edit or 
delete from the database.  These values do not appear in the Result Codes dialog box.  An 
additional value, Bad Result, is also available when editing history results. 
1. In the Calibration Data Entry window, on the Tables menu, click the desired code table. 
2. On the dialog box that opens, do one of the following: 

 Click New to add a new value. 
 Highlight an existing value. 
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3. Type the desired code and its description in the appropriate columns. 

See Also 
Enter Calibration Data (on page 412) 
 

Defining Test Equipment 
SmartPlant Instrumentation allows you to define and assign test equipment to the instruments in 
your plant.  Test equipment is used to check that the calibration of your plant's instruments is 
accurate and operating within their given parameters, and to recalibrate those instruments that do 
not meet their required parameters.  You can assign one item of test equipment to many 
instruments.  Each piece of test equipment has assigned to it one or more user defined 
profiles.  A profile is a template of the default settings/values used by the test equipment.  For 
example, checking the minimum/maximum limits of various temperature gauges, you can assign a 
different profile to your test equipment, that represents the calibration requirements, for each 
temperature gauge.  Test equipment tags are maintained on the domain level in the Test 
Equipment folder and can only be assigned to As-Built plants. 

 
 If you are using the Fluke Documenting Process Calibrator models 743B or 744, there is a 

separate interface and special forms that you use for exchanging and displaying the 
calibration data.  For details, see Working with the Fluke Interface (on page 420). 

 Test equipment cannot include the following data: 
 I/O types 
 P&IDs 
 Process equipment 
 Process lines 
 Process data 
 Electrical power requirements (SmartPlant Electrical integration) 
 Associated symbols for the Enhanced Report Utility 
 Calculation module data 
 Wiring data 
 Loop data or association 

See Also 
Selecting Test Equipment (see "Select Test Equipment" on page 413) 
 

Prerequisites for Creating a Test Equipment Tag 
The following prerequisites are necessary for creating a test equipment tag. 
A free segment text name must be created in the Administration module.  For easy identification 
of a specific item of test equipment, when creating a naming convention for test equipment it is 
advisable to include the serial number of the equipment as part of the tag.  For more details, see 
Define Naming Conventions in the Administration User's Guide, under Domain and Project 
Administration > Naming Conventions. 
1. Define the Instrument Type Profile for the specific test equipment. 

 When creating the Instrument Type Profile you must select General as the process 
function and Test Equipment in the General Process Function Sub-Category column of 
the data window, then in the Instrument Type Profile dialog box you can associate a 
Specification Form with the profile.  For more details, see Define an Instrument Type 
Profile. 
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2. Create the Test Equipment tag.  For more details, see Create a Test Equipment Tag (on 
page 408). 

3. On the calibration sheet, enter calibration data and choose the desired test equipment.  For 
more details on calibration, see Performing Calibrations (on page 395). 

 

Create a Test Equipment Tag 
1. In the Domain Explorer, do one of the following: 

 In the project where you want to add the Test Equipment tag, locate the Instruments 
folder. 

 Locate the Test Equipment folder 
2. Right-click, and from the shortcut menu click New > Test Equipment. 
3. On the New Tag Number dialog box, enter the new tag number in the Tag Number field and 

click OK. 
4. On the Select Test Equipment Type dialog box, select the required test equipment. 
5. On the Tag Number Properties dialog box, enter data as required. 

The new tag is created in the Test Equipment folder located at the domain level of the 
Domain Explorer. 

See Also 
Prerequisites for Creating a Test Equipment Tag (on page 407) 
Test Equipment (see "Defining Test Equipment" on page 407) 
Selecting Test Equipment (see "Select Test Equipment" on page 413) 
 

Calibration Settings Activities 
This topic describes the main flow of activities when defining settings for calibrating instruments. 

 
 If you upgraded the software from a version prior to 2007.5, you must restore the standard 

forms and regenerate the form pages to be able to use existing calibration settings and 
data.  If you intend to use customized calibration forms only, you may skip this upgrade 
step.  For details, see Upgrading the Standard Calibration Forms (on page 400). 

 In order to perform calibrations, a calibration infrastructure must exist.  This infrastructure 
includes definitions of profiles, settings and data entry forms, and, if required, the creation of 
customized calibration forms.  For details, see Flow of Preliminary Activities for Calibration 
(see "Calibration Preliminary Activities" on page 403). 

1. Create a tag number and define the tag calibration settings 
When you create a tag number for an instrument or test equipment, the instrument type of that tag 
number must be associated with one or more calibration profiles suitable for the type of calibration 
to be performed.  When opening the tag calibration settings in the Calibration module, you must 
select the desired calibration profile.  The software loads the values from that profile into the tag 
calibration settings, which you can then view and edit in the Tag Calibration Settings window.  If 
you select a different calibration profile, the software loads settings values from that profile to the 
tag calibration settings and overwrites any existing values.  The tag calibration settings determine 
what kind of input data you require for your calibration, such as ranges, input and output units of 
measure, and tolerances.  These settings serve as a reference for any calibrations you perform 
on the tag provided you do not modify them or select a different profile when performing data 
entry.  For details, see Define Tag Calibration Settings (on page 409). 
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2. Copy existing process data 
If you are defining calibration settings for a tag number associated with process data, you use this 
procedure to copy existing maximum and minimum process data range values into the Variable 
Min and Variable Max fields; you can also copy existing alarm and trip data into the appropriate 
Alarm / Trip fields.  For details, see Copy Existing Process Data (on page 410). 
 
 

Define Tag Calibration Settings 
 Only one set of tag calibration settings is allowed per tag.  Therefore you should use 

the tag calibration settings to define tag-specific data such as alarm / trip points, input and output 
ranges, and units of measure.  Other calibration values that are not tag-specific such as number 
of calibration points, tolerance, and so forth, can be stored in the calibration profile settings. 
1. Start the Calibration module. 
2. Do one of the following: 

 Click Actions > Tag Settings. 

 Click . 
3. On the Enter Tag Number dialog box, type the desired tag number or click Find to search 

instrument tags. 
 If you selected multiple tag numbers, click Actions > Tag List and then click a tag 

number to define the settings for that instrument. 
4. Click Actions > Select Profile. 
5. Define the calibration settings values for the tags as desired. 

 
 If you are defining calibration settings for a tag number associated with process data, you 

can copy existing process data minimum and maximum range values.  For details, see 
Copy Existing Process Data (on page 410). 

 If you are using the Standard Settings calibration sheet, the Measuring Point 
parameter is available for single point calibrations only. 

 If you are using the Standard Settings calibration sheet, the fields in the Set values 
group box are available only if under Calibration type, you selected Switch set point. 

6. Click Save  to save the settings. 

See Also 
Enter Calibration Data (on page 412) 
Define Calibration Profile Settings (on page 405) 
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Copy Existing Process Data 
1. Open the desired instrument tag in the Tag Calibration Settings window. 

 
 It is not possible to copy process data for control valves. 
 Process data does not apply to test equipment. 

2. Click Options > Copy Process Data. 
3. On the Copy Process Data dialog box, click OK. 

 
 You can edit the data in the Process Data module only. 
 The copied data overwrites your previous settings in the Tag Calibration Settings window. 
 If you defined multiple process data cases for the current tag, the data displayed in the 

Process Data pop-up window is determined by the governing case.  For details, see Multiple 
Process Data Cases. 

 The software copies the Min and Max values beside Required range to the Variable 
minimum and Variable maximum fields as well as the alarm and trip data. 

 
 

Define Alarm / Trip Settings 
You enter the required alarm / trip settings in the appropriate Point data window.  You can specify 
up to six trip or alarm indication points.  For each point, you select a unit of measure, enter the 
point values and direction, and type a brief description. 
1. Open the Tag Calibration Settings window for an instrument tag. 
2. In the Alarm / Trips section, for First Point, type the desired values or select them from the 

lists.  When done, define other calibration points as needed. 
 If you are defining calibration settings for a tag number associated with process data, you 

can copy existing process data minimum and maximum range values.  For details, see Copy 
Existing Process Data (on page 410). 

3. Click Save  to save all your calibration settings. 
 
 

Define the Set Point 
After defining the alarm and trip settings, you can also define the set point of the selected 
instrument.  You can either define the set point to be identical to one of the alarm / trip points that 
you have already defined, or you can define the set point manually. 
1. Open the Tag Calibration Settings window for an instrument tag. 
2. In the Set Point section, from the Point list, select one of the following: 

 1st Point, 2nd Point, 3rd Point, and so forth (any defined calibration point up to the 6th 
point): The set point will be identical to the selected alarm/trip point and the rest of the 
fields in this data window become unavailable.  Note that this option is possible only after 
making your alarm/trip definitions. 

 Free: You can define the set point yourself. 
 None: You can make no set point definitions. 

3. Type the rest of the values as desired or select them from the lists. 

4. Click Save  to save all your calibration settings. 
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Calibration Data Entry Activities 
This topic describes the main flow of activities when entering calibration data for instruments with 
predefined calibration settings. 

1. Select a profile 
Profiles provide a means of allowing you to perform different types of calibration for the same 
tag.  When you select a profile in Data Entry mode, the software loads the profile values into the 
Calibration Data Entry form.  For details, see Select a Calibration Profile (on page 412). 

 If desired, you can by-pass profile selection by choosing the existing tag settings. 

2. Enter calibration data 
After selecting a profile or the existing settings for your tag, you enter the calibration data.  The 
software uses any formulas you have defined on the Data Entry form to calculate calibration 
results.  While entering data, the calibration result is accepted as long as the input values do not 
exceed the specified tolerances which are set by the expressions on the form.  On saving a 
calibration record, the software generates a history event.  For details, see Enter Calibration Data 
(on page 412). 

3. View calibration history 
After you enter calibration data and save the record, the software stores a calibration event in the 
history repository which includes your data and a visual representation of the calibration 
form.  You can select desired history events for a particular tag and view and compare an 
instrument's calibration record.  You can also print calibration history reports.  Some properties 
may still be editable if so defined on the Calibration Data Entry form; these properties are related 
to the Codes section on the Standard Data Entry form.  For more information, see View 
Calibration History (on page 414). 

4. Generate calibration reports 
Various calibration reports are available for viewing and printing.  These include a Calibration 
Check List, Calibration Data, various reports that allow you to analyze failure results, and 
Calibration History.  For details, see Generate Calibration Reports (on page 416). 
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Select a Calibration Profile 
1. From the Calibration Data Entry window, open data entry sheets for one or more instrument 

tags and do one of the following: 
 Click Actions > Select Calibration Profile. 

 Click . 
2. On the Select Calibration Profile dialog box, clear the Use data from tag calibration 

settings check box. 
 Loading a profile will overwrite all settings data other than the calibration ranges. 

3. Under Select calibration profile associated with the instrument type, select the desired 
calibration profile. 

 To by-pass the profile and to use the values directly from the instrument tag calibration 
settings, select the Use data from tag calibration settings check box. 

 
 If you selected multiple instruments, the software will open the calibration data entry sheet for 

each instrument in turn and copy data from the selected calibration profile to the data entry 
fields. 

 When copying data from a profile, the software does not change the values for the tag 
calibration settings. 

See Also 
Create a Calibration Profile (on page 405) 
Define Calibration Profile Settings (on page 405) 
 

Enter Calibration Data 
1. In the Tag Calibration Settings window, do one of the following: 

 Click Actions > Data Entry. 
 On the module toolbar, click . 

2. Finish entering the tag's calibration settings and click Save .  You are prompted to open 
the Calibration Data Entry window for the current tag. 

3. In the Calibration Data Entry window, on the module toolbar, click Refresh . 
4. Click the Data Entry tab and enter values in each section by typing or selecting from the lists. 
5. Do the following for each of the points that you defined for the current tag in the Tag 

Calibration Settings window: 
6. In the Calibration Data Entry window, in the Alarms / Trips section, click First Point, 

Second Point, Third Point, Fourth Point, Fifth Point, or Sixth Point. 
7. Under As Found, type the value before calibration. 
8. Under As left, type the value after calibration. 
9. In the Codes section, enter general calibration information as you require. 
10. From the Result Code list, select the desired predefined result code, or custom result code 

predefined in the Result Code dialog box.  
11. If from the Result code list you selected Failed or any other option that indicates a calibration 

result failure, from the Diagnostic code list, select a calibration diagnostic code for this kind 
of failure. 
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12. If from the Result code list you selected Failed or any other option that indicates a calibration 
result failure, from the Action code list, select an action code associated with a solution 
description for this kind of failure. 

13. If from the Result code list you selected Failed or any other option that indicates a calibration 
result failure, from the Damage code list, select a damage code associated with a solution 
description for this kind of failure. 

 If a desired Result, Diagnostic, Damage, or Action code is not available from the list, 
you can define additional codes by selecting the appropriate item on the Options menu. 

14. Enter additional values, and a short note if needed. 
15. Type the pre-calibration values in the As Found column. 

 On the standard calibration data entry page, error values that exceed the maximum 
permissible error are highlighted in red, while values that exceed the intermediate error 
tolerances but do not exceed the permissible error are highlighted in light blue. 

16. After calibration of the instrument, type the values in the As Left column. 

 
 Any error values still highlighted in red show that this instrument's calibration 

failed.  When you save the updated data, the software prompts you to create a Work 
Request.  For details, see Performing Breakdown Maintenance (on page 359). 

 To enter data for custom fields, click the Custom tab. 
 The Domain Administrator can enable or disable the use of custom fields.  Note that the 

custom fields in the Tag Calibration Settings window are independent of the custom 
fields in the Calibration Data Entry window. 

17. Click Save . 

18. To browse through the tags that you selected, click  or . 

 
 Errors are calculated to four decimal places. Any error smaller than 0.0001 will be displayed as 

zero (0) and stored in the database as zero. 
 The fields Compnt_Mfr_ID and Compnt_Mod_ID display the current manufacturer and 

model name associated with the tag.  The fields Compnt_Mfr_Name and 
Compnt_Mod_Name display the history of changes made to the manufacturer and model 
name when saving the Calibration Data Entry sheet. 

See Also 
Calibration Error Calculations (on page 417) 
Define Tag Calibration Settings (on page 409) 
 

Select Test Equipment 
On the Data Entry sheet for a particular instrument tag, you may specify up to four fields for 
selecting test equipment items.  If desired, you can select the same test equipment item more 
than once (you may need to do so when using the same equipment for different calibration 
purposes).  Then, in the Calibration History window, you can view detailed test equipment 
information for each calibration entry.  Detailed test equipment information also appears in the 
Instrument Calibration Results report. 
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View Calibration History 
1. Start the Calibration module. 
2. Do one of the following: 

 Click Actions > History. 

 Click . 
3. On the Enter Tag Number dialog box, type the desired tag number or click Find to search for 

tag numbers. 
 If you selected multiple tag numbers, click Actions > Tag List and then click a tag 

number to view the history event for that instrument. 
4. Open the desired instrument tag in the Calibration History window. 

5. If more than one history record exists for the selected instrument tag, click Previous  or 
Next  to navigate to the desired record. 

 The fields Compnt_Mfr_ID and Compnt_Mod_ID display the current manufacturer and 
model name associated with the tag.  The fields Compnt_Mfr_Name and Compnt_Mod_Name 
display the history of changes made to the manufacturer and model name when saving the 
Calibration Data Entry sheet. 
 
 

List of Calibration Reports 
The following list describes some of the reports that are available in the Calibration module. 

Report Name Description 

Instrument List Displays a list of the available instruments organized by system 
category.  Instruments that are associated with more than one 
category appear once under each category. 

Instrument Structure Displays a list of the available instruments organized by the loops 
to which they belong. 

Calibration Codes — By 
Instrument Type 

For the selected code category, displays the number of 
instruments for which each particular code value applies, 
organized by instrument type. 

Calibration Codes — 
Monthly Analysis 

For the selected code category, displays a month by month 
analysis over the specified date range of the number of 
instruments for which each particular code value applies, 
organized per loop. 

Result Code — Result 
Analysis 

Displays for the specified date range an analysis of the 
instruments per result code.  Note that the result code is a 
user-defined property that has nothing to do with the Calibration 
result property, which the software calculates, and which can 
have the value Passed or Failed. 

Check List — By Loop For one or more selected loops, displays a check list for each 
instrument showing principal settings and input data used for 
calibration.  You can print this report and write As Found, As Left, 
and code values as needed. 
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Report Name Description 

Check List — By Tag For the instruments selected using the filter, displays a check list 
showing principal settings and input data used for 
calibration.  You can print this report and write As Found, As Left, 
and code values as needed. 

History Event Details For one or more selected loops, displays a brief summary of the 
calibration history of all the instruments in those loops, including 
loop errors where relevant. 

Calibration Results For the instruments selected using the filter that have either 
passed or failed the calibration, displays a summary of each 
instrument's calibration settings and results. 

Calibration Equipment Allows you to specify one or more items of calibration equipment 
and displays the frequency of calibration failure for each item of 
calibration equipment.  You can then analyze the results to find 
out if there is a fault in the calibration equipment itself. 

Loop Error For one or more selected loops for which the loop error was 
calculated, displays the error variation over the specified date 
range at the specified calculated point.  This report is useful for 
checking the zero drift of a particular loop over time. 

Component Error For one or more selected instruments, displays the error variation 
over the specified date range at the specified calculated 
point.  This report is useful \ for checking the zero drift of an 
instrument over time. 

Alarm / Trip Points Summary Generates a summary of the trip and alarm point data of all 
selected tags. 

Calibration Certificate 
(available from main 
Calibration module window 
only) 

Generates a summary of the selected tag's calibration results. 

Calibration Results Report Generates a summary of the selected tag's calibration results, 
calibration settings, a graphic representation of the error 
percentage, and test equipment used for calibrating this tag. 
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Generate Calibration Reports 
1. In the appropriate Calibration module window, on the Reports menu, click the menu option for 

the report that you want to generate. 
2. If a filter dialog box opens, do the following, as available: 
3. In the Date range group box, do one of the following to set the date range for the report: 

 To set a specific date range, select Specified dates, and then in the From and To lists 
enter the date range. 

 To generate a report for the [previous, current, or next] [week, month, or year], select 
Predefined period, and then in the lists to the right, select the options that you need. 

4. In the Filter by group box, use the options to set a filter condition for the report that you are 
generating. 

5. Click OK. 

 

 For reports by tag or by loop, click  to search for the items that you want. 
 The loop error report can be displayed even if a loop error calculation was not performed on 

that day; however, the report is only of an earlier calculation date.  The default calculation 
method that the report depends upon is Normal values.  However, if you select a calculation 
method other than Normal for a certain loop the calculation report changes respectively. 

 To generate a calibration equipment report, type the name of the equipment, with or without 
wildcards, in the Calibration equipment field.  If you do not enter a value for calibration 
equipment, you can click OK and select the desired item from the Select Test Equipment 
dialog box. 

 The fields Compnt_Mfr_ID and Compnt_Mod_ID display the current manufacturer and 
model name associated with the tag.  The fields Compnt_Mfr_Name and 
Compnt_Mod_Name display the history of changes made to the manufacturer and model 
name when saving the Calibration Data Entry sheet. 

 
 

Loop Error Calculation 
The loop error feature offers you three different methods to calculate the total error of a selected 
loop: normal, absolute, and root mean square.  The calculation is performed per loop based on 
one or more instrument tags belonging to the loop. 
The error is measured at several points that you predefine in the Tag Calibration Settings 
window.  The error is calculated at the default point that you define in the Preferences dialog 
box.  The loop error is measured relative to the largest tolerance value of all the calibration data 
for the tags that are included in the loop error calculation. 

 
 To make a valid loop error calculation, make sure that your calibration and calculation have 

been time stamped on the same day. 
 Set the value of the loop error calculation method and the loop calculation point on the 

Preferences dialog box.  For details, see Calibration and Maintenance > General 
(Preferences). 

 Define the calibration settings for the selected tags.  Tags have their predefined settings 
which you enter in the Tag Calibration Settings window.  When you calculate the loop error 
of a specific loop you should use the settings to include at least one tag that belongs to the 
designated loop.  For details, see Setting Tags for Loop Error Calculation. 
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 Enter calibration data for the selected tags in the loop.  For details, see Enter Calibration Data 
(on page 412). 

 Select the desired calculation method and perform the actual calculation.  For details, see 
Calculating Loop Error. 

 Generate a loop error report.  For details, see Generate Calibration Reports (on page 416). 
 
 

Calibration Error Calculations 
This topic describes how the software calculates the calibration errors. 

As Found and As Left Errors (% of Span) Calculation 
The following formula is used to calculate the As Found and the As Left errors (% of Span): 

 
Where i = calibration point number 

As Found and As Left Errors (% of Reading) Calculation 
The following formula is used to calculate the As Found and the As Left errors (% of Reading): 

 
Where i = calibration point number 

Error Calculation of Square Root Extraction 
Calibration errors for differential pressure flow instruments that require a square root extraction 
are calculated according to the following formula: 

 
Example: 
out.signalmin = 4 mA 
out.signalmax = 20 mA 
out.signal range = out.signalmax – out.signalmin = 16mA 

% of Input Output Value 

0 4 + (16 * 0) = 4 

25% 4 + (16 * 0.5) = 12 

50% 4 + (16 * 0.707) = 15.3137 

75% 4 + (16 * 0.866) = 17.8564 

100% 4 + (16 * 1) = 20 
 Errors are calculated to four decimal places. Any error smaller than 0.0001 will be 

displayed as zero (0) and stored in the database as zero. 
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Set Tags for Loop Error Calculation 
This procedure explains how to set tags associated with a certain loop for inclusion in the loop 
error calculation. 

 
 You must calibrate the tags before you perform the actual loop error calculation. 

You can also set the tags for inclusion from a view that you create in the Browser module.  For 
details of how to create a view, see Add a New View.  If you use a browser view to set the tags, 
make sure that you include the Tag Number, Loop Number, and Calibration Required 
columns. 
1. Click File > Preferences. 
2. On the Preferences dialog box, do the following: 

a. In the tree view, click Calibration > General. 
b. From the Calculation method list, select the desired loop calculation method.  Select 

Ask user if you want the software to prompt the user for the method at the time of 
performing the loop error calculation. 

c. Beside Calculate at point, enter a value between 1 and 100. 
 The value is set by default to 75%. 

3. Start the Calibration module. 
4. Do one of the following: 

 Click Actions > Tag Settings. 

 Click . 
5. On the Enter Tag Number dialog box, type a tag number or click Find to find the required 

instrument tags. 

 
 You must select at least one tag for each loop that you want to calculate. 
 If you selected more than one tag, click Actions > Tag List and then click the desired tag 

number to define the settings for that instrument. 
6. In the Tag Calibration Settings window, in the Errors / Points section, from the Include in 

loop error list, select Yes. 
7. Define all the remaining settings as needed. 

8. Click Save  to save the settings. 
 You can now start entering calibration data by selecting Yes when prompted after saving 

the data.  Click No when prompted to start the data entry to continue to define calibration settings 
for another tag number. 
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Calculate Loop Errors 
After you set tags for loop error calculation, use this procedure to do the following: 
 Select tags from a given loop for loop error calculation 
 Select a loop error calculation method 
 Perform the loop error calculation 

1. In the Calibration Module window, do one of the following: 
 Click . 
 Click Actions > Data Entry. 

2. On the Enter Tag Number dialog box, click Find to open the Find Tag dialog box. 
3. Under Search parameters, set conditions to filter the tag display as necessary and click OK. 

 
 To ensure that an instrument tag is included in a loop error calculation, in the Tag 

Calibration Settings window, you must set Include in loop error for that tag to 
Yes.  For details, see Setting Tags for Loop Error Calculation. 

 For all instrument tags that are included in a loop error calculation, you must specify the 
Tolerance units of measure value as %. 

4. Under Search results, select the tags that you want to include in the loop error calculation, 
and click OK. 

5. In the Calibration Data Entry window, enter the calibration data for the tags that you 
selected. 

6. To navigate among the tags that you selected for error calculation, do one of the following: 

 On the module toolbar, click  to open the Tag List pop-up window, and click the tag for 
which you want to enter calibration data. 

 On the module toolbar, click Next  to display the next tag or click Previous  to 
display the previous tag. 

 You have to enter the calibration data for all the tags that you want to include in a loop 
error calculation on the same day that you intend to perform the calculation.  If you enter tag 
calibration data more than once on a calculation day, the calculation is performed using the 
results that deviated the most from the predefined tolerance. 

7. Click Options > Loop Error. 
8. If a message appears with a list of tag numbers that are not yet calibrated, do the following: 

a. In the Calibration Data Entry window, enter the calibration data for the desired tag 
numbers. 

b. Click Options > Loop Error. 
c. On the Loop Error Calculation Method message box, select the desired calculation 

method. 
 The calculation method that you set here cannot be changed later.  Make sure 

that you set the optimal calculation method for the selected loop. 
d. Click OK. 

9. On the Loop Error Result dialog box, after you view the results, click Close. 
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Loop Error Result Dialog Box 
This dialog box options enable you to view loop error calculation results.  Loop error is calculated 
at the default point that you define in the Preferences dialog box. 
Show result at point — Select a point at which you want to measure the loop error. 
Window — View the loop error results at the point selected in the Show result at point list.  You 
can view loop error results per tag.  Also, you can view the entire loop error results.  The software 
displays loop error results per tag in the row where the tag number is displayed.  The entire loop 
error results are displayed in the Loop Error row. 
Loop — View the loop number whose loop error has been calculated. 
Tag — View all the calibrated tags associated with the current loop in the loop error calculation. 
Upper Tolerance % — View the upper tolerance percentage of the permissible loop error 
calculation per tag. 
In the Loop Error row, view the upper tolerance percentage of the permissible loop error 
calculation in the entire loop. 
Lower Tolerance % — View the lower tolerance percentage of the permissible loop error 
calculation per tag. 
In the Loop Error row, view the lower tolerance percentage of the permissible loop error 
calculation in the entire loop. 
As Found — View the pre-calibrated values for each calibration point.  Values highlighted in red 
exceed the permissible error.  Values highlighted in light blue exceed the intermediate bounds, 
but do not exceed the permissible error. 
As Left — View the new calibration values for each calibration point.  Values highlighted in red 
exceed the permissible error.  Values highlighted in light blue exceed the intermediate bounds, 
but do not exceed the permissible error. 
% As Found Error — This field displays the As Found error depending on your worst calibration 
result for the current tag within the same time span.  View the As Found loop error value per each 
tag. 
In the Loop Error row, view the calculated As Found loop error value for the current loop.  This 
value depends on all worst calibration results for the tags associated with the loop. 
% As Left Error — This field displays the As Left loop error (% of Span or % of Reading 
depending on your worst calibration result for the current tag within the same time span. 
 

Working with the Fluke Interface 
This interface allows you to exchange calibration data with the Fluke Documenting Process 
Calibrator models 743B and 744.  By means of wizards, you can download (export) tag number 
data to the calibrator, and after collecting the calibration data, you can upload (import) calibration 
data into SmartPlant Instrumentation for all of the calibrated tag numbers. 

 When performing calibration checks with the Fluke calibrator, discrepancies could 
arise between the values entered in SmartPlant Instrumentation and the values downloaded to 
the Fluke calibrator.  These discrepancies are caused by differences in the number of decimal 
places allowed by SmartPlant Instrumentation and the Fluke calibrator resolution causing the 
calibrator to round up or down downloaded values. 
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For example, temperatures in the Fluke Documenting Process Calibrator are limited to one tenth 
of degree Celsius resolution. If the downloaded value has two or more decimal places, the values 
are rounded by the Fluke calibrator and therefore are different to those in SmartPlant 
Instrumentation. This causes unexpected deviations from the anticipated point levels that will be 
reflected in the calibration result points.  
For more information on the level of accuracy for the different values measured by your Fluke 
calibrator , please consult your Fluke documentation or Fluke support. 

 
 If you upgraded the software from a version prior to 2007.5, you must restore the standard 

forms and regenerate the form pages to be able to use existing calibration settings and data.  
For details, see Upgrading the Standard Calibration Forms (on page 400). 

 When performing calibrations using the Fluke interface, there are two special forms that come 
shipped with SmartPlant Instrumentation: d_ff_default_fluke_result.psr and 
d_ff_default_fluke_settings.psr.  These forms can be found on the hard drive where you 
installed the application under the 'Program Files\SmartPlant\Instrumentation\PSR' folder.  
For more information about  using and assigning forms, see Managing Spec Pages Common 
Tasks, Spec Forms Common Tasks, and PSR File Customization Using Infomaker. 

 If you are working on a Citrix console to which a Fluke Calibrator is connected, to enable the 
software to detect the calibrator on the serial port located on the client machine, you must first 
map the serial port to the client machine.  For details, see Map a Serial Port to Use the Fluke 
Calibrator on a Citrix Console (on page 422). 

 

Set up a Profile for the Fluke Calibrator 
This procedure describes the main workflow involved in preparing calibration forms for use with 
the Fluke Calibrator.  For general details of the desired, procedure, see Add Customized 
Calibration Forms to the Database (on page 404). 
1. In the Specifications module, restore the Calibration settings and data entry forms.  
2. Create new calibration pages for Fluke as follows: 

a. Open the Page Editor. 
b. Open the file 'd_ff_default_fluke_settings.psr' (located in the path: 'Program 

Files\SmartPlant\Instrumentation\PSR'). 
c. Regenerate the page. 

d. Click Save as Page  . 
e. On the Save as Page dialog box, click New. 
f. Type a name for the page (Fluke Settings) and if desired, a description. 
g. Open the file 'd_ff_default_fluke_result.psr' and repeat the above steps c-e. 
h. Type a name for the page (Fluke Data Entry) and if desired, a description. 

3. Using these calibration pages, create new calibration forms for settings and data entry and 
save them to the database. 

 These forms are similar to the standard calibration forms, but with the following 
additional properties: 
 CALIB_RES_UDF_C01…C20 — Fields for user-defined results (data entry) values. 
 CALIB_SET_UDF_C01…C15 — Fields for user-defined settings values. 
 Loop Power — None, Enabled 24V, Enabled 28V. 
 Temperature Element Type — All T/C and RTD supported types. 
 TC Source Mode — Applicable for T/C element types only. 
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 Source Mode — Corresponds to the sUEV Fluke property for source user-entered 
values.  The value can be Auto or Manual Entry. 

 Measure Mode — Corresponds to the mUEV Fluke property for measure user-entered 
values.  The value can be Auto or Manual Entry. 

4. Define a new profile for Fluke and assign the Fluke forms that you created.  For details, see 
Create a Calibration Profile (on page 405). 

 

Map a Serial Port to Use the Fluke Calibrator on a Citrix 
Console 

1. Within the Citrix console, at the server location, click Start > Run. 
2. On the Run dialog box, in the Open box, type cmd. 
3. At the command prompt, type net use. 

A summary of the mapping between local and remote ports similar to the following should 
appear: 

 
4. If the desired port, for example COM 1, does not appear in the summary, then type: net use 

COM1: \\Client\COM1:. 
5. At the command prompt, type net use again and check that the desired serial port is now 

included in the mapping. 
 

Download Data from SmartPlant Instrumentation 
 When performing calibration checks with the Fluke calibrator, discrepancies could 

arise between the values entered in SmartPlant Instrumentation and the values downloaded to 
the Fluke calibrator.  These discrepancies are caused by differences in the number of decimal 
places allowed by SmartPlant Instrumentation and the Fluke calibrator resolution causing the 
calibrator to round up or down downloaded values. 
For example, temperatures in the Fluke Documenting Process Calibrator are limited to one tenth 
of degree Celsius resolution. If the downloaded value has two or more decimal places, the values 
are rounded by the Fluke calibrator and therefore are different to those in SmartPlant 
Instrumentation. This causes unexpected deviations from the anticipated point levels that will be 
reflected in the calibration result points.  
For more information on the level of accuracy for the different values measured by your Fluke 
calibrator , please consult your Fluke documentation or Fluke support. 
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1. Connect the Fluke Documenting Process Calibrator to your computer's COM port and switch 
on as described in the Fluke User Manual. 

2. Open the Calibration module and from the Tag Calibration Settings window, define the 
source and output value ranges and units of measure for the desired tag numbers. 

 When performing a calibration for a thermocouple using the Fluke calibrator as an 
external power supply, you must enter the following data using the custom fields indicated: 

Custom Field Property  Acceptable Value 

CALIB_SET_UDF_C1
6  

Loop power 24V / 28V  

CALIB_SET_UDF_C1
7 

Thermocouple type  E / N / J / K / T / B / R / S / C 
/ L / U 

CALIB_SET_UDF_C1
8  

Thermocouple source mode Linear MV / Linear T  

3. Click Actions > Fluke Interface. 
4. Click Next. 
5. On the Connection Options page, define your connection setting and click Test. 

 If the connection test is successful, an appropriate message appears in the 
Connection result box.  If the connection fails, check the physical connections and if 
necessary, select a different communication port and retry. 

6. Click Next to go to the Activity Selector page. 
 If you first want to clear the calibrator, click Flush calibrator memory, ensure that the 

Upload default memlist and procedures check box is selected, and then click Next.  On 
completion of the process click Back. 

7. Click Download data from SmartPlant Instrumentation to the calibrator. 
8. On the Tag Selection for Download page, select the Export check box beside each tag that 

you want to download to the calibrator, and then click Next. 
9. On the Download Data page, click Start to begin the download. 

 The progress bars indicate the current activity.  You will also see an indication on the 
calibrator that data is uploading to it. 

 This procedure downloads the following data to the Fluke calibrator: 
 Tag number. 
 Component_ID value — this is a unique value that SmartPlant Instrumentation automatically 

generates on creation of a tag number.  This number is displayed in the Fluke calibrator 
interface as the tag serial number.  Do not modify this number, either from the calibrator or 
from the SmartPlant Instrumentation database. 

 Source maximum and minimum range values and their units of measure. 
 Output measurement maximum and minimum range values and their units of measure. 
 Calibration strategy. 
 Tolerance. 

The following table shows a sample set of downloaded data values: 

Tag 
Number 

Range 
Min. 

Range 
Max. 

Range 
UOM 

Output Signal 
Min. 

Output Signal 
Max. 

Output Signal 
UOM 

Strategy (Calibration 
type) 

Tolerance 

101- TT - 
100 

100 200 °C 4 20 mA 3 ↑↓ 1 
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Tag 
Number 

Range 
Min. 

Range 
Max. 

Range 
UOM 

Output Signal 
Min. 

Output Signal 
Max. 

Output Signal 
UOM 

Strategy (Calibration 
type) 

Tolerance 

101- PT - 
200 

0 10 Bar (G) 4 20 mA 5 ↑ 1.5 

101- LT - 
300 

0 1000 mm 4 20 mA 3 ↑ 2 

 
 

Upload Data from the Fluke Calibrator 
1. After calibrating your instruments, connect the Fluke Documenting Process Calibrator to your 

computer's COM port and switch on as described in the Fluke User Manual. 
2. Open the Calibration module. 
3. Click Actions > Fluke Interface. 
4. Click Next. 
5. On the Connection Options page, define your connection setting and click Test. 

 If the connection test is successful, an appropriate message appears in the 
Connection result box.  If the connection fails, check the physical connections and if 
necessary, select a different communication port and retry. 

6. Click Next to go to the Activity Selector page. 
7. Click Upload data into SmartPlant Instrumentation from the calibrator. 
8. Click Next. 
9. On the Upload Data page, click Start to begin uploading data from the calibrator. 

 The progress bars indicate the current activity.  You will also see an indication on the 
calibrator that data is downloading from it. 

10. On completion of the upload process, click Next. 
11. On the Upload Summary page, view the tags for which the interface has uploaded calibration 

data into SmartPlant Instrumentation. 
12. Click Finish to complete the operation. 
13. In SmartPlant Instrumentation, open the Calibration module and from the Calibration History 

window, view the tag calibration data. 

 
 The following pressure units of measure are supported by SmartPlant Instrumentation when 

working with the Fluke 743B or 744 Calibrators:  
 Psi 
 Bar 
 InHg 
 mBar 
 inH2O 
 mH2O 
 ftH2O 
 Pa 
 kPa 
 gf/cm² (Fluke: g/cm²) 
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 Any other pressure unit of measure not supported by the Fluke Calibrator (as ‘base’ units) will 
default to ‘psi’ when downloaded to the calibrator. 

 Other units of measure that are not supported by the Fluke Calibrator will appear as voltage 
units. 

 
  



Performing Calibrations 
 

 
426 SmartPlant Instrumentation Detailed Engineering User's Guide 

 

 



 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 427 
 

A 
Access Rights in the Maintenance Module • 

351 
Activate the Construction Module • 384 
Add a Block to a Block Type • 259 
Add a Block Type • 259 
Add a Cable Set • 31 
Add a Cell to the Cell Library (MicroStation) • 

314 
Add a Connector to a Switch • 246 
Add a Connector to an Amplifier • 243 
Add a Group of Terminals to a Terminal Strip • 

87 
Add a Port to a Hub • 251 
Add a Switch Port • 246 
Add a Terminal to a Terminal Strip • 86 
Add a Wire to a Cable Set • 32 
Add an Amplifier Channel to an Amplifier • 

243 
Add an Apparatus to an Apparatus Group • 76 
Add an Installation Index • 389 
Add an Installation Index Category • 390 
Add an Intercom Connector • 252 
Add Cables and Objects to an Existing Cable 

Block Diagram • 160 
Add Customized Calibration Forms to the 

Database • 404 
Add Document References in Hook-Up 

Drawings • 337 
Add Intercom Equipment • 252 
Add Jumpers to the Existing Wiring • 98 
Add User-Defined Wiring Equipment 

Category Properties • 63 
Additional Settings • 366 
Apparatus • 73 
Append Routing Data to a Cable • 151 
Apply a Drawing Generation Method to 

Hook-Ups • 335 
Apply a Reference Cable to Multiple Cables 

Without Sets and Wires • 33 
Apply a Reference Cable to One Cable 

Without Sets and Wires • 34 
Apply Loop Drawing Generation Method • 283 
Apply Naming Conventions to Wiring Items • 

22 
Apply Regional Wire Colors to Project Cables 

• 35 

Arrangement of Telecom Items in the Domain 
Explorer • 230 

Assign a Segment to a Channel • 108 
Assign an Enhanced Symbol to a Hook-Up • 

338 
Assign an Instrument Block to a Drawing 

Page • 267 
Assign an Instrument to a Channel • 107 
Assign Border and Logo Blocks to Hook-Up 

Drawings • 337 
Assign Cables to Drums Automatically (with 

Optimization) • 155 
Assign Cables to Drums Manually (Without 

Optimization) • 156 
Assign Connector Pins to Cable Wires • 201 
Assign Dimensional Data Forms • 369 
Assign General Blocks to All Loop Drawings 

via Instrument Type • 268 
Assign Installation Indexes to Items • 390 
Assign the Same Active Item Library to More 

Than One Plant • 320 
Assigning an External Macro Data Source • 

307 
Assigning Wire Designation • 99 
Associate a Cable with a Panel • 161 
Associate a Loop Block • 263 
Associate a Pin or a Terminal with a Channel 

• 201 
Associate a PLC or DCS Panel with a 

Profibus DP Segment • 215 
Associate a Routing Section with Cables • 

149 
Associate a Segment with a Home-Run Cable 

• 203 
Associate a Symbol with an Item • 23 
Associate a Symbol with Multiple Items • 23 
Associate a Telephone Number with a 

Channel • 248 
Associate an I/O card with an I/O Termination 

• 72 
Associate an Instrument Type with a DDP 

Group • 369 
Associate an Instrument with a Segment • 

183 
Associate Cables with a Pulling Area • 154 
Associate Calibration Profiles with Instrument 

Types • 405 
Associate Function Blocks with Instrument 

Types • 173 
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Associate Function Blocks with Instruments • 
179 

Associate Hook-Up Types with Instrument 
Types • 327 

Associate Instrument Blocks Automatically 
(via Instrument Type) • 263 

Associate Instrument Blocks Manually • 265 
Associate Instrument Tag Numbers with 

Hook-Ups • 327 
Associate Instruments with Device Panels • 

57 
Associate Items with Hook-Ups • 329 
Associate Items with User-Defined 

Sub-Libraries • 322 
Associate Profibus DP Instruments with a DP 

Segment • 214 
Associate Profibus PA Instruments with a PA 

Segment • 214 
Associating an External CAD Drawing • 275 
Automatically Propagate a Signal from a 

Non-Wiring Instrument • 136 
Auto-Wire Control Systems • 128 
Auto-Wire Control Systems Connected to 

Pre-Assigned Junction Boxes • 130 
Auto-Wire Pre-Assigned Junction Boxes • 

126 
Auto-Wire Two Panels • 127 
Auto-Wiring • 123 
Auto-Wiring Task Statuses • 131 

B 
Block Types • 254 

C 
Cable Block Diagrams • 159 
Cable Drums • 153 
Cable Routing • 145 
Cable Routing Flow of Activities • 145 
Cables, Cable Sets, and Wires • 25 
CAD Drawing Block Assignment Common 

Tasks • 261 
CAD Drawing Blocks in SmartPlant 

Instrumentation • 253 
CAD Loop Drawing Generation • 276 
CAD Loop Drawing Generation Common 

Tasks • 282 
CAD Settings for SmartPlant Instrumentation 

• 278 
Calculate Intrinsic Safety • 142 
Calculate Intrinsic Safety for a Loop • 144 
Calculate Loop Errors • 419 

Calculating the Total of Hook-Up Items for a 
Bill of Material • 346 

Calibration Data Entry Activities • 411 
Calibration Error Calculations • 417 
Calibration Forms • 400 
Calibration Module Commands • 396 
Calibration Module Window • 396 
Calibration Preliminary Activities • 403 
Calibration Settings Activities • 408 
Cancel I/O Assignment • 112 
Change a Hook-Ups Sub-Library Association 

• 328 
Change an Auto-Wiring Task Status • 132 
Change Instrument / Segment Association • 

183 
Change the Block Assignment Method from 

Automatic to Manual • 264 
Change the Fieldbus Tag Number List 

Browser View for Segments • 184 
Change the Font Size of Cable and Cable Set 

Names • 103 
Change the Location of a Panel • 158 
Clear Previous Macro Result Records • 286 
Complete a Maintenance Event Record • 365 
Completing the Plug-and-Socket Group 

Wizard (Plug-and-Socket Group Wizard) • 
78 

Configure a Fieldbus Apparatus • 197 
Connect a Cable or a Cable Set to a Terminal 

Strip • 94 
Connect a Home-Run Cable to a 

Plug-and-Socket Box • 202 
Connect a Wire to a Terminal Strip • 96 
Connect Device Cables to a Terminal Strip in 

Batch Mode • 95 
Connecting to an External Data Source • 305 
Connecting to an ODBC Profile • 306 
Connecting to Database Platforms Other 

Than ODBC • 306 
Connection Type Examples • 93 
Construction - Example Scenario • 387 
Construction Flow of Activities • 384 
Construction Module • 383 
Construction Module Revisions • 393 
Construction Options • 387 
Control System Tag Propagation • 113 
Conventional and Fieldbus Multi-Input 

Devices • 221 
Conventional Panels • 37 
Copy Associated Blocks to Other Instrument 

Tags • 266 
Copy Automatically Assigned Blocks to Tags 

of Other Loops • 266 
Copy Blocks to Another <Plant> • 261 
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Copy Default Data to Working Data • 373 
Copy Existing Process Data • 410 
Copy from Vendor Data to Working Data • 

374 
Copy Routing Data to Another Cable • 150 
Copy Working Data to the Default Library • 

373 
Couple an Instrument with a Control System 

Tag • 110 
Create a Cabinet • 39 
Create a Cable • 28 
Create a Cable Block Diagram • 159 
Create a Cable Without Sets and Wires • 33 
Create a Calibration Profile • 405 
Create a Cell Library (MicroStation) • 313 
Create a Channel • 108 
Create a Connector • 29, 200 
Create a Control System Tag • 109 
Create a Control System Tag in the 

Instrument Index Standard Browser View • 
109 

Create a Cross Wiring Cable • 122 
Create a DCS (Distributed Control System) 

Panel • 42 
Create a Device Cable • 58 
Create a Distribution Frame • 238 
Create a DP-Compatible PLC or DCS Panel • 

215 
Create a Fieldbus Brick Assembly • 195 
Create a Fieldbus I/O Card • 205 
Create a Foundation Fieldbus Segment • 182 
Create a General Signal • 138 
Create a HART Instrument • 218 
Create a Home-Run Cable • 185 
Create a Hook-Up Item • 321 
Create a Hook-Up Type • 326 
Create a Hub Cabinet • 249 
Create a Hub Connector • 250 
Create a Junction Box • 37 
Create a Local Tag Signal • 137 
Create a Maintenance Event Record • 364 
Create a Marshaling Rack • 38 
Create a Miscellaneous Cabinet • 248 
Create a Multi-Input Device Panel with 

Terminal Connections • 223 
Create a Multi-Input Instrument with 

Plug-and-Socket Connections for a 
Fieldbus Segment • 223 

Create a Multi-Input Instrument with 
Plug-and-Socket Connections for a Serial 
Loop Interface • 226 

Create a Multi-Input Instrument with Terminal 
Connections for a Fieldbus Segment • 225 

Create a Multi-Input Instrument with Terminal 
Connections for a Serial Loop Interface • 
227 

Create a New Hook-Up Macro Definition • 
298, 344 

Create a New Repair Form • 361 
Create a PA Cabinet • 241 
Create a PABX Cabinet • 244 
Create a PABX Rack • 245 
Create a Panel with Terminals and 

Connectors • 44 
Create a Patch Panel • 239 
Create a PLC (Programmable Logic 

Controller) Panel • 43 
Create a Plug-and-Socket Device Panel • 187 
Create a Plug-and-Socket Junction Box • 188 
Create a Plug-and-Socket Multi-Input Device 

Panel • 222 
Create a Profibus DP Segment • 214 
Create a Profibus PA Segment • 214 
Create a Rack • 46 
Create a Routing Section • 148 
Create a Slot • 47 
Create a Splice Panel • 238 
Create a Spur Cable • 186 
Create a Switch • 245 
Create a Switch Channel • 247 
Create a Telecom Cable • 236 
Create a Telecom Conventional Field Device 

• 235 
Create a Telecom Field Tag • 234 
Create a Telecom Junction Box • 237 
Create a Telecom Plug-and-Socket Field 

Device • 236 
Create a Terminal Strip • 85 
Create a Test Equipment Tag • 408 
Create a User-Defined Function Block • 172 
Create a User-Defined Macro Function • 302 
Create a Virtual Digital Tag • 220 
Create a Wiring Equipment Item • 64 
Create an Amplifier • 242 
Create an Apparatus Group • 75 
Create an External Terminator in a 

Plug-and-Socket Box • 192 
Create an External Terminator on a Terminal 

Strip • 192 
Create an I/O Card • 68 
Create an I/O Card Compatible with HART 

Instruments • 220 
Create an I/O Termination • 70 
Create an Instrument with a Manually 

Configured Device Panel • 52 
Create an Instrument with an Automatically 

Configured Device Panel • 51 
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Create an Instrument Without a Device Panel 
• 54 

Create an Intercom Cabinet • 251 
Create an Internal Terminator • 192 
Create an Intrinsically Safe Circuit Type • 141 
Create an Item Library • 319 
Create an Unassociated Conventional Device 

Panel • 41 
Create an Unassociated Telephone Number • 

248 
Create and Associate a Telephone Number • 

247 
Create and Manage a Pulling Area • 153 
Create Device Panels and Cables in the 

Instrument Index Standard Browser View • 
55 

Create Device Panels for Selected 
Instruments • 55 

Create Foundation Fieldbus and Profibus 
Instruments • 176 

Create Hook-Up Items in Batch Mode • 321 
Create Hook-Ups • 326 
Create Hub Equipment • 250 
Create Tag Sets (MicroStation) • 311 
Create User-Defined Sub-Libraries • 320 
Creating a Wiring Scheme • 21 
Creating and Managing Cables • 25 
Creating Wiring Equipment for Cable Block 

Diagrams • 162 
Cross Wiring • 117 
Customize and Use Wiring Equipment 

Categories • 62 
Customize Cable Routing Terminology • 147 
Customize the Controller/Processor List 

Header in I/O Card Properties • 71 
Customize the Default Library Display and 

Layout • 377 
Customizing Macro Definitions • 297 

D 
Decouple an Instrument and a Control 

System Tag • 110 
Define a Cable Configuration • 26 
Define a Connection Type • 91 
Define a Dimensional Group • 368 
Define a Drawing as a Multi-Drawing • 271 
Define a Drawing as a Multi-Page Drawing • 

272 
Define a New Panel Location • 157 
Define a Preventive Maintenance Activity • 

354 
Define a Preventive Maintenance Attachment 

• 353 

Define a Preventive Maintenance Task • 354 
Define a Process Connection End 

Preparation • 367 
Define a Terminal Strip Configuration • 81 
Define Alarm / Trip Settings • 410 
Define an Apparatus Configuration • 73 
Define Cable Drum Attributes for Cable Types 

• 154 
Define Calibration Profile Settings • 405 
Define Circuit Cables for Intrinsic Safety Loop 

Calculation • 143 
Define Dimensional Group Properties • 368 
Define Foundation Fieldbus and Profibus 

Instrument Type Profiles • 176 
Define Insertion Points for Blocks • 260 
Define Instrument Type Profiles for HART 

Instruments • 218 
Define or Edit a Connector Type • 199 
Define or Edit a Connector Type Pin 

Configuration • 200 
Define Plug-and-Socket Group Layout 

(Plug-and-Socket Group Wizard) • 77 
Define Segment-Wide Parameters • 170 
Define Tag Calibration Settings • 409 
Define Tag Numbers for Intrinsic Safety Loop 

Calculation • 143 
Define the Cell Origin (MicroStation) • 314 
Define the Coordinates of the Cell Origin 

(MicroStation) • 314 
Define the New Ports Group 

(Plug-and-Socket Group Wizard) • 77 
Define the Plug-and-Socket Ports 

(Plug-and-Socket Group Wizard) • 78 
Define the Ports (Plug-and-Socket Group 

Wizard) • 78 
Define the Process Connection Class/Rating 

• 367 
Define the Set Point • 410 
Defining and Executing Auto-Wiring Tasks • 

123 
Defining and Managing Maintenance Event 

Records • 363 
Defining Test Equipment • 407 
Definitions in the Construction Module • 385 
Delete a Cable Configuration • 28 
Delete a Connector • 202 
Delete a Connector Type • 200 
Delete a Control System Tag • 111 
Delete a Fieldbus Segment • 184 
Delete a Hook-Up Macro Definition • 298, 344 
Delete a Panel Location • 158 
Delete a User-Defined Macro Function • 303 
Delete an Installation Index • 386 
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Delete CAD Loop Drawing Generation 
History • 286 

Delete Hook-Up Items • 323 
Delete Hook-Up Sub-Libraries • 324 
Delete Hook-Up Types • 331 
Delete Hook-Ups • 331 
De-Multiplex Tag Signals • 140 
Device Panels and Cables • 49 
Device Panels in SmartPlant Instrumentation 

• 49 
Dimensional Data and Piping • 365 
Disconnect Cables from Items in a Cable 

Block Diagram • 161 
Disconnect Cables, Cable Sets, and Wires • 

97 
Display a Cell on the Desktop (MicroStation) • 

315 
Display Adjacent Connections of a Cable • 

100 
Display and Access Vendor Data • 370 
Display and Access Working Data • 372 
Display AutoCAD Hook-Up Drawings with the 

Enhanced Report Utility • 343 
Display CAD Loop Drawing Generation 

History • 285 
Display MicroStation Hook-Up Drawings with 

the Enhanced Report Utility • 343 
Display SmartSketch Hook-Up Drawings with 

the Enhanced Report Utility • 342 
Display the Farthest Connection of a Cable • 

101 
Displaying CAD Hook-Up Drawings with the 

Enhanced Report Utility Common Tasks • 
342 

Dissociate a Panel from a Location • 158 
Dissociate an Instrument from a Segment • 

183 
Dissociate Blocks from Instruments • 267 
Dissociate Device Panels from Instruments • 

57 
Dissociate Items from Hook-Ups • 330 
Dissociate Profiles from Instrument Types • 

406 
Dissociate Tag Numbers from Hook-Ups • 

330 
Download Data from SmartPlant 

Instrumentation • 422 
Duplicate a Dimensional Group • 369 
Duplicate a Telecom Field Tag • 234 

E 
Edit a Cable Configuration • 27 
Edit a Cable Routing • 150 

Edit a Routing Section • 149 
Edit an Archived Revision • 395 
Edit an Installation Index • 386 
Edit an Installation Index Category • 385 
Edit Apparatus Terminal Properties • 76 
Edit Cable Properties • 30 
Edit Default Dimensional Data • 377 
Edit Hook-Up Drawing Identifying Fields • 335 
Edit the Properties of a Foundation Fieldbus 

Segment • 182 
Edit the Properties of a Plug-and-Socket 

Device Panel • 188 
Edit the Properties of a Plug-and-Socket 

Junction Box • 189 
Edit the Properties of a Terminal • 87 
Edit Wire Properties • 34 
Edit Working Data • 372 
Effect Fieldbus I/O Assignment • 206 
Effect I/O Assignment for a Segment • 107 
Effect I/O Assignment for an Instrument • 106 
Effect I/O Assignment for HART Instruments • 

220 
Enable a Function Block for I/O Assignment • 

184 
Enter Calibration Data • 412 
Enter Default Data into the Default Library • 

376 
Enter Power Supply Data for Panels and 

Instrument Tags • 45 
Enter Preventive Maintenance Details • 358 
Enter Tag Number Dialog Box • 397 
Enter Vendor Data • 371 
Equipment Cabinets and Equipment Items • 

241 
Examples of Farthest Connections of Cables 

• 101 
Export Tag Sets (MicroStation) • 312 
Extend Existing Scheduling • 357 
External Macro Naming Conventions • 304 
External Macro Structure Conventions • 304 

F 
Fence Elements for a Cell (MicroStation) • 

313 
Fieldbus and Profibus Segments Common 

Tasks • 181 
Fieldbus Bricks • 194 
Fieldbus Cables Common Tasks • 185 
Fieldbus Instruments Common Tasks • 175 
Fieldbus Plug-and-Socket Boxes (Panels) • 

186 
Fieldbus Validation • 207 
Fieldbus Validation Common Tasks • 209 
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Fill Out a Repair Form • 362 
Filter Maintenance Activities • 352 
Filter the Display of Data in the I/O 

Assignment Window • 111 
Filter the Local Signal Dialog Box • 137 
Filtering Items on a Cable Block Diagram • 

163 
Find I/O Channels for Assignment • 115 
Flow of Activities for Auto-Wiring • 124 
Flow of Activities for Foundation Fieldbus 

Design • 166 
Flow of Activities for HART Instrumentation • 

217 
Flow of Activities for Profibus Design • 211 
Flow of Activities for Telecom Design • 229 
Force Signal Propagation • 135 
Foundation Fieldbus and Profibus • 165 
Foundation Fieldbus Design • 165 

G 
General Wiring Definitions • 19 
Generate a Bill of Material • 348 
Generate a Connection Report from the 

Connection Window • 103 
Generate a Dimensional Data Sheet • 378 
Generate a Group List, Dimensions List, 

Default Library List, Default Dimensional 
Data, Or Vendor Dimensional Data Report 
• 379 

Generate a Hook-Up Item List Report • 349 
Generate a Hook-Up Tag List Report • 349 
Generate a Macro Report • 295 
Generate a Maintenance Report • 353 
Generate a Panel Strip Report from the Cross 

Wiring Window • 122 
Generate a Report of CAD Loop Drawing 

Generation Errors • 287 
Generate a Segment Wiring Report • 210 
Generate A Suspected Data List, Status 

History, Or Suspected Data History Report 
• 380 

Generate a Validation Report for Multiple 
Segments • 210 

Generate a Validation Report for Multiple 
Segments from the Fieldbus Tag Numbers 
Browser • 210 

Generate a Validation Report for One 
Segment • 209 

Generate an Enhanced Profibus Layout 
Report • 216 

Generate an I/O Tag Assignment Report • 
112 

Generate CAD Hook-Up Drawings • 339 

Generate CAD Loop Drawings • 283 
Generate Calibration Reports • 416 
Generate DDP Reports • 378 
Generate Enhanced Hook-Up Drawings • 340 
Generate Hook-Up Drawings in Mixed Mode • 

341 
Generate Reports For An Installation Index 

Revision Reports • 393 
Generating a Report Using MicroStation • 315 

H 
HART Instruments • 217 
Hook-Up Drawing Generation • 331 
Hook-Up Item Libraries and Sub-Libraries • 

317 
Hook-Up Items and Libraries • 316 
Hook-Up Reports • 345 
Hook-Up Reports Common Tasks • 347 
Hook-Ups in SmartPlant Instrumentation • 

315 
Hook-Ups Module Window • 316 

I 
I/O Assignment • 105 
Import a Tag Set (MicroStation) • 312 
Insert Macros in an AutoCAD Drawing Block • 

296 
Installation Index Category Definitions • 385 
Instrument Maintenance • 350 
Intrinsic Safety • 141 
Issue a New Work Request • 360 

L 
Link a Tag to a Drawing Element 

(MicroStation) • 312 
Link Tag Signals to a General Signal • 139 
List of Calibration Reports • 414 
Loop Block Macro Syntax • 289 
Loop Blocks • 256 
Loop Drawing Generation Methods • 277 
Loop Drawing Reports • 286 
Loop Drawing Types and Drawing Properties 

• 269 
Loop Drawing Types and Drawing Properties 

Common Tasks • 269 
Loop Drawings Module • 253 
Loop Error Calculation • 416 
Loop Error Result Dialog Box • 420 

M 
Maintain CAD Loop Drawing Revisions • 273 



 Index 
 

 

SmartPlant Instrumentation Detailed Engineering User's Guide 433 
 

Maintain Document References • 274 
Maintain Hook-Up Drawing Revisions • 336 
Maintaining a Revision Archive • 394 
Maintenance Event Records • 362 
Make Approvals for Hook-Up Drawings • 336 
Make CAD Drawing Approvals • 274 
Making Connections and Associations for 

Fieldbus • 199 
Making Connections in SmartPlant 

Instrumentation • 91 
Manage Cable Drums Manually • 154 
Manage Code Tables • 406 
Manage Default Dimensional Data • 376 
Manage Intrinsic Safety Circuit Types • 141 
Manage Standard Positions • 147 
Manage Standard Widths • 147 
Manage the Function Blocks Supporting 

Table • 174 
Managing CAD Drawing Blocks Common 

Tasks • 258 
Managing Fieldbus Brick Assemblies and 

Apparatuses Common Tasks • 195 
Managing Fieldbus I/O Cards and I/O 

Assignment Common Tasks • 205 
Managing Fieldbus Panels (Plug-and-Socket 

Boxes) Common Tasks • 187 
Managing Hook-Up Drawings Common 

Tasks • 333 
Managing Hook-Up Items and Libraries 

Common Tasks • 318 
Managing Hook-Ups Common Tasks • 324 
Managing Multi-Input Devices • 221 
Managing Panel Locations • 157 
Managing Terminators Common Tasks • 191 
Map a Serial Port to Use the Fluke Calibrator 

on a Citrix Console • 422 
MicroStation and SmartPlant Instrumentation 

• 307 
Modify a Terminal Strip Configuration • 83 
Modify a User-Defined Macro Function • 302 
Modify Loop Drawing Identifying Information • 

274 
Modify Panel Location Properties • 157 
Modify Properties of a Single-Page Drawing • 

272 
Modify the Internal Links of a 

Plug-and-Socket Group • 79 
Modify Working Data Status • 375 
Move a Terminal • 88 
Move a Terminal Strip to Another Parent Item 

• 85 
Move an External Terminator to Another Port 

in a Plug-and-Socket Box • 193 
Move Cables, Cable Sets, and Wires • 97 

Move Hook-Ups to Another Hook-Up Type • 
328 

Multiplex Tag Signals • 139 

N 
Name and Sequence Uniqueness of Wiring 

Items • 21 

O 
Open an Existing Work Request • 361 
Open Reports by Selecting Document 

Numbers • 350 
Opening a Work Request • 360 

P 
Perform Automatic Cross Wiring • 120 
Perform Breakdown Maintenance • 359 
Perform Manual Cross Wiring • 117 
Perform Preventive Maintenance • 356 
Perform Semiautomatic Cross Wiring • 118 
Performing Breakdown Maintenance • 359 
Performing Calibrations • 395 
Performing Preventive Maintenance • 355 
Piping Design Area • 373 
Possible Cases of Signal Propagation • 133 
Pre-Assign Junction Boxes to Device Panels • 

125 
Preliminary Definitions for Foundation 

Fieldbus Common Tasks • 169 
Preliminary Procedures • 367 
Prerequisites for Connecting to a dBase 

ODBC Profile • 305 
Prerequisites for Creating a Test Equipment 

Tag • 407 
Preventive Maintenance Preliminary 

Activities • 353 
Preview a Cell (MicroStation) • 314 
Principles of Creating Device Panels • 50 
Principles of the DDP Module • 366 
Principles of Wiring Operations in SmartPlant 

Instrumentation • 19 
Print Dimensional Data Sheets From the 

Dimensional Data for Piping Module 
Window • 380 

Print Dimensional Data Sheets From the 
Working Data Window • 380 

Print Empty Sheet Forms • 381 
Printing Dimensional Data Sheets • 380 
Profibus Design • 211 
Profibus Design Common Tasks • 213 
Propagate a Tag Signal Manually • 135 
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R 
Regenerate Dimensional Data Sheets • 376 
Remove a Jumper from the Existing Wiring • 

99 
Remove Items from a User-Defined 

Sub-Library • 323 
Remove Trailing Separators From Wiring 

Item Names • 24 
Rename a Control System Tag • 110 
Rename Device Cables in Batch Mode • 59 
Reports, Revisions and Archives • 393 
Re-Propagate a Tag Signal • 135 

S 
Sample Loop Drawing (After Generation) • 

281 
Schedule Maintenance • 356 
Search for Tag Numbers in the Calibration 

Module • 398 
Select a Calibration Profile • 412 
Select a Graphic for a Terminal Connection • 

89 
Select Test Equipment • 413 
Services and Reports • 378 
Set a Date Format for Maintenance Event 

Record Names • 364 
Set an Item Library As the Active Item Library 

• 320 
Set Cable Routing Options • 146 
Set Cross Wiring Preferences • 120 
Set Default Generation Method for Hook-Up 

Drawings • 335 
Set I/O Assignment Instrument Tag 

Preferences • 105 
Set MicroStation for SmartPlant 

Instrumentation • 308 
Set Preferences for Automatic Naming of 

Jumpers • 99 
Set Tags for Loop Error Calculation • 418 
Set Telecom Device Type Profile Defaults • 

233 
Set the Date Format in CAD Loop Drawings • 

271 
Set the Maximum Number of Cables for the 

Standard Positions • 148 
Set up a Profile for the Fluke Calibrator • 421 
Shipped Block Files • 257 
Shipped Enhanced Hook-Ups Symbols • 333 
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